Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Softwarecentrum ERROR  (gelezen 1051 keer)

Offline seghele

  • Lid
  • Steunpunt: Nee
Softwarecentrum ERROR
« Gepost op: 2012/12/25, 16:10:02 »
Hallo,
Heb waarschijnlijk iets dom gedaan en krijg de error melding in het Softwarecentrum.
Kan dus geen pakket meer installeren of verwijderen.
Hier staat de error lijst:
installArchives() failed: Voorconfigureren van pakketten...
Voorconfigureren van pakketten...
Voorconfigureren van pakketten...
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 435429 files and directories currently installed.)
Unpacking fp-units-rtl-2.6.0 (from .../fp-units-rtl-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-rtl-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/rtl/libpgetopts.a', which is also in package fpc 2.6.0
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking fp-compiler-2.6.0 (from .../fp-compiler-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-compiler-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/samplecfg', which is also in package fpc 2.6.0
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking fp-units-base-2.6.0 (from .../fp-units-base-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-base-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/paszlib/libppaszlib.a', which is also in package fpc 2.6.0
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking fp-units-fcl-2.6.0 (from .../fp-units-fcl-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-fcl-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/fcl-image/fpwritetiff.o', which is also in package fpc 2.6.0
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking fp-units-gtk2-2.6.0 (from .../fp-units-gtk2-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-gtk2-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/gtk2/gtkglext.o', which is also in package fpc 2.6.0
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking fp-utils-2.6.0 (from .../fp-utils-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-utils-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/lexyacc/lexlib.o', which is also in package fpc 2.6.0
No apport report written because MaxReports is reached already
Processing triggers for doc-base ...
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/fp-units-rtl-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-compiler-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-base-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-fcl-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-gtk2-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-utils-2.6.0_2.6.0-6_i386.deb
Error in function:
dpkg: dependency problems prevent configuration of fp-units-fcl:
 fp-units-fcl depends on fp-units-fcl-2.6.0 (= 2.6.0-6); however:
  Package fp-units-fcl-2.6.0 is not installed.

dpkg: error processing fp-units-fcl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fp-utils:
 fp-utils depends on fp-utils-2.6.0 (= 2.6.0-6); however:
  Package fp-utils-2.6.0 is not installed.

dpkg: error processing fp-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lcl-units-0.9.30.4:
 lcl-units-0.9.30.4 depends on fpc-abi-2.6.0; however:
  Package fpc-abi-2.6.0 is not installed.

dpkg: error processing lcl-units-0.9.30.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lcl-gtk2-0.9.30.4:
 lcl-gtk2-0.9.30.4 depends on fpc-abi-2.6.0; however:
  Package fpc-abi-2.6.0 is not installed.
 lcl-gtk2-0.9.30.4 depends on fp-units-rtl; however:
  Package fp-units-rtl is not installed.
 lcl-gtk2-0.9.30.4 depends on fp-units-fcl; however:
  Package fp-units-fcl is not configured yet.

dpkg: error processing lcl-gtk2-0.9.30.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fp-units-gtk2:
 fp-units-gtk2 depends on fp-units-gtk2-2.6.0 (= 2.6.0-6); however:
  Package fp-units-gtk2-2.6.0 is not installed.

dpkg: error processing fp-units-gtk2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fp-units-base:
 fp-units-base depends on fp-units-base-2.6.0 (= 2.6.0-6); however:
  Package fp-units-base-2.6.0 is not installed.

dpkg: error processing fp-units-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fp-compiler:
 fp-compiler depends on fp-compiler-2.6.0 (= 2.6.0-6); however:
  Package fp-compiler-2.6.0 is not installed.

dpkg: error processing fp-compiler (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lcl-0.9.30.4:
 lcl-0.9.30.4 depends on lcl-units-0.9.30.4; however:
  Package lcl-units-0.9.30.4 is not configured yet.

dpkg: error processing lcl-0.9.30.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lcl-utils-0.9.30.4:
 lcl-utils-0.9.30.4 depends on fp-compiler; however:
  Package fp-compiler is not configured yet.

dpkg: error processing lcl-utils-0.9.30.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lazarus-ide-0.9.30.4:
 lazarus-ide-0.9.30.4 depends on fp-compiler; however:
  Package fp-compiler is not configured yet.

dpkg: error processing lazarus-ide-0.9.30.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lazarus-0.9.30.4:
 lazarus-0.9.30.4 depends on lazarus-ide-0.9.30.4 (>= 0.9.30.4-3); however:
  Package lazarus-ide-0.9.30.4 is not configured yet.

dpkg: error processing lazarus-0.9.30.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lazarus:
 lazarus depends on lazarus-0.9.30.4 (= 0.9.30.4-3); however:
  Package lazarus-0.9.30.4 is not configured yet.

dpkg: error processing lazarus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lazarus-ide-gtk2-0.9.30.4:
 lazarus-ide-gtk2-0.9.30.4 depends on lazarus-ide-0.9.30.4; however:
  Package lazarus-ide-0.9.30.4 is not configured yet.

dpkg: error processing lazarus-ide-gtk2-0.9.30.4 (--configure):
 dependency problems - leaving unconfigured
Moderator edit: [ code ] tags geplaatst.
« Laatst bewerkt op: 2012/12/25, 18:57:29 door Ron »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Softwarecentrum ERROR
« Reactie #1 Gepost op: 2012/12/25, 18:20:26 »
Welke versie van Ubuntu gebruik je?
Wilde je Lazarus installeren?
Bij alle pakketten die je wilt installeren zijn er afhankelijkheidsproblemen. Welke pakketten wilde je installeren en hoe?
In der Beschränkung zeigt sich der Meister.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #2 Gepost op: 2012/12/25, 19:38:13 »
Wat heb je gedaan?

Heb je vreemde ppa/software sources toegevoegd, voor extra software?, zet deze eens uit, en probeer opnieuw.

Dit kun je ook proberen, in de terminal ingeven.

sudo apt-get clean && sudo apt-get autoremove
sudo apt-get -f install
sudo dpkg --configure -a
« Laatst bewerkt op: 2012/12/25, 19:41:22 door jan11000 »

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #3 Gepost op: 2012/12/26, 10:41:34 »
Heb Ubuntu 12.10.
Ik heb geen ppa/software sources toegevoegd.
Probeerde een update van Lazarus v1.0.4-0 te installeren via een *.deb bestand.
Moest ook nog fpc-src en pfc voor Lazarus installeren, ook via *.deb.
Daar is het mis gelopen, want ik kreeg enkel error.
Heb getracht om Lazarus te verwijderen via
~$ sudo apt-get --purge remove lazarus*
en ~$ sudo apt-get remove --purge fpc-src*
maar kreeg ook error.


sudo apt-get clean && sudo apt-get autoremove
sudo apt-get -f install
sudo dpkg --configure -a[/quote]
Volgende tekst geeft de resultatenvan de drie , met ERROR.
~$ sudo apt-get clean && sudo apt-get autoremove
[sudo] password for seghers:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
Statusinformatie wordt gelezen... Klaar
U kunt 'apt-get -f install' uitvoeren om dit op te lossen.
De volgende pakketten hebben niet-voldane vereisten:
 fp-compiler : Vereisten: fp-compiler-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-units-base : Vereisten: fp-units-base-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-units-fcl : Vereisten: fp-units-fcl-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-units-gtk2 : Vereisten: fp-units-gtk2-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-utils : Vereisten: fp-utils-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 lcl-gtk2-0.9.30.4 : Vereisten: fpc-abi-2.6.0
                     Vereisten: fp-units-rtl
 lcl-units-0.9.30.4 : Vereisten: fpc-abi-2.6.0
E: Er zijn vereisten waaraan niet voldaan is. Probeer -f te gebruiken.
//********************************
~$ sudo apt-get clean && sudo apt-get autoremove
[sudo] password for seghers:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
Statusinformatie wordt gelezen... Klaar
U kunt 'apt-get -f install' uitvoeren om dit op te lossen.
De volgende pakketten hebben niet-voldane vereisten:
 fp-compiler : Vereisten: fp-compiler-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-units-base : Vereisten: fp-units-base-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-units-fcl : Vereisten: fp-units-fcl-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-units-gtk2 : Vereisten: fp-units-gtk2-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 fp-utils : Vereisten: fp-utils-2.6.0 (= 2.6.0-6) maar het is niet geïnstalleerd
 lcl-gtk2-0.9.30.4 : Vereisten: fpc-abi-2.6.0
                     Vereisten: fp-units-rtl
 lcl-units-0.9.30.4 : Vereisten: fpc-abi-2.6.0
E: Er zijn vereisten waaraan niet voldaan is. Probeer -f te gebruiken.
seghers@seghers:~$ sudo apt-get -f install
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
Statusinformatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... Klaar
De volgende extra pakketten zullen geïnstalleerd worden:
  fp-compiler-2.6.0 fp-units-base-2.6.0 fp-units-fcl-2.6.0 fp-units-gtk2-2.6.0 fp-units-rtl-2.6.0 fp-utils-2.6.0
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  fp-compiler-2.6.0 fp-units-base-2.6.0 fp-units-fcl-2.6.0 fp-units-gtk2-2.6.0 fp-units-rtl-2.6.0 fp-utils-2.6.0
0 pakketten opgewaardeerd, 6 pakketten nieuw geïnstalleerd, 0 te verwijderen en 1 niet opgewaardeerd.
13 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 18,0 MB aan archieven opgehaald worden.
Door deze operatie zal er 104 MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]? j
Ophalen:1 http://archive.ubuntu.com/ubuntu/ quantal/universe fp-units-rtl-2.6.0 i386 2.6.0-6 [2.313 kB]
Ophalen:2 http://archive.ubuntu.com/ubuntu/ quantal/universe fp-compiler-2.6.0 i386 2.6.0-6 [2.348 kB]
Ophalen:3 http://archive.ubuntu.com/ubuntu/ quantal/universe fp-units-base-2.6.0 i386 2.6.0-6 [1.390 kB]
Ophalen:4 http://archive.ubuntu.com/ubuntu/ quantal/universe fp-units-fcl-2.6.0 i386 2.6.0-6 [6.139 kB]
Ophalen:5 http://archive.ubuntu.com/ubuntu/ quantal/universe fp-units-gtk2-2.6.0 i386 2.6.0-6 [1.573 kB]
Ophalen:6 http://archive.ubuntu.com/ubuntu/ quantal/universe fp-utils-2.6.0 i386 2.6.0-6 [4.201 kB]
18,0 MB opgehaald in 5s (3.040 kB/s)       
Voorconfigureren van pakketten...
(Database inlezen ... 435429 files and directories currently installed.)
Uitpakken van fp-units-rtl-2.6.0 (uit .../fp-units-rtl-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-rtl-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/rtl/libpgetopts.a', which is also in package fpc 2.6.0
dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Uitpakken van fp-compiler-2.6.0 (uit .../fp-compiler-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-compiler-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/samplecfg', which is also in package fpc 2.6.0
dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Uitpakken van fp-units-base-2.6.0 (uit .../fp-units-base-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-base-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/paszlib/libppaszlib.a', which is also in package fpc 2.6.0
Er is geen apport-verslag weggeschreven omdat het maximum aantal verslagen (MaxReports) al is bereikt
                                                                                                     dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Uitpakken van fp-units-fcl-2.6.0 (uit .../fp-units-fcl-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-fcl-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/fcl-image/fpwritetiff.o', which is also in package fpc 2.6.0
Er is geen apport-verslag weggeschreven omdat het maximum aantal verslagen (MaxReports) al is bereikt
                                                                                                     dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Uitpakken van fp-units-gtk2-2.6.0 (uit .../fp-units-gtk2-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-units-gtk2-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/gtk2/gtkglext.o', which is also in package fpc 2.6.0
Er is geen apport-verslag weggeschreven omdat het maximum aantal verslagen (MaxReports) al is bereikt
                                                                                                     dpkg-deb: error: subprocess paste was killed by signal (Gebroken pijp)
Uitpakken van fp-utils-2.6.0 (uit .../fp-utils-2.6.0_2.6.0-6_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/fp-utils-2.6.0_2.6.0-6_i386.deb (--unpack):
 trying to overwrite '/usr/lib/fpc/2.6.0/units/i386-linux/lexyacc/lexlib.o', which is also in package fpc 2.6.0
Er is geen apport-verslag weggeschreven omdat het maximum aantal verslagen (MaxReports) al is bereikt
                                                                                                     Processing triggers for doc-base ...
Processing triggers for man-db ...
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/fp-units-rtl-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-compiler-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-base-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-fcl-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-gtk2-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-utils-2.6.0_2.6.0-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
//*******************************
~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of fp-units-fcl:
 fp-units-fcl is afhankelijk van fp-units-fcl-2.6.0 (= 2.6.0-6); maar:
  Pakket `fp-units-fcl-2.6.0' is niet geïnstalleerd.

dpkg: error processing fp-units-fcl (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of fp-utils:
 fp-utils is afhankelijk van fp-utils-2.6.0 (= 2.6.0-6); maar:
  Pakket `fp-utils-2.6.0' is niet geïnstalleerd.

dpkg: error processing fp-utils (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lcl-units-0.9.30.4:
 lcl-units-0.9.30.4 is afhankelijk van fpc-abi-2.6.0; maar:
  Pakket `fpc-abi-2.6.0' is niet geïnstalleerd.

dpkg: error processing lcl-units-0.9.30.4 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lcl-gtk2-0.9.30.4:
 lcl-gtk2-0.9.30.4 is afhankelijk van fpc-abi-2.6.0; maar:
  Pakket `fpc-abi-2.6.0' is niet geïnstalleerd.
 lcl-gtk2-0.9.30.4 is afhankelijk van fp-units-rtl; maar:
  Pakket `fp-units-rtl' is niet geïnstalleerd.
 lcl-gtk2-0.9.30.4 is afhankelijk van fp-units-fcl; maar:
  Pakket fp-units-fcl is nog niet geconfigureerd.

dpkg: error processing lcl-gtk2-0.9.30.4 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of fp-units-gtk2:
 fp-units-gtk2 is afhankelijk van fp-units-gtk2-2.6.0 (= 2.6.0-6); maar:
  Pakket `fp-units-gtk2-2.6.0' is niet geïnstalleerd.

dpkg: error processing fp-units-gtk2 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of fp-units-base:
 fp-units-base is afhankelijk van fp-units-base-2.6.0 (= 2.6.0-6); maar:
  Pakket `fp-units-base-2.6.0' is niet geïnstalleerd.

dpkg: error processing fp-units-base (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of fp-compiler:
 fp-compiler is afhankelijk van fp-compiler-2.6.0 (= 2.6.0-6); maar:
  Pakket `fp-compiler-2.6.0' is niet geïnstalleerd.

dpkg: error processing fp-compiler (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lcl-0.9.30.4:
 lcl-0.9.30.4 is afhankelijk van lcl-units-0.9.30.4; maar:
  Pakket lcl-units-0.9.30.4 is nog niet geconfigureerd.

dpkg: error processing lcl-0.9.30.4 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lcl-utils-0.9.30.4:
 lcl-utils-0.9.30.4 is afhankelijk van fp-compiler; maar:
  Pakket fp-compiler is nog niet geconfigureerd.

dpkg: error processing lcl-utils-0.9.30.4 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lazarus-ide-0.9.30.4:
 lazarus-ide-0.9.30.4 is afhankelijk van fp-compiler; maar:
  Pakket fp-compiler is nog niet geconfigureerd.

dpkg: error processing lazarus-ide-0.9.30.4 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lazarus-0.9.30.4:
 lazarus-0.9.30.4 is afhankelijk van lazarus-ide-0.9.30.4 (>= 0.9.30.4-3); maar:
  Pakket lazarus-ide-0.9.30.4 is nog niet geconfigureerd.

dpkg: error processing lazarus-0.9.30.4 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lazarus:
 lazarus is afhankelijk van lazarus-0.9.30.4 (= 0.9.30.4-3); maar:
  Pakket lazarus-0.9.30.4 is nog niet geconfigureerd.

dpkg: error processing lazarus (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: dependency problems prevent configuration of lazarus-ide-gtk2-0.9.30.4:
 lazarus-ide-gtk2-0.9.30.4 is afhankelijk van lazarus-ide-0.9.30.4; maar:
  Pakket lazarus-ide-0.9.30.4 is nog niet geconfigureerd.

dpkg: error processing lazarus-ide-gtk2-0.9.30.4 (--configure):
 vereistenproblemen - blijft ongeconfigureerd
Fouten gevonden tijdens behandelen van:
 fp-units-fcl
 fp-utils
 lcl-units-0.9.30.4
 lcl-gtk2-0.9.30.4
 fp-units-gtk2
 fp-units-base
 fp-compiler
 lcl-0.9.30.4
 lcl-utils-0.9.30.4
 lazarus-ide-0.9.30.4
 lazarus-0.9.30.4
 lazarus
 lazarus-ide-gtk2-0.9.30.4


[Mod edit: even geholpen met de code tags. Dat gaat met die button met '#' boven het tekstveld  ;)]
« Laatst bewerkt op: 2012/12/27, 22:20:40 door asphyxia »

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #4 Gepost op: 2012/12/26, 10:59:42 »
Mag ik volgende commando's uitvoeren?

Citaat
This command clears the current list of softwares :

sudo rm /var/lib/apt/lists/* -vf

This command re downloads and refreshes the list :

sudo apt-get update

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Softwarecentrum ERROR
« Reactie #5 Gepost op: 2012/12/26, 13:38:06 »
Het commando voor volledig verwijderen sudo apt-get --purge remove pakketnaam ik zag namelijk dat je een keer dit gebruikte sudo apt-get remove --purge fpc-src*

Voordat je dit commando sudo rm /var/lib/apt/lists/* -vf uitvoert zou ik een kopie maken van de map lists.
Het commando verwijdert nl. alle bestanden in de map lists, als het goed is komt er wel een nieuwe lijst er in te staan na het commando sudo apt-get update. Maar beter mee verlegen dan om verlegen. :)
In der Beschränkung zeigt sich der Meister.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #6 Gepost op: 2012/12/26, 15:22:42 »
Citaat
sudo rm /var/lib/apt/lists/* -vf
Dit geeft geen verbetering.
Nog steeds de error boodschap:
"Items kunnen niet worden geïnstalleerd of verwijderd worden totdat de pakkettencatalogus is gerepareerd."
" Herstellen".
Met herstellen gaat het ook niet.
HOPELOOS !!!

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #7 Gepost op: 2012/12/26, 15:28:37 »
Bij het uitvoeren van ~$ sudo apt-get -f install
krijg ik onder meer de meldingen:

Processing triggers for man-db ...
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/fp-units-rtl-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-compiler-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-base-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-fcl-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-units-gtk2-2.6.0_2.6.0-6_i386.deb
 /var/cache/apt/archives/fp-utils-2.6.0_2.6.0-6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Moet ik deze bestanden verwijderen ?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Softwarecentrum ERROR
« Reactie #8 Gepost op: 2012/12/26, 20:02:33 »
Die bestanden kan je proberen te verwijderen met de purge optie.
Laten de bestanden zich verwijderen?

Hier nog wat docu https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

Even een vraag, heb je Synaptic geïnstalleerd staan?
« Laatst bewerkt op: 2012/12/26, 20:04:34 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #9 Gepost op: 2012/12/27, 11:26:25 »
 ;) Eerst en vooral reeds dank voor de positieve reactie.

Heb eerst dit gedaan:
~$ sudo gedit /etc/apt/apt.conf.d/70debconf.
Volgende lijn toegevoegd:
APT::Cache-Limit "100000000";

-> dan  alles verwijderd in:
/var/lib/apt/list/
 
-> daarna
~$ sudo apt-get clean && sudo apt-get autoremove
~$ sudo apt-get -f install
~$ sudo dpkg --configure -a
~$ sudo apt-get update
~$ sudo apt-get install --reinstall update-manager
~$ sudo apt-get update
~$ /usr/bin/update-manager

Na het kliken op "INSTELLINGEN" kreeg ik in de terminal:

gpg: /tmp/tmp3hr30c/trustdb.gpg: trustdb created
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 162, in packages_for_modalias
    cache_map = packages_for_modalias.cache_maps[apt_cache_hash]
KeyError: -1064184580
During handling of the above exception, another exception occurred:
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 103, in <module>
    app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 178, in __init__
    self.init_drivers()
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 1097, in init_drivers
    self.devices = detect.system_device_drivers()
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 415, in system_device_drivers
    for pkg, pkginfo in system_driver_packages(apt_cache).items():
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 319, in system_driver_packages
    for p in packages_for_modalias(apt_cache, alias):
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 164, in packages_for_modalias
    cache_map = _apt_cache_modalias_map(apt_cache)
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 129, in _apt_cache_modalias_map
    m = package.candidate.record['Modaliases']
  File "/usr/lib/python3/dist-packages/apt/package.py", line 429, in record
    return Record(self._records.record)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xeb in position 126: invalid continuation byte

Kan gewoon terug in "Softwarecentrum" en alles doen.
Maar in "Updatebeheer" werkt "Instellingen" niet !!!
Hoe moet ik dat oplossen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Softwarecentrum ERROR
« Reactie #10 Gepost op: 2012/12/27, 22:06:13 »
Moet je inloggen bij Update beheer als je de instellingen wilt veranderen?
In der Beschränkung zeigt sich der Meister.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #11 Gepost op: 2012/12/28, 10:17:54 »
Een goede vraag ! Mijn geheugen ..... op mijn 62 jaar .... amaai.
Sorry, ik weet het niet meer. Waarschijnlijk wel !
Het programma Softwarebronnen (Software Sources v0.92.9) kan ik ook niet openen.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Softwarecentrum ERROR
« Reactie #12 Gepost op: 2012/12/28, 20:05:48 »
Open eens een terminal en type daar gksudo update-manager (kopiëren en plakken kan ook) en geef een ENTER, nu moet je het wachtwoord intyppen en geef een ENTER. Opent het programma en kan je veranderingen aanbrengen? Zo niet kan je de foutmeldingen in de terminal hier plaatsen?
Deze foutmelding, zoals bij mij hoeven niet:
(gksudo:6613): Gdk-CRITICAL **: IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed

(gksudo:6613): Gdk-CRITICAL **: IA__gdk_error_trap_pop: assertion `gdk_error_traps != NULL' failed
Deze zie je altijd als je een grafisch programma opstart vanuit de terminal. :)
In der Beschränkung zeigt sich der Meister.

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #13 Gepost op: 2012/12/28, 22:39:24 »
~$ gksudo update-manager
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 162, in packages_for_modalias
    cache_map = packages_for_modalias.cache_maps[apt_cache_hash]
KeyError: -1063626342

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 103, in <module>
    app = SoftwarePropertiesGtk(datadir=options.data_dir, options=options, file=file)
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 178, in __init__
    self.init_drivers()
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 1097, in init_drivers
    self.devices = detect.system_device_drivers()
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 415, in system_device_drivers
    for pkg, pkginfo in system_driver_packages(apt_cache).items():
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 319, in system_driver_packages
    for p in packages_for_modalias(apt_cache, alias):
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 164, in packages_for_modalias
    cache_map = _apt_cache_modalias_map(apt_cache)
  File "/usr/lib/python3/dist-packages/UbuntuDrivers/detect.py", line 129, in _apt_cache_modalias_map
    m = package.candidate.record['Modaliases']
  File "/usr/lib/python3/dist-packages/apt/package.py", line 429, in record
    return Record(self._records.record)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xeb in position 126: invalid continuation byte

Programma opende zich, na paswoord, en er waren geen updates.
De knop "Instellingen" werkt nog steeds niet!

Offline seghele

  • Lid
  • Steunpunt: Nee
Re: Softwarecentrum ERROR
« Reactie #14 Gepost op: 2012/12/28, 23:33:39 »
Heb gezocht naar een vreemd lettertype in
/var/lib/dpkg/status.

Daar stond inderdaad een " ë ".
Heb deze vervangen door een gewone " e " en na bewaren was het probleem opgelost.

Kan nu via Updatebehher de "Instellingen" activeren en bewerken.
Natuurlijk werkt het programma "Softwarebronnen" opnieuw.

Deze TIP is belangrijk voor andere sukkels zoals ik.
 :)
Nogmaals hartelijk dank voor de reacties en steun.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Softwarecentrum ERROR
« Reactie #15 Gepost op: 2012/12/29, 00:46:42 »
Zo'n sukkel ben je ook niet, als je zelf de fout vind. Chapeau.  :)
In der Beschränkung zeigt sich der Meister.