Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Epson TM T88III thermische bonprinter serieel aansluiten op Ubuntu machine  (gelezen 1494 keer)

Offline HansSch

  • Lid
    • UNICEF-team Den Haag en omstreken
  • Steunpunt: Nee
LS.
Ik wil een Epson TM T88III thermische bonprinter aansluiten op mijn computer een DELL OptiPlex 170L die draait op Ubuntu 12.04.1 LTS
De printer is verbonden mbv een 9 pins kabel (serieel).
De printer wordt niet gezien door Ubuntu.
Ik heb geprobeerd om met behulp van | menu - printers - afdrukbeheer localhost - toevoegen |
helaas het lukt het me niet om de printer toe te voegen.
Gaarne advies!
bvd,
Hans.

Gijsbert - bedankt voor jouw reactie!
Type in je adresbalk van je browser http://localhost:631/  en stel daar de printer in.
Ik heb het in cups geprobeerd - daar kreeg ik de volgende melding:
http://localhost:631 vraagt om een gebruikersnaam en wachtwoord. De website meldt: “CUPS”
Ik heb daar mijn gebruikersnaam en wachtwoord (van ubuntu)  ingevoerd - maar dat was niet voldoende . . .

Unauthorized
Voer uw gebruikersnaam en wachtwoord of de $%$root-gebruikersnaam en bijbehorend wachtwoord in om deze pagina te benaderen. Maakt u gebruik van Kerberos-toegangscontrole, controleer dan of u over een geldig Kerberos-ticket beschikt.
is voor mij "abra cadabra" . . .    ???

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Het inloggen doe ik met mijn gebruikersnaam en wachtwoord( Dan log ik in als administrator). Gaat altijd. Vreemd dat dit bij jou niet lukt.
Dit is wat over Keberos is http://www.cups.org/documentation.php/kerberos.html
Maar dat heb ik nog nooit gezien bij mij. Heb je dat geïnstalleerd?
In der Beschränkung zeigt sich der Meister.

Offline HansSch

  • Lid
    • UNICEF-team Den Haag en omstreken
  • Steunpunt: Nee
nee - niet bewust in ieder geval
Ik heb wel een hulpmiddel voor CUPS-printerconfiguratie en status-applet geïnstalleerd  . . .
  system-config-printer-gnome 1.3.8+20120201-0ubuntu8.1
die heb ik gevonden bij Ubuntu software centrum onder ontwikkeling – afdrukken – printers instellen

als ik het niet via een menu gestuurde interface kan bewerkstelligen, zie ik het somber in !

het enige wat ik kan bedenken is dat ik met een truc die ik van het internet heb geplukt mijn vergeten wachtwoord opnieuw ingesteld heb in een terminal heet dat geloof ik via getypte commando's moest ik in de root iets doen of zoiets - daarna leek alles weer als vanouds - de printer heeft overigens nooit gewerkt met Ubuntu
ik ben in de Ubuntu omgeving een absolute leek  :o

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Zie bijlage. Pak de .ppd uit en kies die als driver.

Bron: http://ubuntuforums.org/showthread.php?t=1410974

Offline HansSch

  • Lid
    • UNICEF-team Den Haag en omstreken
  • Steunpunt: Nee
Ik heb de .ppd uitgepakt en als driver gekozen - nu krijg ik het volgende:
Stuurprogramma ontbreekt
Printer ‘CBM1000’ vereist het programma ‘/usr/lib/cups/filter/rastertocbm1k’, maar dit programma is momenteel niet geïnstalleerd. Installeer dit programma voordat deze printer wordt gebruikt.

Ik heb geprobeerd met Midnight Commander de files te kopiëren van mijn download naar de folder zoals hierboven aangegeven, maar lijk niet de juiste privileges te hebben . . .

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Probeer het volgende pakket te installeren: http://www.citizen-systems.co.jp/english/support/download/printer/driver/cups/data_cups/ctzpos-cups_1.1.0-1_i386.deb

Voer hierna uit:

sudo service cups restart

Offline HansSch

  • Lid
    • UNICEF-team Den Haag en omstreken
  • Steunpunt: Nee
Weer dank voor de reactie - helaas . . .
Heb  nu stap voor stap beschreven wat ik heb gedaan
Heb het pakket geïnstalleerd en daarna in een xterminal de code uitgevoerd.
Er volgde een stop /start actie in het window – maar de printer blijf zwijgen.

Bij een van de eerdere pogingen om de printer aan de gang te krijgen heb ik kans gezien om in het rijtje onder apparaten bij – nieuwe printer – apparaat selecteren – ook een optie “Epson TM/BA/EU printer” te kunnen selecteren. Lijkt me gezien de andere opties de meest voor de hand liggende. Voor de andere opties zou het een LPT printer moeten zijn of een netwerkprinter en ook is er een optie om direct een URI in te vullen.
 
Daarna is dan de volgende stap – Voer apparaat-URI in . . .
Ik heb geen idee wat ik daar moet invullen en heb tot nu toe telkens maar wat geprobeerd.
De laatste poging is nu “epsontm:/” (misschien gaat het daarom de mist in)

Dan gaat het systeem zoeken naar stuurprogramma's en stelt voor om er een te kiezen uit de database – Generic aanbevolen) – text-only (aanbevolen). Dan krijg ik een window voor de printer beschrijving – maakt denk ik niet zo veel uit. Klik ik op toepassen – krijg ik daarna de optie om een testprint te maken / krijg ik CUPS-serverfout – Er is een fout opgetreden tijdens de CUPS-bewerking: ‘client-error-document-format-not-supported’.

Verander ik mijn keuze naar Stuurprogramma kiezen Epson – 9-Pin Series (aanbevolen) – gebruik de nieuwe PPD zoals die is – toepassen.
Dan zie ik de printerstatus Inactief – maak toch een testprint – dan verschijnt er
Bij Printerstatus: Inactief - Printing page 1, 31% complete. – daar blijft het op hangen.
Bij Printerstatus: Inactief - Processing page 1...
Bij Printer wachtrij bekijken staat er idd een in de wachtrij – met re muisklik – vrijgeven verdwijnt ie uit de rij , maar zonder dat er op de printer iets gebeurd

Moeten die PPD files in een bepaalde folder komen te staan net zoals de rasterto* files
Als ik het goed begrijp heb ik eigenlijk een epson-tm-t88iii-rastertotmt.ppd nodig . . .

Ik heb elk van de tot nog toe aangedragen suggesties opgevolgd helaas zonder resultaat.
Hoop dat je er nog licht over kan laten schijnen - wordt zeker gewaardeerd!  :D