Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ruby installeren op Ubuntu 10.04.4 LTS server  (gelezen 568 keer)

Offline janamdo

  • Lid
Ruby installeren op Ubuntu 10.04.4 LTS server
« Gepost op: 2012/12/07, 15:29:30 »
Krijg het niet voor elkaar om Ruby te installeren..
Na server update ..zou eerst ..
sudo apt-get install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5 gcc checkinstall libreadline5 libyaml-0-2 (1)(1)

Daarna een script (2)
sudo apt-get -y install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5
cd /tmp
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xvzf ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure --prefix=/usr\
            --program-suffix=1.9.2\
            --with-ruby-version=1.9.2\
            --disable-install-doc
make
sudo checkinstall -D -y\
                  --fstrans=no\
                  --nodoc\                         --pkgname='ruby1.9.2'\
                  --pkgversion='1.9.2-p290'\
                  --provides='ruby'\
                  --requires='libc6,libffi5,libgdbm3,libncurses5,libreadline5,openssl,libyaml-0-2,zlib1g'\
                  --maintainer=brendan.ribera@gmail.com
sudo update-alternatives --install/usr/bin/ruby ruby /usr/bin/ruby1.9.2 500\
                         --slave /usr/bin/ri ri /usr/bin/ri1.9.2\
                         --slave /usr/bin/irb irb /usr/bin/irb1.9.2\
                         --slave /usr/bin/gem gem /usr/bin/gem1.9.2\             
                         --slave /usr/bin/erb erb /usr/bin/erb1.9.2\
                         --slave /usr/bin/rdoc rdoc /usr/bin/rdoc1.9.2
De sever installeert wel , maar komt niet met de boodschao dat Ruby is geinstalleerd.. en commando ruby -v levert niets op.
Wat zou hier nu fout gaan ?
Deze scriptcode heb ik van eenvideotutorial die bij de geschreven tutorial zit
De geschreven tutorial laat een ander script zien ?
2. Install Ruby¶

The record and playback infrastructure uses Ruby for the processing of recorded sessions.

First, you'll need to install the following dependencies to compile ruby.
sudo apt-get install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5 gcc checkinstall libreadline5 libyaml-0-2
Next, create a file called install-ruby.sh and copy and paste in the following script.

#!/bin/bash
cd /tmp
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xvzf ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure --prefix=/usr\
                     --program-suffix=1.9.2\
                     --with-ruby-version=1.9.2\
                     --disable-install-doc
make
sudo checkinstall -D -y\ 
                                            --fstrans=no\
                                            --nodoc\   
                                            --pkgname='ruby1.9.2'\
                                            --pkgversion='1.9.2-p290'\
                                            --provides='ruby'\
                                            --requires='libc6,libffi5,libgdbm3,libncurses5,libreadline5,openssl,libyaml-0-2,zlib1g'\
                                           --maintainer=brendan.ribera@gmail.com
sudo update-alternatives --install /usr/bin/ruby ruby /usr/bin/ruby1.9.2 500 \
                                                 --slave /usr/bin/ri ri /usr/bin/ri1.9.2 \
                                                  --slave /usr/bin/irb irb /usr/bin/irb1.9.2 \
                                                  --slave /usr/bin/erb erb /usr/bin/erb1.9.2 \
                                                  --slave /usr/bin/rdoc rdoc /usr/bin/rdoc1.9.2
sudo update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.9.2 500
Next, run the script
chmod +x install-ruby.sh
./install-ruby.sh

After the install finishes, type ruby -v. You should see the ruby interpreter output 1.9.2p290 (or later).
$ ruby -vruby 1.9.2p290 (2011-07-09 revision 32553)

2 scripts blijkbaar te gebruiken om Ruby te installeren?
Wat is er mis met de huidige 2 scripts die Ruby moeten installerenop de server ?
 

Offline janamdo

  • Lid
Re: Ruby installeren op Ubuntu 10.04.4 LTS server
« Reactie #1 Gepost op: 2012/12/07, 15:32:19 »
Krijg het niet voor elkaar om Ruby te installeren..
Na server update ..zou eerst ..
sudo apt-get install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5 gcc checkinstall libreadline5 libyaml-0-2 (1)(1)

Daarna een script (2)
sudo apt-get -y install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5
cd /tmp
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xvzf ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure --prefix=/usr\
            --program-suffix=1.9.2\
            --with-ruby-version=1.9.2\
            --disable-install-doc
make
sudo checkinstall -D -y\
                  --fstrans=no\
                  --nodoc\                         --pkgname='ruby1.9.2'\
                  --pkgversion='1.9.2-p290'\
                  --provides='ruby'\
                  --requires='libc6,libffi5,libgdbm3,libncurses5,libreadline5,openssl,libyaml-0-2,zlib1g'\
                  --maintainer=brendan.ribera@gmail.com
sudo update-alternatives --install/usr/bin/ruby ruby /usr/bin/ruby1.9.2 500\
                         --slave /usr/bin/ri ri /usr/bin/ri1.9.2\
                         --slave /usr/bin/irb irb /usr/bin/irb1.9.2\
                         --slave /usr/bin/gem gem /usr/bin/gem1.9.2\             
                         --slave /usr/bin/erb erb /usr/bin/erb1.9.2\
                         --slave /usr/bin/rdoc rdoc /usr/bin/rdoc1.9.2
De sever installeert wel , maar komt niet met de boodschao dat Ruby is geinstalleerd.. en commando ruby -v levert niets op.
Wat zou hier nu fout gaan ?
Deze bovenstaande scriptcode heb ik van eenvideotutorial die bij de geschreven tutorial zit
De geschreven tutorial laat een ander script zien ?
2. Install Ruby¶

The record and playback infrastructure uses Ruby for the processing of recorded sessions.

First, you'll need to install the following dependencies to compile ruby.
sudo apt-get install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5 gcc checkinstall libreadline5 libyaml-0-2
Next, create a file called install-ruby.sh and copy and paste in the following script.

#!/bin/bash
cd /tmp
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xvzf ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure --prefix=/usr\
                     --program-suffix=1.9.2\
                     --with-ruby-version=1.9.2\
                     --disable-install-doc
make
sudo checkinstall -D -y\ 
                                            --fstrans=no\
                                            --nodoc\   
                                            --pkgname='ruby1.9.2'\
                                            --pkgversion='1.9.2-p290'\
                                            --provides='ruby'\
                                            --requires='libc6,libffi5,libgdbm3,libncurses5,libreadline5,openssl,libyaml-0-2,zlib1g'\
                                           --maintainer=brendan.ribera@gmail.com
sudo update-alternatives --install /usr/bin/ruby ruby /usr/bin/ruby1.9.2 500 \
                                                 --slave /usr/bin/ri ri /usr/bin/ri1.9.2 \
                                                  --slave /usr/bin/irb irb /usr/bin/irb1.9.2 \
                                                  --slave /usr/bin/erb erb /usr/bin/erb1.9.2 \
                                                  --slave /usr/bin/rdoc rdoc /usr/bin/rdoc1.9.2
sudo update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.9.2 500
Next, run the script
chmod +x install-ruby.sh
./install-ruby.sh

After the install finishes, type ruby -v. You should see the ruby interpreter output 1.9.2p290 (or later).
$ ruby -vruby 1.9.2p290 (2011-07-09 revision 32553)

2 scripts blijkbaar te gebruiken om Ruby te installeren?
Wat is er mis met de huidige 2 scripts die Ruby moeten installerenop de server ?

Offline janamdo

  • Lid
Re: Ruby installeren op Ubuntu 10.04.4 LTS server
« Reactie #2 Gepost op: 2012/12/07, 15:34:59 »
Krijg het niet voor elkaar om Ruby te installeren..
Na server update ..zou eerst ..
sudo apt-get install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5 gcc checkinstall libreadline5 libyaml-0-2 (1)(1)

Daarna een script (2)
sudo apt-get -y install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5
cd /tmp
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xvzf ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure --prefix=/usr\
            --program-suffix=1.9.2\
            --with-ruby-version=1.9.2\
            --disable-install-doc
make
sudo checkinstall -D -y\
                  --fstrans=no\
                  --nodoc\                         --pkgname='ruby1.9.2'\
                  --pkgversion='1.9.2-p290'\
                  --provides='ruby'\
                  --requires='libc6,libffi5,libgdbm3,libncurses5,libreadline5,openssl,libyaml-0-2,zlib1g'\
                  --maintainer=brendan.ribera@gmail.com
sudo update-alternatives --install/usr/bin/ruby ruby /usr/bin/ruby1.9.2 500\
                         --slave /usr/bin/ri ri /usr/bin/ri1.9.2\
                         --slave /usr/bin/irb irb /usr/bin/irb1.9.2\
                         --slave /usr/bin/gem gem /usr/bin/gem1.9.2\             
                         --slave /usr/bin/erb erb /usr/bin/erb1.9.2\
                         --slave /usr/bin/rdoc rdoc /usr/bin/rdoc1.9.2
De sever installeert wel , maar komt niet met de boodschao dat Ruby is geinstalleerd.. en commando ruby -v levert niets op.
Wat zou hier nu fout gaan ?
Deze scriptcode hierboven heb ik van eenvideotutorial die bij de geschreven tutorial zit

De geschreven tutorial laat een ander script hieronder zien om ruby te installeren.


2. Install Ruby¶

The record and playback infrastructure uses Ruby for the processing of recorded sessions.

First, you'll need to install the following dependencies to compile ruby.
sudo apt-get install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5 gcc checkinstall libreadline5 libyaml-0-2
Next, create a file called install-ruby.sh and copy and paste in the following script.

#!/bin/bash
cd /tmp
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xvzf ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure --prefix=/usr\
                     --program-suffix=1.9.2\
                     --with-ruby-version=1.9.2\
                     --disable-install-doc
make
sudo checkinstall -D -y\ 
                                            --fstrans=no\
                                            --nodoc\   
                                            --pkgname='ruby1.9.2'\
                                            --pkgversion='1.9.2-p290'\
                                            --provides='ruby'\
                                            --requires='libc6,libffi5,libgdbm3,libncurses5,libreadline5,openssl,libyaml-0-2,zlib1g'\
                                           --maintainer=brendan.ribera@gmail.com
sudo update-alternatives --install /usr/bin/ruby ruby /usr/bin/ruby1.9.2 500 \
                                                 --slave /usr/bin/ri ri /usr/bin/ri1.9.2 \
                                                  --slave /usr/bin/irb irb /usr/bin/irb1.9.2 \
                                                  --slave /usr/bin/erb erb /usr/bin/erb1.9.2 \
                                                  --slave /usr/bin/rdoc rdoc /usr/bin/rdoc1.9.2
sudo update-alternatives --install /usr/bin/gem gem /usr/bin/gem1.9.2 500
Next, run the script
chmod +x install-ruby.sh
./install-ruby.sh

After the install finishes, type ruby -v. You should see the ruby interpreter output 1.9.2p290 (or later).
$ ruby -vruby 1.9.2p290 (2011-07-09 revision 32553)

2 scripts blijkbaar te gebruiken om Ruby te installeren?
Wat is er mis met de huidige 2 scripts die Ruby moeten installeren op de server ?

Offline janamdo

  • Lid
Re: Ruby installeren op Ubuntu 10.04.4 LTS server
« Reactie #3 Gepost op: 2012/12/07, 19:59:27 »
Eri s fout gegaan hier met de post..het hoeft maar één keer natuurlijk gepost worden..dus de andere 2 kunnen verwijderd worden

Offline janamdo

  • Lid
Re: Ruby installeren op Ubuntu 10.04.4 LTS server
« Reactie #4 Gepost op: 2012/12/07, 22:33:29 »
Verder speuren op het forum van de ontwikkelaar over de installatie van Ruby levert mogelijk de oplossing
inderdaad deze foutmelding heb ik ook gezien dacht ik bij het uitvoeren v/h script
-------------------------------------------------------------------------------------------------------------------------------------
Hi Maurice,

>  -bash: ./install-ruby.sh: /bin/bash^M: bad interpreter: no such file or directory


That was the clue.  You are saving the bash script as a DOS text file (carriage return + line feed) and bash will not accept it as a valid script.

If you save it as a UNIX text file (line feed), it will work.

--------------------------------------------------------------------------------------------------------------------------------------
De script heb ik in nano geplakt en ik begrijp nu dat er een "bash"scripting taal word gebruikt.
 
Nano ( console editor) informatie in betrekking tot het gebruik van het uitvoeren van een unix text file :
Citaat
If you need to use a text editor from the command line, you can use nano, which is a simple to use text editor. When running it from the command line, always use the following command, which ensures that the editor will not introduce line breaks:

nano -w

Ik heb het advies hier op het forum gekregen om nano te gaan gebruiken, maar hoe zit nu precies met de scripttaal Bash en  nano editor om de code regels als UNIX text file opte slaan ?
Je kunt het script saven en dan aangeven in nano editor dat het als een UNIX bestand opgeslagen moet worden, maar dit heb ik nog niet kunnen vinden.
Inmiddels heb ik het wel gevonden : converted from Mac format

Nou heb het script  nog niet aan de gang gekregen in nano..ik ga maar eerst eens proberen om een klein voorbeeldscriptje via het internet te maken in de nanoeditor..als dat werkt dan weet ik de workflow in nano en in putty
Dit is ookeen drama, want er zijn tientallem  my world bash scripts en allemaal verschillend

 
« Laatst bewerkt op: 2012/12/08, 20:18:33 door janamdo »

Offline janamdo

  • Lid
Re: Ruby installeren op Ubuntu 10.04.4 LTS server
« Reactie #5 Gepost op: 2012/12/12, 13:13:24 »
Ik ben er behoorlijk mee aan de slag gegaan met het script
Nu als root ingelogd op de server en het nano BBB(bigbluebutton) script opgeslagen in de "root" map die in de hoofdmap  van de server staat
Hieronder het script
Nadat ik alle eerste vereiste bestanden heb ingeladen ..en dat ziet er zonder foutmeldingen goed uit..dan begonnen door in nano  bbb.sh op te slaan en bbb.sh komt in de root map te staan (root@server01:~#)
daarna
-   chmod +x bbb.sh
-    ./bbb.sh

De installatie lijkt de gehele tijd goed te verlopen en ik krijg de indruk dat het gaat lukken
maar dan komt er een foutmelding!
./bbb.sh: line 23: --slave: command not found
Wat gaat hier mis ?
- it means that Linux or UNIX searched for command everywhere it knew to look and could not find a program by that name
- Another cause is you misspelled the command name (typo)
- or administrator does not at all install the command on your Linux/UNIX based system.
Nog maar een paar compileer vereisten er random opgezet, maar de foutmelding blijft
Kan ook te maken hebben dat ik het script toch niet vanuit usr/bin draai...? en vanuit een rootmap is niet mogelijk zonder symlink?..dus ik moet een symlink maken met de rootmap en binmap.
Kan ook het script ... installeren het script in de USR/Bin  met sado nano waar ik het pad kan opgeven 
of nog handiger naar de map Bin toegaan en daar nano openen en dan saven..dat lijkt me het gemakkelijkst.

BBB is open source software, maar het is moeilijk om het te installeren en als het fout gaat zal je een gevorderde linux gebruiker moet zijn.

Hoe moet ik als adminstrator ( wanneer ben je dat? ..als je zoals ik de server installeert en inlogt met root as user ?)..uitzoeken..ligt niet aan het script dan 




bbb.sh in nano opgeslagen in rootmap
#!/bin/bash
sudo apt-get -y install zlib1g-dev libssl-dev libreadline5-dev libyaml-dev build-essential bison checkinstall libffi5
cd /tmp
wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p290.tar.gz
tar xvzf ruby-1.9.2-p290.tar.gz
cd ruby-1.9.2-p290
./configure --prefix=/usr\
            --program-suffix=1.9.2\
            --with-ruby-version=1.9.2\
            --disable-install-doc
make
sudo checkinstall -D -y\
                  --fstrans=no\
                  --nodoc\                         --pkgname='ruby1.9.2'\
                  --pkgversion='1.9.2-p290'\
                  --provides='ruby'\
                  --requires='libc6,libffi5,libgdbm3,libncurses5,libreadline5,openssl,libyaml-0-2,zlib1g'\
                  --maintainer=brendan.ribera@gmail.com
sudo update-alternatives --install/usr/bin/ruby ruby /usr/bin/ruby1.9.2 500\
                         --slave /usr/bin/ri ri /usr/bin/ri1.9.2\
                         --slave /usr/bin/irb irb /usr/bin/irb1.9.2\
                         --slave /usr/bin/gem gem /usr/bin/gem1.9.2\             
                         --slave /usr/bin/erb erb /usr/bin/erb1.9.2\
                         --slave /usr/bin/rdoc rdoc /usr/bin/rdoc1.9.2
« Laatst bewerkt op: 2012/12/12, 15:25:23 door janamdo »

Offline janamdo

  • Lid
Re: Ruby installeren op Ubuntu 10.04.4 LTS server
« Reactie #6 Gepost op: 2012/12/12, 17:04:58 »
Ok ..eindelijk heb ik Ruby op de server staan!!... via de developer van BBB het script gedownload ivm copy en paste probleem (UNIXregels)!
Inmiddels heb ik random wat compileer commando's erop gezet en met de code van de developer lukte het om ruby op de server te krijgen

Kan ik niet zeggen dat het gestructeerd gaat de installatie van Ruby en of opnieuw installeren gaat lukken ..als laatste stap moest ik een Gem pakket erop zetten maar die liep ook vast..nakijken op het forum van de developer liet dezelfde fout zien ..en het gem pakket zou er niet volledig op staan?..dus dat is weer foutzoeken op de server.

Zal weer met een schone installatie moeten beginnen..voordat ik dat package management beheers?


« Laatst bewerkt op: 2012/12/12, 17:07:02 door janamdo »

Offline janamdo

  • Lid
Re: Ruby installeren op Ubuntu 10.04.4 LTS server
« Reactie #7 Gepost op: 2012/12/12, 18:50:38 »
Ok  BBB staat op de server  http://91.233.105.234/ en draait normaal en kan ik m integreren in een Wordpress website
Wat een nare installatie zeg.. was genoodzaakt om helemaal de basisbeginselen van lunix me eigen te maken
Ik heb toch aardig wat kunnen leren /instuderen..trial and error.
Gelukkig vroeger ms dos gedaan, dus kon daar nog gebruik van maken van die kennis

Nadat ik het juiste script had gedownload liep de installatie verder probleemloos..phh
Bedankt voor de uitleg hier!
« Laatst bewerkt op: 2012/12/12, 21:39:24 door janamdo »