Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: telkens I/O error na installatie  (gelezen 1572 keer)

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
telkens I/O error na installatie
« Gepost op: 2012/11/16, 20:00:16 »
Ik heb sinds ik enige tijd geleden volledig over ben gegaan op Ubuntu steeds een probleem.
Nadat de installatie 2 dagen heft gedraaid krijg ik tijdens het opstarten de foutmelding dat / niet aangekoppeld kan worden. Daarna dat /tmp niet aangemeld kan worden. Als ik daarna de recovery mode opstart krijg ik bij de schijf controle de fout: I/O error, dev sda, sector 400542 (het getal is niet echt.

Weet iemand wat ik hier aan kan doen?

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #1 Gepost op: 2012/11/16, 21:31:11 »
Ga de gezondheid van je HDD even na:
sudo smartctl -a /dev/sdaMocht dat niet "Passed" zijn, dan éérst je data redden naar een andere HDD; pas als dat gebeurd is , hier het advies krijgen een nieuwe HDD te kopen.
Je kunt de SMART-status overigens ook te zien krijgen via Toepassingen --> hulpmiddelen --> Schijfgereedschap en dan je HDD selecteren. (rechterkolom, redelijk bovenaan)
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #2 Gepost op: 2012/11/16, 21:48:39 »
Bedankt voor je antwoord. Er zijn inderdaad een aantal slechte sectoren gedetecteerd.

Wel vervelend met een laptop die net 3 maanden oud is.

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #3 Gepost op: 2012/11/16, 21:55:12 »
Op naar de garantiebepalingen en laat je niet met een kluit in het riet sturen!!
Dit is een wezenlijke bekorting van de levensverwachting en -duur  van je HDD.
Bovendien mag je verwachten dat een HDD langer meegaat dan 3 maanden.
Misschien wil je melden welke laptop (merk, type, aankoopwijze en -winkel), zodat anderen misschien hun mening kunnen geven over de garantieafwikkeling door de verkoper.
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #4 Gepost op: 2012/11/16, 21:57:22 »
Ik heb een ASUS-N53SV gekocht bij Coolblue webshop. Heb al een mailtje gestuurd voor de garantie. Ik neem het niet dat mijn laptop die niet al te goedkoop was het nu al begeeft.

Nu snel al mijn data veilig stellen wat altijd al voor 98% gedaan is.

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #5 Gepost op: 2012/11/17, 09:50:40 »
Citaat
Ik neem het niet dat mijn laptop die niet al te goedkoop was het nu al begeeft.
Dat mag je wel zo zeggen, zowel qua prijs als qua levensduur.
Succes!!
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #6 Gepost op: 2012/11/17, 14:15:10 »
Ga de gezondheid van je HDD even na:
sudo smartctl -a /dev/sdaMocht dat niet "Passed" zijn, dan éérst je data redden naar een andere HDD; pas als dat gebeurd is , hier het advies krijgen een nieuwe HDD te kopen.
Je kunt de SMART-status overigens ook te zien krijgen via Toepassingen --> hulpmiddelen --> Schijfgereedschap en dan je HDD selecteren. (rechterkolom, redelijk bovenaan)

Ik heb deze actie nog eens gedaan en nu komt er wel passed uit. Ik vind dit eigenlijk best wel vreemd. Zou het ook nog door iets anders kunnen komen?

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #7 Gepost op: 2012/11/17, 15:12:55 »
Ga de gezondheid van je HDD even na:
sudo smartctl -a /dev/sdaMocht dat niet "Passed" zijn, dan éérst je data redden naar een andere HDD; pas als dat gebeurd is , hier het advies krijgen een nieuwe HDD te kopen.
Je kunt de SMART-status overigens ook te zien krijgen via Toepassingen --> hulpmiddelen --> Schijfgereedschap en dan je HDD selecteren. (rechterkolom, redelijk bovenaan)

Ik heb deze actie nog eens gedaan en nu komt er wel passed uit. Ik vind dit eigenlijk best wel vreemd. Zou het ook nog door iets anders kunnen komen?

Bij mij is grofweg hetzelfde aan de hand. Ik krijg ook weleens dat soort meldingen (i/o error op bepaalde sector) maar SMART-tests slagen altijd, ook de uitgebreide van > 2 uur. Zelfs het officiele controleprogramma van Western Digital gaf hier aan dat de schijf ok was. Er zijn wel meer mensen met HDD-gerelateerde problemen in Linux: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550559 die toch niet allemaal aan hardware toe te schrijven zijn. Ik heb op dezelfde PC Windows staan en daar nooit meldingen dat er iets met de schijf mis is. Samengevat: Harde Schijf 'kapot' zou kunnen, maar het probleem kan ook bij de Linuxkernel liggen. Een pasklare oplossing heb ik helaas niet.

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #8 Gepost op: 2012/11/17, 20:24:33 »
N.a.v. deze topic ook maar eens gekeken naar de staat van m 'n harde schijf, deze is nu iets meer dan een jaar oud.
Resultaat:


15 slechte sectoren, het vreemde is dat met een Surface test in Windows geen bad sectors worden gevonden. 
 

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #9 Gepost op: 2012/11/17, 20:42:08 »
Mijn schrijf heeft 2711 slechte sectoren en is +- 3 maanden oud.

Dus:
Of de Windows check klopt niet
Of de Ubuntu check klopt niet
Of Ubuntu geeft sneller aan dat de sector slecht is

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #10 Gepost op: 2012/11/17, 21:18:50 »
Of ik heb er overheen gelezen, of ik zie écht nergens het merk van je HDD staan.
Als deze HDD met het tooltje van de fabrikant in Linux resp.  in  Windows verschillende resultaten geeft, zou ik een mailtje met deze resultaten naar de fabrikant sturen en een kijken wat die ervan zegt.
{Wijs de fabrikant er desnoods op dat het antwoord "Linux wordt niet ondersteund", ook naar een forum gaat}
Blijf wel fanatiek backuppen!!
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #11 Gepost op: 2012/11/17, 21:54:28 »
Mijn schrijf heeft 2711 slechte sectoren en is +- 3 maanden oud.
Dat zijn er wel erg veel. Weet je zeker dat terwijl de laptop aanstond, deze niet al te abrupt werd bewogen. Dat zou ook slechte sectoren kunnen veroorzaken. Heb je verder  al gecheckt, of je de harddisk kunt testen in het BIOS? Die optie heb ik namelijk in het BIOS, van de Lenovo laptop uit mijn onderschrift. Eventueel zou je de Ultimate Boot CD kunnen downloaden. Daarop staan diagnostische software voor verschillende harddisk merken. Pas als deze diagnostische software fouten vind in de harddisk, zou je in aanmerking kunnen komen voor garantie.

Zoals dat bijvoorbeeld bij mij het geval was, met de laptop uit mijn onderschrift. Zie voor info mijn topic op het Salland Automatisering forum Probleem met harddisk nieuwe laptop.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #12 Gepost op: 2012/11/17, 22:09:39 »
Of ik heb er overheen gelezen, of ik zie écht nergens het merk van je HDD staan.
Als deze HDD met het tooltje van de fabrikant in Linux resp.  in  Windows verschillende resultaten geeft, zou ik een mailtje met deze resultaten naar de fabrikant sturen en een kijken wat die ervan zegt.
{Wijs de fabrikant er desnoods op dat het antwoord "Linux wordt niet ondersteund", ook naar een forum gaat}
Blijf wel fanatiek backuppen!!

Het merk HDD is Seagate. Het is inmiddels een week geleden dat ik Windows draaide. De check in windows is iets langer geleden. Een tooltje kan ik zo snel niet vinden.


Mijn schrijf heeft 2711 slechte sectoren en is +- 3 maanden oud.
Dat zijn er wel erg veel. Weet je zeker dat terwijl de laptop aanstond, deze niet al te abrupt werd bewogen. Dat zou ook slechte sectoren kunnen veroorzaken. Heb je verder  al gecheckt, of je de harddisk kunt testen in het BIOS? Die optie heb ik namelijk in het BIOS, van de Lenovo laptop uit mijn onderschrift. Eventueel zou je de Ultimate Boot CD kunnen downloaden. Daarop staan diagnostische software voor verschillende harddisk merken. Pas als deze diagnostische software fouten vind in de harddisk, zou je in aanmerking kunnen komen voor garantie.

Zoals dat bijvoorbeeld bij mij het geval was, met de laptop uit mijn onderschrift. Zie voor info mijn topic op het Salland Automatisering forum Probleem met harddisk nieuwe laptop.

Dat het er veel zijn klopt (ik weet niet wat normaal is op deze leeftijd want ik heb er eerder nooit naar gekeken). Ik zal de Ultimate Boot CD eens proberen.

Ik heb nooit mijn laptop, als deze aan staat, altijd stil op een tafel staan dus aan beweging kan het niet liggen.


Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #13 Gepost op: 2012/11/18, 00:05:36 »
Mijn schrijf heeft 2711 slechte sectoren en is +- 3 maanden oud.
Dat zijn er wel erg veel. Weet je zeker dat terwijl de laptop aanstond, deze niet al te abrupt werd bewogen. Dat zou ook slechte sectoren kunnen veroorzaken. Heb je verder  al gecheckt, of je de harddisk kunt testen in het BIOS? Die optie heb ik namelijk in het BIOS, van de Lenovo laptop uit mijn onderschrift. Eventueel zou je de Ultimate Boot CD kunnen downloaden. Daarop staan diagnostische software voor verschillende harddisk merken. Pas als deze diagnostische software fouten vind in de harddisk, zou je in aanmerking kunnen komen voor garantie.

Zoals dat bijvoorbeeld bij mij het geval was, met de laptop uit mijn onderschrift. Zie voor info mijn topic op het Salland Automatisering forum Probleem met harddisk nieuwe laptop.
Op de Ultimate Boot CD staat een Linux distro: PartdedMagic waar een HD Surface test op staat, momenteel loopt deze test bij mij. De test duurt uren, het resultaat zie ik morgen wel. Grappig, tijdens de test kan je gewoon internetten, in PartdedMagic zit standaard Firefox  :D

Offline cjmanschot

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #14 Gepost op: 2012/11/18, 01:52:58 »
Mijn eigen ervaring is dat die tooltjes, zowel onder Windows als onder linux niet altijd de juiste waarden aangeven, of verschillende uitkomsten. Ook bij het uitlezen van de smart-status. Wat ik zelf altijd doe is met een Live-cd opstarten en dan in de terminal:
sudo badblocks -v /dev/sda , intikken en dan kijken of er cijferreeksen getoond worden in de terminal, daar is de -v (verbose) optie voor. zie je geen cijferreeksen dan eindigt de terminaluitvoer met: no badblocks found, ok dus.

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #15 Gepost op: 2012/11/18, 10:12:00 »
Resultaat van de complete disk surface and performs various test routines : Completed without errors
Dus ook met Ultimate Boot CD geen bad sectors.
Bram, test je schijf eens met de  Ultimate Boot CD , de test heeft bij mij ongeveer 4 uur geduurd

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #16 Gepost op: 2012/11/18, 10:24:58 »
Resultaat van de complete disk surface and performs various test routines : Completed without errors
Dus ook met Ultimate Boot CD geen bad sectors.
Bram, test je schijf eens met de  Ultimate Boot CD , de test heeft bij mij ongeveer 4 uur geduurd

Heb je een SMART-test gedaan of het diagnoseprogramma van de fabrikant? SMART-test kun je net zo goed vanuit Ubuntu zelf doen maar het programma van de fabrikant moet je idd vanaf een opstart-CD uitvoeren. Zelf heb ik die van WD gedraaid en dat duurde ook erg lang. Geen fouten gevonden dus ondanks dat ik wel van die i/o-errors van de kernel krijg af en toe.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #17 Gepost op: 2012/11/18, 10:47:00 »
Probeer eens de hd's aan te sluiten, op je hoofd controller, meestal 4 sata poorten. De extra 2 soms sata600 poorten laat deze vrij.
En test je pc eens.

Dan heb je nog dat ssd's problemen kunnen hebben, probeer zonder ssd of probeer een andere poort.

Misschien kun je iets met boot opties doen, maar dan zou je je hardware moeten gaan opzoeken op google tav linux.
https://help.ubuntu.com/community/BootOptions

http://forums.debian.net/viewtopic.php?f=7&t=80238
Misschien groene schijven die in snel in slaap gaan en ubuntu start deze weer op. Laat de schijf de hele tijd iets doen zonder in slaap te vallen, en kijk of er errors komen.
Zelf heb ik een green wd schijf, de tijd verhoogt met wd software, in de schijf heb ik de software gewijzigd, naar de hoogste stand. Mijn schijf was steeds uit aan aan het gaan, met smart kun je dit uitlezen.
« Laatst bewerkt op: 2012/11/18, 11:09:03 door jan11000 »

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #18 Gepost op: 2012/11/18, 13:08:10 »
Resultaat van de complete disk surface and performs various test routines : Completed without errors
Dus ook met Ultimate Boot CD geen bad sectors.
Bram, test je schijf eens met de  Ultimate Boot CD , de test heeft bij mij ongeveer 4 uur geduurd

Heb je een SMART-test gedaan of het diagnoseprogramma van de fabrikant? SMART-test kun je net zo goed vanuit Ubuntu zelf doen maar het programma van de fabrikant moet je idd vanaf een opstart-CD uitvoeren. Zelf heb ik die van WD gedraaid en dat duurde ook erg lang. Geen fouten gevonden dus ondanks dat ik wel van die i/o-errors van de kernel krijg af en toe.
De Ultimate Boot cd heeft verschillende opties om je HD te testen, voor een Samsung kan je de software van de fabrikant gebruiken, in mijn geval estool.
Vraag mij af: waarom heeft schijfbeheer in Ubuntu wel slechte sectoren gevonden..

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #19 Gepost op: 2012/11/19, 16:49:26 »
Ik zal de test van Ultimate Boot CD in het weekend draaien.

(Het kan toch niet aan de boot optie UEFI liggen?)

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #20 Gepost op: 2012/11/19, 17:51:13 »
Ik zal de test van Ultimate Boot CD in het weekend draaien.

(Het kan toch niet aan de boot optie UEFI liggen?)
Of je problemen ontstaan door UEFI weet ik niet, maar ......
http://webwereld.nl/nieuws/108001/windows-8-blokkeert-linux-en-drivers.html
http://webwereld.nl/nieuws/108042/-windows-8-blokkeert-linux-in-de-praktijk-w-l-.html

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #21 Gepost op: 2012/11/19, 21:03:02 »
Ik zal de test van Ultimate Boot CD in het weekend draaien.

(Het kan toch niet aan de boot optie UEFI liggen?)
Of je problemen ontstaan door UEFI weet ik niet, maar ......
http://webwereld.nl/nieuws/108001/windows-8-blokkeert-linux-en-drivers.html
http://webwereld.nl/nieuws/108042/-windows-8-blokkeert-linux-in-de-praktijk-w-l-.html

Ja maar daar krijg je niet opeens slechte sectoren van op je schijf. Als UEFI in de weg zit dan zou je Linux niet eens gestart/geïnstalleerd krijgen. Misschien interessant leesvoer voor TS maar niet echt relevant denk ik.

Offline RikRik

  • Lid
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #22 Gepost op: 2012/11/19, 21:16:25 »
Ik zal de test van Ultimate Boot CD in het weekend draaien.

(Het kan toch niet aan de boot optie UEFI liggen?)
Of je problemen ontstaan door UEFI weet ik niet, maar ......
http://webwereld.nl/nieuws/108001/windows-8-blokkeert-linux-en-drivers.html
http://webwereld.nl/nieuws/108042/-windows-8-blokkeert-linux-in-de-praktijk-w-l-.html

Ja maar daar krijg je niet opeens slechte sectoren van op je schijf. Als UEFI in de weg zit dan zou je Linux niet eens gestart/geïnstalleerd krijgen. Misschien interessant leesvoer voor TS maar niet echt relevant denk ik.
Ik heb geen idee hoor maar er staat bijvoorbeeld:
Deze certificaatverplichting geldt voor het besturingssysteem zelf, wat Linux mogelijk de pas afsnijdt. Daarnaast geldt dit voor programmatuur die bij het opstarten meelift. Gewone applicaties vallen hier dus niet onder, maar drivers voor hardwarecomponenten weer wel.

Offline bram.eikelboom

  • Lid
    • B-boom webhosting & webdesign
  • Steunpunt: Nee
Re: telkens I/O error na installatie
« Reactie #23 Gepost op: 2012/11/19, 21:24:15 »
Ik zie nu iets opmerkelijks.

Als ik bij het schijfgereedschap kijk naar bad blocks staat daar Defect (lezen)

Maar als ik via de terminal het commando sudo badblocks -v /dev/sda uitvoer komt daar uit dat er 20 bad blocks zijn gevonden.

sudo smartctl -a /dev/sda geeft nog steeds passed.

PS ik heb UEFI voor de zekerheid maar uit gezet