Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Webcam: Trust 120spacecom; Storing na upgrade P. Pangolin 12.04.(Niet opgelost!)  (gelezen 1789 keer)

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
De Terminal geeft aan na intikken: lsusb

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0c45:600d Microdia TwinkleCam USB camera

Kan iemand mij helpen?
f.schuijff
« Laatst bewerkt op: 2013/02/05, 11:37:49 door f.schuijff »

Offline joop905

  • Lid
  • Steunpunt: Nee
 Je kan het eens proberen met Cheese.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Ik had in oude en in nieuwe versie zowel Cheese als Gucvieuw ter beschikking, daar is geen storing, wel bij camgebruik tijdens chatten.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
De storing: bovenste helft van beeld is goed,
                      onderste helft is volledig gestoord > (bewegende) gekleurde blokjes en balkjes.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Ik denk dat je de gspca driver moet hebben. Daar heb ik al menigeen webcam mee aan de gang  gekregen. 
Voor info http://www.kernel.org/doc/Documentation/video4linux/gspca.txt
En een adres voor easygspca.deb te downloaden, als deze versie niet werkt voor jouw Ubuntu, moet je even kijken of er wel een juiste versie is. Dit programma kijkt welke webcam er is en installeert vervolgens de driver.
http://packages.ubuntu.com/hardy/all/gspca-source/download

« Laatst bewerkt op: 2012/11/10, 11:46:30 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Reacties tot heden onvoldoende.
Ik denk dat een oplossing nodig heb voor in de Terminal!?!
Hulp is gewenst.

Offline Brumm3l

  • Lid
  • Steunpunt: Nee
Reacties tot heden onvoldoende.
Ik denk dat een oplossing nodig heb voor in de Terminal!?!
Hulp is gewenst.

De oplossingen die Gijsbert aanraadde werkten niet? Heb je beide opties geprobeerd?

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Hallo Gijsbert en Brumm3l,

Bedankt voor jullie inbreng. In 1e instantie begreep ik bij beide opties/ideeën niet wat ik er mee aan moest.
Nu ben ik met de 1e optie aan de slag gegaan (viel best mee) en resultaat als volgt:
~$ deb http://ubuntu.mirror.cambrium.nl/ubuntu/ hardy main universe
Opdracht ‘deb’ niet gevonden, bedoelde u:
 Opdracht ‘debc’ uit pakket ‘devscripts’ (main)
 Opdracht ‘derb’ uit pakket ‘libicu-dev’ (main)
 Opdracht ‘dab’ uit pakket ‘bsdgames’ (universe)
 Opdracht ‘debi’ uit pakket ‘devscripts’ (main)
 Opdracht ‘xdeb’ uit pakket ‘xdeb’ (universe)
deb: opdracht niet gevonden
Wat betekent dit, had ik iets anders moeten doen? Graag uitleg/hulp.
Heb eerst het betreffende mirror-bestandje gedownload.
PS: Wat is mirror?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Deze regel deb http://ubuntu.mirror.cambrium.nl/ubuntu/hardy main universe ik heb even de spatie voor hardy verwijdert, pas je alleen toe om een softwarebron toe te voegen.
Als je deze pagina opent http://packages.ubuntu.com/hardy/all/gspca-source/download kan je onder het kopje Europe op deze link klikken en start de download nl.archive.ubuntu.com/ubuntu Als je het pakket gspca-source dus, gaat installeren, komt er een melding dat er extra pakketten worden geïnstalleerd.
In deze link staat hoe je Easycam 2 moet installeren http://www.unixmen.com/install-webcam-drivers-with-easycam-2/
« Laatst bewerkt op: 2012/11/10, 11:47:11 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Hoy Gijsbert,

Jouw deb commandoregel heb ik uitgeprobeert > werkt niet.
Vervolgens aangepast naar "precise main universe" en "precise main" en "precise universe" > werkt ook niet.
Jouw http:/....../gspca > lukt mij niet. Wellicht niet geschikt voor ¨Microdia Twinklecam USB camera" onder driver: v4l2 ?
Jouw http:/.../easycam > geeft alleen optie voor Hardy niet voor Precise Pangolin.
Vervolgens heb ik Cheese verwijderd > maakt geen verschil.
Vervolgens ook Guvcview verwijderd waar hij in Lucid goed op draaide > tot mijn verbazing blijft verstoorde cam gewoon doorlopen onder precise pangolin. Welk programma loopt hij nu eigenlijk op?

Inmiddels besloten om mijn softwarecentrum-upgrade te vervangen door volledige herinstallatie vanuit iso-bestand.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Het is geen regel voor in de terminal maar voor een softwarebron toe te voegen. Open softwarebronnen:


Vervolgens op toevoegen klikken, dan krijg je een veld om de apt regel in te vullen, hier komt de regel:





En klaar:

Nu de softwarebronnen opnieuw laden.


« Laatst bewerkt op: 2012/11/10, 11:48:22 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Aanpassing softwarebronnen uitgevoerd > "downloaden is mislukt".
Nogmaals met hardy vervangen door precise > "downloaden is mislukt".

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Ik het zelf nog eens uitgetest op Ubuntu 12.10 er wordt maar een deel geïnstalleerd van Easycam. Ook kwam ik nog tegen op internet dat Eascam2 niet te installeren is op 12.04 en hoger i.v.m. het ontbreken van bibliotheken. Helaas zonde van de moeite, vandaar alles doorgestreept. We gaan een andere poging wagen.
Geef dit commando in de terminal lsmod | grep videodev kan je de uitkomst hier vermelden?




In der Beschränkung zeigt sich der Meister.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Op " lsmod | grep videodev " volgt in terminal géén reactie !

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Tevens de extra aangevulde én niet bruikbare broncodes weer verwijderd.
Deze broncode: "Medibuntu (source) - Ubuntu 12.04 "precise pangolin (http:/....Broncode)" staat (standaard) uit, ik neem aan dat dat zo moet blijven !?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Op " lsmod | grep videodev " volgt in terminal géén reactie !
Vreemd, ik heb nu geen camera er aanhangen, maar wel een tv-kaart, voor jou zou er iets soort gelijk eruit moeten komen:
$ lsmod | grep videodev
videodev              120309  3 tuner,saa7134,v4l2_common
En daar gaat het om v4l2 , de videodriver of er staat v4l, oudere driver dus.
Dan mis je toch een driver, geef dit commando eens in de terminal sudo modprobe -l | grep gspca
Kan je de uitkomst hier plaatsen?
Als deze module in de lijst staat gspca_sonixb kan je deze installeren met sudo modprobe gspca_sonixb
Tevens de extra aangevulde én niet bruikbare broncodes weer verwijderd.
Deze broncode: "Medibuntu (source) - Ubuntu 12.04 "precise pangolin (http:/....Broncode)" staat (standaard) uit, ik neem aan dat dat zo moet blijven !?
Dat kan zo blijven, Medibuntu is de Ubuntu versie met extra multimedia pakketten.
In der Beschränkung zeigt sich der Meister.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Sorry ik was vanmiddag vergeten dat webcam losgekoppeld was (ivm. USB-stick bootable maken).
lsmod | grep videodev  >  videodev       86588  1 gspca_main
sudo modprobe -l | grep gspca  >  o.a.
kernel/drivers/media/video/gspca/gspca_main.ko
kernel/drivers/media/video/gspca/gspca_sonixb.ko
kernel/drivers/media/video/gspca/gspca_sonixj.ko
sudo modprobe gspca_sonixb  >  vraagt ww + enter > geeft geen reactie !? Ook geen updates via updatebeheer.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Sorry ik was vanmiddag vergeten dat webcam losgekoppeld was (ivm. USB-stick bootable maken).
lsmod | grep videodev  >  videodev       86588  1 gspca_main
sudo modprobe -l | grep gspca  >  o.a.
kernel/drivers/media/video/gspca/gspca_main.ko
kernel/drivers/media/video/gspca/gspca_sonixb.ko
kernel/drivers/media/video/gspca/gspca_sonixj.ko
sudo modprobe gspca_sonixb  >  vraagt ww + enter > geeft geen reactie !? Ook geen updates via updatebeheer.
Ais je het wachtwoord intypt zie je niets, gewoon blind typen en geef een ENTER. Dit commando activeert alleen de module in de kernel.
In der Beschränkung zeigt sich der Meister.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
""Ais je het wachtwoord intypt zie je niets, gewoon blind typen en geef een ENTER. Dit commando activeert alleen de module in de   kernel.""
Heb ik zo gedaan, geen verbetering in storing webcam.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Heb je de computer opnieuw opgestart? Na de opstart zou de kernel module geladen moeten worden.

ID volgens jou eerste post volgens lsusb 0c45:600d

http://www.kernel.org/doc/Documentation/video4linux/gspca.txt volgens deze site hoort de sonixb module erbij:
sonixb      0c45:600d   spcaCam@120

« Laatst bewerkt op: 2012/11/11, 09:36:31 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Na herinstall/upgraden:

Webcam = Trust Spacec@m 120
storing:  bovenste helft van beeld is goed,
                 onderste helft is volledig gestoord > (bewegende) gekleurde blokjes en balkjes.
http://www.kernel.org/doc/Documentation/video4linux/gspca.txt volgens deze site hoort de sonixb module erbij:  sonixb      0c45:600d   spcaCam@120

De Terminal geeft aan na intikken: lsusb
Bus 004 Device 002: ID 0c45:600d Microdia TwinkleCam USB camera

lsmod | grep videodev  >  videodev       86588  1 gspca_main

sudo modprobe -l | grep gspca  >  "onder andere"
kernel/drivers/media/video/gspca/gspca_main.ko
kernel/drivers/media/video/gspca/gspca_sonixb.ko
kernel/drivers/media/video/gspca/gspca_sonixj.ko
sudo modprobe gspca_sonixb  >  vraagt ww + enter

Na herstarten blijft de storing !?

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Deze al geprobeert ?
type (copy/paste) in een terminal:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
enter

Testing.............................
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Hallo, ik ben nu weer (na herinstallatie Xubuntu 12.04) verder op zoek naar de oplossing voor webcam-storing.

Idee van DeBaas: terminalopdracht: LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype + enter
uitgevoerd --> reactie:
ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
skype: opdracht niet gevonden

Wat zegt dit?

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
In term.opdr: LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype  staat v4l1 ipv.v4l2?

In Xubuntu-terminal staat: gspca_sonixb.ko  én  gspca_sonixj.ko
terwijl de chatsite hem herkent als: V4L2   ?!?

Offline f.schuijff

  • Lid
  • Steunpunt: Nee
Wellicht bruikbare info.
Gisteren bij kennis op zijn Windows-pc. mijn webcam uitgeprobeerd.
Moest hiervoor installeren: D-Link CIF Webcam.
Webcam werkte PRIMA.

Nu nog op Xubuntu !?