Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Zetten van UMASK  (gelezen 1962 keer)

Offline quick_snack

  • Lid
  • Steunpunt: Nee
Zetten van UMASK
« Gepost op: 2006/02/19, 03:26:23 »
Ik probeer binnen Breezy voor alle gebruikers een umask in te stellen van 0002.
Dit in het kader van groepstoegang op files (staat er verder los van).

Nu heb ik de umas ingesteld in /etc/profile en bij een aanmelding via een login krijgt ik dit keurig voor elkaar.

Als echter met GDM wordt aangemeld krijg ik bij het openen van een terminalvenster nog steeds 0022 als umask.

Binnen de .bash_profile van de userdir wordt gerefereerd naar /etc/login.defs maar daar wordt niets gezet.

Het enige wat ik nog kan doen is hem nog eens een keer vermelden in de ~/.bashrc (de  ~/.bash_profile werkt alleen bij login shells).

Weet iemand hier een meer structurele manier om deze te zetten? Als er meerdere users aangemaakt worden zou ik niet de hele tijd dit willen aanpassen (misschien een default ergens?).

Alvast bedankt!
Hmmmm. De server dappert de server-install.
In de huiskamer zijn de raampjes weer terug...

Offline quick_snack

  • Lid
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #1 Gepost op: 2006/02/19, 03:42:01 »
Uhhh, al gevonden: /etc/skel. Daar staan de files in die bij aanmaak van een user (via adduser maar wellicht ook via gnome) worden gekopieerd.

Dat is 1 ding maar misschien kan iemand me vertellen of het ergens anders beter kan worden ingesteld.

edit: typo
Hmmmm. De server dappert de server-install.
In de huiskamer zijn de raampjes weer terug...

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #2 Gepost op: 2006/02/19, 12:40:31 »
Leuk he profiles en environment variables. Afhankelijk van hoe je inlogt en wat je shell is ziet het er allemaal heel anders uit. Voor dapper+1 zijn er plannen om dit in Ubuntu te verbeteren maar voorlopig zit je vast aan het op veel plaatsen veranderen.

Offline quick_snack

  • Lid
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #3 Gepost op: 2006/02/19, 14:13:43 »
Ja, heel leuk maar ik zou graag willen weten waar die 0022 nu vandaan komt. Of is het standaard in de kernel gebakken of zo?
Hmmmm. De server dappert de server-install.
In de huiskamer zijn de raampjes weer terug...

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #4 Gepost op: 2006/02/19, 15:50:16 »
~/.bashrc
/etc/gdm/gdm.conf
/etc/bash.bashrc

Offline quick_snack

  • Lid
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #5 Gepost op: 2006/02/19, 16:11:04 »
Citaat van: Dennis
~/.bashrc
staat niets in, was tweede waar ik naar keek, zie eerdere post
Citaat
/etc/gdm/gdm.conf
staat niets in/kan niet vinden
Citaat
/etc/bash.bashrc
staat niet in, was eerste waar ik naar keek
Hmmmm. De server dappert de server-install.
In de huiskamer zijn de raampjes weer terug...

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #6 Gepost op: 2006/02/19, 18:17:58 »
~/.bash_profile
/etc/X11/Xsession.d (oid)
/etc/profile

Offline quick_snack

  • Lid
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #7 Gepost op: 2006/02/20, 02:17:02 »
Citaat van: Dennis
~/.bash_profile
staat niks in alleen verwijzing naar /etc/login.defs waar ook niets in staat
Citaat
/etc/X11/Xsession.d (oid)
heb gekeken in /etc/X11/Xsession en in de dir Xsession.d maar de files hierin bevatten ook niets. Wel wordt ~./.gnomerc gesourced maar die heb ik er niet in staan
Citaat
/etc/profile
in mijn eerste post zei ik al dat ik de umask hierin had aangepast naar 0002 maar dat dit alleen werkte voor logins

Bedankt voor je suggesties maar ik zal nog wel ff verder moeten zoeken. ;)
Hmmmm. De server dappert de server-install.
In de huiskamer zijn de raampjes weer terug...

Offline quick_snack

  • Lid
  • Steunpunt: Nee
Zetten van UMASK
« Reactie #8 Gepost op: 2006/02/20, 02:55:44 »
Mwah. Ik heb het voor elkaar denk ik. De umask 0022 wordt niet gezet maar schijnt default te zijn bij een GDM/Gnome sessie. Al wat gegoogled en er schijnt zelfs een bug te zijn dat Nautilus bij het creeren van files hier geen rekening mee houdt.

De aanpassing kreeg ik via een thread met een gnome-ontwikkelaar die suggereerde de setting te plaatsen in /etc/gdm/Xsession(die geldt als een soort moederfile voor alle sessies die daarna komen (Gnome, KDE etc.))

Vlak onder # initialize variables etc.moet dan een nieuwe regel worden aangemaakt met umask 0002.

Bij het starten van een terminalvenster geeft u nu gelukkig (en zonder aanpassing van de .bash.bashrc):
famxxxx@kajadaxxxx:~$ umask
0002
famxxxx@kajadaxxxx:~$
He he

edit:typo
Hmmmm. De server dappert de server-install.
In de huiskamer zijn de raampjes weer terug...