Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: VLC in PVR = Tv-analoog modus doet het niet meer  (gelezen 488 keer)

Offline blokkendoos

  • Lid
  • Steunpunt: Nee
VLC in PVR = Tv-analoog modus doet het niet meer
« Gepost op: 2012/10/29, 18:12:29 »
Sinds de installatie van Ubuntu 12.04 op mijn machine met televisiekaart kon ik met vlc televisie kijken. Ctrl+C dan PVR en dan hoefde ik alleen nog het kanaal in te geven.
De Samsung ziggo-ontvanger had het voor de derde maal in 1,5 jaar begeven en nu heb ik een Humax 5100C gekregen. Het televisiesignaal komt via de kabel nog steeds goed door in mijn werkkamer (getest met de tv). Alleen blijft alles zwart in VLC.
Wel kan ik bestaande films en opnames gewoon in VLC afspelen. Maar TV wil niet meer.
Ik heb inmiddels VLC gedeïnstalleerd en weer opnieuw geïnstalleerd.
Hier wat lspci uitvoer:

1:07.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) Video Decoder (rev 01)

peter@ubX4:~$ dmesg | grep tv
[    7.768237] ivtv: Start initialization, version 1.4.3
[    7.768396] ivtv0: Initializing card 0
[    7.768401] ivtv0: Autodetected Hauppauge card (cx23416 based)
[    7.768669] ivtv 0000:01:07.0: PCI INT A -> Link[APC4] -> GSI 19 (level, low) -> IRQ 19
[    7.768680] ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
[    7.820858] tveeprom 2-0050: The eeprom says no radio is present, but the tuner type
[    7.820864] tveeprom 2-0050: indicates otherwise. I will assume that radio is present.
[    7.820868] tveeprom 2-0050: Hauppauge model 26589, rev C9A5, serial# 9458039
[    7.820871] tveeprom 2-0050: tuner model is TCL MPE05-2 (idx 105, type 38)
[    7.820875] tveeprom 2-0050: TV standards PAL(B/G) PAL(I) SECAM(L/L') PAL(D/D1/K) (eeprom 0x74)
[    7.820879] tveeprom 2-0050: audio processor is CX25843 (idx 37)
[    7.820882] tveeprom 2-0050: decoder processor is CX25843 (idx 30)
[    7.820884] tveeprom 2-0050: has radio
[    7.820888] ivtv0: Autodetected Hauppauge WinTV PVR-150
[    8.164095] cx25840 2-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #0)
[    9.291277] wm8775 2-001b: chip found @ 0x36 (ivtv i2c driver #0)
[    9.388265] ivtv0: Registered device video1 for encoder MPG (4096 kB)
[    9.388762] ivtv0: Registered device video33 for encoder YUV (2048 kB)
[    9.388926] ivtv0: Registered device vbi1 for encoder VBI (1024 kB)
[    9.389062] ivtv0: Registered device video25 for encoder PCM (320 kB)
[    9.389201] ivtv0: Registered device radio1 for encoder radio
[    9.389205] ivtv0: Initialized card: Hauppauge WinTV PVR-150
[    9.390408] ivtv: End initialization
[   10.254519] ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
[   10.456204] ivtv0: Encoder revision: 0x02060039
peter@ubX4:~$ dmesg | grep Haup
[    7.768401] ivtv0: Autodetected Hauppauge card (cx23416 based)
[    7.820868] tveeprom 2-0050: Hauppauge model 26589, rev C9A5, serial# 9458039
[    7.820888] ivtv0: Autodetected Hauppauge WinTV PVR-150
[    9.389205] ivtv0: Initialized card: Hauppauge WinTV PVR-150

vlc vanaf prompt gestart:
VLC media player 2.0.3 Twoflower (revision 2.0.2-93-g77aa89e)
[0x9184908] main libvlc: Start vlc met standaardinterface. Gebruik 'cvlc' om vlc zonder interface te gebruiken.
Got bus address:  "unix:abstract=/tmp/dbus-wU6R4MCrwG,guid=800a2e26dfd79b139ffe6a7100000052"
Connected to accessibility bus at:  "unix:abstract=/tmp/dbus-wU6R4MCrwG,guid=800a2e26dfd79b139ffe6a7100000052"
Registered DEC:  true
Registered event listener change listener:  true
---Tot zover gaat het goed. Kies ik nu in VLC voor de optie PVR en vul ik een frequentie in dan verschijnt er aan de lopende band in de terminal de volgende foutcode:
[0xb72044b0] main access error: Read error: Invalid argument

Wie weet raad?



 

« Laatst bewerkt op: 2015/08/27, 21:10:43 door blokkendoos »

Offline blokkendoos

  • Lid
  • Steunpunt: Nee
Re: [opgelost] VLC in PVR modus doet het niet meer
« Reactie #1 Gepost op: 2012/11/03, 14:48:27 »
Opgelost door de permanent aangesloten webcam uit de usb-poort te halen.

Blijft nu de vraag hoe je de aangesloten apparaatnamen van webcam en tv-kaart achterhaald?


Offline blokkendoos

  • Lid
  • Steunpunt: Nee
Re: VLC in PVR = Tv-analoog modus doet het niet meer
« Reactie #2 Gepost op: 2015/08/27, 21:12:26 »
3 jaar later:
Nu ben ik na een nieuwe installatie van Xubuntu 14.04.3 weer tegen hetzelfde probleem aangelopen.
Alleen moet de oplossing echt anders zijn want die usb-webcam zit er niet in.

lspci:
05:0a.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) Video Decoder (rev 01)

04:~$ dmesg | grep video
[   12.885032] Linux video capture interface: v2.00
[   15.805615] ivtv0: Registered device video0 for encoder MPG (4096 kB)
[   15.808709] ivtv0: Registered device video32 for encoder YUV (2048 kB)
[   15.833372] ivtv0: Registered device video24 for encoder PCM (320 kB)

@X4xubun1404:~$ dmesg | grep tv
[   14.271675] ivtv: Start initialization, version 1.4.3
[   14.271852] ivtv0: Initializing card 0
[   14.271857] ivtv0: Autodetected Hauppauge card (cx23416 based)
[   14.344522] tveeprom 0-0050: The eeprom says no radio is present, but the tuner type
[   14.344529] tveeprom 0-0050: indicates otherwise. I will assume that radio is present.
[   14.344533] tveeprom 0-0050: Hauppauge model 26589, rev C9A5, serial# 9458039
[   14.344536] tveeprom 0-0050: tuner model is TCL MPE05-2 (idx 105, type 38)
[   14.344540] tveeprom 0-0050: TV standards PAL(B/G) PAL(I) SECAM(L/L') PAL(D/D1/K) (eeprom 0x74)
[   14.344543] tveeprom 0-0050: audio processor is CX25843 (idx 37)
[   14.344546] tveeprom 0-0050: decoder processor is CX25843 (idx 30)
[   14.344548] tveeprom 0-0050: has radio
[   14.344552] ivtv0: Autodetected Hauppauge WinTV PVR-150
[   14.447554] cx25840 0-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #0)
[   15.125892] wm8775 0-001b: chip found @ 0x36 (ivtv i2c driver #0)
[   15.805615] ivtv0: Registered device video0 for encoder MPG (4096 kB)
[   15.808709] ivtv0: Registered device video32 for encoder YUV (2048 kB)
[   15.833038] ivtv0: Registered device vbi0 for encoder VBI (1024 kB)
[   15.833372] ivtv0: Registered device video24 for encoder PCM (320 kB)
[   15.839612] ivtv0: Registered device radio0 for encoder radio
[   15.839621] ivtv0: Initialized card: Hauppauge WinTV PVR-150
[   15.840850] ivtv: End initialization
[   15.899550] ivtv-alsa: module loading...
[   17.342563] ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
[   17.540182] ivtv0: Encoder revision: 0x02060039

Voorheen moest ik kiezen voor PVR en daar kies ik nu maar voor Tv-analoog omdat ik nog
via het analoge kanaal kijk van de kabelaar.

Ik ben helemaal niet thuis op dit gebied, dus ik kan wel wat hulp gebruiken, a.u.b.
-------------
Ik heb net vanaf een usbstick Mint13 gestart en dan werkt het weer als vanouds. Volgens mij duidt dat op een probleem bij VLC. De gebruikte vlc-versie bij mint is Twoflower. Wat die onder Xubuntu is moet ik nu nog even gaan bekijken.




« Laatst bewerkt op: 2015/08/27, 22:47:17 door blokkendoos »