Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Foutmelding undefined reference to `crypt' tijdens make vsftpd  (gelezen 1128 keer)

Offline Stormlord

  • Lid
  • Steunpunt: Nee
Hallo,

Er bestaan nog al wat problemen met  vsftpd versie 2.3.5
Het grrotste probleem (voor mij) is de foutmelding "500 OOPS: vsftpd: refusing to run with writable root inside chroot ()"
Een workaround is "allow_writeable_chroot=YES" in de configuratie zetten, maar deze pas sinds 3.0.0 geimplementeerd.

Dus versie 3.0.2 gedownload en make uitgevoerd.
Na make krijg ik de volgende melding:

sysdeputil.o: In function `vsf_sysdep_check_auth':
sysdeputil.c:(.text+0x109): undefined reference to `crypt'
sysdeputil.c:(.text+0x13a): undefined reference to `crypt'
collect2: ld gaf exit-status 1 terug
make: *** [vsftpd] Fout 1

Weet iemand hoe ik dit kan oplossen?
Versie Ubuntu: 12.04

Alvast bedankt.
Groet,
Egbert

Offline gavinspearhead

  • Lid
    • URD
  • Steunpunt: Nee
Re: Foutmelding undefined reference to `crypt' tijdens make vsftpd
« Reactie #1 Gepost op: 2012/10/26, 23:56:09 »
Het lijkt er op dat je een dev package mist. Wsl libxcrypt-dev

sudo apt-get install libxcrypt-dev
URD - http://www.urdland.com - Usenet Resource Downloader

Offline Stormlord

  • Lid
  • Steunpunt: Nee
Re: Foutmelding undefined reference to `crypt' tijdens make vsftpd
« Reactie #2 Gepost op: 2012/10/27, 11:17:40 »
Het lijkt er op dat je een dev package mist. Wsl libxcrypt-dev

sudo apt-get install libxcrypt-dev

Hoi,
Bedankt voor je reactie.
Ik had al libgcrypt11_1.5.0-3ubuntu0.1_i386.deb geinstalleerd, maar helaas zonder enig succses. (Deze bleek overigens al te bestaan)
Ook heb ik jouw suggestie (libxcrypt-dev) geinstalleerd, maar helaas ook zonder resultaat. Ik blijf nog steeds de zelfde foutmelding houden.

Egbert