Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Xubuntu start niet meer op  (gelezen 1202 keer)

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Xubuntu start niet meer op
« Gepost op: 2012/10/18, 17:14:02 »
OS = Xubuntu 12.04 LTS
Video-kaart  = Nvdia EN8600GTS/G/HTDP

Ben al ruim een uur aan het worstelen, maar een van  m'n  Xubuntu-pc's start niet meer op of slaat vast op het moment dat er beeld moet verschijnen. Ik zie dan enkel een dunne strook blauw bovenaan aan m'n beeldscherm en dan stokt alles. Video-driver probleem? Heb al via het grub-menu meerdere malen een oudere kernel trachten te installeren. Bij kernel 26 (ik zat bij 31 of 32 geloof ik ;ken die nummers niet uit m'n hoofd) start de pc soms wel op met een of andere nood video-driver, want het beeld is abominabel, maar meestal blijft de pc hangen met die dunne strook blauw bovenaan.
Heb ook via de recovery-mode het nodige geprobeerd, maar niets helpt. Ook het installeren van de recommended video-driver lost het probleem niet op.
Het gedonder begon toen de update-manager foutmeldingen begon te geven. Dat was het volgende :

"The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f

The following packages have unmet dependencies:

libc6: Depends: libc-bin (= 2.15-0ubuntu10.3) but 2.15-0ubuntu10.3 is installed
libc6:i386: Depends: libc-bin (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10.3 is installed"

Ik heb alles gedaan wat gevraagd wordt, maar niets helpt.

Wie o wie weet wat ik nu nog kan doen om de pc weer aan de gang te krijgen? Dit is trouwens binnen niet al te lange tijd de tweede keer dat het ding vastloopt met n.b. een LTS-versie! Die zouden toch juist extra stabiel moeten zijn?! De vorige keer kon ik de zaak herstellen door naar de vorige kernel terug te keren.
Een boek doet het altijd...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Xubuntu start niet meer op
« Reactie #1 Gepost op: 2012/10/18, 18:25:54 »
De kans lijkt mij aanwezig, dat er fouten op je HD, of in je geheugen zitten.
Je kunt eens starten vanaf de CD/DVD/USB en de test laten lopen.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #2 Gepost op: 2012/10/18, 19:54:22 »
Heb HD en geheugen getest. Krijg geen foutmeldingen. Dus daaraan ligt het mi niet.

Wat nu  :'(
Een boek doet het altijd...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Xubuntu start niet meer op
« Reactie #3 Gepost op: 2012/10/18, 20:12:51 »
Het enige waar ik aan kan denken, is het terminal commando: sudo apt-get install -f of vanuit synaptic proberen de gebroken pakketten te repareren.
Bedenk wel, dat in één uurtje je een compleet nieuw systeem installeert ........
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #4 Gepost op: 2012/10/18, 20:25:37 »
sudo apt-get install -f heb ik ook al geprobeerd. Geen resultaat helaas. Ik weet dat een schoon systeem zo geinstalleerd is. Alleen de zaak vervolgens op mijn persoonlijke instellingen afconfigureren duurt ietsje langer dan uurtje! Daarom heb ik de zaak liever hersteld.
Het gekke is dat wanneer ik naar kernel nr. 26 (zo noem ik 'm maar even voor het gemak) terugga, dan start de pc soms wel op, maar soms ook niet. Wel dan met een basis-video-driver waardoor het beeld een ramp is. Wel leesbaar, maar zeer vermoeiend. Blijft allemaal vreemd. Kom steeds iets tegen over 'unmet dependencies'. Ik ben niet zo'n wizard dat ik daar veel van snap. Basishandelingen lukken nog wel, maar het moet niet te ingewikkeld worden.

Dus als er iemand is die nog meer mogelijke oplossing weet dan graag!

Een boek doet het altijd...

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #5 Gepost op: 2012/10/18, 20:37:03 »
Krijg nu ook de volgende melding :

"An error occurred, please run Package Manager from the right click menu or apt-get in an terminal tot see what is wrong. The error message was 'Error: BrokenCount >0'. This usually means that your installed packages have unmet dependencies"

Hellup!!
Een boek doet het altijd...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Xubuntu start niet meer op
« Reactie #6 Gepost op: 2012/10/18, 20:40:57 »
Heb je soms extra repositories toegevoegd ?
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #7 Gepost op: 2012/10/18, 20:49:12 »
Nee.  Op de pc waar ik nu dit op typ staat exact dezelfde Xubuntu 12.04 LTS met precies dezelfde repositories en alle overige instellingen en software en die werkt als een zonnetje. Nooit problemen mee...
Een boek doet het altijd...

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Xubuntu start niet meer op
« Reactie #8 Gepost op: 2012/10/18, 21:53:26 »
Een schot in de ruimte:
Type eens: sudo apt-get update && sudo apt-get upgrade
Let goed op, of één van de genoemde pakketten in beeld komt.
Lukt dit niet, type dan eens: sudo apt-get dist-upgrade
Let hierbij goed op, dat er niet te veel verwijderd wordt.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #9 Gepost op: 2012/10/19, 09:07:07 »
Ik heb de 3 commando's uitgevoerd, maar iedere keer krijg ik onderstaande melding te zien :

The following packages have unmet dependencies:

libc6: Depends: libc-bin (= 2.15-0ubuntu10.3) but 2.15-0ubuntu10.3 is installed
libc6:i386: Depends: libc-bin (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10.3 is installed

Dit gaat mij alleen boven de pet. 

Wanneer ik synaptic start geeft die de melding :

"You have 2 broken packages on your system! Use the "Broken" filter to locate them".

Bij 'broken dependencies' staan dan weer libc6 en libc6:i386. Loop ik dus steeds weer tegenaan.


Een boek doet het altijd...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #10 Gepost op: 2012/10/19, 15:05:57 »
Het zou kunnen, dat er twee verschillende problemen tegelijk optreden.

1. Gebroken pakketten:
Probeer dit eens:

- start Synaptic Pakketbeheer
Werkbalk Synaptic: Bewerken - Gebroken pakketten repareren

2. Beeldproblemen
De genoemde beeldproblemen kunnen wellicht worden verholpen met de updates van vandaag, waarin een reparatie zit voor beeldproblemen met intel (o.a. vastlopers grafische omgeving).
« Laatst bewerkt op: 2012/10/19, 15:08:25 door Pjotr »

Offline FrSu

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #11 Gepost op: 2012/10/21, 22:13:10 »
Bedraad aan internet hangen en in de Grub kiezen voor de herstel modus. Kijk maar eens of je dan verder komt. Er moet in elk geval de keuzemogelijkheid in zitten om gebroken pakketten te repareren.
Van Dos>Win 3.11>Win 95>Win 98>Win 2000>Win XP >Vista (Oeps, was foutje)>Win 7>Win 8>geheel gestopt met Win (behalve op de HP Touch)>Elementary Loki.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #12 Gepost op: 2012/10/22, 17:32:19 »
@Pjotr : Heb de optie 'Gebroken pakketten repareren' geprobeerd, maar krijg dan de volgende foutmelding :

E: Internal Error, No file name for libc6

Ik kom steeds overal 'libc6' en 'libc6:i386' tegen. Dit schijnen de boosdoeners te zijn. Wegdoen kan voor zover ik concludeer niet, omdat hier allerlei balngrijke pakketten aan 'vastzitten'. Ik draai overigens met de 64-bits versie van Xubuntu 12.04 LTS. Omdat ik i386 in de foutmelding zie staan vermeld ik het maar even.

Taai probleem zeg!!

@FrSu : alle opties van de Recovery mode heb ik al geprobeerd. Niets helpt!
Een boek doet het altijd...

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #13 Gepost op: 2012/10/22, 19:31:04 »
Iets om te proberen via de terminal;
sudo apt-get update
apt-get clean
apt-get install -fy
dpkg -i /var/cache/apt/archives/*.deb
dpkg --configure -a
apt-get install -fy
apt-get dist-upgrade

Ref: https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/983543

En dat laatste wat je opgeeft, is item #7
https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/983543/comments/7

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #14 Gepost op: 2012/10/23, 09:03:15 »
donpedroll heel erg bedankt! Je commando-reeks heeft het probleem opgelost!!! Alles moet wel als superuser worden uitgevoerd. Alles werkt nu weer naar behoren. Broken packages zijn weg, geen beeldproblemen meer en de laatste kernel-versie (32) wordt gebruikt. Nou ben ik toch wel benieuwd naar het volgende : weet je misschien wat hier nou precies aan de hand was? Wat was het probleem nou eigenlijk? Dit is de eerste keer dat ik een dergelijke hardnekkig probleem meemaak met een LTS-versie.

Ik zet hieronder voor de compleetheid nog even alle uit te voeren commando's op een rij voor eventuele anderen die tegen ditzelfde probleem aanlopen :

sudo apt-get update
sudo apt-get clean
sudo apt-get install -fy
sudo dpkg -i /var/cache/apt/archives/*.deb
sudo dpkg --configure -a
sudo apt-get install -fy
sudo apt-get dist-upgrade
sudo dpkg --purge libc6:i386 cupswrappermfc7860dw:i386 libgcc1:i386
sudo dpkg -i /var/cache/apt/archives/libc6_2.15-0ubuntu10.2_amd64.deb
sudo apt-get install -f

Een boek doet het altijd...

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #15 Gepost op: 2012/10/23, 10:08:49 »
Wat er precies aan de hand was is een beetje gissen, maar zag het volgende
Citaat
libc6: Depends: libc-bin (= 2.15-0ubuntu10.3) but 2.15-0ubuntu10.3 is installed
libc6:i386: Depends: libc-bin (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10.3 is installed"
Hieruit maak ik op dat de libc6 een 10.3 versie was en de libc6:i386  een versie 10.2 aanwijst.

Het lijkt erop dat er een package probleem was tussen de verschillende lib-bin versies, maar wat de grond van dit probleem is geweest ... een raadsel.

Offline kfboerne

  • Lid
  • Steunpunt: Nee
Re: Xubuntu start niet meer op
« Reactie #16 Gepost op: 2012/10/23, 11:14:45 »
Ok, nou in elk geval heb je me een heleboel werk bespaard, want ik stond op het punt om Xubuntu maar opnieuw te gaan installeren. Uiteraard bestaat het perfecte OS niet, maar dat dit bij een LTS-versie gebeurt, verbaast me toch wel.

Nogmaals bedankt! En uiteraard ook alle andere 'meedenkers'.....
Een boek doet het altijd...