Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] VirtualBox VMS map achteraf onzichtbaar maken; Virt OS onbenaderbaar  (gelezen 669 keer)

Offline wowo

  • Lid
  • Steunpunt: Nee
Heb Virtual box standaard geïnstalleerd zodat de VirtualBox VMS map ( met daarin de mappen van de virtuele OS´ s met daarin weer de desbetreffende bestanden met oa. de .vdi) in mijn persoonlijke map kwam te staan.

Nu wil ik de VirtualBox VMS map liever onzichtbaar maken door de map te hernoemen door er een punt voor te zetten.
Als ik nu VirtualBox opstart en de standaardmap voor Virtuele machines ( bestand > voorkeuren > algemeen) aanpas, blijven de virtuele OS's toch nog onbenaderbaar.
Er komt een foutmelding waarbij het oude pad vermeld staat. Verversen help ook niet. :(
Hoe kan ik dit oplossen ?????
Zie ook afbeelding.
« Laatst bewerkt op: 2012/10/17, 16:14:42 door wowo »
Desktop Ubuntu 18.04 LTS

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Zo te zien zitten er in de definitiefile .vbox harde verwijzingen die dus niet meeveranderen bij het hernoemen van de map. Deze zou je aan kunnen passen met bv gedit.

Je kunt ook de entries weggooien uit de manager en deze wee opnieuw toevoegen door ze simpelweg vanuit nautilus te slepen naar het virtualbox-icoon in de starter.

Offline wowo

  • Lid
  • Steunpunt: Nee
Zo te zien zitten er in de definitiefile .vbox harde verwijzingen die dus niet meeveranderen bij het hernoemen van de map. Deze zou je aan kunnen passen met bv gedit.

Je kunt ook de entries weggooien uit de manager en deze wee opnieuw toevoegen door ze simpelweg vanuit nautilus te slepen naar het virtualbox-icoon in de starter.
Als ik met leafpad de definitiefile .vbox bekijk dan zie ik daar geen precieze locatie van .vdi vermeld staan :
<?xml version="1.0"?>
<!--
** DO NOT EDIT THIS FILE.
** If you make changes to this file while any VirtualBox related application
** is running, your changes will be overwritten later, without taking effect.
** Use VBoxManage or the VirtualBox Manager GUI to make changes.
-->
<VirtualBox xmlns="http://www.innotek.de/VirtualBox-settings" version="1.12-linux">
  <Machine uuid="{1a41f9a0-3426-4703-b229-b90122925a20}" name="xubuntu-12-04-1" OSType="Ubuntu_64" snapshotFolder="Snapshots" lastStateChange="2012-10-17T12:41:13Z">
    <MediaRegistry>
      <HardDisks>
        <HardDisk uuid="{d79aafb5-9191-4908-9c41-dc4adfb5c674}" location="xubuntu-12-04-1.vdi" format="VDI" type="Normal"/>
      </HardDisks>
      <DVDImages>
        <Image uuid="{a1c74703-f0e2-4d76-84ff-f42e0635bdc4}" location="/home/silencio1/Virtual Besturingssystemen( .iso)/xubuntu-12.04.1-desktop-amd64.iso"/>
        <Image uuid="{0d58a0b1-4625-42f5-8ab8-8d70c471ab9d}" location="/usr/share/virtualbox/VBoxGuestAdditions.iso"/>
      </DVDImages>
      <FloppyImages/>
    </MediaRegistry>
    <ExtraData>
      <ExtraDataItem name="GUI/LastCloseAction" value="powerOff"/>
      <ExtraDataItem name="GUI/LastGuestSizeHint" value="1024,768"/>
      <ExtraDataItem name="GUI/LastNormalWindowPosition" value="248,226,1024,790"/>
      <ExtraDataItem name="GUI/MiniToolBarAlignment" value="bottom"/>
      <ExtraDataItem name="GUI/SaveMountedAtRuntime" value="yes"/>
      <ExtraDataItem name="GUI/ShowMiniToolBar" value="yes"/>
    </ExtraData>
    <Hardware version="2">
      <CPU count="1" hotplug="false">
        <HardwareVirtEx enabled="true" exclusive="true"/>
        <HardwareVirtExNestedPaging enabled="true"/>
        <HardwareVirtExVPID enabled="true"/>
        <PAE enabled="false"/>
        <HardwareVirtExLargePages enabled="false"/>
        <HardwareVirtForce enabled="false"/>
      </CPU>
      <Memory RAMSize="512" PageFusion="false"/>
      <HID Pointing="USBTablet" Keyboard="PS2Keyboard"/>
      <HPET enabled="false"/>
      <Chipset type="PIIX3"/>
      <Boot>
        <Order position="1" device="Floppy"/>
        <Order position="2" device="DVD"/>
        <Order position="3" device="HardDisk"/>
        <Order position="4" device="None"/>
      </Boot>
      <Display VRAMSize="12" monitorCount="1" accelerate3D="false" accelerate2DVideo="false"/>
      <VideoRecording enabled="true" file="Test.webm" horzRes="640" vertRes="480"/>
      <RemoteDisplay enabled="false" authType="Null" authTimeout="5000"/>
      <BIOS>
        <ACPI enabled="true"/>
        <IOAPIC enabled="true"/>
        <Logo fadeIn="true" fadeOut="true" displayTime="0"/>
        <BootMenu mode="MessageAndMenu"/>
        <TimeOffset value="0"/>
        <PXEDebug enabled="false"/>
      </BIOS>
      <USBController enabled="true" enabledEhci="true"/>
      <Network>
        <Adapter slot="0" enabled="true" MACAddress="0800278C6EE7" cable="true" speed="0" type="82540EM">
          <DisabledModes/>
          <NAT>
            <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
            <Alias logging="false" proxy-only="false" use-same-ports="false"/>
          </NAT>
        </Adapter>
        <Adapter slot="1" enabled="false" MACAddress="080027B25400" cable="true" speed="0" type="82540EM">
          <DisabledModes>
            <NAT>
              <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
              <Alias logging="false" proxy-only="false" use-same-ports="false"/>
            </NAT>
          </DisabledModes>
        </Adapter>
        <Adapter slot="2" enabled="false" MACAddress="080027B3AD5D" cable="true" speed="0" type="82540EM">
          <DisabledModes>
            <NAT>
              <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
              <Alias logging="false" proxy-only="false" use-same-ports="false"/>
            </NAT>
          </DisabledModes>
        </Adapter>
        <Adapter slot="3" enabled="false" MACAddress="080027985BFA" cable="true" speed="0" type="82540EM">
          <DisabledModes>
            <NAT>
              <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
              <Alias logging="false" proxy-only="false" use-same-ports="false"/>
            </NAT>
          </DisabledModes>
        </Adapter>
        <Adapter slot="4" enabled="false" MACAddress="080027CCBEDE" cable="true" speed="0" type="82540EM">
          <DisabledModes>
            <NAT>
              <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
              <Alias logging="false" proxy-only="false" use-same-ports="false"/>
            </NAT>
          </DisabledModes>
        </Adapter>
        <Adapter slot="5" enabled="false" MACAddress="080027F9D143" cable="true" speed="0" type="82540EM">
          <DisabledModes>
            <NAT>
              <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
              <Alias logging="false" proxy-only="false" use-same-ports="false"/>
            </NAT>
          </DisabledModes>
        </Adapter>
        <Adapter slot="6" enabled="false" MACAddress="080027D6C6CD" cable="true" speed="0" type="82540EM">
          <DisabledModes>
            <NAT>
              <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
              <Alias logging="false" proxy-only="false" use-same-ports="false"/>
            </NAT>
          </DisabledModes>
        </Adapter>
        <Adapter slot="7" enabled="false" MACAddress="080027D4C959" cable="true" speed="0" type="82540EM">
          <DisabledModes>
            <NAT>
              <DNS pass-domain="true" use-proxy="false" use-host-resolver="false"/>
              <Alias logging="false" proxy-only="false" use-same-ports="false"/>
            </NAT>
          </DisabledModes>
        </Adapter>
      </Network>
      <UART>
        <Port slot="0" enabled="false" IOBase="0x3f8" IRQ="4" hostMode="Disconnected"/>
        <Port slot="1" enabled="false" IOBase="0x2f8" IRQ="3" hostMode="Disconnected"/>
      </UART>
      <LPT>
        <Port slot="0" enabled="false" IOBase="0x378" IRQ="7"/>
        <Port slot="1" enabled="false" IOBase="0x378" IRQ="7"/>
      </LPT>
      <AudioAdapter controller="AC97" driver="Pulse" enabled="true"/>
      <RTC localOrUTC="UTC"/>
      <SharedFolders>
        <SharedFolder name="VirtualBox_Gedeelde_Map" hostPath="/home/silencio1/VirtualBox Gedeelde Map" writable="true" autoMount="true"/>
      </SharedFolders>
      <Clipboard mode="Bidirectional"/>
      <DragAndDrop mode="Bidirectional"/>
      <IO>
        <IoCache enabled="true" size="5"/>
        <BandwidthGroups/>
      </IO>
      <HostPci>
        <Devices/>
      </HostPci>
      <EmulatedUSB>
        <CardReader enabled="false"/>
      </EmulatedUSB>
      <Guest memoryBalloonSize="0"/>
      <GuestProperties>
        <GuestProperty name="/VirtualBox/HostInfo/GUI/LanguageID" value="nl_NL" timestamp="1350477563660384000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/Product" value="Linux" timestamp="1350477579484966000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/Release" value="3.2.0-32-generic" timestamp="1350477579485452000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/Version" value="#51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012" timestamp="1350477579485786000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/OS/ServicePack" value="" timestamp="1350477579486145000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Version" value="4.2.0" timestamp="1350477579486466000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/VersionExt" value="4.2.0" timestamp="1350477579486857000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Revision" value="80737" timestamp="1350477579487231000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/Net/0/V4/IP" value="10.0.2.15" timestamp="1350477579488651000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/Net/0/V4/Broadcast" value="10.0.2.255" timestamp="1350477579489176000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/Net/0/V4/Netmask" value="255.255.255.0" timestamp="1350477579489546000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/Net/0/MAC" value="0800278C6EE7" timestamp="1350477579489891000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/Net/0/Status" value="Up" timestamp="1350477579490213000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/Vbgl/Video/SavedMode" value="1024x768x32" timestamp="1350477580441493000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestAdd/HostVerLastChecked" value="4.2.0" timestamp="1350477615990677000" flags=""/>
        <GuestProperty name="/VirtualBox/GuestInfo/Net/Count" value="1" timestamp="1350477669498970000" flags=""/>
      </GuestProperties>
    </Hardware>
    <StorageControllers>
      <StorageController name="IDE controller" type="PIIX4" PortCount="2" useHostIOCache="true" Bootable="true">
        <AttachedDevice passthrough="false" type="DVD" port="1" device="0"/>
      </StorageController>
      <StorageController name="SATA controller" type="AHCI" PortCount="1" useHostIOCache="false" Bootable="true" IDE0MasterEmulationPort="0" IDE0SlaveEmulationPort="1" IDE1MasterEmulationPort="2" IDE1SlaveEmulationPort="3">
        <AttachedDevice type="HardDisk" port="0" device="0">
          <Image uuid="{d79aafb5-9191-4908-9c41-dc4adfb5c674}"/>
        </AttachedDevice>
      </StorageController>
    </StorageControllers>
  </Machine>
</VirtualBox>
Waarschijnlijk wordt de verwijzing op een andere plaats gemaakt ?
Dat verwijderen en slepen durf ik nog niet want anders ben ik toch bang dat alles verlies.
Ik ben nl al een hele tijd bezig on Windows XP te configureren met alle software, hardware en zo.
Desktop Ubuntu 18.04 LTS

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Idd, ik zie ook geen harde verwijzing naar een map.
Onder de algemene settings zit ook nog zoiets als een default pad. Kijk daar eens naar.

Offline wowo

  • Lid
  • Steunpunt: Nee
Idd, ik zie ook geen harde verwijzing naar een map.
Onder de algemene settings zit ook nog zoiets als een default pad. Kijk daar eens naar.
Ja maar dat is toch hetzelfde als ik al schreef: bestand > voorkeuren > algemeen > standaardmap voor virtuele machines en dat is niet voldoende.

Ik heb in de map .Virtualbox het bestand VirtualBox.xml geopend.
<?xml version="1.0"?>
<!--
** DO NOT EDIT THIS FILE.
** If you make changes to this file while any VirtualBox related application
** is running, your changes will be overwritten later, without taking effect.
** Use VBoxManage or the VirtualBox Manager GUI to make changes.
-->
<VirtualBox xmlns="http://www.innotek.de/VirtualBox-settings" version="1.12-linux">
  <Global>
    <ExtraData>
      <ExtraDataItem name="GUI/DetailsPageBoxes" value="general,preview,system,display,storage,audio,network,usb,sharedFolders,description"/>
      <ExtraDataItem name="GUI/GroupDefinitions/" value="m=92cea563-76db-4628-b607-3d5d1a0426ec,m=1a41f9a0-3426-4703-b229-b90122925a20"/>
      <ExtraDataItem name="GUI/HostScreenSaverDisabled" value="false"/>
      <ExtraDataItem name="GUI/Input/AutoCapture" value="true"/>
      <ExtraDataItem name="GUI/Input/HostKeyCombination" value="65508"/>
      <ExtraDataItem name="GUI/LastItemSelected" value="m=xubuntu-12-04-1"/>
      <ExtraDataItem name="GUI/LastWindowPosition" value="573,398,706,550"/>
      <ExtraDataItem name="GUI/RecentFolderCD" value="/home/silencio1/Virtual Besturingssystemen( .iso)"/>
      <ExtraDataItem name="GUI/RecentListCD" value="/home/silencio1/Virtual Besturingssystemen( .iso)/WinXPx86Pro+NET.iso;/home/silencio1/Virtual Besturingssystemen( .iso)/xubuntu-12.04.1-desktop-amd64.iso;"/>
      <ExtraDataItem name="GUI/SplitterSizes" value="210,490"/>
      <ExtraDataItem name="GUI/SuppressMessages" value=",remindAboutMouseIntegrationOn,remindAboutAutoCapture,remindAboutMouseIntegrationOff"/>
      <ExtraDataItem name="GUI/TrayIcon/Enabled" value="false"/>
      <ExtraDataItem name="GUI/UpdateCheckCount" value="6"/>
      <ExtraDataItem name="GUI/UpdateDate" value="1 d, 2012-10-18, stable, 4.2.0"/>
    </ExtraData>
    <MachineRegistry>
      <MachineEntry uuid="{92cea563-76db-4628-b607-3d5d1a0426ec}" src="/home/silencio1/VirtualBox VMs/windows-xp/windows-xp.vbox"/>
      <MachineEntry uuid="{1a41f9a0-3426-4703-b229-b90122925a20}" src="/home/silencio1/VirtualBox VMs/xubuntu-12-04-1/xubuntu-12-04-1.vbox"/>
    </MachineRegistry>
    <MediaRegistry>
      <HardDisks/>
      <DVDImages/>
      <FloppyImages/>
    </MediaRegistry>
    <NetserviceRegistry>
      <DHCPServers>
        <DHCPServer networkName="HostInterfaceNetworking-vboxnet0" IPAddress="192.168.56.100" networkMask="255.255.255.0" lowerIP="192.168.56.101" upperIP="192.168.56.254" enabled="1"/>
      </DHCPServers>
    </NetserviceRegistry>
    <SystemProperties defaultMachineFolder="/home/silencio1/.VirtualBox VMs" defaultHardDiskFormat="VDI" VRDEAuthLibrary="VBoxAuth" webServiceAuthLibrary="VBoxAuth" LogHistoryCount="3"/>
    <USBDeviceFilters/>
  </Global>
</VirtualBox>
Je ziet dat de locatie van "defaultMachineFolder" door de aanpassing in de virtalboxmanager al veranderd is met een punt ervoor maar dat bij:
"<MachineEntry uuid="{92cea563-76db-4628-b607-3d5d1a0426ec}" src="/home/silencio1/VirtualBox VMs/windows-xp/windows-xp.vbox"/>"
en
 "<MachineEntry uuid="{1a41f9a0-3426-4703-b229-b90122925a20}" src="/home/silencio1/VirtualBox VMs/xubuntu-12-04-1/xubuntu-12-04-1.vbox"/>  er nog geen puntje ervoor staat.
Nadat ik dit had aangepast met leafpad was alles weer in orde.
Hopelijk blijft het zo.
Desktop Ubuntu 18.04 LTS

Offline wowo

  • Lid
  • Steunpunt: Nee
Krijg wel nog een foutmelding dat de door mij gebruikte .iso 's niet meer te vinden waren omdat ik die map ook onzichtbaar had gemaakt. Door deze uit de "historie" te verwijderen, is nu alles in orde.
Desktop Ubuntu 18.04 LTS