Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Virtualhost niet aan de praat.  (gelezen 1149 keer)

Offline wilvs

  • Lid
Virtualhost niet aan de praat.
« Gepost op: 2012/10/06, 13:18:37 »
Goedemiddag,

Ik zal even in het kort schetsen wat ik gedaan heb.:
- De laatste ubuntu versie geinstalleerd
- LAMP geinstalleerd en draaiende gekregen
- Webmin geinstalleerd
- 2 domeinnamen door laten verwijzen naar mijn IP-adres thuis

De twee domeinnamen samen in httpd.conf werken niet, tenminste, de doorverwijzingen komen telkens bij het bovenste internetpagina uit. Dus de doorschakeling werkt wel, alleen nu wil ik deze voor allebei de doorverwijzigingen laten werken.
- Webmin weer gedeinstalleerd.
- Probleem blijft.
- Wat zie ik over het hoofd, ik heb onderstaand het httpd.conf bestand meegestuurd.



-------------------------
ServerName localhost

NameVirtualhost *:80

<VirtualHost *:80>
        ServerName www.site1.nl
   
   DocumentRoot /var/www/site1.nl/
   <Directory /var/www/site1.nl>
   Options Indexes FollowSymLinks MultiViews
   DirectoryIndex index.html index.php
   AllowOverride None
   Order allow,deny
   allow from all
   </Directory>

</VirtualHost>


 <VirtualHost *:80>
        ServerName www.site2.nl
      
   DocumentRoot /var/www/site2.nl/
   <Directory /var/www/site2.nl>
   Options Indexes FollowSymLinks MultiViews
   DirectoryIndex index.html index.php
   AllowOverride None
   Order allow,deny
   allow from all
   </Directory>

</VirtualHost>


Groeten,
wilfred



Offline tap

  • Lid
  • Steunpunt: Nee
Re: Virtualhost niet aan de praat.
« Reactie #1 Gepost op: 2012/10/06, 17:09:48 »
Om maar even aan het begin te beginnen.

Heb je ingesteld dat apache2 weet dat je wilt werken met virtualhosts?

Heb je in de file /etc/apache2/apache2.conf de volgende regel opgenomen

Include sites-enabled/
Ik heb dat zelf op de volgende manier gedaan

include sites-enabled/hostname.netDaarna van sites-enabled een symlink maken richting sites-available
Daar heb ik de file hostname.net aangemaakt.

In de file hostname.net heb ik daarna de links gemaakt.

Die zien er zo uit

<VirtualHost *:80>
  Servername webmail.hostname.net
  DocumentRoot /var/www/webmail
</VirtualHost>

<VirtualHost *:80>
  ServerName todo.hostname.net
  Redirect / https://todo.hostname.net
</VirtualHost>

<VirtualHost *:443>
  SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/todo.pem
    SSLCertificateKeyFile /etc/apache2/ssl/todo.key
  ServerName todo.hostname.net
  ServerAlias todo.hostname.net
  DocumentRoot /var/www/todo
</VirtualHost>


Het tweede en derde voorbeeld is voor ssl op je website

Ik heb hier wel de aanname gedaan dat je apache2 hebt geïnstalleerd.

Succes!



Offline wilvs

  • Lid
Re: Virtualhost niet aan de praat.
« Reactie #2 Gepost op: 2012/10/06, 20:41:41 »
Beste Tap,

Bedankt voor je reactie. Ook na deze aanpassingen kom ik niet verder. Er wordt telkens maar 1 pagina getoond, de pagina welke in het tekstbestandje bovenaan staat. En inderdaad, apache2 was reeds geinstalleerd.

gr.
Wilfred

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Virtualhost niet aan de praat.
« Reactie #3 Gepost op: 2012/10/07, 16:08:43 »
Wilfred,

Heb jij wel in de DNS records aangegeven dat meerder subdomains verwijzen naar je server?

Er van uitgaat dat je zelf de volgende subdomains hebt gemaakt

test1.hostname.net
test2.hostname.net

Wat gebeurt er nu als je het probeert met ietsanders.hostname.net?

Kom je dan alsnog op test1.hostname.net uit?

Offline wilvs

  • Lid
Re: Virtualhost niet aan de praat.
« Reactie #4 Gepost op: 2012/10/07, 20:15:21 »
Tap,

Ik heb bij mijn hostingbedrijf aangegeven dat ik allebei de sites doorverwijs naar mijn server thuis. Los van elkaar werken allebij de sites wel, maar wanneer ik ze samen  onder sites-available plaats en vervolgens met a2ensite, service apache2 reload dan krijg ik alleen maar de eerste site te zien.


Ik heb apache2 nu verwijderd en weer opnieuw geinstalleerd. Bovenstaande herhaald en nu laat deze alleen maar de apache2 welkomstpagina zien ipv 1 of meerdere sites.

gr.
Wilfred

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Virtualhost niet aan de praat.
« Reactie #5 Gepost op: 2012/10/09, 00:21:09 »
Hoi Wilfred,

Ik heb hem dan ook niet scherp.
Ik heb de aanname gedaan dat je werkt met subdomains. Gebruik je www.site1.net en www.site2.net of zoals ik heb aangenomen site1.hostname.net en site2.hostname.net

Volgens mij moet dit niks uitmaken maar wie weet.
Wat je zou kunnen doen is hier de inhoud van je Virtualhost file dumpen dan kan ik er even naar kijken.

Groet, Tap.

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Virtualhost niet aan de praat.
« Reactie #6 Gepost op: 2012/10/09, 17:42:57 »
Je kunt de NameVirtualHost *:80 even weghalen, want dan ga je werken met namebased virtualhosts. Kan ook, maar dan moet je ze expliciet noemen.

Je kunt trouwens prima twee domeinen zo doen als je aangeeft, ik ben ook even aan het puzzelen waarom het niet werkt :)

Zoals je zelf al aangaf: virtualhosts aanmaken in losse bestanden in sites-available (niet in sites-enabled of de httpd.conf) en met a2ensite aanzetten. (of zelf de symlink maken)

Kun je (zoals tap vraagt) hier de inhoud van je virtualhost files plaatsen?

Hoe word er doorverwezen vanaf de hosting partij? op ip adres (een A record) of via een alias? (CNAME)
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline wilvs

  • Lid
Re: Virtualhost niet aan de praat.
« Reactie #7 Gepost op: 2012/10/10, 13:53:08 »
<VirtualHost *:80>
        ServerName www.site1.nl
ServerAlias site1.nl

DocumentRoot /var/www/site1.nl
<Directory /var/www/site1.nl>
Options Indexes FollowSymLinks MultiViews
DirectoryIndex index.html index.php
AllowOverride None
Order allow,deny
allow from all
</Directory>

</VirtualHost>


<VirtualHost *:80>
        ServerName www.site2.nl
ServerAlias site2.nl


DocumentRoot /var/www/site2.nl
<Directory /var/www/site2.nl>
Options Indexes FollowSymLinks MultiViews
DirectoryIndex index.html index.php
AllowOverride None
Order allow,deny
allow from all
</Directory>

</VirtualHost>

Hierboven het bestandje httpd.conf welke ik zelf zo gecreeerd heb.
Ik heb bij site 2 aangegeven middels een A record dat deze naar mijn thuis ip adres doorverwijst. Ik denk dat dit wel goed staat, ga hier nog even een screenshot van maken en posten.
Ben even afgestapt van losse bestanden en nu dus alles in in httpd.conf gezet.

gr.
Wilfred

Offline wilvs

  • Lid
Re: Virtualhost niet aan de praat.
« Reactie #8 Gepost op: 2012/10/10, 13:59:08 »
Screenshot gemaakt bij mijndomein.nl
Dit is van de 2e site, welke ik dus niet te zien krijg.
Bij de eerste site heb ik geen A record aangemaakt of gewijzigd.


gr.
Wilfred
« Laatst bewerkt op: 2012/10/10, 14:23:26 door wilvs »

Offline wilvs

  • Lid
Re: Virtualhost niet aan de praat.
« Reactie #9 Gepost op: 2012/10/10, 14:22:38 »

Wow, even snelle reactie, ik heb het tot nu toe aan de praat. De httpd.conf code nog wat aangepast:
ServerName localhost

NameVirtualHost 10.0.0.13:80

<VirtualHost 10.0.0.13:80>
        ServerName www.site1.nl
ServerAlias site1.nl

DocumentRoot /var/www/site1.nl
<Directory /var/www/site1.nl>
Options Indexes FollowSymLinks MultiViews
DirectoryIndex index.html index.php
AllowOverride None
Order allow,deny
allow from all
</Directory>

</VirtualHost>


<VirtualHost 10.0.0.13:80>
        ServerName www.site2.nl
ServerAlias site2.nl


DocumentRoot /var/www/site2.nl
<Directory /var/www/site2.nl>
Options Indexes FollowSymLinks MultiViews
DirectoryIndex index.html index.php
AllowOverride None
Order allow,deny
allow from all
</Directory>

</VirtualHost>

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Virtualhost niet aan de praat.
« Reactie #10 Gepost op: 2012/10/10, 18:26:10 »
Gefeliciteerd!
Begrijp ik nu goed dat het in de regel ServerName Localhost zat?


Offline wilvs

  • Lid
Re: Virtualhost niet aan de praat.
« Reactie #11 Gepost op: 2012/10/10, 18:41:32 »
Hoi Tap,

Die regel had ik al eens een keertje bijgevoegd, maar geen resultaat.  Ik ga zodadelijk testen waar het aan lag. Even wat in cq uitschakelen. Je hoort nog.