Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opstartfout  (gelezen 915 keer)

Offline Anno

  • Lid
  • Steunpunt: Nee
Opstartfout
« Gepost op: 2012/09/19, 17:14:14 »
Bij het opstarten krijg ik steeds de waarschuwing:
Er is een fout opgetreden tijdens het aankoppelen van smbfs.

Het kan dan op de s toets drukken, en dan start de computer gewoon door. De volgende keer gebeurt echter hetzelfde weer.
Ik heb geen idee wat het betekent en wat ik er aan kan doen.
Ik weet zelfs niet of ik hier op het goede forum zit.
Anno.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #1 Gepost op: 2012/09/19, 17:47:54 »
Een samba-bestandssysteem dat niet langer bereikbaar is?

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #2 Gepost op: 2012/09/19, 18:06:40 »
Ik weet niet of het met Samba te maken heeft. Ik kan niet via "Netwerk" in mijn netwerk komen, maar wel via het volgende scriptje:"gvfs-mount smb://nas-destolp/documenten/"

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #3 Gepost op: 2012/09/19, 18:34:13 »
Het heeft in elk geval te maken met samba. Google maar eens op "smbfs". Blijkbaar lukt het niet, om het betreffende samba-bestandssysteem aan te koppelen tijdens de opstart.

Hoe je dat moet oplossen weet ik niet, aangezien ik zelf geen samba gebruik. Maar je weet nu in elk geval wel, in welke hoek je de oplossing moet zoeken...

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #4 Gepost op: 2012/09/20, 09:47:11 »
Ik heb op Google gezocht en er is erg veel te vinden over smbfs, maar echt wijzer wordt ik er niet van. Ik heb gezien dat er een commando is waarmee je andere schijven kunt mounten via een Terminal. Misschien dat er ergens een script draait bij het opstarten, dat dat commando gebruikt, maar waar kan ik dat dan vinden. Ik heb het commande in de terminal geprobeerd en dat zag er zo uit:

anno@AnnoW-Ubuntu:~$ mount.smbfs

Usage:  mount.cifs <remotetarget> <dir> -o <options>

Mount the remote target, specified as a UNC name, to a local directory.

Options:
   user=<arg>
   pass=<arg>
   dom=<arg>

Less commonly used options:
   credentials=<filename>,guest,perm,noperm,setuids,nosetuids,rw,ro,
   sep=<char>,iocharset=<codepage>,suid,nosuid,exec,noexec,serverino,
   mapchars,nomapchars,nolock,servernetbiosname=<SRV_RFC1001NAME>
   directio,nounix,cifsacl,sec=<authentication mechanism>,sign,fsc

Options not needed for servers supporting CIFS Unix extensions
   (e.g. unneeded for mounts to most Samba versions):
   uid=<uid>,gid=<gid>,dir_mode=<mode>,file_mode=<mode>,sfu

Rarely used options:
   port=<tcpport>,rsize=<size>,wsize=<size>,unc=<unc_name>,ip=<ip_address>,
   dev,nodev,nouser_xattr,netbiosname=<OUR_RFC1001NAME>,hard,soft,intr,
   nointr,ignorecase,noposixpaths,noacl,prefixpath=<path>,nobrl

Options are described in more detail in the manual page
   man 8 mount.cifs

To display the version number of the mount helper:
   mount.cifs -V

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #5 Gepost op: 2012/09/20, 11:15:24 »
Het gaat alleen om een samba-bestandssysteem, hè..... Dus eentje op afstand. Kijk eens in je opstarttoepassingen.

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #6 Gepost op: 2012/09/20, 11:59:20 »
Rechtsboven in mijn scherm zit een knop in de vorm van een radertje. Daaronder zit een menu met opstarttoepassingen. Dat bedoel je denk ik. Bij opstarttoepassingen O0 staat helemaal niets.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #7 Gepost op: 2012/09/20, 12:12:53 »
Maak ze eerst eens allemaal zichtbaar:
https://sites.google.com/site/computertip/snelheid
(punt 4, rechterkolom)

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #8 Gepost op: 2012/09/20, 13:06:26 »
Kan een van dse volgende items er iets mee te maken hebben?
-bestanden(geen beschrijving)
-hulpmiddelen voor aankoppelen (apparaten aankoppelen en autorun uitvoeren)
-netwerk (uw netwerkverbindingen beheren)
-uw bestanden delen (persoonlijke bestanden delen. opstarten indien ingeschakeld)
-werkomgeving delen (server voor chrome-bureaublad op afstand)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #9 Gepost op: 2012/09/20, 14:23:38 »
Geen flauw idee. Probeer eens wat? Eentje uitschakelen, afmelden, aanmelden. Net zolang tot je de boosdoener hebt gevonden.

En kijk ook eens bij de eigenschappen van de opstarttoepassingen: wat starten ze "onder de motorkap"?
« Laatst bewerkt op: 2012/09/20, 14:25:20 door Pjotr »

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #10 Gepost op: 2012/09/20, 16:05:48 »
Ik heb alle opstarttoepassingen uitgeschakeld, maar de melding blijft: het gebeurt voor datr Ubuntu is opgestart.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #11 Gepost op: 2012/09/20, 17:21:19 »
Wat geeft:
gedit /etc/fstab

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #12 Gepost op: 2012/09/20, 17:25:33 »
Dat geeft:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda9 during installation
UUID=e771d8d5-da79-4c2b-bd38-a77a8b91af3c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda7 during installation
UUID=dba458a8-b5ee-4bff-b34b-1ab2a8f899e3 none            swap    sw              0       0
# Mount our network drive
//nas-destolp/P1_C_5/media/public smbfs guest 0 0

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #13 Gepost op: 2012/09/20, 17:30:37 »
Doe eens dit:
gksudo gedit /etc/fstab
Druk op Enter.

Zet een hekje voor de laatste regel, dus die wordt dan als volgt:
# //nas-destolp/P1_C_5/media/public smbfs guest 0 0
Sla het gewijzigde bestand op en herstart je computer. Helpt dit?
« Laatst bewerkt op: 2012/09/20, 17:37:33 door Pjotr »

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #14 Gepost op: 2012/09/20, 17:41:31 »
 :) Dat heeft geholpen. Geeft dat geen andere problemen, want ik denk dat het zou kunnen dat ik hiermee een verbinding heb uitgeschakeld.


Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Ja
Re: Opstartfout
« Reactie #15 Gepost op: 2012/09/20, 17:46:00 »
Hiermee heb je slechts het automatisch aankoppelen uitgezet, wat niet erg is, daar het toch al niet werkte ;)
Trotse eigenaar van een Nokia N900, een Nokia N9 en een Jolla.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #16 Gepost op: 2012/09/20, 17:48:31 »
Mooi.  :)
Wat je hiermee hebt gedaan, is dat je het Samba-bestandssysteem hebt uitgeschakeld als permanent beschikbaar bestandssysteem. Want wat in /etc/fstab staat, moet altijd beschikbaar zijn voor het systeem.

Zoals gezegd heb ik geen ervaring met Samba en NAS, maar ik vermoed dat de nieuwe situatie ook de betere is: een NAS zal immers niet altijd aanstaan...

Vermoedelijk heb je Ubuntu geïnstalleerd met een via Samba aangekoppelde NAS, waardoor die toen door het installatieprogramma is gehouden voor een permanent beschikbaar bestandssysteem. En dus in fstab is gezet.

Wat een oude wijsheid onderstreept: maak je ijzerwaar zo simpel mogelijk tijdens installatie, dus alleen scherm, toetsenbord en muis. Randapparatuur pas aansluiten na voltooide installatie....

---toevoeging: Timo is me te snel af....
« Laatst bewerkt op: 2012/09/20, 17:50:49 door Pjotr »

Offline Anno

  • Lid
  • Steunpunt: Nee
Re: Opstartfout
« Reactie #17 Gepost op: 2012/09/20, 17:52:01 »
Pjotr en Timo, bedankt voor de hulp!