Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met 'network settings' (draadloos)  (gelezen 3220 keer)

thunderbirdje

  • Gast
Probleem met 'network settings' (draadloos)
« Gepost op: 2007/02/23, 23:30:11 »
Hoi iedereen...

Als blije Linux-man stuit ik echter op een eerder raar kantje...

Mijn draadloos netwerk werkte perfect (via system > Network settings had ik prachtig twee kaartjes staan: 'wired connection eth0' en 'wireless connection wlan0'. Zo kon ik de SSID en Key aanpassen wanneer ik op de 'wireless connection' klikte.

Echter, tot vorig weekend, starte ik mijn laptop op en had ik plots 2 wired connections staan!!! De wireless was veranderd in 'wired'!!! Maar behoudt wel de naam 'wlan0'. Deze lijkt omgetoverd in een netwerkkaart met draad :s Ik heb nergens kunnen vinden in welke config-bestanden je dit kan aanpassen?

de /etc/network/interfaces heb ik al meerdere malen aangepast, maar daar kan je niet kiezen of een wlan0 wireless of wired moet worden? (alleen kan je bv bij wlan0 SSID definiëren, wat mislukt omdat het een wired connection is geworden).

Ook al probeerde ik ndiswrapper (wat eigenlijk niet hoefde want het heeft gewerkt). Dit progje werkt (aanvaard windows-driver), geeft ook melding dat de kaart gevonden is. Echter kan dit geen draadloze verbinding ondersteunen omdat deze (op één of ander lager niveau???) als wired is gedefinieerd. Grrrmpfl.

Na 3 avonden zoeken word ik het toch 'n beetje beu, en vroeg mij af of jullie konden helpen?

- Dual boot (windows XP Home) en Ubuntu
- Draadloos netwerk gebruikt (WEP Open, Hex key) -> werkte reeds vroeger al (aan de router-instellingen is niets veranderd).
- Met netwerkkabel op de netwerkkaart werkt alles perfect.

Als je nog iets meer moet weten... Geen probleem.

Hartelijk dank alvast!

baszsiejj

  • Gast
Probleem met 'network settings' (draadloos)
« Reactie #1 Gepost op: 2007/02/24, 12:31:22 »
heb je wel ontvangst met die wireless card?
of kan je em niet meer gebruiken, wel raar natuurlijk

ik ken iemand hier die erg veel weet van wireless networking, ik zal hem hierheen verwijzen =)

grtz,
 bas

thunderbirdje

  • Gast
Probleem met 'network settings' (draadloos)
« Reactie #2 Gepost op: 2007/02/24, 13:24:26 »
Dag Bas

Ontvangst heb ik :-) (zit knal naast de router :-))

Super bedankt alvast!!

greets

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
Probleem met 'network settings' (draadloos)
« Reactie #3 Gepost op: 2007/02/24, 18:07:00 »
Hiervoor moet /etc/network/interfaces aangepast worden, daar kan je makkelijk je essid en uw WEP key definieren. Doe 't volgende ongeveer:
sudo gedit /etc/network/interfaces                                                         (en zorg dat de wlan0 er zo uitziet ongeveer:)

auto wlan0
iface wlan0 inet dhcp
wireless_essid jouw_essid
wireless_key jouw_key

.. En opslaan en run derna sudo /etc/init.d/networking restart

Als da hier nie lukt zou ik graag eens willen zien wat sudo iwconfig en sudo ifconfig zegt :)

thunderbirdje

  • Gast
Probleem met 'network settings' (draadloos)
« Reactie #4 Gepost op: 2007/02/24, 20:58:11 »
Hoi phar0z

Bovenstaande uitgetest...

Bij sudo /etc/init.d/networking restart krijg ik reeds de melding:

thunderbird@jennifer:~$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...                                          There is already a pid file /var/run/dhclient.eth0.pid with pid 4637
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:0d:9d:5b:a3:58
Sending on   LPF/eth0/00:0d:9d:5b:a3:58
Sending on   Socket/fallback
DHCPRELEASE on eth0 to 192.168.123.254 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
There is already a pid file /var/run/dhclient.wlan0.pid with pid 4795
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:00:00:00:00:00
Sending on   LPF/wlan0/00:00:00:00:00:00
Sending on   Socket/fallback
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Operation not supported.
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; Operation not supported.
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; Operation not supported.
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; Operation not supported.
There is already a pid file /var/run/dhclient.wlan0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFFLAGS: No such device
SIOCSIFFLAGS: No such device
Listening on LPF/wlan0/00:00:00:00:00:00
Sending on   LPF/wlan0/00:00:00:00:00:00
Sending on   Socket/fallback
receive_packet failed on wlan0: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
send_packet: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
send_packet: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
send_packet: Network is down
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
send_packet: Network is down
sudo iwconfig:

thunderbird@jennifer:~$ sudo iwconfig
lo        no wireless extensions.

wlan0     no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.
sudo ifconfig:

thunderbird@jennifer:~$ sudo ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:74 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5504 (5.3 KiB)  TX bytes:5504 (5.3 KiB)
Het GUI-venster waarover ik sprak hier helemaal boven...



Hopelijk weet je hiermee iets meer? :-)

Greets!

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
Probleem met 'network settings' (draadloos)
« Reactie #5 Gepost op: 2007/02/24, 22:33:06 »
Welke ontvanger gebruikt ge? mag ik eens output zien van lspci en lsusb?

thunderbirdje

  • Gast
Probleem met 'network settings' (draadloos)
« Reactie #6 Gepost op: 2007/02/24, 23:53:36 »
Natuurlijk...

Ik heb één connectie voor een vaste netwerkkabel (eth0) en één draadloze netwerkkaart (wlan0, maar wordt weergevene als 'wired').

thunderbird@jennifer:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:09.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01)
00:0a.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1
thunderbird@jennifer:~$ lsusb
Bus 001 Device 008: ID 045e:007d Microsoft Corp. Notebook Optical Mouse
Bus 001 Device 001: ID 0000:0000  
thunderbird@jennifer:~$

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
Probleem met 'network settings' (draadloos)
« Reactie #7 Gepost op: 2007/02/26, 20:21:35 »
0:12.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller -> dit is uw netwerkkaart

00:09.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01) -> dit is dus uw wireless pci kaart

Deze kaart werkt in ubuntu dapper, maar nie in ubuntu edgy. Hebt gij een update gedaan van dapper naar edgy? Da zou dus perfect verklaren waarom ze eerst werkte en nu nie meer (vandaar da ge dus nu ziet dat ook een wired is geworde)

U kunt de windows drivers installeren met ndiswrapper ofwel een kernel recompile doen (maak gebruik van make menuconfig) en zorg dat onderstaande er zo uitziet:

Device Drivers  --->
    Network device support  --->
        Wireless LAN (non-hamradio)  --->
            IEEE 802.11 for Host AP (Prism2/2.5/3 and WEP/TKIP/CCMP)
                Support downloading firmware images with Host AP driver
                    Support for non-volatile firmware download
                Host AP driver for Prism2.5 PCI adaptors

Bekijk eens http://www.friedhoff.org/ma311.html#kernel%20config  (wel nix aantrekken van wpa en hostap)

thunderbirdje

  • Gast
Probleem met 'network settings' (draadloos)
« Reactie #8 Gepost op: 2007/02/28, 18:05:18 »
Hoi phar0z!

Bedankt voor alle info! Door wat je schreef over de kernel hercompileren heb ik ontdekt dat ik bij het opstraten keuze heb tussen 2 kernels:

2.6.17-11 en 2.6.17-10

Als ik opstart met de -10 heb ik 'wireless connection' staan en werkt alles perfect... bij de -11 is deze 'wired connection'.

Kan dit gekomen zijn door updates?

Ndiswrapper werkt nog niet met de driver bij mijn kaart bijgeleverd, maar ben nu op zoek naar de Orinoco-driver (schijnt compatibel te zijn).

Super bedankt! Ben nu al blij dat ik onder -10 wireless kan!

Greets!

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
Probleem met 'network settings' (draadloos)
« Reactie #9 Gepost op: 2007/02/28, 18:29:08 »
ah kernel recompilen is gelukt zie ik :) ja normaal he dan da ge meerdere kernels ziet :)

Uw probleem is idd te wijten aan updaten, ik ontdekte da uw kaart nie werkte op ubuntu edgy ..

Alé, ik zou eens booten naar uw 2.6.17-11kernel en diene Orinoco driver een kans geven
Download hem op http://sourceforge.net/project/downloading.php?groupname=orinoco&filename=orinoco-0.15.tar.gz&use_mirror=switch

(zie http://www.nongnu.org/orinoco/downloads/  neem de 0.15 final)

Nada ge Orinoco driver hebt gedownload, moet 't als volgt geinstalleerd worden: (plaats het via cp of mv commando in een bepaalde map en ga die map in via cd commando en doe dan volgende:)

tar zxvf orinoco*.tar.gz
cd orinoco*
make && sudo make install

Offline stani

  • Lid
    • http://pythonide.stani.be
  • Steunpunt: Nee
Probleem met 'network settings' (draadloos)
« Reactie #10 Gepost op: 2007/03/11, 04:26:57 »
Ik had net hetzelfde probleem. Deze oplossing is enkel voor de prism2.5 wavelan (probeer dit niet bij een andere draadloze kaart). We moeten wat toevoegen aan de blacklist omdat hij de verkeerde drivers laadt:

sudo gedit /etc/modprobe.d/blacklist

Voeg vervolgens dit toe:

blacklist prism2
blacklist prism2_pci
blacklist hostap_pci
blacklist hostap

Opslaan en heropstarten. Dat moet het doen!

Veel succes,

Stani

PS Deze methode werkt ook op Edgy en Feisty.

Offline stani

  • Lid
    • http://pythonide.stani.be
  • Steunpunt: Nee
Probleem met 'network settings' (draadloos)
« Reactie #11 Gepost op: 2007/03/15, 14:07:11 »
Als je wil dat dit wordt opgelost voor Feisty, ga dan naar launchpad:

https://launchpad.net/ubuntu/+source/linux-source-2.6.17/+bug/63989

Citaat
Can everyone affected please attach (do not paste into comment) the output of "lspci -vv" and "lspci -vvn", make sure to name the file something like lspci-vv-.txt
Stani