Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Gnomeradio geen geluid  (gelezen 744 keer)

Offline Haris

  • Lid
  • Steunpunt: Ja
Gnomeradio geen geluid
« Gepost op: 2012/08/29, 18:21:27 »
Hauppauge 250 iTVc16 (CX23416) werkt goed met beeld en geluid.
Nu getracht Gnomeradio 1.8 FM radio aan de praat te krijgen.
Zenders scannen en vastleggen gelukt, maar geen geluid.
Het opnemen gaat ook, ik krijg grote files,MP3,Wav,ogg etc.... 1 mb per minuut, maar er staat niets, dus geen geluid op de files.
Graag wat commando's om uit te vinden waar het geluid zit.
Werk met Lucid.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #1 Gepost op: 2012/08/29, 20:57:42 »
Helaas werkt de ivtv-driver niet via de standaard radio-API van V4L. Je zult met het tooltje
ivtv-radio
aan de slag moeten.
ivtv-radio -f 87.5
(vervang de frequentie door die naar jouw keuze, mogelijk moet je het als root uitvoeren met sudo).
Daarna kun je testen of de kaart juist is afgestemd met:
aplay -f dat < /dev/video24
(afbreken met ctrl+c).

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #2 Gepost op: 2012/08/30, 14:11:10 »
Dank, ik krijg:

~$ ivtv-radio -87.95
set to freq 87.95
Running aplay -f dat < /dev/video24
Playing raw data ´stdin´ : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo

Maar nergens geluid. Heb ook andere freq. geprobeerd.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #3 Gepost op: 2012/08/30, 19:26:28 »
Staat je geluid aan? Is de kabel op de radio-ingang aangesloten? Heb je toevallig een gesplitst signaal, dus voor radio en tv een aparte kabel?

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #4 Gepost op: 2012/08/30, 19:38:35 »
Ja, geluid staat aan, ik kan van alles afspelen via de groene uitgang...
 

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #5 Gepost op: 2012/08/30, 19:41:01 »
Ben je toevallig tv aan het opnemen of kijken? Tijdens het radio luisteren kun je geen gebruik maken van de tv-functie van de kaart.

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #6 Gepost op: 2012/08/30, 19:43:16 »
Neen...
Is er niet uit te vinden waar het radiogeluid zich in de kaart bevindt en waar het naar toe gaat of zo? :rolleyes:

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #7 Gepost op: 2012/08/30, 19:45:32 »
Neen...
Is er niet uit te vinden waar het radiogeluid zich in de kaart bevindt en waar het naar toe gaat of zo? :rolleyes:
Wat is de uitvoer van:
v4l2-ctl --all
?

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #8 Gepost op: 2012/08/30, 19:57:33 »
~$ v4l2-ctl --all
Driver Info:
   Driver name   : ivtv
   Card type     : Hauppauge WinTV PVR-250
   Bus info      : PCI:0000:01:09.0
   Driver version: 66561
   Capabilities  : 0x01070051
      Video Capture
      VBI Capture
      Sliced VBI Capture
      Tuner
      Audio
      Radio
      Read/Write
Format Video Capture:
   Width/Height  : 720/576
   Pixel Format  : 'MPEG'
   Field         : Interlaced
   Bytes per Line: 0
   Size Image    : 131072
   Colorspace    : Broadcast NTSC/PAL (SMPTE170M/ITU601)
Format Sliced VBI Capture:
   Service Set    :
   Service Line  0:          /         
   Service Line  1:          /         
   Service Line  2:          /         
   Service Line  3:          /         
   Service Line  4:          /         
   Service Line  5:          /         
   Service Line  6:          /         
   Service Line  7:          /         
   Service Line  8:          /         
   Service Line  9:          /         
   Service Line 10:          /         
   Service Line 11:          /         
   Service Line 12:          /         
   Service Line 13:          /         
   Service Line 14:          /         
   Service Line 15:          /         
   Service Line 16:          /         
   Service Line 17:          /         
   Service Line 18:          /         
   Service Line 19:          /         
   Service Line 20:          /         
   Service Line 21:          /         
   Service Line 22:          /         
   Service Line 23:          /         
   I/O Size       : 0
Format VBI Capture:
   Sampling Rate   : 27000000 Hz
   Offset          : 248 samples (9.18519e-06 secs after leading edge)
   Samples per Line: 1439
   Sample Format   : GREY
   Start 1st Field : 6
   Count 1st Field : 18
   Start 2nd Field : 318
   Count 2nd Field : 18
Crop Capability Video Output:
   Bounds      : Left 0, Top 0, Width 720, Height 576
   Default     : Left 0, Top 0, Width 720, Height 576
   Pixel Aspect: 59/54
Video input : 0 (Tuner 1)
Audio input : 0 (Tuner 1)
Frequency: 6400 (400.000000 MHz)
Video Standard = 0x0000000f
   PAL-B/B1/G/H
Tuner:
   Name                 : ivtv TV Tuner
   Capabilities         : 62.5 kHz multi-standard stereo lang1 lang2
   Frequency range      : 44.0 MHz - 958.0 MHz
   Signal strength/AFC  : 0%/-187500
   Current audio mode   : stereo
   Available subchannels: mono
haris@haris-desktop:~$


[Mod edit: zou je in het vervolg even code-tags willen gebruiken als je code plaatst? Alvast bedankt namens het forum :-)]
« Laatst bewerkt op: 2012/08/30, 20:14:58 door TopGear »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #9 Gepost op: 2012/08/30, 20:05:28 »
Kun je nu nog de uitvoer plaatsen van:

ls /dev | grep video
?

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #10 Gepost op: 2012/08/30, 20:09:37 »
video0
video24
video32

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #11 Gepost op: 2012/08/30, 20:11:56 »
Staat toevallig gnome-radio nog aan? Probeer anders je pc te herstarten alvorens nog een poging te ondernemen.

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #12 Gepost op: 2012/08/30, 20:29:00 »
Herstart gedaan, niets.
In de gnomeradio settings staat de mixer source op 'line'.
Is dat ok?

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #13 Gepost op: 2012/08/30, 20:46:58 »
Het lijkt me beter als je gnome-radio afsluit als je met ivtv-radio aan de slag wilt, bedoelde ik.

Ik weet niet zeker of je tv-kaart een aparte mixer heeft. Kun je bij Geluidsinstellingen, tabblad invoer/hardware (ligt aan je Ubuntu-versie) een tv-kaart zien?

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #14 Gepost op: 2012/08/30, 21:07:02 »
Neen, geen tv kaart te zien...

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #15 Gepost op: 2012/08/31, 23:35:47 »
Hoera, ik heb geluid! :)

Volgende post gevonden:
http://ubuntuforums.org/archive/index.php/t-1941368.html

Configuration editor, apps, gnomeradio.

device       /dev/radio0
driver        v4l2        (stond op: any)
Configuration editor afsluiten.

Gnomeradio starten. (krijg geen geluid)
In terminal: $ aplay -f dat < /dec/video24
krijg: Playing raw data ´stdin´ : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo

en het geluid gaat aan!

Nu is de vraag natuurlijk, hoe krijg ik geluid zonder de terminal te gebruiken?

Offline Haris

  • Lid
  • Steunpunt: Ja
Re: Gnomeradio geen geluid
« Reactie #16 Gepost op: 2012/09/01, 00:07:15 »
Nog een puntje, de opnameknop reageert en maakt een file aan maar op die file staat geen geluid, wel MB's....

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Gnomeradio geen geluid
« Reactie #17 Gepost op: 2012/09/01, 13:17:05 »
Je zult met bijvoorbeeld VLC /dev/video24 moeten openen. Met VLC kun je ook opnemen.