Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: index.php moet in URL staan om gestart te worden  (gelezen 804 keer)

Offline Josr

  • Lid
  • Steunpunt: Nee
index.php moet in URL staan om gestart te worden
« Gepost op: 2012/08/15, 11:44:01 »
Ik gebruik al jaren een LAMP server (8.04) om sites op te testen, dat werkt goed. Nu heb mijn site omgezet naar PHP.
Als ik nu de URL aangeef wordt index.php niet automatisch gestart, ik moet de index.php in de URL opnemen.
Voorbeeld:
http://86.80.118.169/riechelmann.tv/index.php   i.p.v.   http://86.80.118.169/riechelmann.tv/
Wat moet ik doen om index.pnp automatisch te laten starten?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: index.php moet in URL staan om gestart te worden
« Reactie #1 Gepost op: 2012/08/15, 13:57:58 »
Heb je de server een keer opnieuw gestart na de overgang op PHP ?
Verder gebruik je een antieke versie, een nieuwe installatie met een nieuwere versie is wel aan te raden.
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: index.php moet in URL staan om gestart te worden
« Reactie #2 Gepost op: 2012/08/15, 15:04:36 »
Wat moet ik doen om index.pnp automatisch te laten starten?
Zorg dat de DirectoryIndex-opdracht in het configuratiebestand behalve index.html ook index.php bevat.

Ik weet helaas niet waar die opdracht voor de met LAMP meekomende Apache precies staat (en voor LAMPP/XAMPP is het ongetwijfeld weer anders). In de standaard httpd.conf van Apache zelf staat het pakweg halverwege, in een <IfModule dir_module> blok.

Offline Josr

  • Lid
  • Steunpunt: Nee
Re: index.php moet in URL staan om gestart te worden
« Reactie #3 Gepost op: 2012/08/17, 17:02:09 »
Naar aanleiding van je advies ik heb uitgevonden dat ik  /etc/apache2/mods-enabled/dir.conf moet aanpassen met de volgende regel:
<IfModule mod_dir.c>
          DirectoryIndex index.html index.cgi index.pl index.php index.xhtml index.htm
</IfModule>

Echter dir.conf staat in mijn systeem in: /etc/apache2/mods-available/ en heeft al de juiste inhoud.
Ik ga binnenkort upgraden naar 12.04 en dan zal e.e.a. verder uitproberen.
Hartelijk dank voor jullie advies.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: index.php moet in URL staan om gestart te worden
« Reactie #4 Gepost op: 2012/08/17, 17:05:09 »
In dat geval zou alleen het commando "sudo a2enmod dir" en daarna een restart van Apache ook al moeten werken.
Wel gek, want die module zou standaard gewoon aan moeten staan.

Offline Josr

  • Lid
  • Steunpunt: Nee
Re: index.php moet in URL staan om gestart te worden
« Reactie #5 Gepost op: 2012/08/27, 08:23:19 »
Syntax error on line 7 of /etc/apache2/conf.d/phpmyadmin.conf:
Invalid command 'DirectoryIndex', perhaps misspelled or defined by a module not included in the server configuration
   ...fail!

De inhoud van deze file:

# phpMyAdmin default Apache configuration
Alias /phpmyadmin /usr/share/phpmyadmin
<Directory /usr/share/phpmyadmin>
   Options Indexes FollowSymLinks
   DirectoryIndex index.php

....   # Authorize for setup
   .
   .
   .

Deze regel op meerdere manieren aangepast zonder resultaat.
De oorzaak zou in "phpMyAdmin" kunnen liggen.

Ik wacht nu eerst even de upgrade naar 12.04 even af.

Hartelijk dank voor uw bijdrage

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: index.php moet in URL staan om gestart te worden
« Reactie #6 Gepost op: 2012/08/27, 10:59:06 »
...defined by a module not included in the server configuration...
Is de dir-module wel geladen?

Ergens voor je die opdracht gebruikt moet iets als:
LoadModule dir_module modules/mod_dir.soin de configuratie staan.

Bovendien weet ik niet of het verstandig is die opdracht (nog eens?) in een <Directory> blok te zetten. In mijn httpd.conf staat hij gewoon 'los' in de body van het bestand, na het instellen van de defaults voor de document root.