Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Lightdm staat in de verkeerde resolutie  (gelezen 574 keer)

Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
[opgelost] Lightdm staat in de verkeerde resolutie
« Gepost op: 2012/07/18, 18:20:53 »
Hallo allemaal,

Ik heb sinds kort een 21,5" monitor in bezit die ik heb aangesloten op mijn netbook (qua specs is een netbook mij genoeg, echter het scherm is een beetje klein). Op zich is dat prima gegaan, alleen heb ik een klein dingetje wat me best wel irriteert, namelijk Lightdm (het inlogscherm) staat niet in de goede resolutie. Volgens mij staat hij in 800x640, wat ietwat laag is voor mijn monitor die 1920x1080 aan kan. Ik heb de resolutie al proberen aan te passen d.m.v. xrandr, dat helpt echter niet. Voor de goede orde zal ik even een linkje geven met (ongeveer) wat ik heb gedaan: http://www.sudo-juice.com/lightdm-resolution/

Heeft iemand toevallig een idee hoe ik dit probleem kan verhelpen?

Luckiboy
« Laatst bewerkt op: 2012/12/11, 21:43:22 door Luckiboy »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #1 Gepost op: 2012/07/18, 19:00:37 »
De beeldverhouding "hard" vastleggen in /etc/X11/xorg.conf?

Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #2 Gepost op: 2012/07/18, 19:06:26 »
12.04 heeft geen xorg.conf meer  :(

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #3 Gepost op: 2012/07/18, 19:18:14 »
Dat weet ik, maar daar hebben we het volgende op gevonden:
https://sites.google.com/site/computertip/geenbeeld#TOC-Alleen-voor-gevorderden
(punt 9, rechterkolom)

Gewoon alsnog aanmaken, dus. :)

Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #4 Gepost op: 2012/07/18, 19:42:10 »
Pjotr, ik krijg gelijk bij de eerste stap, Xorg -configure, al een foutmelding.
Citaat
Fatal Server Error:
Could not create lock file in /tmp/.tX0-lock

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #5 Gepost op: 2012/07/18, 19:45:36 »
Eerst moet je blijkbaar even het bestandssysteem lezen-schrijven aankoppelen. Tik in (let goed op de spaties, dit is een opdracht die makkelijk verkeerd wordt ingetikt!):
mount -n -o remount,rw /
Druk op Enter.

Je krijgt nu een waarschuwing te zien van mntent, over /etc/fstab. Deze waarschuwing kun je gewoon negeren.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #6 Gepost op: 2012/07/18, 20:18:00 »
sudo dpkg-reconfigure lightdm

Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #7 Gepost op: 2012/07/18, 21:15:47 »
@Vistaus
Dat heb ik al geprobeerd, haalt niks uit :(

@Pjotr
Oké, ik heb nu xorg.conf in /etc/X11/ met de inhoud:
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
Screen      1  "Screen1" RightOf "Screen0"
Screen      2  "Screen2" RightOf "Screen1"
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/X11/misc"
FontPath     "/usr/share/fonts/X11/cyrillic"
FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/Type1"
FontPath     "/usr/share/fonts/X11/100dpi"
FontPath     "/usr/share/fonts/X11/75dpi"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath     "built-ins"
EndSection

Section "Module"
Load  "record"
Load  "dri"
Load  "dbe"
Load  "dri2"
Load  "glx"
Load  "extmod"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option     "Protocol" "auto"
Option     "Device" "/dev/input/mice"
Option     "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Monitor"
Identifier   "Monitor1"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Monitor"
Identifier   "Monitor2"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "DRI"                # [<bool>]
        #Option     "ColorKey"            # <i>
        #Option     "VideoKey"            # <i>
        #Option     "FallbackDebug"      # [<bool>]
        #Option     "Tiling"              # [<bool>]
        #Option     "LinearFramebuffer"  # [<bool>]
        #Option     "Shadow"              # [<bool>]
        #Option     "SwapbuffersWait"    # [<bool>]
        #Option     "TripleBuffer"        # [<bool>]
        #Option     "XvMC"                # [<bool>]
        #Option     "XvPreferOverlay"    # [<bool>]
        #Option     "DebugFlushBatches"  # [<bool>]
        #Option     "DebugFlushCaches"    # [<bool>]
        #Option     "DebugWait"          # [<bool>]
        #Option     "HotPlug"            # [<bool>]
        #Option     "RelaxedFencing"      # [<bool>]
Identifier  "Card0"
Driver      "intel"
BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"            # [<bool>]
        #Option     "Rotate"              # <str>
        #Option     "fbdev"              # <str>
        #Option     "debug"              # [<bool>]
Identifier  "Card1"
Driver      "fbdev"
BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"            # [<bool>]
        #Option     "DefaultRefresh"      # [<bool>]
        #Option     "ModeSetClearScreen" # [<bool>]
Identifier  "Card2"
Driver      "vesa"
BusID       "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device     "Card1"
Monitor    "Monitor1"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device     "Card2"
Monitor    "Monitor2"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Ik heb echter geen idee wat ik hieraan zou moeten veranderen?

Bedankt voor alle tot zo ver aangeboden hulp.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #8 Gepost op: 2012/07/18, 21:20:33 »
Hier staat een handleiding, ook voor het vullen van xorg.conf:
https://wiki.ubuntu.com/X/Config/Resolution

Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #9 Gepost op: 2012/07/19, 12:22:48 »
Pjotr, ik heb je links geprobeerd, met als gevolg dat lightdm helemaal niet meer verscheen. sudo rm /etc/X11/xorg.conf, nu weer terug bij af. Wat kan ik hebben foutgedaan en/of heeft iemand nog ideeën?

Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #10 Gepost op: 2012/07/19, 12:50:54 »
Voor de duidelijkheid post ik nog een screenshot van mijn scherm-instellingen:

Ik hoop dat het zo wat duidelijker wordt en/of dat jullie er iets mee kunnen

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #11 Gepost op: 2012/07/20, 20:19:31 »
Ik weet dat je randr al had geprobeerd, maar misschien dat dit alsnog helpt?
http://www.ashwinraon.com/2012/05/how-to-change-lightdm-resolution-in-ubuntu/

Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #12 Gepost op: 2012/07/28, 20:47:28 »
Sorry dat het zo lang duurde (vakantie 8-)), ik heb je link geprobeerd, Vistaus, maar ik krijg bij het uitvoeren van het script (./lightdmxrandr.sh) de output:  /bin/sh: 0: Can't open xrandr --output VGA1 --primary --mode 1920x1080.
Wat doe ik fout?


Offline Luckiboy

  • Documentatieteam
    • luckiboy
  • Steunpunt: Nee
Re: Lightdm staat in de verkeerde resolutie
« Reactie #13 Gepost op: 2012/12/11, 21:38:17 »
Sorry voor het naar boven halen van dit oude topic, maar ik wil even zeggen dat het opgelost is!  :) Na enig puzzelen geeft de volgende werkwijze de oplossing:

gksudo gedit /etc/lightdm/lightdm.conf
Voeg in dit bestand de volgende regel toe (en verander ev. de resoluties en namen): display-setup-script=xrandr --output VGA1 --mode 1920x1080 --output LVDS1 --off
Herstarten en mijn lightdm is net zo strak als het hoort  :D