Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Problemen met SSH over extern IP-adres in één richting  (gelezen 836 keer)

Offline Exeleration-G

  • Lid
    • exeleration-g
  • Steunpunt: Nee
Problemen met SSH over extern IP-adres in één richting
« Gepost op: 2012/07/16, 19:48:11 »
Dag allemaal.

Ik gebruik thuis een computer met Lubuntu 12.04 en een laptop met Ubuntu 12.04. Op beide systemen is ssh geïnstalleerd. Het volgende lukt wel:

- vanuit mijn laptop SSH'en in de computer met behulp van lokaal IP-adres
- vanuit mijn laptop SSH'en in de computer met behulp van naam en computernaam (gebruiker@Thuis-PC)
- vanuit mijn computer SSH'en in de laptop met behulp van lokaal IP-adres
- vanuit mijn computer SSH'en in de laptop met behulp van naam en computernaam (gebruiker@Laptop)
- vanuit mijn computer SSH'en in de laptop met behulp van extern IP-adres

Echter, het lukt niet om vanuit mijn laptop te SSH'en in de computer met behulp van het extern IP-adres. Ik krijg dan een foutmelding in de terminal: het wachtwoord zou onjuist zijn. In de router is poort 22 geopend voor beide systemen. Ik heb op zowel de laptop als op de computer de map ~/.ssh verwijderd, maar dit hielp niet.

Ik heb geen idee wat er verkeerd gaat. Als iemand zou kunnen helpen, zou dat fijn zijn.

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #1 Gepost op: 2012/07/16, 22:40:19 »
Met welk account probeer je dit te doen?
Standaard is het niet toegestaan om met root via ssh in te loggen.
Normaal zou je dus zo verbinden:
ssh gebruiker@12.34.56.78

Je kunt op de ontvangende kant ook even in de logfiles kijken....die geven waarschijnlijk aan wat er mis gaat
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline rja

  • Lid
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #2 Gepost op: 2012/07/17, 13:10:02 »
Je kunt ook optie -vv toevoegen aan het ssh commando.

Dan laat hij veel meer informatie zien.

Offline Exeleration-G

  • Lid
    • exeleration-g
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #3 Gepost op: 2012/07/17, 16:07:18 »
Buzzin, welke log zou ik moeten raadplegen?

Dit is de output van ssh -vv:
gijs@Gijs-PC:~$ ssh -vv bart@<externe.ip> -p 22
OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to <externe.ip> [<externe.ip>] port 22.
debug1: Connection established.
debug1: identity file /home/gijs/.ssh/id_rsa type -1
debug1: identity file /home/gijs/.ssh/id_rsa-cert type -1
debug1: identity file /home/gijs/.ssh/id_dsa type -1
debug1: identity file /home/gijs/.ssh/id_dsa-cert type -1
debug1: identity file /home/gijs/.ssh/id_ecdsa type -1
debug1: identity file /home/gijs/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9p1 Debian-5ubuntu1
debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-rsa-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-dss-cert-v00@openssh.com,ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: kex_parse_kexinit: ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-sha2-256,hmac-sha2-256-96,hmac-sha2-512,hmac-sha2-512-96,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit:
debug2: kex_parse_kexinit: first_kex_follows 0
debug2: kex_parse_kexinit: reserved 0
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 3f:dd:f6:0f:3a:4f:6d:4c:65:45:2b:ed:25:e9:10:62
debug1: Host '<externe.ip>' is known and matches the ECDSA host key.
debug1: Found key in /home/gijs/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/gijs/.ssh/id_rsa ((nil))
debug2: key: /home/gijs/.ssh/id_dsa ((nil))
debug2: key: /home/gijs/.ssh/id_ecdsa ((nil))
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/gijs/.ssh/id_rsa
debug1: Trying private key: /home/gijs/.ssh/id_dsa
debug1: Trying private key: /home/gijs/.ssh/id_ecdsa
debug2: we did not send a packet, disable method
debug1: Next authentication method: password
bart@<externe.ip>'s password:
debug2: we sent a password packet, wait for reply
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
bart@<externe.ip>'s password:
debug2: we sent a password packet, wait for reply
debug1: Authentications that can continue: publickey,password
Permission denied, please try again.
bart@<externe.ip>'s password:
debug2: we sent a password packet, wait for reply
debug1: Authentications that can continue: publickey,password
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey,password).
gijs@Gijs-PC:~$

Offline Exeleration-G

  • Lid
    • exeleration-g
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #4 Gepost op: 2012/07/17, 16:17:36 »
Deze draad lijkt over hetzelfde probleem te gaan. Misschien ligt het dan wel aan de router.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #5 Gepost op: 2012/07/18, 14:58:51 »
Ik begrijp de indeling van je netwerk niet helemaal.

Lukt wel:
Citaat
- vanuit mijn computer SSH'en in de laptop met behulp van extern IP-adres

Lukt niet:
Citaat
vanuit mijn laptop te SSH'en in de computer met behulp van het extern IP-adres

En dit:
Citaat
In de router is poort 22 geopend voor beide systemen.

Ik begrijp dat beide computers in hetzelfde lokale netwerk staan bij je thuis. De meeste providers leveren maar 1 extern IP adres, en de externe poort 22 kan je maar forwarden naar 1 computer.
Heb je misschien meerdere externe IP adressen? Zo niet, hoe heb je dan poort 22 geopend naar 2 computers tegelijk? Dat kan  voor zover ik weet namelijk helemaal niet. Hoe moet je router weten naar welke computer hij de pakketten die binnenkomen op poort 22 moet doorsturen?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #6 Gepost op: 2012/07/18, 15:18:56 »
Wat je verder nog kan bekijken zijn de bestanden in /var/log
Open op de computer een terminal en voer dit commando uit:
tail -f /var/log/auth.log |grep sshd
Als je nu vanuit de laptop via het interne IP adres inlogt, dan zie je als het goed is een aantal meldingen die normaal zijn.
Zie je vreemde meldingen als je het nu eens via het externe IP probeert?

Offline Exeleration-G

  • Lid
    • exeleration-g
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #7 Gepost op: 2012/07/18, 15:27:48 »
Dag Johan, bedankt voor je reactie. Zowel de computer als de laptop staan inderdaad in één netwerk achter één IP-adres. Ik was even vergeten hoe een router, en het openen van poorten, precies werkt.

Ik ga nu eerst proberen de SSH-poort van de computer te veranderen in 23, en zal ook 'Port 22' in /etc/ssh/sshd_config vervangen door 'Port 23'. Eens kijken of het dan wel lukt.

Offline Exeleration-G

  • Lid
    • exeleration-g
  • Steunpunt: Nee
Re: Problemen met SSH over extern IP-adres in één richting
« Reactie #8 Gepost op: 2012/07/18, 20:54:22 »
De output van de computer (=SSH-server) bij SSH'en over intern IP-adres:
bart@Thuis:~$ tail -f /var/log/auth.log | grep sshd
Jul 18 20:35:47 Thuis sudo:     bart : TTY=pts/1 ; PWD=/home/bart ; USER=root ; COMMAND=/usr/bin/leafpad /etc/ssh/sshd_config
Jul 18 20:40:36 Thuis sshd[3199]: Accepted password for bart from 192.168.1.66 port 41128 ssh2
Jul 18 20:40:36 Thuis sshd[3199]: pam_unix(sshd:session): session opened for user bart by (uid=0)
Jul 18 20:41:41 Thuis sshd[3414]: Received disconnect from 192.168.1.66: 11: disconnected by user
Jul 18 20:41:41 Thuis sshd[3199]: pam_unix(sshd:session): session closed for user bart


SSH over het extern IP-adres: ook na het veranderen van de poort van 22 naar 23 in zowel /etc/ssh/sshd_config als de router kom ik de computer niet binnen. Het bovengenoemde tailcommando geeft geen output bij het uitvoeren van deze SSH-actie. Op mijn laptop krijg ik de volgende output:
gijs@Gijs-PC:~$ ssh -vv bart@<extern.ip> -p 23
OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to <extern.ip> [<extern.ip>] port 23.
debug1: connect to address <extern.ip> port 23: Connection refused
ssh: connect to host <extern.ip> port 23: Connection refused
gijs@Gijs-PC:~$
« Laatst bewerkt op: 2012/07/18, 20:59:50 door Exeleration-G »