Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Connectie met VPN lijkt niet gebruikt te worden  (gelezen 448 keer)

Offline devlam

  • Lid
  • Steunpunt: Nee
Connectie met VPN lijkt niet gebruikt te worden
« Gepost op: 2012/07/06, 15:10:35 »
Heb vandaag op mijn ubuntu server een pptp vpn server opgezet conform het stappenplan van computer totaal, http://computertotaal.nl/software/22371-veilig-surfen-met-uw-eigen-vpn/2.html.
Vanaf een windows-7 machine lukt het ook een connectie te maken met deze VPN server.
Echter volgens het stappenplan zou vervolgens http://www.whatsmyip.org/ niet meer een ip-nummer uit de range van de provider moeten tonen maar een ip-nummer uit de eigen opgegeven range.

Bij mij is nog steeds een ip-nummer uit de provider-range zichtbaar.

Heb het hele stappenplan weer gecontroleerd en ik kan geen fout ontdekken. Heeft iemand een idee waar ik het probleem moet zoeken?
Wat me wel opvalt dat als de VPN-connectie aktief is bepaalde sites niet laden (b.v. nu.nl en abnamro.nl). Zodra ik de vpn-connectie afsluit verschijnen deze wel weer in beeld.

Offline devlam

  • Lid
  • Steunpunt: Nee
Re: Connectie met VPN lijkt niet gebruikt te worden
« Reactie #1 Gepost op: 2012/07/10, 14:16:06 »
Jammer, niemand een idee of hint?

Offline devlam

  • Lid
  • Steunpunt: Nee
Re: Connectie met VPN lijkt niet gebruikt te worden
« Reactie #2 Gepost op: 2012/07/10, 17:12:29 »
Nog een Nederlands youtube filmpje gevonden waar het opzetten van een PPTPD VPN wordt besproken (Zie http://marc0183.wordpress.com/2011/09/15/howto-installatie-vpn-server-op-ubuntu-server-11-04/.

Er zodoende achter gekomen dat in de /etc/pptpd.conf de localip en de remoteip in een andere range moet worden ingesteld dan de range die je binnen je locale netwerk gebruikt. Dat had ik dus niet gedaan.
Na een herstart van Ubuntu blijft het resultaat echter hetzelfde.

Wat ik nu wel zie is dat in de details van de status van de VPN connectie nu als client IPv4 adress het eerste ip van de opgegeven remoteip wordt vermeld en bij server IPv4 address de localip. Dat lijkt dus goed te zijn.

In de details staat ook nog als destination address het ip-nummer van mijn ubuntu server. Dat is ook het ip-nummer die ik bij het instellen van de VPN is opgegeven en waarnaar poort 1723 is geforward.

Echter de site www.whatismyip.org toont dus niet het client ip zoals in de details van de VPN is vermeld.  En nu.nl is nog steeds niet te benaderen, zowel niet met Chrome als met Internet Explorer.

Binnen de geavanceerde instellingen van chrome is de VPN-verbinding zichtbaar bij de VPN-settings.