Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Onderste werkbalk niet zichtbaar in Xubuntu 12.04  (gelezen 4870 keer)

Offline Cees

  • Lid
Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Gepost op: 2012/06/29, 17:01:46 »
Op de Toshiba Satellite M30 laptop heb ik naast Windows XP Xubuntu 12.04 geïnstalleerd. Na de installatie alle updates opgehaald.
Het probleem is dat de onderste werkbalk niet zichtbaar is maar is wel actief, want als ik met de muis halverwege onderaan het scherm dubbelklik wordt wel een applicatie opgestart. Met een rechtermuisklik onderaan het scherm kun je naar de werkbalk-voorkeuren gaan en daar is de optie "werkbalk automatisch tonen en verbergen" uitgevinkt, dus de onderste werkbalk zou permanent in beeld moeten zijn. Als de schermresolutie op 1024x768 wordt gezet, dan is de onderste werkbalk wel zichtbaar en na het weer terugzetten op de oorspronkelijke resolutie van 1280x800 blijft de werkbalk ook zichtbaar en doet alles het naar wens.
Als de schermresolutie op 1024x768 wordt gezet en de laptop wordt herstart, dan is de onderste werkbalk zichtbaar, alleen bij de resolutie van 1280x800 gaat het mis, dan is de werkbalk niet zichtbaar. Alleen tevoorschijn te toveren door even de resolutie te veranderen en dan weer terug. Hoe is Xubuntu in te stellen dat de werkbalk wordt getoond. Alvast bedankt voor je hulp.

Offline Marqeaux

  • Lid
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #1 Gepost op: 2012/06/29, 17:59:19 »
Heb je de extra stuurprogramma's geïnstalleerd? Zo nee, doe dat eens en kijk of je probleem na een restart is opgelost? Het lijkt me een puur grafisch probleem...
I'm just a simple guy who uses open source software. What's your excuse?

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #2 Gepost op: 2012/07/01, 10:59:34 »
Na het starten van "Extra stuurprogramma's" wordt aangegeven dat er geen stuurprogramma's beschikbaar zijn.
Als na het opstarten van Xubuntu de schermresolutie wordt veranderd naar 1024x768 en vervolgens weer terug naar 1280x800 doet Xubuntu het helemaal goed. Bij het opstarten van Xubuntu wordt het opstartscherm niet goed weergegeven, je ziet geen Xubuntu staan met die oplichtende puntjes eronder. Het lijkt er dus op dat Xubuntu uitgaat van een verkeerde schermresolutie alvorens die op 1200x 800 wordt gezet. Waar is het configuratie bestand van Xubuntu te vinden waar de initiele schermresolutie in staat? Mogelijk is die aan te passen.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #3 Gepost op: 2012/07/01, 11:18:09 »
Het lijkt me geen resolutieprobleem, maar puur een werkbalkprobleem. Het zwarte opstartscherm is normaal, trouwens.

Probeer eens de volgende noodgreep, wanneer de onderste werkbalk er niet is:

Hulpmiddelen - Terminalvenster

Tik de volgende toverspreuk in (voorkom fouten: kopieer en plak):
xfwm4 --replace
Druk op Enter.

Daarmee herstart je de vensterbeheerder, en dan is de boel hopelijk weer in orde. De echte oplossing zal moeten komen van de updates, verwacht ik...
« Laatst bewerkt op: 2012/07/01, 11:21:11 door Pjotr »

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #4 Gepost op: 2012/07/01, 11:36:10 »
In terminalvenster xfwm4 --replace uitgevoerd. Het scherm flitst dan even op waarbij de werkbalk even zichtbaar is en keert direct daarna weer terug in de oude positie, dus de werkbalk niet meer zichtbaar. De terminalprompt komt ook niet terug. Ook na een herstart blijft het bij het oude. Bij het afsluiten zie je ook heel even de werkbalk. Het lijkt erop dat 'ie verscholen zit achter de werkbladafbeelding.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #5 Gepost op: 2012/07/01, 12:32:31 »
Maak eens een nieuwe gebruiker aan, waarbij je alles op de standaardinstellingen laat staan. Meld je vervolgens aan in het nieuwe gebruikersaccount. Is het probleem daarin ook  aanwezig?

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #6 Gepost op: 2012/07/01, 13:39:45 »
Probleem is volgens mij dat de monitor niet herkent wordt, misschien samen met geen goede vidokaart driver.
Zelf heb ik dit ook met 1 pc waar geen driver voor is, en de monitor herkent hij niet, bij 1024x768 werken de balken wel goed.
Dus zoek een manier om aan te geven wat de waarde moet zijn van je monitor.
Misschien xrand met bepaalde waarde laten starten na het booten. Zoek of dit nog in xubuntu zit, of dat er een andere manier is.
https://wiki.ubuntu.com/X/Config/Resolution/
« Laatst bewerkt op: 2012/07/01, 13:41:47 door jan11000 »

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #7 Gepost op: 2012/07/01, 19:47:07 »
Pjotr en Jan,

een nieuwe gebruiker aangemaakt en als nieuwe gebruiker ingelogd, maar de werkbalk kwam ook niet tevoorschijn.
Daarna weer als mezelf ingelogd maar toen eens gekozen voor de "Xfce sessie" en tot mijn verbazing stond de werkbalk toen wel onderin het scherm (bij een resolutie van 1280x800). Het menu is wel anders dan eerst. Daarna weer afgemeld en vervolgens onder "Xubuntu sessie" aangemeld en toen stond de werkbalk ook onder in het scherm en het menu is weer hetzelfde als voorheen. Na een volledige start staat de werkbalk ook onder in het scherm, dus door eenmaal onder een "Xfce sessie" te draaien lijkt het probleem opgelost.
Maar toch blijft er een probleem met de grafische kaart waar Jan op attendeerde. Als ik b.v. het spel Mahjongg aanroep en het scherm maximaal maak, dan zijn de Mahjongg stenen aan de onderzijde (ca. 2/5 deel van het scherm) niet zichtbaar tenzij ik een steen aanklik, dan komt 'ie tevoorschijn. De werkbalk staat overigens wel onder in het scherm.
De Toshiba laptop heeft de Nvidia Geforce FX Go5200 grafische kaart en uit informatie van deze site en die van Pjotr (https://sites.google.com/site/computertip/xubuntu) lees ik dat Nvidia kaarten een probleem zijn.
xrandr geeft de volgende info:
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 4096 x 4096
LVDS-1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1280x800       60.0*+
   1024x768       59.9 
   800x600        59.9 
   640x480        59.4 
   720x400        59.6 
   640x400        60.0 
   640x350        59.8 
VGA-1 disconnected (normal left inverted right x axis y axis)
TV-1 disconnected (normal left inverted right x axis y axis)
DVI-D-1 disconnected (normal left inverted right x axis y axis)

Hoe nu verder met de nvidia driver?
Groet, Cees

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #8 Gepost op: 2012/07/01, 19:53:34 »
Met Mahjongg is er waarschijnlijk wat anders aan de hand. Zie dit draadje:
http://forum.ubuntu-nl.org/software-en-configuratie/spontane-venster-verplaatsing-in-xubuntu/

Dat heeft dus vermoedelijk niets te maken met het stuurprogramma voor je grafische kaart. Enfin, het vreemde werkbalkprobleem lijkt nu in elk geval te zijn "opgelost", dus dat is alvast winst....

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #9 Gepost op: 2012/07/01, 20:03:35 »
Test eens met meerdere programma's of je alles op het scherm hebt.

https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173/+bug/948053
Als ik hier kijk dan is er geen nvidia driver voor je gpu, omdat de xorg gewijzigd is.
Er is wel de open source drivers nouveau, misschien is deze al geinstalleerd.
Nouveau driver wordt geinstalleerd bij oude nvidia videokaarten die niet meer ondersteund worden.

Indien je nog problemen hebt, probeer met xrandr je scherm bij te sturen, welke je monitor standaard wilt hebben, zie handleiding van je monitor.
« Laatst bewerkt op: 2012/07/01, 20:15:11 door jan11000 »

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #10 Gepost op: 2012/07/02, 10:33:50 »
Van de andere kaartspellen die standaard worden geïnstalleerd treedt hetzelfde probleem op. B.v. bij freecell is het onderste deel van de kaarten niet zichtbaar tenzij je op een kaart klikt. Tevens heb ik LibreOffice Writer geïnstalleerd en daar doen ook rare dingen voor. De tekst wordt niet goed weergegeven (zowel een .docx als .odt), als je naar beneden scrollt en dan weer naar boven komt de tekst tevoorschijn. Ook als je de instellingen bij Opties wilt aanpassen, staat de tekst Opties in het menu niet vermeld, alleen een streepje en dit streepje aangeklikt te hebben staan de teksten in de buttons "Ok", "Annuleren" etc niet ingevuld. Ook op andere plekken ziet het er wat vreemd uit.
Met de Chromium browser die ook is geïnstalleerd, is geen enkel probleem, alles wordt goed weergegeven.
Als ik nu de schermresolutie terugbreng naar 1024x768 en dat accepteer (behoudt deze configuratie) en vervolgens weer terugga naar de resolutie 1280x800 zijn alle problemen over, dus de spelletjes doen het goed en doet LibreOffice Writer het zonder problemen.
Als Xubuntu wordt opgestart zie je een zwart scherm en daarin verschijnt even een witte balk die dan weer verdwijnt. Ook zie je even Xubuntu 12.04 met de puntjes eronder verschijnen maar dat staat niet midden in het beeld maar iets linksboven. Het lijkt erop dat Xubuntu begint met een resolutie groter dan 1280x800.
Grubmenu is ook al een aangepast zodat dit menu in de resolutie van 1280x800 verschijnt, maar bij het opstarten van Xubuntu wordt kennelijk die resolutie weer vergeten. Staat dat niet ergens in een Config file?
De onderste werkbalk wordt steeds goed weergegeven, dus dat probleem is opgelost (even naar Xfce sessie en terug).
De Nouveau driver is erbij geïnstalleerd maar dat bracht geen verandering.
Xubuntu is geïnstalleerd op een Toshiba Satellite M30 laptop, dus moet eens kijken wat xrandr kan doen. Heb hier geen ervaring mee.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #11 Gepost op: 2012/07/02, 11:05:17 »
Je zou eventueel ook dit eens kunnen proberen:
https://sites.google.com/site/computertip/geenbeeld#TOC-Alleen-voor-gevorderden
(punt 9, rechterkolom)

Daarmee schakel je de autodetectie uit en dwing je Xubuntu om de hard vastgelegde schermresolutie te gebruiken.

Maar dat veronderstelt wel de nodige ervaring met Linux...
« Laatst bewerkt op: 2012/07/02, 11:15:53 door Pjotr »

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #12 Gepost op: 2012/07/02, 16:41:18 »
Pjotr, bij Xorg -configure is het even stil en krijg dan de melding: Fatal server error. Could not create lock file in /tmp/.tx0-lock. Verder wordt er doorverwezen naar wiki.x.org. Ik zie dat de /tmp map wel bestaat. De x.org site ben ik nog aan het bekijken. Hoe nu verder?
Kan met xrandr ook de xorg.conf worden aangemaakt waarbij de resolutie hard wordt gedefinieerd (xrandr --size 1280x800).
Groet, Cees

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #13 Gepost op: 2012/07/02, 18:08:35 »
Met xrand kun je de xorg niet mee wijzigen.
Zelf heb ik vroeger xrand gebruikt om een scherm bij te sturen, dwz opstarten mint en dan in de terminal xrandr met scherm grootte, dan sprong de scherm naar de goede formaat.
Dit kun je indien dit werkt automatisch laten uitvoeren, na het opstarten.
Je kan gewoon in de terminal proberen, na booten is het weg, dus je kan gewoon proberen.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #14 Gepost op: 2012/07/02, 18:19:48 »
Ik denk dat de tip van jan11000 inderdaad de beste is. +1 dus.  :)

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #15 Gepost op: 2012/07/02, 20:26:56 »
Je zou deze Engelstalige info over xrandr kunnen checken How change display resolution settings using xrandr. Waarin ze 1024X768 als voorbeeld hebben genomen. Als daarvan iets niet duidelijk is, kun je er altijd nog vragen over stellen. 
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Xubuntu 18.04.3
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 20.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #16 Gepost op: 2012/07/03, 14:21:35 »
Als via de terminal de volgende commando's worden uitgevoerd lijkt het grafisch probleem opgelost:
xrandr --output LVDS-1 --mode 1024x768
xrandr --output LVDS-1 --mode 1280x800
Dus even een andere resolutie kiezen en dan weer terug.
Om dit automatisch bij het opstarten te laten gebeuren, wordt in het voorbeeld genoemd in
"http://www.ubuntugeek.com/how-change-display-resolution-settings-using-xrandr.html" het default bestand aangepast volgens "gksudo gedit /etc/gdm/Init/Default". Maar het pad etc/gdm bestaat niet in Xubuntu, w.s iets van Ubuntu.
Waar staat het default bestand in Xubuntu waarin de xrandr commando's kunnen worden gezet en zodat ze uitgevoerd kunnen worden na het opstarten?

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #17 Gepost op: 2012/07/03, 15:09:01 »
Ik zou een bash file maken, dus een text file met de naam: monitor.sh ,  aan de sh is te zien dat dit een bash file is.
In deze file je xrandr zetten. En de sh file uitvoerbaar maken, zie eigenschappen van de sh file.
In de settings scherm vind je , "session en startup", daar kun je je sh file laten opstarten.

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #18 Gepost op: 2012/07/03, 19:35:15 »
De bash file aangemaakt met de xrandr commando's erin. In eerste instantie 1 regel ingezet die de resolutie terugzet naar 1024x768 met 1 lege regel erachter. Het bestand is uitvoerbaar gemaakt. Met rechtermuisklik uitvoeren gaat goed, de schermresolutie wordt dan veranderd. De bash file toegevoegd aan "Toepassing autostart" in "Sessie en Opstart" maar na een herstart gebeurt er niets, de resolutie blijft 1280x800.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #19 Gepost op: 2012/07/03, 19:39:33 »
Probeer dit eens:

Voeg een opstarttoepassing toe.
Menuknop - Instellingen - Instellingenbeheerder - Sessie en Opstart
Tabblad Toepassing autostart: klik op Toevoegen
Vul de velden als volgt in (gebruik kopiëren en plakken, dat is het makkelijkste):

Naam:
Schermresolutie juist zetten

Beschrijving:
noodgreep

Opdracht:
xrandr --output LVDS-1 --mode 1024x768 && xrandr --output LVDS-1 --mode 1280x800
Klik op OK en op Sluiten.

Herstart je computer. Als het goed is, staat de resolutie nu correct.

Let op: gebruikersvoorkeur, dus Dropbox-installatie herhalen per gebruikersaccount.

« Laatst bewerkt op: 2012/07/03, 19:41:41 door Pjotr »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #20 Gepost op: 2012/07/03, 20:26:11 »
Zet "sleep 10" voor de xrandr opdracht(er boven dus), hierdoor wacht de bash even, en je pc kan eerst opstarten, en dan de xrandr uitvoeren.

Weet je zeker dat de bash wordt uitgevoerd?

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #21 Gepost op: 2012/07/03, 21:11:56 »
Sleep is mogelijk wel handig, ja.... Het wordt dan:

sleep 10 && xrandr --output LVDS-1 --mode 1024x768 && xrandr --output LVDS-1 --mode 1280x800

Offline Cees

  • Lid
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #22 Gepost op: 2012/07/04, 08:42:54 »
Na toevoeging van het commando in "Toepassing autostart" wordt het bij het herstarten van de computer niet uitgevoerd (ook na uit- en aanzetten). Als ik het commando kopieer en plak in de Terminal venster wordt het wel uitgevoerd. Zie schermafdruk in de bijlage.


Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #23 Gepost op: 2012/07/04, 09:49:21 »
Zet de commando's eens in een file b.v. noodgreep.sh en zet deze file ergens onder je home map neer.
Voeg dan bij het opstarten de file toe, met b.v. sh /home/cees/noodgreep.sh.
Deze manier van werken heeft bij mij altijd gewerkt ..........
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onderste werkbalk niet zichtbaar in Xubuntu 12.04
« Reactie #24 Gepost op: 2012/07/04, 10:10:18 »
Je zou ook nog eens sleep kunnen zetten voor de tweede opdracht, dus:
sleep 10 && xrandr --output LVDS-1 --mode 1024x768 && sleep 5 && xrandr --output LVDS-1 --mode 1280x800
Als dat niet werkt, kun je Rons idee eens proberen. Overigens is deze syntax dan waarschijnlijk iets beter (zoals ik pas heb gemerkt bij Dropbox):
sh -c "~/noodgreep.sh"
Het bestand noodgreep.sh moet trouwens eerst wel even uitvoerbaar worden gemaakt.  :)