Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Hulp met Cedega.  (gelezen 5473 keer)

Jasonthuis

  • Gast
Hulp met Cedega.
« Gepost op: 2007/02/20, 20:36:46 »



Hoe los ik dit op? (ik weet niet wat voor videokaart ik precies heb en hoe ik daar achter moet komen, maar als et goed is, is ie van Ati).
Ik gebruik Kubuntu 6.10

B.V.D.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #1 Gepost op: 2007/02/20, 21:33:34 »
Citaat
lspci | grep VGA
in de terminal

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #2 Gepost op: 2007/02/20, 21:44:26 »
heb ik gedaan leoquant, dit komt eruit:
Citaat
01:00.0 VGA compatible controller: ATI Technologies Inc RV515 [Radeon X1300]
wat moet ik nu doen om het cedega-probleem te verhelpen?

B.V.D.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #3 Gepost op: 2007/02/20, 21:47:55 »
Citaat van: Jasonthuis
heb ik gedaan leoquant, dit komt eruit:
Citaat
01:00.0 VGA compatible controller: ATI Technologies Inc RV515 [Radeon X1300]
wat moet ik nu doen om het cedega-probleem te verhelpen?

B.V.D.
u heeft geen direct rendering en 3d acceleratie. dus de drivers voor de kaart
moeten geinstall. worden.
zie: https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Offline Kev

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #4 Gepost op: 2007/02/20, 22:25:28 »
Ja effe linkje volgen in de post van leo en dan komt alles wel weer goed.
Zeg vraagje betaal je voor Cedega en hoe kom je er aan.
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #5 Gepost op: 2007/02/20, 22:36:02 »
ik heb geprobeerd wat er in de link van leoquant stond, maar bij mij is gebeurd wat er bij trouble shooting staat, nl. dit:
Troubleshooting

If fglrxinfo gives you the following, your installation is not completed correctly:

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

In this case, watch for these things:

    *

      As fglrx is proprietary, just like many other proprietary software you might want to try to reboot your machine.
    *

      Make sure that the resctricted-modules package installed correspond to the kernel your are running and that you can load the fglrx driver, either by issuing the command "sudo modprobe fglrx" or by verifying that the module appears in the list of loaded modules, by issuing the command "lsmod";
    *

      It may be necessary to establish a symbolic link for the /usr/lib/dri folder, by issuing the following command: "sudo ln -s /usr/lib/dri /usr/lib/xorg/modules/dri";
    *

      You may have to unload the radeon and dri modules, by issuing "sudo rmmod radeon" and "sudo rmmod dri";
    *

      Make sure you unload the module ati-agp by issuing "sudo rmmod ati-agp" and blacklist it in /etc/modprobe.d/blacklist.
    *

      Check the /etc/X11/xorg.conf in Section "Module" to have this line: Load "dri" and it is not commented.
    *

      Check the /var/log/Xorg.0.log file for errors. Firstly, search for (EE) (You can probably ignore any wacom entries). If you find the following then the Composite extension has been enabled (on my system it seems to be enabled by default, and must be explicitly disabled):
(II) fglrx(0): Composite extension enabled, disabling direct rendering
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *

The ATI binary drivers do not support Composite. Ensure that the following entry is not in your xorg.conf:

Section "Extensions"
    Option "Composite" "true"
EndSection

If there is no Composite entry, add one specifying "false" rather than true. This was necessary on my system.

If you are looking for a specific video configuration please read the driver's manual. It will tell you all about dual-head configurations for example :) .

man fglrx

If you suffer from a "white screen" overlayed onto gdm upon logout and the system seizing up, i.e., if you share the Ubuntu system with multiple users, then modify the file /etc/X11/gdm/gdm.conf and either add or change the AlwaysRestartServer option:

AlwaysRestartServer=true

Maar hier snap ik niks van en de helft lukt niet en als ik die test van cedega run heb ik nog steeds dezelfde problemen .
en Kev: ik heb Cedega ergens gedownload om te kijken of het lukt (nu nog niet dus) en zodra het volledig draait en doet wat het moet doen dan ga ik er wel voor betalen op die site.

Offline Kev

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #6 Gepost op: 2007/02/20, 22:40:46 »
Citaat van: Jasonthuis
ik heb geprobeerd wat er in de link van leoquant stond, maar bij mij is gebeurd wat er bij trouble shooting staat, nl. dit:
Troubleshooting

If fglrxinfo gives you the following, your installation is not completed correctly:

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

In this case, watch for these things:

    *

      As fglrx is proprietary, just like many other proprietary software you might want to try to reboot your machine.
    *

      Make sure that the resctricted-modules package installed correspond to the kernel your are running and that you can load the fglrx driver, either by issuing the command "sudo modprobe fglrx" or by verifying that the module appears in the list of loaded modules, by issuing the command "lsmod";
    *

      It may be necessary to establish a symbolic link for the /usr/lib/dri folder, by issuing the following command: "sudo ln -s /usr/lib/dri /usr/lib/xorg/modules/dri";
    *

      You may have to unload the radeon and dri modules, by issuing "sudo rmmod radeon" and "sudo rmmod dri";
    *

      Make sure you unload the module ati-agp by issuing "sudo rmmod ati-agp" and blacklist it in /etc/modprobe.d/blacklist.
    *

      Check the /etc/X11/xorg.conf in Section "Module" to have this line: Load "dri" and it is not commented.
    *

      Check the /var/log/Xorg.0.log file for errors. Firstly, search for (EE) (You can probably ignore any wacom entries). If you find the following then the Composite extension has been enabled (on my system it seems to be enabled by default, and must be explicitly disabled):
(II) fglrx(0): Composite extension enabled, disabling direct rendering
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *

The ATI binary drivers do not support Composite. Ensure that the following entry is not in your xorg.conf:

Section "Extensions"
    Option "Composite" "true"
EndSection

If there is no Composite entry, add one specifying "false" rather than true. This was necessary on my system.

If you are looking for a specific video configuration please read the driver's manual. It will tell you all about dual-head configurations for example :) .

man fglrx

If you suffer from a "white screen" overlayed onto gdm upon logout and the system seizing up, i.e., if you share the Ubuntu system with multiple users, then modify the file /etc/X11/gdm/gdm.conf and either add or change the AlwaysRestartServer option:

AlwaysRestartServer=true

Maar hier snap ik niks van en de helft lukt niet en als ik die test van cedega run heb ik nog steeds dezelfde problemen .
en Kev: ik heb Cedega ergens gedownload om te kijken of het lukt (nu nog niet dus) en zodra het volledig draait en doet wat het moet doen dan ga ik er wel voor betalen op die site.
Wel ik moet helaas verdergaan vandaag, maar geef de inhoud van je Xorg.conf file en dan zullen de andere forumleden er zich over buigen om je verder te helpen.
Dit bestand vind jeonder de map /etc
All Hail Lelouch, The 99th Emperor of Britannia
All Hail Lelouch! All Hail Lelouch!
Iedereen heeft het recht op mijn waarheid, zo wees geprezen.

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #7 Gepost op: 2007/02/20, 22:53:47 »
inhoud van xorg.conf:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
   Identifier     "Default Layout"
   Screen      0  "aticonfig-Screen[0]" 0 0
   InputDevice    "Generic Keyboard"
   InputDevice    "Configured Mouse"
   InputDevice    "stylus" "SendCoreEvents"
   InputDevice    "cursor" "SendCoreEvents"
   InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

   # path to defoma fonts
   FontPath     "/usr/share/X11/fonts/misc"
   FontPath     "/usr/share/X11/fonts/cyrillic"
   FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath     "/usr/share/X11/fonts/Type1"
   FontPath     "/usr/share/X11/fonts/100dpi"
   FontPath     "/usr/share/X11/fonts/75dpi"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load  "i2c"
   Load  "bitmap"
   Load  "ddc"
   Load  "dri"
   Load  "extmod"
   Load  "freetype"
   Load  "glx"
   Load  "int10"
   Load  "type1"
   Load  "vbe"
EndSection

Section "InputDevice"
   Identifier  "Generic Keyboard"
   Driver      "kbd"
   Option       "CoreKeyboard"
   Option       "XkbRules" "xorg"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "us"
   Option       "XkbOptions" "lv3:ralt_switch"
   Option       "XkbVariant" "intl"
EndSection

Section "InputDevice"
   Identifier  "Configured Mouse"
   Driver      "mouse"
   Option       "CorePointer"
   Option       "Device" "/dev/input/mice"
   Option       "Protocol" "ExplorerPS/2"
   Option       "ZAxisMapping" "4 5"
   Option       "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
   Identifier  "stylus"
   Driver      "wacom"
   Option       "Device" "/dev/wacom"          # Change to
   Option       "Type" "stylus"
   Option       "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
   Identifier  "eraser"
   Driver      "wacom"
   Option       "Device" "/dev/wacom"          # Change to
   Option       "Type" "eraser"
   Option       "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
   Identifier  "cursor"
   Driver      "wacom"
   Option       "Device" "/dev/wacom"          # Change to
   Option       "Type" "cursor"
   Option       "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   HorizSync    28.0 - 51.0
   VertRefresh  43.0 - 60.0
   Option       "DPMS"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "ATI Technologies, Inc. ATI Default Card"
   Driver      "vesa"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]"
   Driver      "fglrx"
   Option       "VideoOverlay" "on"
   Option       "OpenGLOverlay" "off"
EndSection

Section "Screen"
   Identifier "Default Screen"
   Device     "ATI Technologies, Inc. ATI Default Card"
   Monitor    "Generic Monitor"
   DefaultDepth     24
   SubSection "Display"
      Depth     1
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     4
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     8
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     15
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     16
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth     24
      Modes    "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]"
   Device     "aticonfig-Device[0]"
   Monitor    "aticonfig-Monitor[0]"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
   Mode         0666
EndSection

Wat nu?
BVD

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #8 Gepost op: 2007/02/21, 08:30:09 »
Citaat
Section "Device"
    Identifier  "ATI Technologies, Inc. ATI Default Card"
    Driver      "vesa"
    BusID       "PCI:1:0:0"
EndSection
u heeft de vesa driver. deze heeft geen direct rendering en geen 3d acceleratie. das niet genoeg voor spelletjes de vesa driver.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #9 Gepost op: 2007/02/21, 08:34:49 »
ik heb een draadje van josjonkmans, waarmee een aantal mensen geholpen zijn:

Eerst driver goed installeren:

Citaat
Eerst gaan we de Xorg file aanpassen, in deze file staan de opties en intellingen van bijvoorbeeld de videokaart en monitor opgeslagen. We gaan deze wijzigen met behulp van de volgende code:

sudo gedit /etc/X11/xorg.conf

Vervolgens voegen we deze code toe aan het bestand (het liefst onderaan de file):

Section "Extensions"
        Option  "Composite" "Disable"
EndSection

Nu gaan we de Ati driver installeren met behulp van de volgende code:

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo depmod -a

Nu gaan we de driver configureren met behulp van de volgende code:

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

* indien je naderhand nog wijzigingen heb aangebracht aan de Xorg.conf file dan dien je deze code nog een keer uit te voeren:

sudo aticonfig --overlay-type=Xv

Nu hoeven we alleen de X server te herstarten dit kunnen we doen met (sudo shutdown -r now), maar ikzelf heb de voorkeur om gewoon simpelweg alleen de X server te herstarten door CTRL+ALT+BACKSPACE tegelijk in te drukken. Dit scheeld weer wat tijd wink.

Nu hebben we alles geinstalleerd staan en waarschijnlijk is nu de resolutie wel goed in te stellen, maar dit wil niet gelijk zeggen dat alles ook echt goed geinstalleerd staat. Dit controleren we met de volgende code:

fglrxinfo

De output van de code zou zoiets als dit moeten zijn:

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Ati radeon X200 Generic
OpenGL version string: 2.0.6011 (8.28.8)

Indien het om een 1 of andere reden helemaal fout is gegaan is het allemaal te herstellen door of de backup van de Xorg.conf file via de restore mode terug te zetten, of door de volgende code in te typen:

sudo dpkg-reconfigure xserver-xorg

Als de monitor hierna nog niet de juiste resolutie kan weergeven, dan kun je hier a kijken in de xorg.conf bij section "monitor"

deze waardes horen erbij te staan, let op: dit is van mijn monitor, die van jou zal waarschijnlijk andere waardes hebben:

HorizSync    28.0 - 64.0
VertRefresh  43.0 - 60.0

Zoek dus deze waardes op, op de site van je monitor merk bij de specificaties, of ff op google zoeken.

Offline SWAT

  • Administrator
    • http://www.schauenburg.nl/
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #10 Gepost op: 2007/02/21, 10:23:07 »
Zie hier voor de wiki informatie om je 3D accelleratie aan te zetten :D
https://help.ubuntu.com/community/BinaryDriverHowto

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #11 Gepost op: 2007/02/21, 12:50:08 »
het begint al lekker:
jas0n@Jason:~$ sudo gedit /etc/X11/xorg.conf
Password:
sudo: gedit: command not found
jas0n@Jason:~$
jas0n@Jason:~$

:(

en SWAT, die guide heb ik al geprobeerd, maar dat ging juist niet goed.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #12 Gepost op: 2007/02/21, 12:53:38 »
Citaat van: Jasonthuis
het begint al lekker:
jas0n@Jason:~$ sudo gedit /etc/X11/xorg.conf
Password:
sudo: gedit: command not found
jas0n@Jason:~$
jas0n@Jason:~$

:(

en SWAT, die guide heb ik al geprobeerd, maar dat ging juist niet goed.
Citaat
sudo kate /etc/X11/xorg.conf
sorry je hebt kubuntu! dat wordt dan kate ipv gedit.

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #13 Gepost op: 2007/02/21, 13:36:31 »
Citaat
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
ik snap niet wat hier bedoeld wordt, er staat tekst tussen enzo

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #14 Gepost op: 2007/02/21, 14:41:33 »
uname -r  geeft je kernel aan die je gebruikt. doe dit maar eens in de terminal. :)

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #15 Gepost op: 2007/02/21, 15:32:26 »
heb ik gedaan:
jas0n@Jason:~$ uname -r
2.6.17-11-generic

moet ik hier iets meedoen in de bovenstaande stappen?

Edit:
ik probeerde verder te gaan, maar
Citaat
sudo depmod -a
doet niks in de terminal als ik het intyp, er gebeurt gewoon niks.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #16 Gepost op: 2007/02/21, 15:49:38 »
Citaat
sudo apt-get install linux-restricted-modules-`uname -r`
in de terminal.
verder alle stappen doorlopen.

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #17 Gepost op: 2007/02/21, 16:40:46 »
er gebeurt niks als ik het volgende commando intyp:
Citaat
sudo depmod -a
moet ik deze stap maar overslaan dan?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #18 Gepost op: 2007/02/21, 16:54:43 »
Citaat van: Jasonthuis
er gebeurt niks als ik het volgende commando intyp:
Citaat
sudo depmod -a
moet ik deze stap maar overslaan dan?
ja doorgaan met de stappen. eerst:
Citaat
fglrxinfo
in de terminal, en de uitkomst posten.

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #19 Gepost op: 2007/02/21, 17:04:28 »
Gedaan, uitkomst:
Citaat
jas0n@Jason:~$ fglrxinfo
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

jas0n@Jason:~$

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #20 Gepost op: 2007/02/21, 17:09:35 »
@jason
ik ben vanaf nu (vandaag) niet meer beschikbaar. morgen weer een dag.
wanneer je de stappen hebt doorlopen, en je loopt na een reboot vast en heb je geen graf.omgeving meer, noteer dan:
 sudo dpkg-reconfigure xserver-xorg (in de terminal)
 volg alle stappen, laat de computer "kiezen"/ default dus. bij graf. drivers: kies     je vesa. dan kom je terug in de graf. omgeving zoals je nu hebt.

:)

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #21 Gepost op: 2007/02/21, 17:11:14 »
ik ga het proberen en anders wacht ik wel tot morgen, ik heb geen haast.

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #22 Gepost op: 2007/02/21, 20:02:24 »
Herneem eens vanaf
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed

Maar dus niet #... ! ;)
Dan depmod enz...

Jasonthuis

  • Gast
Hulp met Cedega.
« Reactie #23 Gepost op: 2007/02/21, 20:49:02 »
Ok, heb ik gedaan, zie hier het resultaat:

dus we zijn nu iets verder, maar die 3d acceleration blijft maar irritant doen :S.
Wat nu?

B.V.D.

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Hulp met Cedega.
« Reactie #24 Gepost op: 2007/02/21, 21:15:28 »
en bij fglrxinfo? Wat krijg je?