Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Xubuntu toetsenbord doet raar  (gelezen 760 keer)

Offline sjurres

  • Lid
  • Steunpunt: Nee
Xubuntu toetsenbord doet raar
« Gepost op: 2012/06/13, 12:03:40 »
Hallo,

korte vraag, maar voor mij wel zeer dringend,

Na installatie van Xubuntu op een 2e laptop doet het toetsenbord raar, het @ teken zit bijvoorbeeld onder Shift-`, en de underscore onder Shift-7.

Ik heb bij de installatie het toetsenbord op nederlands gezet, dit later handmatig op Engels (US) gezet, dit mocht niet helpen,

Iemand hier die me bij dit probleem kan helpen?

Alvast bedankt,

Groeten, Sjors

http://forum.ubuntu-nl.org/installatie/toetsenbord-blues/msg24118/
Dit topic wel gevonden met de Search, maar waar moet ik die codes dan invullen,

Wel vreemd dat ie het op mijn eigen laptop gewoon normaal doet
« Laatst bewerkt op: 2012/06/13, 12:08:06 door sjurres »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu toetsenbord doet raar
« Reactie #1 Gepost op: 2012/06/13, 12:21:45 »
Bij installatie toetsenbord op de verkeerde indeling zetten, betekent dat deze de "systeemindeling" blijft. Nederlandse toetsenborden zijn (helaas!) zowat uitgestorven; vrijwel iedereen heeft tegenwoordig een Amerikaans-Engels toetsenbord.

Via een gebruikersvoorkeur kun je wel wat doen aan een verkeerde keuze, in een gebruikersaccount, maar beter is het om de boel fundamenteel aan te pakken. Als volgt:

Menu - Hulpmiddelen - Terminalvenster

Tik in (kopieer en plak, dat is het beste):
gksudo leafpad /etc/X11/xorg.conf

Kopieer en plak de volgende tekst in dat tekstbestand:
# instelling voor Amerikaans-Engels toetsenbord met dode toetsen
#
Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc104"
    Option        "XkbLayout"    "us"
    Option        "XkbVariant"    "intl"
EndSection

Sla het bestand op en sluit het.

Herstart je computer.
« Laatst bewerkt op: 2012/06/13, 12:24:06 door Pjotr »

Offline sjurres

  • Lid
  • Steunpunt: Nee
Re: Xubuntu toetsenbord doet raar
« Reactie #2 Gepost op: 2012/06/13, 17:17:28 »
Bij installatie toetsenbord op de verkeerde indeling zetten, betekent dat deze de "systeemindeling" blijft. Nederlandse toetsenborden zijn (helaas!) zowat uitgestorven; vrijwel iedereen heeft tegenwoordig een Amerikaans-Engels toetsenbord.

Via een gebruikersvoorkeur kun je wel wat doen aan een verkeerde keuze, in een gebruikersaccount, maar beter is het om de boel fundamenteel aan te pakken. Als volgt:

Menu - Hulpmiddelen - Terminalvenster

Tik in (kopieer en plak, dat is het beste):
gksudo leafpad /etc/X11/xorg.conf

Kopieer en plak de volgende tekst in dat tekstbestand:
# instelling voor Amerikaans-Engels toetsenbord met dode toetsen
#
Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc104"
    Option        "XkbLayout"    "us"
    Option        "XkbVariant"    "intl"
EndSection

Sla het bestand op en sluit het.

Herstart je computer.

Helaas heeft dit niet geholpen.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Xubuntu toetsenbord doet raar
« Reactie #3 Gepost op: 2012/06/13, 18:26:44 »
Pas ook je gebruikersvoorkeur dienovereenkomstig aan:
Engels (US, internationaal met dode toetsen).

Of vink aan dat-ie de standaardinstellingen moet gebruiken.
« Laatst bewerkt op: 2012/06/13, 18:32:02 door Pjotr »