Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: netwerk - internet  (gelezen 3050 keer)

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Gepost op: 2007/02/19, 11:26:34 »
hallo, ik ben net begonnen met ubuntu (ik snap er nog niet zoveel van) en ik heb een probleem
ik heb dual boot (windows xp media center & linux - ubuntu) maar op ubuntu kan ik mijn internet, dat nochtans wel werkt bij windows, niet gebruiken
ik heb een draadloze router (d-link di-524) met een bijgeleverde cdrom met drivers, maar die kan ik niet openen met ubuntu... kan iemand mij helpen om mijn internet te laten werken?

alvast bedankt

killerjoe

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #1 Gepost op: 2007/02/19, 12:40:52 »
typ eens sudo iwconfig, ik vermoed dat je er ath0 zal bij zien staan. (je hebt een d-link router dus vermoed ik dat je een d-link pci ontvanger zult hebben met de Atheros chipset)

Je moet je draadloos internet nog configureren he (de essid dus specifieren, en - als dit er is - de WEP of WPA instellen)
sudo iwconfig ath0 essid jouw_essid       (kijk via windows anders wat de essid is als ge hem nie weet) of doe iwlist ath0 scan om jouw essid te weten :)

Je kan ook network-manager gebruiken natuurlijk :)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
netwerk - internet
« Reactie #2 Gepost op: 2007/02/19, 12:44:57 »
Ter aanvulling op de uitstekende instructie van phar0z:
Haal eerst even de beveiliging van je draadloze netwerk af, en vervang die tijdelijk door een MAC-adresfilter in de router aan te zetten. Zo heb je nog enige beveiliging, terwijl je wel je handen vrij hebt om Ubuntu goed in te stellen. Daarna kun je de beveiliging weer verhogen.

Overigens: mocht uiteindelijk WPA niet goed werken (komt soms voor), kies dan voor WEP. In de komende versie 7.04 (over twee maanden), zal draadloze ondersteuning voor WPA overigens beter zijn.

Groet, Pjotr.

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #3 Gepost op: 2007/02/19, 13:01:26 »
ik ga eens proberen

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #4 Gepost op: 2007/02/19, 13:28:17 »
nee er staat geen ath0 :(
er staat: (sorry voor typfouten maar ik kan niet opslaan vanuit linux en openen in windows :( )
lo             no wireless extensions
eth0         no wireless extensions
rausb1     RT2500USB WLAN ESSID:"garage"
               mode: manager frequency: 2412 ghz
               bit rate = 11mb/s
               RTS thr: off fragment thr: off
               encryption key: off
               link quality = 0/70 signal level: -120 dBm noise level: -216 dBm
               RX invalid nwid: 0 RX invalid crypt: 0 RX invalid frag: 0
               Tx excessive retries: 0 invalid misc: 0 missed beacon : 0
sit0          no wireless extensions


(en daar snap ik *************** van)

wat ik wel weet is: ik gebruik WEP en hier staat bij encripty off
dus: waar kan ik dat aanpassen?


alvast bedankt, killerjoe

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #5 Gepost op: 2007/02/19, 13:33:34 »
oh ja, die andere 2 commandos gaan niet :(

Offline SWAT

  • Administrator
    • http://www.schauenburg.nl/
  • Steunpunt: Nee
netwerk - internet
« Reactie #6 Gepost op: 2007/02/19, 13:37:00 »
als je WEP zou gebruiken, dan zou dat aangegeven zijn (c.q. bij de instellingen van je router). Je kunt ook eens proberen "sudo iwlist rausb1 scan" en "sudo iwconfig"
Je kunt natuurlijk ook een keer hier een kijkje nemen: http://www.zwhlug.org/HOWTO_WLAN

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #7 Gepost op: 2007/02/19, 13:46:03 »
geen probleem ge hebt rausb1, is in orde :)
Doe sudo iwlist rausb1 scan (tenzij ge zeker zijt dat garage uw essid is:))

Is uw essid zeker garage: sudo iwconfig rausb1 essid garage
Stel uw key is A1B3C5D7E1, dan doet ge sudo iwconfig rausb1 key A1B3C5D7E1

En dan sudo /etc/init.d/networking restart

En tzou moeten werken :)

Je kan nu network-manager gebruiken voor dit te configureren ofwel sudo nano /etc/network/interfaces, en zorg dat er staat:

auto rausb1
iface rausb1 inet dhcp
wireless-essid garage
wireless-key jouw_key_die_je_in_router_hebt_ingesteld

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #8 Gepost op: 2007/02/19, 14:48:58 »
ok, ik ga nog eens proberen in elk geval al bedankt

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #9 Gepost op: 2007/02/19, 15:29:06 »
nee, het gaat niet
ik vrees dat het onmogelijk is... :( :(

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #10 Gepost op: 2007/02/19, 15:43:21 »
ben je zeker dat garage je essid is? Als je met sudo iwconfig rausb1 key jouw_key instelt zou het moeten werken.

Wat loopt er precies fout?

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #11 Gepost op: 2007/02/19, 15:50:42 »
het probleem is dat ath0 & rausb1 niet bestaan...
ik zou echt niet weten hoe ik die kan laten bestaan of het zonder hen oplossen (dat zit ik al heel de tijd te proberen)

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #12 Gepost op: 2007/02/19, 15:52:52 »
ath0 besta nie maar hoeft niet, da is voor pci kaarten met atheros chipset, vergeet die ath0 maar :)

En rausb1 bestaat wel, doe maar eens sudo iwconfig rausb1

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #13 Gepost op: 2007/02/19, 15:54:00 »
kga nog ne keer proberen

danku voor de goede hoop :)

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #14 Gepost op: 2007/02/19, 16:10:03 »
uihm,

hij zegt dit:

simon@speelcomputer:~$ sudo iwconfig rausb1
Password:
rausb1    No such device

simon@speelcomputer:~$ sudo iwconfig rausb1
rausb1    No such device

simon@speelcomputer:~$

Offline SWAT

  • Administrator
    • http://www.schauenburg.nl/
  • Steunpunt: Nee
netwerk - internet
« Reactie #15 Gepost op: 2007/02/19, 16:17:49 »
probeer het eens met "sudo iwconfig" en "sudo ifconfig" en post je gegevens eventjes hier :)

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #16 Gepost op: 2007/02/19, 16:27:20 »
daarnet was het er wel, je zei:

rausb1     RT2500USB WLAN ESSID:"garage"
               mode: manager frequency: 2412 ghz
               bit rate = 11mb/s
               RTS thr: off fragment thr: off
               encryption key: off
               link quality = 0/70 signal level: -120 dBm noise level: -216 dBm
               RX invalid nwid: 0 RX invalid crypt: 0 RX invalid frag: 0
               Tx excessive retries: 0 invalid misc: 0 missed beacon : 0

:S

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #17 Gepost op: 2007/02/19, 16:30:39 »
(heb heb opnieuw geïnstalleerd :p , hij blokkeerde op network settings )

de gegevens:

simon@speelcomputer:~$ sudo iwconfig
Password:
lo        no wireless extensions.

eth0      no wireless extensions.

rausb0    RT2500USB WLAN  ESSID:"mshome"  
          Mode:Managed  Frequency=2.412 GHz  Bit Rate=11 Mb/s  
          RTS thr:off   Fragment thr:off
          Encryption key:7369-6D6F-6E   Security mode:open
          Link Quality=0/70  Signal level:-120 dBm  Noise level:-215 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

simon@speelcomputer:~$ sudo ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:18 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1284 (1.2 KiB)  TX bytes:1284 (1.2 KiB)

rausb0    Link encap:Ethernet  HWaddr 00:13:46:E9:E6:BD  
          inet6 addr: fe80::213:46ff:fee9:e6bd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:32358 (31.5 KiB)  TX bytes:144222 (140.8 KiB)

simon@speelcomputer:~$





zie je, nu is het rausb0 :(

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #18 Gepost op: 2007/02/19, 16:43:30 »
dus mshome is je essid en 7369-6D6F-6E is je key?

Doe sudo gedit  /etc/network/interfaces en verwijder alles wat je ziet na rausb0 en/of rausb1 ... en dan voeg je volgend toe:

auto rausb0
iface rausb0 inet dhcp
wireless-essid mshome
wireless-key 73696D6F6E

auto rausb1
iface rausb1 inet dhcp
wireless-essid mshome
wireless-key 73696D6F6E

En opslaan :)

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #19 Gepost op: 2007/02/19, 16:54:08 »
dat gaat niet...
dus gwn 'sudo gedit/etc/network/interfaces' typen in de terminal?
gaat niet

maar sudo gedit wel, dan doet hij gedit open...

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #20 Gepost op: 2007/02/19, 17:00:59 »
je bent spatie vergeten (spatie na gedit) zie hierboven

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
netwerk - internet
« Reactie #21 Gepost op: 2007/02/19, 17:01:17 »
tussen gedit en /etc... moet een spatie...

edit: oeps, phar0z is mij weer te snel af :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #22 Gepost op: 2007/02/19, 17:17:11 »
:p, ik weet niet hoe ik het gedaan heb maar mijn internet werkt perfect onder linux :) :) (hopelijk ook nog onder windows, maar daarmee ben ik meer vertrouwd :) ) allemaal 1000X dank voor jullie hulp

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
netwerk - internet
« Reactie #23 Gepost op: 2007/02/19, 17:18:26 »
hoe je het gedaan hebt? door die benodigde stuff dat ik zei in je /etc/network/interfaces te plaatsen :)

Offline simon delva

  • Lid
  • Steunpunt: Nee
netwerk - internet
« Reactie #24 Gepost op: 2007/02/19, 20:25:18 »
neje, kweetet...

mijn ESSID was ni mshome mr garage... (toch)
en toen ik die goed had gezet ging het...

maar toch bedankt :) :)