Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Shut down werkt niet  (gelezen 1616 keer)

Offline Piliniak

  • Lid
  • Steunpunt: Nee
Shut down werkt niet
« Gepost op: 2012/05/17, 10:06:33 »
Ik heb een Dell Inspiron 1720 waar ik sinds kort Ubuntu 12.04 LTS op draai. Als ik mijn laptop wil afsluiten door Shut Down... te kiezen gaat hij niet helemaal uit. Het scherm wordt zwart en alle lichtjes op mijn laptop gaan uit, behalve de 'power' knop. Je hoort dan ook dat er van alles blijf draaien in de laptop. Hoe lang ik ook wacht, hij gaat niet uit. Daarom houd ik dan maar de 'power'-knop een tijdje ingedrukt tot hij helemaal uit gaat.

Toen ik zocht wat het zou kunnen zijn kwam ik op deze oplossing: http://askubuntu.com/questions/122933/dell-studio-1569-cannot-shutdown-in-ubuntu-11-10-or-12-04

Ik heb het geprobeerd en de eerste keer na het invoeren van deze commando's sloot hij normaal af, maar sindsdien niet meer.

Iemand een idee hoe ik dit op los?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Shut down werkt niet
« Reactie #1 Gepost op: 2012/05/17, 11:28:50 »
Ik neem aan dat je na het veranderen in /etc/default/grub met gedit, het bestand wel opgeslagen?
Zo ja, open eens een terminal en type daarin sudo shutdown now -P en geef een ENTER, sluit de computer nu af?
In der Beschränkung zeigt sich der Meister.

Offline Piliniak

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #2 Gepost op: 2012/05/17, 15:29:07 »
Ja, dank sluit 'ie netjes af.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Shut down werkt niet
« Reactie #3 Gepost op: 2012/05/17, 15:51:21 »
Ik weet niet waar je dat commando neer moet zetten om gewoon met de knop de computer uit te schakelen, misschien een van de andere leden?
In der Beschränkung zeigt sich der Meister.

Offline Piliniak

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #4 Gepost op: 2012/05/17, 17:39:56 »
Zou handig zijn ja.

Offline Piliniak

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #5 Gepost op: 2012/05/17, 22:26:54 »
Ik heb het sudo shutdown now -P net weer geprobeerd, maar nu werkt het niet meer. Hij gaat weer op een soort van standby.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #6 Gepost op: 2012/05/18, 07:43:51 »
Ik heb een Dell Inspiron 1720 waar ik sinds kort Ubuntu 12.04 LTS op draai.
Had je Ubuntu wel kunnen installeren zonder gebruik te hebben gemaakt van boot opties, zoals acpi=off of noacpi
Staat verder acpi in het BIOS wel op [Enabled]
En zou je verder de output kunnen posten van dmesg | grep acpi [Enter]
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline den boete

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #7 Gepost op: 2012/05/18, 11:36:57 »
Ik heb hetzelfde probleem, de output van dmesg | grep acpi is :
[    0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x02] lapic_id[0x02] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x03] lapic_id[0x03] disabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x04] lapic_id[0x04] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x05] lapic_id[0x05] disabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x06] lapic_id[0x06] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x07] lapic_id[0x07] disabled)
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high level lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high level lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x02] high level lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x03] high level lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x04] high level lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x05] high level lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x06] high level lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x07] high level lint[0x1])
 

Ondertussen heb ik ook in de BIOS volgende optie aangepast :
ACPI Suspend state : S1 state (was oorspronkelijk S3 state)
Dit bracht geen oplossing. Dus ga ik die instelling terugzetten.
« Laatst bewerkt op: 2012/05/18, 11:51:35 door den boete »
Don't limit your challenges, challenge your limits.

Offline Piliniak

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #8 Gepost op: 2012/05/18, 15:12:07 »
Ik heb een Dell Inspiron 1720 waar ik sinds kort Ubuntu 12.04 LTS op draai.
Had je Ubuntu wel kunnen installeren zonder gebruik te hebben gemaakt van boot opties, zoals acpi=off of noacpi
Staat verder acpi in het BIOS wel op [Enabled]
En zou je verder de output kunnen posten van dmesg | grep acpi [Enter]

Ik weet niet precies of ik hiermee antwoord geef op je vragen, maar ik heb 11.10 zich laten updaten naar 12.04, heb toen niks van acpi=off of noacpi gezien.
Ik heb in het BIOS gekeken en daar heb ik geen acpi kunnen vinden.

De output is:

Citaat
[    0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[    0.000000] ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] enabled)
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=867f467d-a50d-46d8-9629-847d2b99d9f7 ro quiet splash acpi=force vt.handoff=7
[    0.412300] ACPI: acpi_idle registered with cpuidle
[   17.132283] acpi device:31: registered as cooling_device2

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #9 Gepost op: 2012/05/18, 16:34:41 »
@den boete en Piliniak

Ik denk dat het belangrijkste is dat in het BIOS ACPI 2.0 Support en ACPI APIC Support staan op [Enabled]
Zo staat dit namelijk bij mij, in het BIOS van mijn Asus P5B moederbord. En:
Repost Video on S3 Resume [Disabled]
Verder staat bij mij Suspend Mode op [Auto] De Options zijn: S1 (POS) only, S3 only en Auto.

Ook zou je zelfde output, maar dan met acpi in hoofdletters, kunnen checken.
  dmesg | grep ACPI [Enter]

Check eventueel deze Engelstalige thread http://ubuntuforums.org/showthread.php?t=1968376 waarin de TS van de gesloten nvidia drivers teruggegaan is, naar de open bron nouveau drivers.

Op mijn PC met die Asus P5B moederbord en nvidia 7900GS videokaart, kan ik zowel Ubuntu 12.10 testversie en Xubuntu 12.04 met de gesloten bron nvidia drivers actief, normaal afsluiten. Ik heb daarvoor geen workaround hoeven uitvoeren.


@Piliniak, je dmesg | grep acpi output lijkt me in orde. Alhoewel je zo te zien gebruik maakt van de boot option: acpi=force hetgeen ACPI activeert, ook voor stokoude Pc's. Verder zou in principe er wel iets over ACPI in het BIOS behoren te vinden zijn. Had je in het BIOS al gecheckt bij Power?
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Piliniak

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #10 Gepost op: 2012/05/18, 17:43:19 »
Het enige wat ik bij Power kan enable'en is geloof ik dat ie automatisch aan gaat als ik er een USB-apparaat in stop.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #11 Gepost op: 2012/05/18, 18:09:43 »
Welke mogelijkheden heb je in het BIOS dan verder nog bij Power? Daar staat toch ook de door jou eerder genoemde optie: "ACPI Suspend state : S1 state (was oorspronkelijk S3 state)"
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline den boete

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #12 Gepost op: 2012/05/18, 18:21:01 »
Na zoeken op het web kwam ik hier terecht : http://ubuntuforums.org/showthread.php?t=1968376&page=5
Na doorscrollen tot bijna onderaan stond in de tekst volgende verwijzing : http://support.amd.com/us/gpudownload/Pages/index.aspx
Van de AMD-site waar ik toen terecht kwam kon ik de juiste videodriver mijn configuratie downloaden.
(Radeon HD4350 draaiend op Ubuntu 64 bits)
Je vind jouw type videokaart wanneer je volgend commando uitvoert :
sudo lshw > lshw.txtof volgend indien je html verkiest :
sudo lshw -html > hardware.htmlDe naam van het binnengehaalde bestand was : amd-driver-installer-12-4-x86.x86_64.run
Het startte niet zelf op, ik wou eens kijken met Gedit wat daar zoal in zat, en toen kwam er een balk in Gedit hoever hij al zat met de verwerking van het bestand.
Dit heeft een half uur geduurd.
Bij het afsluiten zag ik dat er zeker iets veranderd was, en de computer sloot ook volledig af.
Nogmaals gestart en afgesloten -> voorlopig werkt het !
Bij tweede herstart : terug hetzelfde probleem...ik ga nu even naar de BIOS kijken op jolo te anwoorden.
« Laatst bewerkt op: 2012/05/18, 18:30:22 door den boete »
Don't limit your challenges, challenge your limits.

Offline Piliniak

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #13 Gepost op: 2012/05/18, 18:28:18 »
Ik heb mijn nVidea drivers verwijdert en Nouveau geinstalleerd, tot nu toe lijkt hij het normaal te doen.

In mijn BIOS staat bij Power Management: Wake on mode, Wake on time, iets met USB en iets als Wake on LAN. Alles staat hierbij op off.

Offline den boete

  • Lid
  • Steunpunt: Nee
Re: Shut down werkt niet
« Reactie #14 Gepost op: 2012/05/18, 18:49:31 »
Ik heb daarnet de niet-vrije driver verwijderd. Ik ga een tijdje evalueren welk effect dit heeft.
Afsluiten is nu reeds 3 maal goed gelukt !

@Jolo : de verdere BIOS-instellingen zijn :
After Power Failure : Stay Off (Stay Off / Last state / Power On)
Wake On LAN from S5 : Stay Off (Stay Off / Power On)
ACPI Suspend State : S3 State (S3 State / S1 State)
S3 State Indicator : Blink (Blink / On / Alternate Color)
S1 State Indicator : Blink (Blink / On)
Enhanced Intel Speedstep Technologie : Enable
CPU C State : Enable
C1E : Enable
Wake system from S5 : Disable
PCIe ASPM Support : Disable
« Laatst bewerkt op: 2012/05/18, 18:51:39 door den boete »
Don't limit your challenges, challenge your limits.