Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: schermkleuren te koel in unity - hoe aanpassen?  (gelezen 1474 keer)

Offline begonia

  • Lid
  • Steunpunt: Nee
schermkleuren te koel in unity - hoe aanpassen?
« Gepost op: 2012/05/15, 07:41:40 »
In precise pangoling op mijn laptop zijn de schermkleuren net iets te blauw. Vroeger loste ik dat altijd op door een (zelfgemaakt) scriptje mee te laten opstarten met de inhoud:

xgamma -ggamma 1.0 -rgamma 1.0 -bgamma 0.90

Hiermee was het probleem volledig opgelost. Het scherm van mijn goedkope laptop zag er lux en riant uit. Met "-bagamma 0.90" verminder je het blauw en dat is alles wat ik nodig had.
Doe ik dit onder 12.04, dan ZIE ik dat het werkt, onder het opstarten, maar ik zie ook dat deze instelling vlak voordat het klaar is "geneutraliseerd" wordt. En dan heb ik ik mijn te blauwige sfeertje terug.
Ik heb gekeken onder "kleuren" in de systeeminstellingen. En goed gekeken. En gezocht. Ik kan er niks mee.
Je moet "icc" profielen maken. En je moet je beeldscherm calibreren. Super-lastig.
Is er iemand die weet hoe ik mijn schermkleuren aan kan passen in 12.04. Ik zou erg blij zijn.


Offline begonia

  • Lid
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #2 Gepost op: 2012/05/15, 12:09:29 »
Bedankt voor je reactie. Ubuntu heeft zelf al het juiste icc profiel geïnstalleerd. Maar ik vind het niet mooi. Het is gewoon iets te blauw. Ik kan niks vinden wat ik daar aan kan doen.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #3 Gepost op: 2012/05/15, 12:15:20 »
Laat je scriptje eens opstarten *als gebruikersvoorkeur*, dus via de opstarttoepassingen?

Offline begonia

  • Lid
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #4 Gepost op: 2012/05/15, 12:45:32 »
Dat is precies wat ik gedaan heb. Je ziet dan tijdens het paarse ubuntu-opstartscherm de kleur warmer worden en vlak voordat de desktop verschijnt wordt het paars dan weer koel. Ik kan niks bedenken wat ik daar tegen kan doen.
Ik heb gelezen dat lightdm het doet. Ik moest dan het xgama script aanroepen vanuit het configuratiebestand van lightdm. Maar dat is ook niks geworden.

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #5 Gepost op: 2012/05/15, 12:47:43 »
Misschien even spelen met het contrast in je monitorinstellingen? Of indien je een nVidia-videokaart hebt kun je evt. ook via nVidia X Server Settings (te vinden in de Dash) ook de kleurbalans regelen.

Offline begonia

  • Lid
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #6 Gepost op: 2012/05/15, 12:50:18 »
Ik weet het, Nvidia en ook Ati hebben nette configuratie-tools. Maar het is een Asus Eee. Intel spul. Ik krijg niks gevonden. Echt jammer.
In kde heb je Kgamma. Daar kan je het altijd mee regelen. Maar dat werkt vast niet onder Unity. Ik kan het trouwens wel proberen. Maar ik ben er niet optimistisch over.

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #7 Gepost op: 2012/05/15, 12:51:14 »
Excuus, ik dacht het om een normale desktop ging :-[
KGamma werkt wel onder Unity alleen je trekt wel wat KDE-spul mee...

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #8 Gepost op: 2012/05/15, 13:19:38 »
Voer het scriptje eens handmatig uit, als terminalopdracht, dus nadat alles is opgestart?

Als het werkt: je kunt dan in het vervolg gebruikmaken van het "geheugen" van de terminal: tik op pijltje omhoog en de laatstgebruikte opdracht verschijnt.

Offline begonia

  • Lid
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #9 Gepost op: 2012/05/15, 13:39:00 »
Als ik het in een terminal uitvoer werkt het inderdaad perfect. En op de manier die je voorstelt zou het zeker ook kunnen. Maar ik vind het niet zo elegant.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #10 Gepost op: 2012/05/15, 13:43:49 »
Als ik het in een terminal uitvoer werkt het inderdaad perfect. En op de manier die je voorstelt zou het zeker ook kunnen. Maar ik vind het niet zo elegant.
Nee, elegant is het niet.... Het zou via opstarttoepassingen gewoon blijvend moeten werken. Enfin.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #11 Gepost op: 2012/05/15, 20:16:29 »
Telkens je terminal openen en pijltjje omhoog is inderdaad niet de meest elegante oplossing. Maar probeer het eens in je opstarttoepassingen met een "sleep" opdracht: hiermee wordt het commando enkele seconden uitgesteld. Zo zal het pas uitgevoerd worden nadat de desktop goed en wel gereed is.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #12 Gepost op: 2012/05/15, 20:16:46 »
Telkens je terminal openen en pijltje omhoog is inderdaad niet de meest elegante oplossing. Maar probeer het eens in je opstarttoepassingen met een "sleep" opdracht: hiermee wordt het commando enkele seconden uitgesteld. Zo zal het pas uitgevoerd worden nadat de desktop goed en wel gereed is.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #13 Gepost op: 2012/05/15, 21:50:10 »
Goed idee van vanadium....

Probeer het eens met de volgende opdrachtregel in de opstarttoepassingen:
sleep 20 xgamma -ggamma 1.0 -rgamma 1.0 -bgamma 0.90

Mogelijk is een sleepwaarde van 10, of zelfs 5, al genoeg....

Offline begonia

  • Lid
  • Steunpunt: Nee
Re: schermkleuren te koel in unity - hoe aanpassen?
« Reactie #14 Gepost op: 2012/05/16, 18:44:01 »
Deze tip is het!!!
Oh wat ben ik blij.
Dat wil zeggen, ik heb het zo opgelost:

#!/bin/bash
sleep 10 && xgamma -ggamma 1.0 -rgamma 1.0 -bgamma 0.84
Bedankt!