Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [bijna opgelost] Kan niet updaten  (gelezen 873 keer)

Offline AntondeJager

  • Lid
  • Steunpunt: Nee
[bijna opgelost] Kan niet updaten
« Gepost op: 2012/05/07, 22:56:58 »
Kan niet updaten. Probleem kan haast niet in mijn systeem liggen. Had hier van de week problemen mee onder 11.10. Daarna 11.10 opnieuw geïnstalleerd, zonder resultaat. Vervolgens terug 10.04 eroverheen gezet (12.04 lukte niet). Weer zonder resultaat. Nu 12.04 eroverheen gezet, maar weer zonder resultaat.

Zie volgende melding bij starten van Software Centrum:
Citaat
"The application Ubuntu Software Centrum has closed unexpectedly"

Onder details staat: ExecutablePath: /usr/share/software-center/software-center

Bij starten van de updatemanager de volgende foutmelding:
Citaat
Could not initialize the package information

An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_precise_main_binary-i386_Packages, E:De pakketlijsten of het statusbestand konden of niet ontleed, of niet geopend worden.'

Heb al geprobeerd om de server te wisselen naar de mainserver, maar dat helpt niet. Ook voorvoegsels uk en us geprobeerd in plaats van nl, maar baat niets.

Kan dit probleem te maken hebben met de proxyserver via welke ik op internet zit?
« Laatst bewerkt op: 2012/05/10, 09:03:30 door AntondeJager »

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #1 Gepost op: 2012/05/07, 23:07:13 »

Offline AntondeJager

  • Lid
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #2 Gepost op: 2012/05/08, 19:12:02 »
Bedankt voor je reactie.

Deze bewerking heb ik al een aantal maal geprobeerd. Via het commando wat jij geeft in je webstek worden de partiële lijsten en de map partial niet verwijderd. Maar ook dat heb ik al een keer geprobeerd. Het maakt echter niets uit. Ik krijg opnieuw de foutmelding.

In de uitvoer die ik krijg bij sudo apt-get update, staat bij sommige lijsten "File format not regocnized". Ook een aantal keer "is not a bzip2 file". Verder een aantal keer "Geen Hash-vermelding in releasebestand." Aan het eind de melding: "E: Some index files failed to download. They have been ignored, or old ones used instead."

Zojuist heb ik vanuit de terminal het software center gestart via het commando software-center. Ik krijg dan ook een hele reeks foutmeldingen. Als je wilt, kan ik die hier posten, maar dat is nogal een heel verhaal. (Hoe post ik dat op een nette manier?)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: Kan niet updaten
« Reactie #3 Gepost op: 2012/05/08, 19:20:28 »
(Hoe post ik dat op een nette manier?)
Zet het tussen code tags ( [ code ] en [ /code ] maar dan zonder de spaties).
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger uit 0166
Er is ook nog een andere hobby.

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Kan niet updaten
« Reactie #4 Gepost op: 2012/05/08, 19:23:13 »
Onder network/werk, niet het icon rechtsbovenin of in Firefox, de proxy al systemwide ingestelt  ?
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline AntondeJager

  • Lid
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #5 Gepost op: 2012/05/08, 20:01:54 »
Heb ik zojuist gedaan. Maar het helpt helaas niet. Heb alle mogelijke instellingen geprobeerd.

De output van sudo apt-get update, is te lang om te posten (meer dan 20000 karakters).

Citaat
Zet het tussen code tags ( [ code ] en [ /code ] maar dan zonder de spaties).
Bedankt voor je uitleg.
« Laatst bewerkt op: 2012/05/08, 20:11:18 door AntondeJager »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #6 Gepost op: 2012/05/08, 20:31:10 »
Je kan proberen of  het helpt als je de proxy handmatig instelt voor apt (en dus ook het softwarecentrum, synaptic enz.)
Zet dit in het bestand /etc/apt/apt.conf, of maak dat bestand aan indien het nog niet bestaat:
Acquire::http::Proxy "http://127.0.0.1:8000/";
Verander uiteraard wel het IP adres en poortnummer. En let op de puntcomma aan het einde.

Offline AntondeJager

  • Lid
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #7 Gepost op: 2012/05/08, 20:45:51 »
Ik weet niet het juiste IP-adres. Gebruik nu
Acquire::http::Proxy "http://proxy.kliksafe.nl:8080/";Verbinding wordt tot stand gebracht, maar bij een flink aantal lijsten zegt hij: Authentication Required. (In de proxy zit een filteringsysteem met een gebruikersnaam en wachtwoord.) Hoe kan ik die authenticatie meegeven?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #8 Gepost op: 2012/05/08, 21:16:43 »
http://gebruikersnaam:password@proxy.kliksafe.nl enz.

Offline AntondeJager

  • Lid
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #9 Gepost op: 2012/05/08, 22:08:41 »
Dankje. Dat werkt zover.
Krijg nu de melding over ongeldige ondertekeningen. Moet ik dan die keys toevoegen? Hoe werkt dat ook al weer? Ik ga wel even googlen.

Krijg ook de volgende melding: "W: Conflicterende distributie: http://archive.ubuntu.com precise-updates Release (verwachtte precise-updates, maar kreeg precise)"

En daaronder nog een ongeldige ondertekening, maar dan niet met een code, maar met "NODATA 1 NODATA 2"
« Laatst bewerkt op: 2012/05/08, 22:11:06 door AntondeJager »

Offline AntondeJager

  • Lid
  • Steunpunt: Nee
Re: Kan niet updaten
« Reactie #10 Gepost op: 2012/05/08, 22:59:23 »
Heb met behulp van de volgende code de keys toegevoegd.
    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys <key id>
Daarna apt-get update. Dat gaat nu goed. Maar de ondertekening voor extras.ubuntu.com is nog steeds ongeldig. Moet ik daar een andere keyserver voor hebben?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: [bijna opgelost] Kan niet updaten
« Reactie #11 Gepost op: 2012/05/11, 21:45:02 »
Ben je verplicht om gebruik te maken van die kliksafe proxy? Of kan je ook direct het internet op zonder tussenkomst van die proxy?
Een directe verbinding zou het allemaal een stuk makkelijker maken.