Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Alweer Grub...  (gelezen 394 keer)

Offline Starterke

  • Lid
  • Steunpunt: Nee
[opgelost] Alweer Grub...
« Gepost op: 2012/05/07, 14:02:31 »
Voila, hier ben ik weer.
Altijd nadat ik een nieuwe installatie heb gedaan kan ik grub niet zien op mijn scherm. Het systeem start wel op na de time-out, maar ik zie dus de lijst niet verschijnen.
Ik kan dus geen enkel ander systeem opstarten. Ze staan er nog wel allemaal, dat kon ik zien in de fdisk lijst.
Dit heb ik vroeger altijd kunnen oplossen door in het etc/default/grub  bestand mijn schermresolutie toe te voegen.
Nu werkt dat dus niet meer. Niet in Kubuntu 12.04 en niet in Ubuntu 12.04.

Dit krijg ik te zien bij update-grub:
/usr/sbin/grub-mkconfig: 25: /etc/default/grub: 1440x900: not found

Ik ben eens in dat bestand gaan kijken, maar weet niet of en waar ik mijn schermresolutie moet toevoegen  :|
Ik heb dus geen update-grub kunnen uitvoeren.

Iemand een idee wat ik kan doen?

« Laatst bewerkt op: 2012/05/07, 15:40:49 door Starterke »

Offline DeBaas

  • Lid
  • Steunpunt: Ja
Re: Alweer Grub...
« Reactie #1 Gepost op: 2012/05/07, 14:25:32 »
# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

sudo gedit
open /etc/default/grub
haal het hekje weg bij GRUB_TERMINAL=console
Dan krijg je e.e.a. in een tekstscherm of:
haal het hekje weg bij GFXMODE= 640x480 en verander 640x480 in een andere standaardwaarde 1440x900 zou moeten werken, zoniet kies een lagere zinvolle waarde.

http://en.wikipedia.org/wiki/VESA_BIOS_Extensions#Modes_defined_by_VESA
https://help.ubuntu.com/community/Grub2

of:
staat de timeout soms op 0 ?
GRUB_TIMEOUT=5

en altijd weer update-grub ;)
« Laatst bewerkt op: 2012/05/07, 14:42:44 door DeBaas »
Ik beantwoord GEEN hulpvragen via PB en/of MAIL

Offline Starterke

  • Lid
  • Steunpunt: Nee
Re: Alweer Grub...
« Reactie #2 Gepost op: 2012/05/07, 15:14:08 »
Ik heb een # geplaatst voor GRUB_GFXMODE=640x480, maar dat heeft niet geholpen.
De rest stond zoals u het laat zien.

Wat ik altijd te zien krijg bij de start is een melding van mijn scherm waarop staat: "92Khz/58Hz te groot". Dit zweeft op en af over het zwarte scherm terwijl de computer verder start naar het laatst geïnstalleerde systeem. Ubuntu start dan gewoon op.

Ik heb te weinig tijd nu om die pagina's te bestuderen, ik snap er bijna niks van...
Hier is mijn config bestand zoals het nu is, misschien ziet iemand direct wat ik moet veranderen:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# GRUB_GFXMODE="640x480" "1440x900"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"



Offline Starterke

  • Lid
  • Steunpunt: Nee
Re: Alweer Grub...
« Reactie #3 Gepost op: 2012/05/07, 15:40:12 »
Oeps, had verkeerd gelezen en het # bij GRUB_TERMINAL=console teruggezet.
Heb het weer weggehaald en nu werkt het weer.

Probleem is dus opgelost. Bedankt    :)