Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: no init found, try passing init= bootarg in Maverick 10.10  (gelezen 544 keer)

Offline perro30

  • Lid
  • Steunpunt: Nee
no init found, try passing init= bootarg in Maverick 10.10
« Gepost op: 2012/04/23, 21:42:38 »
Ik heb al sinds een tijd Ubuntu 10.10 Netbook versie op mijn Dell Inspiron Mini 1010, is altijd goed gegaan en is eigenlijk de laatste versie die goed op deze kleine laptop draait, zo heb ik ook gelezen.
Gisteren deed het touchpad gek en de laptop sloot zichzelf af.
Nu krijg ik bij opstart
Citaat
no init found, try passing init= bootarg

Heb een en ander daarover gelezen, ook dat de 10.10 live CD min of meer een bug zou hebben.
Maar het is de enige live CD die goed opstart, oudere Ubuntu live versies wensen niet op te starten, dan missen ze iets, of er ontbreekt iets.
Ook de Knoppix live CD weigert dienst.

De enige die goed werkt is de Ubuntu 10.10 Netbook live CD.
Heb nu "sudo fdisk -l" gedaan en het resultaat:
Citaat
Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (minimum/optimal): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0008b4ea

Device              Boot            Start                End                      Blocks                     Id                      System
/dev/sda1        *                   1                       19076                  153219072            83                      Linux
/dev/sda2                              19076             19458                   3068929                  5                      Extended
/dev/sda5                               19706             19458                  3068928               82                       Linux swap / Solaris
als ik nu "sudo fsck /dev/sda1" ingeef krijg ik:
Citaat
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010(
fsck.ext4: Device of resource busy tijdens openen van /dev/sda1
Bestandssysteem exclusief aangekoppeld of geopend door ander programma?

Reboot werkt dus niet hierna, ik krijg dezelfde init fout als hierboven aangegeven.

Heb ook getracht alles te herinstalleren, maar dit loopt aan het begin al vast, d.w.z. als er wordt gevraagd dat je internetverbinding aan staat, de laptop direct verbonden is met elektriciteit en of je gelijk updates wenst te installeren en software van derden, en daar loopt het vast, de muispointer blijft draaien en draaien tot in het oneindige en het gaat niet verder.

Wat is er aan de hand?

Hoor het graag, daar ik voor mijn werk zeer afhankelijk ben van deze kleine laptop. Gelukkig staan er op dit moment geen speciale documenten en zo op, die had toevallig pas al weggebrand op een data-DVD.

Bedankt voor de reacties en hulp hierbij.

Offline perro30

  • Lid
  • Steunpunt: Nee
Re: no init found, try passing init= bootarg in Maverick 10.10
« Reactie #1 Gepost op: 2012/04/23, 21:43:54 »
sorry, dubbel geplaatst
« Laatst bewerkt op: 2012/04/23, 22:17:00 door perro30 »

Offline perro30

  • Lid
  • Steunpunt: Nee
Re: no init found, try passing init= bootarg in Maverick 10.10
« Reactie #2 Gepost op: 2012/04/23, 22:13:45 »
Voor de goede orde, krijg nu binnen de niet geinstalleerde live CD, als ik de harde schijf wil openen:
Error:
UNABLE TO MOUNT 157 GB FILESYSTEM
A job is pending on /dev/sda1

Las ook nog ergens dit:

Citaat
The message "Kernel panic: no init found. Try passing init= option to kernel" probably means the kernel can not find the root file system. Please try to modify the "root=" kernel parameter in the grub entry. Make sure that the value of the "root=" kernel parameter point to the right root-file-system device/partition.

Is dit wellicht een oplossing, maar hoe kan ik init= option to kernel doen en dan modify the root kernel parameter in the grub entry, pointing to the right root file system device/partition? Hoe gaat dat in zijn werk in Ubuntu 10.10?
« Laatst bewerkt op: 2012/04/26, 13:38:08 door perro30 »

Offline perro30

  • Lid
  • Steunpunt: Nee
Re: no init found, try passing init= bootarg in Maverick 10.10
« Reactie #3 Gepost op: 2012/04/29, 23:55:36 »
Gelukkig is alles nu weer opgelost, via de SystemRescueCD, alles doet het weer als vanouds goed met mijn Dell mini laptop.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: no init found, try passing init= bootarg in Maverick 10.10
« Reactie #4 Gepost op: 2012/04/30, 00:05:07 »
Alleen wordt 10.10 niet meer ondersteund dus je doet er beter aan te upgraden naar een versie die wel wordt ondersteund (12.04 is de nieuwste + 5 jaar ondersteuning).

Offline perro30

  • Lid
  • Steunpunt: Nee
Re: no init found, try passing init= bootarg in Maverick 10.10
« Reactie #5 Gepost op: 2012/04/30, 00:32:17 »
Bedankt Vistaus, maar ik heb destijds al duidelijk gelezen dat alleen op mijn Dell Inspiron Mini 1010 de netbook versie van Ubuntu 10.10 past, geen verdere versies, en dat ging al mis sinds Ubuntu 11.04, dit was zelfs op de Ubuntu site over deze mini laptop.
Op mijn vaste PC staat inmiddels wel de Ubuntu 12.04 sinds gisteren, die is van 11.10 naar 12.04 geupgrade.
En die is mooi.
Maar ik kan toch wel via deze kleine laptop weer werken via het werk, waarvoor ik deze nodig heb, ik heb hierop toch de LibreOffice geinstalleerd en dus kan alles, wat ik hierop heb geschreven, lezen in de LibreOffice in 12.04 en daar gaat het eigenlijk om.

Nogmaals bedankt en wens je morgen een fijne Koninginnedag toe.