Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Nieuwe dag, Nieuw probleem : Vandaag werkt firefox niet meer.  (gelezen 347 keer)

Offline boos

  • Lid
  • Steunpunt: Nee
Het lijkt niet meer te lukken om een flash plugin in firefox te activeren.
about:plugins geeft: Er zijn geen plug-ins geïnstalleerd
Dit na herinstallatie van zowel firefox als de flash plugin via de synaptic package manager.

Gisteren werkte de 3.6.27 versie van firefox nog prima.
Die was handmatig geinstalleerd, al enige tijd geleden, omdat deze versie nodig is om de sunray administratie software op een sun machine te beheren.
Dit lukt niet met de nieuwere firefox browsers.

Ook deze errors kom ik regelmatig tegen, met diverse programma's.
Nu heb ik begrepen, dat de lib directory's op een 64 machine de 64 bit library's heeft, maar op een 32 bit machine de 32 bit library's heeft.
Dus de zelfde directory naam, kan verschillende library's bevatten, die dan ook nog de zelfde naam hebben ????

firefox-bin:17283): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: verkeerde ELF-klasse: ELFCLASS64
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-cone-plugin.so [/usr/lib/mozilla/plugins/libtotem-cone-plugin.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-gmp-plugin.so [/usr/lib/mozilla/plugins/libtotem-gmp-plugin.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-mully-plugin.so [/usr/lib/mozilla/plugins/libtotem-mully-plugin.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so [/usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so [/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/skypebuttons.so [/usr/lib/mozilla/plugins/skypebuttons.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/nspluginwrapper/plugins/npwrapper.npica.so [/usr/lib/nspluginwrapper/plugins/npwrapper.npica.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/nspluginwrapper/plugins/npwrapper.nppdf.so [/usr/lib/nspluginwrapper/plugins/npwrapper.nppdf.so: verkeerde ELF-klasse: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/flashplugin-installer/libflashplayer.so [/usr/lib/flashplugin-installer/libflashplayer.so: verkeerde ELF-klasse: ELFCLASS64]

Wie weet een oplossing die deze problemen voor nu en de toekomst voorkomt ?

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: Nieuwe dag, Nieuw probleem : Vandaag werkt firefox niet meer.
« Reactie #1 Gepost op: 2012/04/18, 14:05:38 »
Heb je de niet vrije multimedia extra's uit het softwarecentrum geïnstalleerd ?
Daar zit de hele zaak in.

http://wiki.ubuntu-nl.org/DirectDoen

- Roc
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Nieuwe dag, Nieuw probleem : Vandaag werkt firefox niet meer.
« Reactie #2 Gepost op: 2012/04/18, 14:11:47 »
Heb je misschien een 32-bits versie van Firefox geïnstalleerd op een 64-bits systeem? Of andersom?
De foutmeldingen die je ziet lijken wel die kant op te wijzen.

Offline boos

  • Lid
  • Steunpunt: Nee
Re: Nieuwe dag, Nieuw probleem : Vandaag werkt firefox niet meer.
« Reactie #3 Gepost op: 2012/04/18, 14:54:31 »
Tja, ik heb nu eerst alles weg gehaald met de synaptic, Daarna opnieuw firefox geinstalleerd.
Verder vond ik nog een commando uit 2009 of zo, om flash-not-free oid te installeren.
sudo apt-get install flashplugin-nonfree

Nu lijkt dit weer te werken. De nieuwe versie dan. firefox 11.0
Is er nu nog een mogelijkheid om de oude versie 3.6.27 er naast te installeren ?

Het versie conflict zou daaruit kunnen komen, dat een 32 bit firefox versie op een 64 bit os geinstalleerd is.
Ik dacht dat dit ook zou moeten kunnen. Andersom misschien niet, maar 32 bit op 64 bit os wel.

Waar is nu de firefox start button / icon ?
Niet op het buroblad, en ook niet in het start menu. ??
« Laatst bewerkt op: 2012/04/18, 15:37:09 door boos »