Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen Flash meer in Lucid....  (gelezen 495 keer)

Offline Marqeaux

  • Lid
  • Steunpunt: Nee
Geen Flash meer in Lucid....
« Gepost op: 2012/04/12, 23:17:00 »
Hoi,

Hierover is al vele malen geschreven in dit forum, maar ik loop toch tegen een probleem aan die ik niet op kan lossen: Ik heb op mijn oude desktop-PC met 10.04 erop van de één op de andere dag geen Flash meer. Ik heb zo'n beetje alles geprobeerd wat je kunt verzinnen, maar ik krijg het niet voor elkaar!

Ja, ik heb de allerlaatste versie, en deze wordt ook netjes herkend. In Firefox en Chromium staat de plugin er ook gewoon netjes bij. Alleen.... ik krijg geen toch geen Flash op websites! Deïnstalleren en opnieuw installeren hielp niets, ook niet handmatig installeren. De plugin wordt herkend, maar toch krijg ik de melding dat ik Flash moet downloaden en installeren.

Iemand met een oplossing? Het kost me al de hele avond, maar ik doe een allerlaatste poging hier. Lukt het niet, dan moet ik maar met een image terug in de tijd. Eerst kijken of ik het op een "chique" manier op kan lossen (met jullie hulp!)

Bedankt alvast!

Toevoeging: Ik heb besloten om het maar "niet chique" op te lossen door simpelweg een backup-image terug te zetten. Ik zit op dit moment even krap in mijn tijd, en dit is de snelste manier om het probleem op te lossen. De image is al teruggezet, en de updates draaien op het moment van schrijven. Eens kijken hoe het uitpakt....

Update: Het terugzetten van de image heeft het probleem niet opgelost. Bij één van de laatste updates die Canonical heeft vrijgegegeven heeft (vermoed ik!) gezorgd voor dit probleem, aangezien dit plots en zeer recentelijk is gebeurd. Of is de allerlaatste versie van libflashplayer.so zo brak als de pest? Zijn er nog meer mensen met dit probleem?
« Laatst bewerkt op: 2012/04/13, 01:20:33 door Marqeaux »
I'm just a simple guy who uses open source software. What's your excuse?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Geen Flash meer in Lucid....
« Reactie #1 Gepost op: 2012/04/13, 08:40:52 »
Kijk even in Synaptic welk Flash pakket je geïnstalleerd hebt staan.
Er zijn er meerdere, en sommige werken beter dan andere.
flashplugin-installer en flashplugin-nonfree zijn de oudere pakketten, die zou ik volledig verwijderen.
Degene die je wel moet hebben is adobe-flashplugin en die zit in de "partner" pakketbron.

Hierna kan je wat controles doen.
Kijk welke pakketten er allemaal geïnstalleerd staan die een versie van het bestand libflashplayer.so leveren:
dpkg -S libflashplayer.soDat zou dit resultaat op moeten leveren:
adobe-flashplugin: /usr/lib/adobe-flashplugin/libflashplayer.so
Vervolgens of er nog meer bestanden op je systeem staan op plekken waar ze niet horen:
sudo updatedb
locate libflashplayer.so
De laatste zou alleen deze regel moeten geven:
/usr/lib/adobe-flashplugin/libflashplayer.so
Vervolgens alle browsers even afsluiten en opnieuw starten en het zou moeten werken.
Zo niet, dan zou je even in de instellingen van je browser moeten kijken.

Offline Marqeaux

  • Lid
  • Steunpunt: Nee
Re: Geen Flash meer in Lucid....
« Reactie #2 Gepost op: 2012/04/13, 18:35:36 »
Hoi Johan,

Nee hoor, het mocht niet baten. Bij de opdracht

dpkg -S libflashplayer.so
krijg ik meteen dat hij het bestand niet heeft gevonden. En na het updaten van de database, en met de code:

locate libflashplayer.so
krijg ik het volgende te zien:

marco@marco-desktop:~$ locate libflashplayer.so
/usr/lib/flashplugin-installer/libflashplayer.so
/usr/share/ubufox/plugins/libflashplayer.so

De tweede is een verwijzing naar de eerste, dus dat is niet het werkelijke bestand. Libflashplayer.so bestaat gewoon op mijn systeem, maar het wordt via dpkg dus niet gevonden. Apart....

Ik heb zojuist de hele riedel opnieuw gedaan (dus alles gedeïnstalleerd, en vervolgens het pakket uit de partnerbronnen geïnstalleerd, maarreh... het mag niet baten. Het gekke is dat Firefox libflashplayer.so wèl gewoon herkent als ik bij "about:plugins" kijk. Maar als ik op een site kom met Flash, dan krijg ik óf een zwart vlak, óf de welbekende melding: "Get Adobe Flash Player". Handmatig de boel installeren baat ook niet. Hij vertikt het gewoon om te werken.

Ik heb ook Chromium weer even opnieuw geinstalleerd, en daar crasht de plugin. Ik denk dat er iets niet helemaal lekker is gegaan bij de update.

Ik waan me weer helemaal in 2006, toen dit soort zaken in Linux-distro's bijna gewoon was. Ik heb deze machine 3 weken voor het laatst uit gezet, en toen was er niets aan de hand. Maar sinds gisteren, toen ik alle updates had verwerkt, toen was het raak.

Heb je eventueel nog verdere suggesties? 
I'm just a simple guy who uses open source software. What's your excuse?

Offline Marqeaux

  • Lid
  • Steunpunt: Nee
Re: Geen Flash meer in Lucid....
« Reactie #3 Gepost op: 2012/04/13, 21:14:58 »
Ah, ik zie ineens meerdere mensen met hetzelfde, of in ieder geval een gelijkend probleem. Dit draadje mag wat mij betreft samengevoegd worden met deze thread:
http://forum.ubuntu-nl.org/software-en-configuratie/flash-probleem-73477/msg813002/#new

Blijkbaar toch een brakke Flash plugin (wat ik al vermoedde)....
I'm just a simple guy who uses open source software. What's your excuse?