Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: portforwarding op TLS 10.04  (gelezen 693 keer)

Offline jkuiper

  • Lid
  • Steunpunt: Nee
portforwarding op TLS 10.04
« Gepost op: 2012/04/11, 10:19:26 »
Ik ben al twee weken bezig met dit probleem

Ik heb Ubuntu 10.04 TLS on a HP 64 bits geinstalleerd.
Deze applicaties heb ik handmatig toegevoegd.
De server heeft twee netwerkkaarten ( internal (192.168.2/24 [eth1] , external 194.123.xx.xx [eth0]).
Met OpenVPN maak ik geen gebruik van bridging, maar routing. Zover ik weet is de firewall goed geconfigureerd:

# Generated by iptables-save v1.4.4 on Thu Mar 29 12:06:38 2012
*nat
:PREROUTING ACCEPT [23:2307]
:POSTROUTING ACCEPT [2:452]
:OUTPUT ACCEPT [2:452]
-A POSTROUTING -s 192.210.5.0/24 -o eth0 -j MASQUERADE
COMMIT
*mangle
:PREROUTING ACCEPT [66:6249]
:INPUT ACCEPT [46:4255]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [26:4701]
:POSTROUTING ACCEPT [26:4701]
COMMIT
*filter
:FORWARD DROP [0:0]
:INPUT DROP [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT ! -i eth0 -j ACCEPT
-A INPUT -m state --state ESTABLISHED -j ACCEPT
-A INPUT -m state --state RELATED -j ACCEPT
-A INPUT -p tcp -m tcp --dport 20 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 21 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 80 -j ACCEPT
-A INPUT -p udp -m udp --dport 1024:65535 --sport 53 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 443 -j ACCEPT
-A INPUT -p tcp -m tcp -s 77.169.176.90 --dport 10000 -j ACCEPT
-A INPUT -p tcp -m tcp --dport auth -j ACCEPT
-A INPUT -p tcp -m tcp --dport 2049:2050 -j DROP
-A INPUT -p tcp -m tcp --dport 6000:6063 -j DROP
-A FORWARD -s 192.210.5.0/24 -o eth0 -j ACCEPT
-A FORWARD -m state -d 192.210.5.0/24 -i eth0 --state ESTABLISHED,RELATED -j ACC
EPT
-A INPUT -p tcp -m tcp --dport 7000:7010 -j DROP
-A INPUT -p tcp -m tcp --dport 1024:65535 -j ACCEPT
-A INPUT -p tcp --dport 50000:51000 -j ACCEPT
-A INPUT -p udp --dport 1194 -j ACCEPT
# tun devices
-A INPUT -i tun+ -j ACCEPT
-A FORWARD -i tun+ -j ACCEPT
-A OUTPUT -o tun+ -j ACCEPT
# tap devices
-A INPUT -i tap+ -j ACCEPT
-A FORWARD -i tap+ -j ACCEPT
COMMIT
Inlogen op en de OpenVPN server is geen probleem. Ik krijg van OpenVPN een ipadres toegewezen en deze wordt vrolijk geintregeerd op mijn desktop. Maar het probleem ligt elders. Ik kan de samba server of andere ssh server op de geconnecteerde netwerk niet benaderen. De remote netwerk is niet hetzelfde als die bij mij thuis.

vpn client ----> vpnserver ----> ssh vpnserver ---> werkt.

vpn client ----> vpnserver ----> ssh vpnserver   |-> andere sshserver ---> werkt niet
                           |-------------------------  |

In sysctl.conf de ipforwarding staat op 1:
/etc# sysctl -p
net.ipv4.ip_forward = 1

Ik heb ook gebrobeerd om een paort forwarding uit tw voeren naar een aandere webserver de  de remote lan, maar dat wil ook niet werken.

Twee vraagjes (heb er nog wel meer):
1. Werkt opUbuntu 10.04 TLS het routing gedeelte alleen via een bridge of kan het ouderwetde routing nog steeds?
2. Zitten er toch foutne in mijn firewallsettings.

Ik word er een beetje moe van dit probleem. Ik heb nog een andere server draaien met Redhat 9 met dezeflde configuratie en werkt zonder problemen.

Windows desktops, die een gateway en DNS hebben naar deze server werken naar behoren. Ik kan gewoon browsen op het internet.

« Laatst bewerkt op: 2012/04/17, 12:57:45 door jkuiper »

Offline jkuiper

  • Lid
  • Steunpunt: Nee
Re: portforwarding op TLS 10.04
« Reactie #1 Gepost op: 2012/04/17, 12:57:08 »
Niemand die deze situatie ook heeft gehad of kent?

Ik zal het wel makkelijker maken. Dit script gemaakt en uitgevoerd:
iptables -F &&
iptables -X &&
iptables -t nat -F &&
iptables -t nat -X &&
iptables -t mangle -F &&
iptables -t mangle -X
iptables -A INPUT -i lo -j ACCEPT &&
iptables -A INPUT -i eth0 -j ACCEPT &&
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT &&
iptables -A INPUT -p icmp -m icmp --icmp-type any -j ACCEPT &&
iptables -A INPUT -p udp -m udp --dport 1024:65535 --sport 53 -j ACCEPT &&
iptables -A INPUT -p tcp --dport 22 -j ACCEPT &&
iptables -A INPUT -p tcp -m tcp --dport auth -j ACCEPT &&
iptables -A INPUT -i tun+ -j ACCEPT &&
iptables -A INPUT -p udp --dport 1194 -j ACCEPT &&
iptables -A FORWARD -i tun+ -j ACCEPT &&
iptables -A FORWARD -o tun+ -j ACCEPT &&
iptables -A OUTPUT -o lo -j ACCEPT &&
iptables -A OUTPUT -o eth0 -j ACCEPT &&
iptables -A OUTPUT -o tun+ -j ACCEPT
Dit zal MOETEN werken volgens vele websites.
Een verbinding via een andere naar OpenVPN gemaakt. Als ik nu een SSH verbinding maakt , krijg ik foutmelding #10060. TCPDUMP geeft aan dat het pakketje wel wordt ontvangen, maar geen response krijgt.

Maar waarom weet ik niet  ??? ??? ??? ??? ??? ???