Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geluid niet werkend na update  (gelezen 1498 keer)

Offline NielsH

  • Lid
  • Steunpunt: Nee
Geluid niet werkend na update
« Gepost op: 2012/04/05, 14:16:30 »
Dag Allemaal

al tijdje gebruik ik ubuntu (of afgeleiden) als mijn primair os. Sinds gisterenavond werkt mijn audio niet meer. Enige wat ik me kan voorstellen, is dat er gisteren een update was en dat ik daardoor nu met een audio-probleem zit.

Enige wat je hebt is een 'kraakje' net wanneer bv een Mp3-bestand begint af te spelen. Rest hoor je niets meer.

Heb geen idee wat ik moet aanvangen.

Heb een ASUS US30D.

Iemand raad (zeker nu ik net een abonnement op Deezer.com gewonnen had en ik absoluut niet wil overstappen naar Windows)?

Bedankt.

niels

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #1 Gepost op: 2012/04/05, 15:11:22 »
Welke Ubuntuversie?

Offline NielsH

  • Lid
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #2 Gepost op: 2012/04/05, 16:12:53 »
Was ik inderdaad vergeten te vermelden:
11.10

niels

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #3 Gepost op: 2012/04/05, 16:25:55 »
Was ik inderdaad vergeten te vermelden:
11.10

niels
Net een kernel-update gehad? Zo ja, start eens op vanaf de vorige kernel (staat onder "Previous Linux versions" in het Grubmenu).

Offline NielsH

  • Lid
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #4 Gepost op: 2012/04/05, 17:08:18 »
Hey Pjotr

bedankt voor de suggestie (vorige kernel). Helaas werkte die oplossing niet. Heb ook even gekeken wat mijn updates gisteren waren en er staat geen kernelupdate, noch iets met audio (voor zover ik dat kan zien) bij. Alleen Thunderbird update en iets met de naam modemmanager (?).

Ik ben overigens ook in windows 7 (dual boot) het volume volledig gaan aanzetten (las ergens dat dat ook het probleem zou kunnen zijn).

Heb gisteren in windows 7 (moest er gisteren even zijn) wel nog een update van ASUS zelf doorgevoerd (geen bios, dat weet ik, had de nogal ruime term "Software"). Denk dat dit backupsoftware was, dus dat kan het niet zijn...

Wat nu?

Offline NielsH

  • Lid
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #5 Gepost op: 2012/04/05, 17:11:38 »
Ook nog even aangeven dat net nadat ik het vorig bericht postte, het geluid terug werkte.

Was gisteren ook het geval af en toe: opstartgeluid was er niet, hier en daar een paar "plokjes" wanneer je bv een youtube filmpje afspeelde (geen geluid) en dan na een minuut of 5 werkt alles heel plots wel...

Snapetnietmeer...

Offline NielsH

  • Lid
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #6 Gepost op: 2012/04/06, 13:19:31 »
Blijft hetzelfde vandaag: nog steeds geen geluid...

Iemand raad?


Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #7 Gepost op: 2012/04/08, 18:02:19 »
Bedoel je dat je afwisselend wel en geen geluid hebt? Kun je eventueel een hyperlink geven van die Asus laptop?  Zou je de output kunnen posten van het volgende commando
hwinfo --sound [Enter] Als het kopiƫren plakken niet lukt, doe dan het volgende commando hwinfo --sound > sound.txt [Enter] en voeg die sound.txt in je volgende bericht toe, als een bijlage. Als je voldoende Linux ervaring hebt, zou je deze hyperlink kunnen checken https://wiki.ubuntu.com/DebuggingSoundProblems
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline NielsH

  • Lid
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #8 Gepost op: 2012/04/09, 11:22:11 »
Dag Jolo

bedankt voor je antwoord.

Ziehier wat ik terugkreeg.

process 2835: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
niels@niels-U30Sd:~$ hwinfo --sound
> hal.1: read hal dataprocess 2849: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file ../../dbus/dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
12: PCI 1b.0: 0403 Audio device                                 
  [Created at pci.318]
  Unique ID: u1Nb.8z5fa5aeCX3
  SysFS ID: /devices/pci0000:00/0000:00:1b.0
  SysFS BusID: 0000:00:1b.0
  Hardware Class: sound
  Model: "Intel Audio device"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x1c20
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x1053
  Revision: 0x05
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xdf600000-0xdf603fff (rw,non-prefetchable)
  IRQ: 44 (3389 events)
  Module Alias: "pci:v00008086d00001C20sv00001043sd00001053bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown


En, neen, ik heb niet zoveel ervaring :-) Alle hulp wordt met plezier aanvaard!

niels

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Geluid niet werkend na update
« Reactie #9 Gepost op: 2012/04/09, 15:14:29 »
Dan heb je dus Intel onboard audio. Wel heb je zo te zien een dbus-errors.c in je output. Ik weet niet, of dat met je geluid probleem te maken heeft. Vergelijk eventueel de hwinfo --sound [Enter] output, met en zonder geluid.

Klik intussen in Ubuntu op het speaker icoontje > Geluidsinstellingen > Hardware. Als je PC speakers aangesloten zijn op de geluidskaart, selecteer je daar het analoge apparaat en speakers testen. Klik zowel op Testen voor links en rechts. Weet je verder zeker, dat je PC speakers nog wel goed functioneren? Kun je eventueel ook testen met een hoofdtelefoon? Probeer behalve MP3 ook andere geluid bronnen. Zoals wav bestanden van een muziek cd of youtube.
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM