Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Clonezilla gebruikt om partitie terug te zetten-->opstartproblemen  (gelezen 731 keer)

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Ik heb Clonezilla gebruikt om een partitie vanaf USB terug te zetten (was primaire partitie sda4 en werd (een iets grotere) logische partitie sda8). Dat is gelukt zonder problemen. Toen opstarten en Ubuntu startte niet op, maar ik weet "zeker" dat ik in Clonezilla "expert" =D mode heb uitgevinkt dat grub zou worden geherinstalleert en ook de hidden data tussen MBR en 1e partitie klonen was uitgevinkt. Hoe dat ook, ik heb daarna dus grub met de Ubuntu live USB geherinstalleert (zoals dat volgens Computertip moet) en Ubuntu start nu wel weer op.

Sudo update-grub laat ook de windows 7 loader partitie zien en ik verwachtte dat win7 zou starten maar dat gaat dus niet!

Wat kan er aan de hand zijn? Win7 staat op twee partities (een 200MB SYSTEM partitie en een 50 GB Win7 partitie), dit is normaal op HP computers schijnbaar...die beide partities kunnen toch niet zijn verandert door Clonezilla, dat kan ik me niet voorstellen. Grub is geherinstalleert in het MBR, dus waarom zou win7 dan niet starten?

Dus, Clonezilla gebruikt, grub moeten herinstalleren om ubuntu te kunnen booten maar win7 lukt niet.
Zelfs starten en dan op F11 drukken om de HP Recovery partition op te starten lukt niet!
Maar Ubuntu start na herinstall grub dus (gelukkig) wel gewoon.

Nu mis ik win7, maar als ik system herstel doe vanaf USB dan verlies ik Ubuntu.
« Laatst bewerkt op: 2012/03/29, 23:29:15 door Al Bunty »
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Clonezilla gebruikt om partitie terug te zetten-->opstartproblemen
« Reactie #1 Gepost op: 2012/03/29, 23:38:59 »
Probeer dit eens:
Bekende problemen

Bij een dual-boot installatie is er soms geen keuze voor een ander besturingssysteem. Dit kan worden opgelost door in een Terminalvenster de volgende opdrachten te geven:

sudo os-prober
sudo update-grub

van http://wiki.ubuntu-nl.org/community/Grub2#Bekende_problemen
In der Beschränkung zeigt sich der Meister.

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Re: Clonezilla gebruikt om partitie terug te zetten-->opstartproblemen
« Reactie #2 Gepost op: 2012/03/30, 00:45:17 »
Probeer dit eens:
Bekende problemen

Bij een dual-boot installatie is er soms geen keuze voor een ander besturingssysteem. Dit kan worden opgelost door in een Terminalvenster de volgende opdrachten te geven:

sudo os-prober
sudo update-grub

van http://wiki.ubuntu-nl.org/community/Grub2#Bekende_problemen
Dat trucje sudo update-grub ken ik wel, heb ik al gedaan, en hij detecteert keurig netjes de win7 patitie(s) en de ubuntu partitie, en ook de HP recovery partitie staat in het grub menu en was ook van daaruit te starten. De win 7 en ubuntu staan er nog steeds (na sudo update-grub) maar ze starten niet!

Heeft dit http://sourceforge.net/projects/clonezilla/forums/forum/394750/topic/3920670
http://ubuntuforums.org/showthread.php?t=1555002    
er iets mee te maken?

Er moet toch iets met het MBR zijn gebeurt...maar omdat ik grub op sda gheb herinstalleert dacht ik dan moet het toch weer goed zijn? Maar bijv. ook de F11 key press voor de Recovery partition moet in het MBR worden opgevangen...Als ik de boot flag voor de recovery partition zet met gparted dan werkt F11 wel om in de HP recovery te komen...
« Laatst bewerkt op: 2012/04/02, 19:50:20 door Al Bunty »
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10