Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: SSH wil niet meer starten kan wel via webmin op de server  (gelezen 1090 keer)

Offline Sjorsishier

  • Lid
  • Steunpunt: Nee
SSH wil niet meer starten kan wel via webmin op de server
« Gepost op: 2012/03/29, 10:55:06 »
Hallo allemaal,


Ik heb geen idee waar ik dit moet zoeken.
Na een herstart kan ik de server niet meer benaderen met SSH

Als ik met webmin probeer om de SSH te starten krijg ik alleen de melding:

Starting service ssh ..

start: Job failed to start
.. mislukt!
Daar kom ik niet echt verder mee.

Mijn settings zijn standaard althans de zelfde als mijn laptop:

Kan iemand me zeggen wat ik kan/moet doen?

Want dit is erg lastig, ik heb geen desktop op de server en geen vnc, dus webmin en ssh zijn voor mij van belang.

Dank voor de hulp, hier onder dus mijn instelling voor de SSH

===========================================
# ssh - OpenBSD Secure Shell server
#
# The OpenSSH server provides secure shell access to the system.

description   "OpenSSH server"

#start on filesystem
stop on runlevel [!2345]

respawn
respawn limit 10 5
umask 022
# replaces SSHD_OOM_ADJUST in /etc/default/ssh
oom never

pre-start script
    test -x /usr/sbin/sshd || { stop; exit 0; }
    test -e /etc/ssh/sshd_not_to_be_run && { stop; exit 0; }
    test -c /dev/null || { stop; exit 0; }

    mkdir -p -m0755 /var/run/sshd
end script

# if you used to set SSHD_OPTS in /etc/default/ssh, you can change the
# 'exec' line here instead
exec /usr/sbin/sshd -D


===========================================
« Laatst bewerkt op: 2012/03/29, 10:58:03 door Sjorsishier »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: SSH wil niet meer starten kan wel via webmin op de server
« Reactie #1 Gepost op: 2012/03/29, 22:10:52 »
Open een terminal en type /etc/init.d/sshd  of ssh restart krijg je foutmeldingen? Of kijk in je var/log voor fouten. Kan je die hier vermelden?
In der Beschränkung zeigt sich der Meister.

Offline Sjorsishier

  • Lid
  • Steunpunt: Nee
Re: SSH wil niet meer starten kan wel via webmin op de server
« Reactie #2 Gepost op: 2012/03/29, 23:03:48 »
Hallo Gijsbert,

Dat is nu net het probleem, hoe open ik nog een terminal?

ssh werkt niet, de ssh optie in webmin werkt niet

Dank voor je reatie

Groeten Sjors

Offline Sjorsishier

  • Lid
  • Steunpunt: Nee
Re: SSH wil niet meer starten kan wel via webmin op de server
« Reactie #3 Gepost op: 2012/03/29, 23:06:10 »
ps

in var/log zie ik nergens een ssh gerelateerde foutmelding

In webmin kan ik de ssh staren en krijg alleen een melding dat het starten niet gelukt is

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: SSH wil niet meer starten kan wel via webmin op de server
« Reactie #4 Gepost op: 2012/03/29, 23:26:23 »
Sorry slordigheidje van mij, onder Hulpmiddelen staat de terminal.
Type dit commando in sudo service ssh restart en geef een ENTER. Nu moet je het wachtwoord intypen, jouw wachtwoord, hiervan zie je niets, gewoon blind intypen en geef een ENTER.
Dan moet je zoiets dergelijks zien:
gijs@gijs-desktop──> /home/gijs
sudo service ssh restart
[sudo] password for gijs:
ssh start/running, process 31106

« Laatst bewerkt op: 2012/03/29, 23:28:29 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline Sjorsishier

  • Lid
  • Steunpunt: Nee
Re: SSH wil niet meer starten kan wel via webmin op de server
« Reactie #5 Gepost op: 2012/03/30, 11:53:50 »
Hallo Gijs,


Ik heb eerst de opdracht
 sudo service ssh restart gegeven.
Toen heb ik mijn wachtwoord (even naar XXX gezet hier in het forum).
Toen heb ik sudo service ssh restart XXX als een regel gegeven omdat na sudo service ssh restart het scherm (shell opdracht) weer terug komt)
Zie hier onder wat ik zie in het shell opdracht scherm:

> sudo service ssh restart
restart: Unknown instance:
> XXX
bash: XXX: command not found
> sudo service ssh restart
restart: Unknown instance:
> sudo service ssh restart XXX
restart: Env must be KEY=VALUE pairs

De /var/log/auth.log heeft onderstaande inhoud:

USER=root ; COMMAND=/usr/sbin/service ssh restart
Mar 30 09:19:15 vs2832 su[5593]: pam_unix(su:session): session closed for user root
Mar 30 09:19:48 vs2832 su[5655]: Successful su for root by root
Mar 30 09:19:48 vs2832 su[5655]: + ??? root:root
Mar 30 09:19:48 vs2832 su[5655]: pam_env(su:session): Unable to open env file: /etc/default/locale: No such file or directory
Mar 30 09:19:48 vs2832 su[5655]: pam_unix(su:session): session opened for user root by (uid=0)
Mar 30 09:19:56 vs2832 sudo:     root : TTY=unknown ; PWD=/root ; USER=root ; COMMAND=/usr/sbin/service ssh restart XXX
Mar 30 09:19:56 vs2832 su[5655]: pam_unix(su:session): session closed for user root
Mar 30 09:25:02 vs2832 su[7412]: Successful su for root by root
Mar 30 09:25:02 vs2832 su[7412]: + ??? root:root
Mar 30 09:25:02 vs2832 su[7412]: pam_env(su:session): Unable to open env file: /etc/default/locale: No such file or directory
Mar 30 09:25:02 vs2832 su[7412]: pam_unix(su:session): session opened for user root by (uid=0)
Mar 30 09:25:04 vs2832 sudo:     root : TTY=unknown ; PWD=/root ; USER=root ; COMMAND=/usr/sbin/service ssh restart
Mar 30 09:25:04 vs2832 su[7412]: pam_unix(su:session): session closed for user root

putty geeft de meldin: putty fatal error verbining is geweigerd.


Ik hoop dat de ssh weer aan de gang komt een herinstall van deze server is 3-4 dagen werk ;-(
De andere kant is, zonder ssh is het erg moeilijk om ook maar iets op de server te kunnen doen.

Al vast heel veel dank en ik hoop dat je me nog van tips kunt voorzien

Groetjes


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: SSH wil niet meer starten kan wel via webmin op de server
« Reactie #6 Gepost op: 2012/03/30, 23:08:47 »
Is je configuratie file nog in orde? Lees hier meer http://wiki.ubuntu-nl.org/community/Openssh-server vanaf Configuratie en lees ook de link naar Ubuntu firewall. Als je er niet uitkomt schrijf je maar weer.

Mijn ssh config file, te openen met het commando sudo gedit /etc/ssh/sshd_config:
# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

AllowGroups ssh

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

In der Beschränkung zeigt sich der Meister.