Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ATI Radeon 9700 driver melding na installatie  (gelezen 4675 keer)

Issib

  • Gast
ATI Radeon 9700 driver melding na installatie
« Gepost op: 2007/02/14, 21:13:23 »
Hallo,

ik had het volgende probleem: mijn pc liep vast zodra ik door de screensavers browste of zodra de screensaver uit zichzelf aansprong.

Hierop heb ik (gelukkig geholpen, omdat ik nieuw ben met linux) het fglrx-386 packet geinstalleerd.
(een aanpassing gemaakt in mijn sources.list en daarna Synaptic herladen vervolgens kon ik het pakket ubuntu-fglrx-386 vinden en installeren)

Nadat ik de driver had geinstalleerd, kreeg ik een soort waarschuwing: 'more actions are necessary! You will need to disable the fglrx driver from linux-restricted-modules by adding the word fglrx to the DISABLED_MODULES in /etc/default/linux-restricted-modules-common and running sudo /sbin/lrm-manager. If you don't do this, you will lose 3D accelleration.

Ik heb de pc herstart en daarna eerst nog gedaan:

sudo gedit /etc/X11/xorg.conf
De driver "ati" in de section Device vervangen door "fglrx"

Daarna kon ik probleemloos door de screensavers browsen, mijn pc loopt er niet meer op vast.
Ik zit alleen nog met de waarschuwing die ik heb gekregen nadat ik de driver had geinstalleerd, voordat ik mijn pc heb herstart.

Moet ik dit nou doen of niet? Ik weet niet precies wat er wordt bedoeld.
Hopelijk weet iemand van jullie dit.

Issib

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #1 Gepost op: 2007/02/15, 00:20:37 »
ik heb hier een vervolg/aanvulling op.
Ik ontdekte dat de screensavers het toch niet doen. Wel de preview, en hij loopt niet meer vast, maar als de screensaver uit zichzelf aanspringt, krijg ik gewoon zwart beeld (zonder dat de pc vastloopt).

Ik heb gedaan: sudo glxinfo | rendering, dan kreeg ik als output 'no', hetgeen betekent dat de 3D-accelleratie uitstaat, naar ik heb begrepen.

Voordat ik de driver installeerde, was de output hiervan 'yes' maar liep m'n pc dus vast op die screensavers.

Nu heb ik toch maar gedaan wat er in de waarschuwing kwam na het installeren van de driver, dus:
sudo gedit /etc/default/linux-restricted-modules-common
en dan in die file tussen de " " (waar nog niks tussen stond) fglix gezet.
En als tweede:
sudo /sbin/lrm-manager
Ik zag niet of dat iets deed of niet, maar als ik daarna weer de glxinfo opvraag, blijft de output 'no' dus nog steeds geen 3D-accelleratie.

Iemand een idee hoe ik 3D-accelleratie aankrijg?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #2 Gepost op: 2007/02/15, 09:50:09 »
Probeer eens dit:
het is niet "fglix", maar "fglrx", wat je had moeten schrijven in dat bestand. Corrigeer het eens?

Doe daarna eens in de terminal: fglrxinfo

Helpt dit?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #3 Gepost op: 2007/02/15, 10:10:07 »
profoX: jij bent ATI-deskundige, kun je hier even helpen?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #4 Gepost op: 2007/02/15, 10:54:51 »
Ik ken het pakket "ubuntu-fglrx-386" niet, ik heb driver installaties voor fglrx altijd op een andere manier gedaan (met het pakket "xorg-driver-fglrx") ...

Kan je even kort beschrijven hoe je fglrx hebt geïnstalleerd?
Welke versie van Ubuntu gebruik je?
En wat voor ATI kaart heb je precies (model)?
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #5 Gepost op: 2007/02/15, 13:03:59 »
@profoX: Bedankt voor je interventie!
Ik zal wel even antwoorden....  :-)

Ik heb Issib in dit draadje geholpen aan het pakket "ubuntu-fglrx-386":
http://forum.ubuntu-nl.org/topic/7316

Issib heeft nu dus al een goede pakketbronnenlijst, met Seveas erin. Het pakket "ubuntu-fglrx-386" komt ook van Seveas af.
Beschrijving: The fglrx driver for Ubuntu (386 kernel)
This package will install the fglrx driver for Xorg and the linux kernel on
Ubuntu systems. You really should keep this package installed for upgrades.

- Hij heeft 6.06 Dapper Drake
- Zijn kaart is een ATI Radeon 9700

Is het wellicht beter, om "ubuntu-fglrx-386" terug te draaien en over te stappen op jouw bekende aanpak? Zo ja, weet jij hoe dat het beste kan?

Groet, Pjotr.

Issib

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #6 Gepost op: 2007/02/17, 00:11:13 »
Hallo!
Wat een aardige mensen hier allemaal op dit forum. Ik sta echt versteld van de hulp hier en dat gratis en voor niets! Dus bedankt.
Ik ben trouwens geen 'hij' maar een 'zij' :) Niet dat dat er iets toe doet hoop ik.

Ik heb nog even gekeken in dat bestand, maar ik had het wel goed neergezet, ik had het hier alleen verkeerd overgetypt.
Als ik glrxinfo doe krijg ik:

display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

Azalin

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #7 Gepost op: 2007/02/17, 00:20:46 »
Het lijkt er op dat je nog niet de restricted modules geinstalleerd hebt staan. De resitricted modules zijn stukjes software die niet standaard geinstalleerd worden vanwege bepaalde redenen (ik meen copyright en debian regels). Hierin bevindt zich belangrijke software die de fglrx aan de praat weet te krijgen. Open via Systeem>Beheer>Synaptic pakketbeheer. Zoek dan via de zoekknop op restricted en selecteer linux-restricted-modules-generic (als je edgy hebt, anders selecteer linux-restricted-modules-686 of -k7 als je Dapper draait, zorg wel dat je dan ook linux-686 of linux-k7 geinstalleerd hebt)

Zodra dit geinstalleerd staat je computer opnieuw opstarten (men beweert dat ctrl-alt-backspace helpt maar dat wil nog wel eens heel vaak fout gaan) Doe dan eens glxinfo | grep direct in een terminal. Krijg je dan direct rendering: yes, dan is alles gelukt en moet je OpenGL screensaver ook werken

Issib

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #8 Gepost op: 2007/02/17, 00:30:13 »
ik heb al wel een paar restricted modules aanstaan in die synaptic package manager.
Heb er nog maar even niets aan veranderd, want ik weet niet hoe ik zeker kan weten welke versies ik moet pakken. Ik heb Dapper, maar geen idee of dit K7 is.

Dit staat aan:
linux-restricted-modules-2.6.15-23-386 (installed version: 2.6.15.11-1)
linux-restricted-modules-2.6.15-28-386 (installed version: 2.6.15.12-28.1)
linux-restricted-modules-386 (installed version: 2.6.15.26)
linux-restricted-modules-common (installed version: 2.6.15.12-28.1)

Zijn die restricted modules nou heel andere dingen dan wat ik in mijn sources.list heb staan? Ik denk dat ik deze twee door elkaar haal en het verschil niet begrijp.

Azalin

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #9 Gepost op: 2007/02/17, 00:36:21 »
Heb je een Intel processor of een AMD processor? Dat is eigenlijk het verschil tussen de -k7 en -686 restricted modules. Heb je een pentium dan is 686 weer iets specifieker voor je processor dan een generieke 386 kernel.
Ik heb zelf meegemaakt dat het wel degelijk uti maakt welke kernel je hebt draaien ,... terwijl er ook mensen zijn die zweren bij de 386 kernel onder Dapper... je zou als je een intel processor hebt, het linux-686 pakket samen met de restricted modules eens moeten installeren. Als je een AMD processor hebt dan de linux-k7 en bijbehorende restricted modules mee installeren.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #10 Gepost op: 2007/02/17, 11:12:29 »
@ Azalin: je kunt gewoon alles generiek houden op de 386 kernel, ook met AMD. Heb ik zelf ook gedaan, met mijn AMD. Een experiment met de K7 kernel beviel me niet: ik merkte geen snelheidswinst, maar wel dat mijn updates trager binnenkwamen.

Ik ben er dus zo een, die zweert bij de 386 kernel!

Offline Ambiorix

  • Lid
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #11 Gepost op: 2007/02/19, 20:04:37 »
Heb de drivers voor ATI 9800 gedownload van ATI.com.
Krijg volgende melding bij installatie :

Kan het bestand ‘/home/charly/ati-driver-…ler-8.33.6-x86.x86_64.run’ niet openen met gebruikmaking van de Westers (ISO-8859-15)-tekencodering.
Niet in staat de tekencodering automatisch te vinden.
Ga na of u niet probeert om een binair bestand te openen.
Selecteer een tekencodering uit het menu en probeert het opnieuw.

Wat nu?

Richard

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #12 Gepost op: 2007/02/20, 13:03:10 »
Je moet er op letten dag je de driver opnieuw moet laten debuggen.

Offline Ambiorix

  • Lid
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #13 Gepost op: 2007/02/20, 17:37:35 »
Citaat van: Richard
Je moet er op letten dag je de driver opnieuw moet laten debuggen.
Ik ben nog maar een groentje in linux (nog geen week aan het gebruiken)
Hoe doe ik dat?

Issib

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #14 Gepost op: 2007/02/20, 18:01:57 »
Ik heb hetzelfde als Ambiorix gedaan, dus de driver (auto-install) bij Radeon gedownload en geinstalleerd
(eerst de file permissions aangepast naar 'execute' en daarna sudo bash ati-driver-installer-833.6-x86.x86-64.run
(hoewel ik nog niet helemaal begrijp wat dat 'sudo bash' nu helemaal doet, maar het werkte)

waarna de install wat dingen uitvoerde en daarna zei:
'it is important to save your X window configuration file, and then run aticonfig (in a console window) to complete the configuration of the display settings.'

Eerst heb ik maar in het log van de installatie gekeken waarin ik zag: 'precompiled kernel module version mismatched.' Waardoor hij dus niks heeft uitgevoerd.

Ik vind het echt moeilijk om die driver aan de praat te krijgen, vooral omdat ik net als Ambiorix een groentje ben en niks snap van al die commando's en wat nu waar staat.
Ook kom ik overal opmerkingen tegen dat Ati en linux een mismatch zijn.

Betekent dit dat ik eigenlijk beter een andere videokaart kan kopen, of zijn er wel menden die een Ati aan de praat hebben gekregen?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #15 Gepost op: 2007/02/20, 18:55:30 »
@Issib:

Je hebt nu alleen geen 3D. Als je geen spelletjes speelt, heb je genoeg aan 2D via je huidige  Mesa driver. Wil je het toch helemaal goed hebben, doe dan dit:

Herbegin eens met een schone lei (schone installatie) en volg de volgende instructie eens op voor je ATI:
http://forum.ubuntu-nl.org/message/71992#p71992

Voordat je dat doet, eerst ff de bronnenlijst weer aanvullen zoals in het eerdere draadje waar ik je hielp.

Groet, Pjotr.

Offline Ambiorix

  • Lid
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #16 Gepost op: 2007/02/21, 19:50:09 »
Citaat van: Ambiorix
Heb de drivers voor ATI 9800 gedownload van ATI.com.
Krijg volgende melding bij installatie :

Kan het bestand ‘/home/charly/ati-driver-…ler-8.33.6-x86.x86_64.run’ niet openen met gebruikmaking van de Westers (ISO-8859-15)-tekencodering.
Niet in staat de tekencodering automatisch te vinden.
Ga na of u niet probeert om een binair bestand te openen.
Selecteer een tekencodering uit het menu en probeert het opnieuw.

Wat nu?
Kan iemand mij uitleggen hoe ik deze driver geinstalleerd krijg?
Staat nu gedownload in mijn persoonlijke map.
Bij dubbelklikken op bestand krijg ik telkens voorvermelde melding

Issib

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #17 Gepost op: 2007/02/21, 20:40:35 »
Hoi Ambiorix, ik kreeg precies deze melding ook, voordat ik de permissions aanpaste.
Aangezien ik net zo'n groentje ben als jij :) weet ik niet of dit bij jou ook het probleem is, maar je kunt dus via Places naar je persoonlijke map gaan, rechtsklikken, Permissions kiezen, volgens mij heb je Execute-rechten nodig, ik had ze allemaal aangevinkt om maar eens wat te proberen.

Let wel, ik ben een groentje, maar misschien heb jij er ook wat aan.

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #18 Gepost op: 2007/02/21, 21:32:39 »
https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Deel 2, ati drivers zelf. Werkt jullie kaart niet met fglrx misschien? Want dat heeft toch wel wat voordelen bij kernel-updates...

Issib

  • Gast
ATI Radeon 9700 driver melding na installatie
« Reactie #19 Gepost op: 2007/02/22, 10:17:03 »
Nou ik heb fglrx geinstalleerd (helemaal bovenaan deze thread staat hoe ik dat heb gedaan, dit met behulp van Pjotr123) maar het lijkt niks uit te maken voor zover ik kan beoordelen. De screensavers doen het in elk geval heel houterig, en vaak loopt m'n pc er ook op vast.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #20 Gepost op: 2007/02/22, 10:23:04 »
Citaat van: Issib
Nou ik heb fglrx geinstalleerd (helemaal bovenaan deze thread staat hoe ik dat heb gedaan, dit met behulp van Pjotr123) maar het lijkt niks uit te maken voor zover ik kan beoordelen. De screensavers doen het in elk geval heel houterig, en vaak loopt m'n pc er ook op vast.
heb je de restricted modules geinstalled?
sudo apt-get install linux-restricted-modules-`uname -r`  in de terminal

Offline Ambiorix

  • Lid
  • Steunpunt: Nee
ATI Radeon 9700 driver melding na installatie
« Reactie #21 Gepost op: 2007/02/22, 17:38:21 »
Dank aan Issib, Zappa en leoquant,
Ik heb het dankzij jullie tips op de wereld gekregen.