Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 11.10 wil niet meer updaten  (gelezen 809 keer)

Offline Kenji

  • Lid
  • Steunpunt: Nee
Ubuntu 11.10 wil niet meer updaten
« Gepost op: 2012/03/09, 16:58:48 »
oke ik heb nu ubuntu versie 11.10
en toen ik updates binnen wou halen deed hij daar al heel moeilijk mee, dus heb ik het met de terminal de updates binnen gehaalt (abt-get)
maar als ik ze installeer dan doet hij weer moeilijk

aanschouw de foutcode die hij geeft wanneer ik ze probeer te installeren
De afhankelijkheden van de volgende pakketten konden niet geïnstalleerd worden:

Controleer of u softwarebronnen van een derde partij gebruikt. Als dat zo is, schakel ze dan uit, omdat ze een veelvoorkomende bron van problemen zijn.
Voer ook de volgende opdracht uit in een Terminalvenster: apt-get install -f

libc6: Depends: libc-bin (= 2.13-20ubuntu5) maar 2.13-20ubuntu5.1 is geïnstalleerd
libc6-dev: Depends: libc6 (= 2.13-20ubuntu5.1) maar 2.13-20ubuntu5 is geïnstalleerd
Depends: libc-dev-bin (= 2.13-20ubuntu5.1) maar 2.13-20ubuntu5.1 is geïnstalleerd

resultaat is dat hij bij ieder progamma nu zeikt dat er iets niet klopt en weet ik veel wat

+ foutmelding bovenin de bar = Fout=BrokenCount>0

++ de standaard mediaplayer, banshee dus ondersteund geen mp3,4 noem het op ook met de zogenaamde plug in die hij zelf ervoor suggeerde werkte het alsnog niet

dus wie gaat mij vandaag gelukkig maken :p

~Kenji

Offline Fridididi

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 11.10 wil niet meer updaten
« Reactie #1 Gepost op: 2012/03/12, 08:20:41 »
Ik heb dit probleem ook sinds afgelopen weekend:


$ dpkg -l | grep libc6
ii  libc6                                                    2.13-20ubuntu5                             Embedded GNU C Library: Shared libraries
iU  libc6-dev                                                2.13-20ubuntu5.1                           Embedded GNU C Library: Development Libraries and Header Files


$ sudo dpkg-reconfigure libc6-dev
/usr/sbin/dpkg-reconfigure: libc6-dev is beschadigd of niet volledig geïnstalleerd


$ sudo apt-get -f install
Pakketlijsten worden ingelezen... Klaar
Boom van afhankelijkheden wordt opgebouwd       
Statusinformatie wordt gelezen... Klaar 
Vereisten worden gecorrigeerd... Klaar
De volgende pakketten werden automatisch geïnstalleerd en zijn niet langer nodig:
  wine1.3-gecko flashplugin-downloader
U kunt deze verwijderen via 'apt-get autoremove'.
De volgende extra pakketten zullen geïnstalleerd worden:
  libc-bin libc6
Voorgestelde pakketten:
  glibc-doc
De volgende pakketten zullen opgewaardeerd worden:
  libc-bin libc6
2 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 5 niet opgewaardeerd.
3 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0 B/4734 kB aan archieven opgehaald worden.
Door deze operatie zal er 16,4 kB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]?
Voorconfigureren van pakketten...
Instellen van tzdata (2012b-0ubuntu0.11.10) ...
restorecon set context /etc/localtime->system_u:object_r:locale_t:s0 failed:'Operation not supported'
dpkg: fout bij afhandelen van tzdata (--configure):
 subproces installed post-installation script gaf een foutwaarde 1 terug
Geen apport-rapport geschreven omdat MaxReports al bereikt is
                                                             Fouten gevonden tijdens behandelen van:
 tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)


Er gaat dus iets fout bij het instellen van tzdata. Het niet kunnen updaten van libc6 lijkt een gevolg te zijn, maar veroozaakt nu juist problemen.

Offline Fridididi

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 11.10 wil niet meer updaten
« Reactie #2 Gepost op: 2012/03/12, 08:59:31 »
Het probleem wordt veroorzaakt door selinux.
Ik had het geinstalleerd, maar me er verder nog niet in verdiept. De volgende lelijke oplossing workaround zorgt er in elk geval voor dat je weer kunt updaten:

# sudo rm /sbin/restorecon ; sudo apt-get -f install ; sudo ln -s /sbin/setfiles /sbin/restorecon

Ik heb selinux ook maar weer verwijderd. Die installeer ik wel weer als ik tijd heb om me te verdiepen in de werking ervan.
« Laatst bewerkt op: 2012/03/12, 09:05:33 door Fridididi »