Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NFS Xubuntu probleempje  (gelezen 999 keer)

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
NFS Xubuntu probleempje
« Gepost op: 2012/03/04, 13:47:33 »
Hallo allen,

Ik ben even helemaal de weg kwijt... Ik heb gister mijn 4e pc (notebook) voorzien van XUbuntu. Niks mis mee.

Nu heb ik het volgende probleem:
Ik maak in al mijn pc's verbinding met mijn server. Ik doe dit via fstab. In mijn home map maak ik mapjes aan waar de verschillende directoty's van mijn nas worden gemount. Ik doe dat dus in al mijn pc's op exact de zelfde manier.

Mijn laatste installatie geeft echter foutmeldingen...

Ik heb nfs-common geinstalleerd, zoals op al mijn pc's. Ik draai zowel amd64 als i386 versies. Alle andere pc's maken verbinding met de server. Ra ra wat zie ik over het hoofd...

sudo mount -a
[sudo] password for ernst:
[mntent]: regel 17 in /etc/fstab is ongeldig
[mntent]: regel 19 in /etc/fstab is ongeldig
[mntent]: regel 21 in /etc/fstab is ongeldig
[mntent]: regel 23 in /etc/fstab is ongeldig

Dit zet ik in mijn fstab:
#Ernst-Jan
# /volume1/music
192.168.178.27:/volume1/music /home/ernst/music nfs rw,hard,intr 0 0
# /volume1/photo
192.168.178.27:/volume1/photo /home/ernst/photo nfs rw,hard,intr 0 0
# /volume1/video
192.168.178.27:/volume1/video /home/ernst/video nfs rw,hard,intr 0 0
# /volume1/home/ernst
192.168.178.27:/volume1/homes/ernst /home/ernst/home nfs rw,hard,intr 0 0


Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Re: NFS Xubuntu probleempje
« Reactie #2 Gepost op: 2012/03/04, 15:10:00 »
Dag Jan,

Aan het end van mijn fstab staat keurig een lege regel. Als ik die weg haal krijg ik een extra foutmelding dat het end van mijn fstab niet een einde regel marker heeft.

Dat is dus niet het probleem helaas. Ik snap er helemaal niets van. De toegevoegde regels heb ik kant en klaar in een bestandje staan. Dit werkt echt altijd... Wat gaat hier mis....

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: NFS Xubuntu probleempje
« Reactie #3 Gepost op: 2012/03/04, 15:37:58 »
Maak een nieuwe fstab, kopieer alles over.
Wis de 4 foute regels,
typ deze, dus zonder te kopiƫren, en kijk of ze nu wel werken.

Offline ejfrolich

  • Lid
  • Steunpunt: Nee
Re: NFS Xubuntu probleempje
« Reactie #4 Gepost op: 2012/03/08, 21:55:08 »
Ha Jan,

Het heeft even geduurd want ff geen tijd. Ik begrijp de reden niet maar je oplossing werkt. Ik heb alleen de 4 foute regels over getypt.

Grappig is dat ik de kopieer methode al 5 jaar ongestraft toepas. En ook op een ander i386 xubuntu systeem van de zelfde installatie cd... Ik vind het bizar dat dit de oplossing is.

Bedankt voor je hulp!

Ernst-Jan