Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Digitaal geluid in ubuntu 12.04  (gelezen 954 keer)

Offline golden07

  • Lid
  • Steunpunt: Nee
Digitaal geluid in ubuntu 12.04
« Gepost op: 2012/03/04, 10:20:20 »
Hallo,

Ik heb pc bij de tv staan voor het kijken van films en afspelen van muziek. Nou wou ik hier ubuntu 12.04 beta op installeren, bijna alles gaat goed, echter werkt het digitale surround geluid (dts e.d.) niet, ik heb wel stereo geluid via de spdif poort op het moederbord ( ik heb moederbord ASRock E350M1/USB3 met een Realtek ALC892) hoe kan ik er voor zorgen dat ik ook dts geluid e.d. kan afspelen?

Met vriendelijke groet,

Golden07

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Digitaal geluid in ubuntu 12.04
« Reactie #1 Gepost op: 2012/03/04, 12:05:11 »
Je hebt de Hardware en Uitvoer in Geluidsvoorkeuren goed ingesteld?

Offline golden07

  • Lid
  • Steunpunt: Nee
Re: Digitaal geluid in ubuntu 12.04
« Reactie #2 Gepost op: 2012/03/04, 12:11:44 »
ja, deze staat op de spdif invoer, het werkt ook wel, alleen geen surround functie. ook het kiezen van de digitale output in xbmc werkt niet.

Offline ORbit

  • Lid
    • http://www.mansolein.com
  • Steunpunt: Nee
Re: Digitaal geluid in ubuntu 12.04
« Reactie #3 Gepost op: 2012/09/10, 09:07:42 »
Voor als je het nog nodig hebt, dit heb ik gedaan op mijn 350 asus bordje:

Re: Simultaneous analog and digital sound out
After a lot of trying I got this working on Lucid on my zotac ion box, I use this for xbmc.

Here goes, I wanted iec598 (spdif) and simultaneous on board analog.

I finally found this website:
http://www.randomwalking.com/project...roject=mediapc

Step 1 - Sudo Edit: /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf
I just had to uncomment the bottom example definition

[Profile output:analog-stereo+output:iec958-stereo+input:analog-stereo]
description = Foobar
output-mappings = analog-stereo iec958-stereo
input-mappings = analog-stereo

I didn't even change the description even though it would probably be a good idea.

Step 2 - install paprefs using apt-get or whatever you like (this is a pulse audio pref gui)

I then rebooted (may not be necessary)

Step 3 - I opened the paprefs System > Preferences > Pulse Audio Preferences
Navigate to the "Simultaneous Output" tab and select "Add virtual output...".
reboot machine again (this time very necessary)

Step 4 - open normal sound preferences: System > Preferences > Sound
In the "Hardware" tab select the Profile named "Foobar" or whatever you used for your description in step 1.
Then select the "Output" tab and choose the device labeled "Simultaneous output to Internal Audio Digital Stereo (IEC985), Internal Audio Analog Stereo" or whatever matches what you are trying to do.

Step 5 - I went back to xbmc and the correct output option then was available in the sound settings.

Worked great, and didn't have to muck about with those unintelligible asound files. I have heard a bunch of people complain about pulse audio, but this was way easier than making a new asound file.


systeem-geluid-uitvoer-intern geluid digitaal stereo hdmi

-Geluidsuitvoer wat je nodig hebt voor de film/muziek
-Apparaat voor geluidsdoorvoer: Simultaneous output to intern geluid Didgitaal stereo (hdmi) intern geluid analoog stereo (pulse audio)
-Doorgifte geluidsuitvoer apparaat: hda ait sb iec958(alsa)