Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu 10.04LTS reageert niet op toetsenbord en muis (of heel langzaam)  (gelezen 1670 keer)

Offline laudaka

  • Lid
  • Steunpunt: Nee
Hoi allemaal,
Bij iemand die ik help met haar computer met Ubuntu 10.04LTS gebeurde er opeens dit: Ik wilde de instellingen voor de panelen (werkbalken) bovenaan en onderaan veranderen zodat ze verborgen zijn tenzij je er met de muis tegenaan botst. Dus rechtsklikte ik eerst onderaan op een grijs stuk van het paneel en in dat context-menu koos ik voor Eigenschappen, Automatisch Verbergen. En toen ging het opeens mis.

De pc reageerde niet meer op muisklikken en ook niet meer op het toetsenbord. Ik heb geprobeerd naar een virtuele terminal te wisselen met Ctrl-Alt-F1, Ctrl-Alt-F2, etc. en dat lukte dus nog wel. Na een herstart merkte ik dat het nog steeds mis was. Maar de grafische omgeving reageert nog wel op muisklikken en toetsaanslagen, maar extreem langzaam. Daarom kan ik dus ook wel naar een virtuele terminal wisselen.

Ik heb meerdere dingen geprobeerd maar ik kon niet die instelling van paneel-eigenschappen veranderen waarvan ik een groot vermoeden heb dat die de boosdoener was. Haar pc is een Pentium 4 en ik heb wel eerder dit soort dingen mis zien gaan op oude pc's. Wat ik helaas wel vergeten ben te doen is even top of htop te draaien, dus ik weet niet of er een proces was wat extreem veel processortijd gebruikte.

Uiteindelijk heb ik gekozen voor een noodoplossing: de hele directory ~/.gconf wissen. (Heb wel eerst een kopie gemaakt die ik nog terug kan zetten). Systeem herstart, en dan hopen dat de grafisch omgeving GNOME weer werkt omdat alle instellingen van GNOME gereset zijn. Ja dat werkte dus wel, maar de default-instellingen die GNOME aanmaakt en in een nieuw aangemaakte ~/.gconf directory neerzet zijn toch niet helemaal de default-instellingen van Ubuntu. En ik moest ook nog een heleboel instellingen veranderen omdat ik veel veranderd had om het op Windows te laten lijken. En er zijn allerlei dingen die het opeens niet meer doen, en vraag me niet hoeveel instellingen ik nog over het hoofd heb gezien. Samengevat: dit was niet meer dan een noodoplossing. En ik ben een beetje moedeloos :(

Drie vragen:
* Wie heeft ervaring met een (bijna) onresponsief systeem? Waar kan het van komen? Hoe zoek je uit waar het van komt?
* Kan ik een instelling van de grafisch omgeving GNOME veranderen terwijl GNOME niet draait? Zou dat bijvoorbeeld kunnen met behulp van de recovery mode (van het GRUB boot menu)? Ik wil dus graag de oorspronkelijke ~/.gconf directory terugzetten. Als het goed is heb ik dan weer de oude instellingen terug, inclusief die verkeerde instelling die ik dus op één of andere manier wil veranderen.
* Zoek ik de oplossing helemaal in de verkeerde richting?  ???

Bij deze alvast bedankt voor de reacties,
Paulus/laudaka


Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04LTS reageert niet op toetsenbord en muis (of heel langzaam)
« Reactie #1 Gepost op: 2012/02/25, 13:22:17 »
Als je de ./gconf folder in zijn geheel weghaalt, dan ben je nogal wat settings kwijt.
Plaats hem eens terug en probeer de uitleg van deze site eens: http://www.watchingthenet.com/restore-panels-in-ubuntu-back-to-their-default-settings.html
De volgende ubuntu community geeft ook deze info: http://ubuntuforums.org/showthread.php?t=1690239
« Laatst bewerkt op: 2012/02/25, 13:26:10 door donpedroII »

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04LTS reageert niet op toetsenbord en muis (of heel langzaam)
« Reactie #2 Gepost op: 2012/02/25, 13:53:14 »
Drie vragen:
* Wie heeft ervaring met een (bijna) onresponsief systeem? Waar kan het van komen? Hoe zoek je uit waar het van komt?
* Kan ik een instelling van de grafisch omgeving GNOME veranderen terwijl GNOME niet draait? Zou dat bijvoorbeeld kunnen met behulp van de recovery mode (van het GRUB boot menu)? Ik wil dus graag de oorspronkelijke ~/.gconf directory terugzetten. Als het goed is heb ik dan weer de oude instellingen terug, inclusief die verkeerde instelling die ik dus op één of andere manier wil veranderen.
* Zoek ik de oplossing helemaal in de verkeerde richting?
*Ik heb er ervaring mee, bij mij kwam het meestal doordat mijn RAM vol zat en daardoor ging hij SWAPpen (wat op mijn PC resulteert in een bijna lock-up). Ik weet niet hoeveel RAM je hebt, maar probeer dit eens uit.
* Ik verander ook wel eens wat aan de Gnome balkjes en dat gaat zonder problemen. De enige problemen die ik met Gnome wel eens mee maak is dat hij zeer zeldzaam een soort oude look krijgt ('windows 95-style').
Dus ja, Gnome kan gewoon aangepast worden zonder problemen.
Hoe je deze instellingen als ik het me goed herinner beter kan herstellen: ~/.gnome2 verwijderen (hernoemen).
* Ik denk dat je toch wel in de goede richting zat, probeer de volgende keer eens met de top/htop te kijken of er een proces geheugen vreet.
Plaats ook eens de specs hier als je wilt.
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline laudaka

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04LTS reageert niet op toetsenbord en muis (of heel langzaam)
« Reactie #3 Gepost op: 2012/02/25, 19:03:51 »
Hartelijk bedankt voor jullie goede reacties DonpedroII en Cheap :) Ik ga er de komende dagen uitgebreid naar kijken. En ik zal ook de uitgebreide specificaties van de hardware van die computer hier op het forum neerzetten. Ik laat horen of het gelukt is en hoe.

Nog een aanvulling op de probleemomschrijving: Als ik met Ctrl-Alt-F1, Ctrl-Alt-F2, etc. naar een andere virtuele terminal wissel dan kan ik daar gewoon normaal inloggen en ik kan gewoon commando's typen. Het systeem reageert absoluut niet traag in de virtuele terminals. Dus ik ga zeker met top (of handiger htop) en free kijken wat er met de processor gebeurt en met het geheugen.

Offline laudaka

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04LTS reageert niet op toetsenbord en muis (of heel langzaam)
« Reactie #4 Gepost op: 2012/03/02, 16:46:32 »
Hoi Donpedro en Cheap,
Heb de fout gevonden! Het lukte me eerst om de fout thuis te reproduceren (ook op Ubuntu 10.04 LTS) en te herstellen. En bij haar lukte het ook om de fout te herstellen.

Ik had bij haar een heleboel instellingen van GNOME zo veranderd dat Ubuntu meer op Windows gaat lijken. Onder andere had ik beide panelen onderaan gezet (de meeste mensen verplaatsen alle applets naar één paneel en wissen het tweede paneel als ze meer de Windows-stijl willen). Als je in Ubuntu 10.04 dan ook nog één van de twee panelen instelt op automatisch verbergen gaat het mis.

top/htop lieten op mijn pc zelfs 99% cpu gebruik zien voor gnome-panel

De links met oplossingen waar jullie mee kwamen waren inderdaad de goede. Ik neem me voor om over een paar dagen nog uitgebreider hier neer te zetten wat er te zien was in top/htop en hoe ik het precies heb hersteld. Het is me gelukt al haar GNOME instellingen terug te halen inclusief de ongelukkige instellingen van de panelen. Toen heb ik met gconftool alleen dat "Automatisch verbergen" van beide panelen weer uit gezet. Dus zelfs haar panelen waren weer helemaal precies zoals ze ze gewend was, inclusief wat ik eraan aangepast had.

Bedankt voor jullie oplossingen :) :) Heel leerzaam.
Paulus/laudaka

Offline laudaka

  • Lid
  • Steunpunt: Nee
Re: Ubuntu 10.04LTS reageert niet op toetsenbord en muis (of heel langzaam)
« Reactie #5 Gepost op: 2012/03/15, 22:56:40 »
Hoi Donpedro en Cheap,
Hier een uitgebreid verslag. En wat extra uitleg die handig kan zijn voor anderen met een vergelijkbaar probleem.

Specificaties pc van haar
Processor volgens BIOS: Intel Celeron 2.6 GHz
Totaal geheugen volgens BIOS: 1280 MiB (1 GiB + 256 MiB dus)
Grootte partitie Ubuntu: 33 GiB
besturingssysteem: Ubuntu 10.04 LTS
GNOME versie: 2.30.2

Als ik sudo lshw draai krijg ik dezelfde hardware specificaties.

Hoe heb ik de fout op mijn eigen pc gereproduceerd?
* Rechtsklikken in een grijs gebied op het paneel bovenaan. Eigenschappen, Oriëntatie, Onder.
* Rechtsklikken in een grijs gebied op de bovenste van de twee panelen (die nu beide onderaan zijn). Eigenschappen, Automatisch verbergen.
Precies die combinatie van instellingen zorgt voor een grafische omgeving die niet of nauwelijks op de muis en toetsenbord reageert in Ubuntu 10.04 LTS/GNOME 2.30.2

Bij top/htop zie ik dat gnome-panel heel veel processortijd gebruikt. Bij mijn pc over de 98% en bij haar pc zie ik ook verdachte dingen bij htop. Met top -b -n1 > uitvoer_van_top.txt heb ik het weggeschreven naar een bestand. Dit is hoe het op haar pc eruit zag:
top - 09:51:33 up 10 min,  3 users,  load average: 2.71, 2.37, 1.32
Tasks: 131 total,   3 running, 127 sleeping,   0 stopped,   1 zombie
Cpu(s): 71.3%us, 25.4%sy,  0.0%ni,  1.3%id,  1.8%wa,  0.2%hi,  0.1%si,  0.0%st
Mem:   1285216k total,   686272k used,   598944k free,    62320k buffers
Swap:  1539064k total,        0k used,  1539064k free,   328724k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND          
 1202 jane      20   0 98364  69m  10m R 36.3  5.5   3:23.22 gnome-panel      
  842 root      20   0 27188  13m 6504 R 16.5  1.1   3:13.35 Xorg            
 1195 jane      20   0 31104  20m 8208 S  9.9  1.6   1:44.96 metacity        
 1382 jane      20   0  325m  83m  27m S  9.9  6.7   0:13.99 firefox          
 1521 jane      20   0  2616 1336  980 S  9.9  0.1   0:15.28 htop            
 1230 jane      20   0 39912  12m 9804 S  3.3  1.0   0:26.58 wnck-applet      
 1184 jane      20   0 92024  11m 7456 S  1.7  0.9   0:16.80 gnome-settings-  
 1712 jane      20   0  2544 1088  808 R  1.7  0.1   0:00.02 top              
    1 root      20   0  2804 1620 1172 S  0.0  0.1   0:00.54 init            
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.00 kthreadd        
    3 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration/0      
    4 root      20   0     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0      
    5 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 watchdog/0      
    6 root      20   0     0    0    0 S  0.0  0.0   0:00.13 events/0        
    7 root      20   0     0    0    0 S  0.0  0.0   0:00.00 cpuset          
    8 root      20   0     0    0    0 S  0.0  0.0   0:00.00 khelper          
    9 root      20   0     0    0    0 S  0.0  0.0   0:00.00 netns            
   10 root      20   0     0    0    0 S  0.0  0.0   0:00.00 async/mgr        
   11 root      20   0     0    0    0 S  0.0  0.0   0:00.00 pm              
   12 root      20   0     0    0    0 S  0.0  0.0   0:00.00 sync_supers      
   13 root      20   0     0    0    0 S  0.0  0.0   0:00.00 bdi-default      
   14 root      20   0     0    0    0 S  0.0  0.0   0:00.00 kintegrityd/0    
   15 root      20   0     0    0    0 S  0.0  0.0   0:00.05 kblockd/0        
etc.

Hier is minder duidelijk te zien dat gnome-panel de boosdoener is, maar het blijft een verdacht hoge waarde. En die waarde was constant zo hoog. En ook Xorg en metacity bleven deze vreemd hoge waardes houden.

Oplossing om de panelen te herstellen naar de standaardinstellingen
Het probleem is dus niet een te hoge swap-neiging van Linux. Nietemin bedankt voor de nuttige link naar die Computertip website, Cheap. Ik moet echt vaker die website lezen. Wel heb ik hiervan geleerd dat het eerste wat je moet doen bij een niet responsief systeem is kijken wat er bij top/htop te zien is. Zelfs als je in de niet-grafische virtuele terminals nog wel prima kan typen.

De link naar http://www.watchingthenet.com/restore-panels-in-ubuntu-back-to-their-default-settings.html was wat ik zocht, Donpedro. Bovenaan staat het weliswaar niet helemaal goed maar er staan heel veel zinnige reacties onder, waaronder ook oplossingen die wel kloppen. Die link naar het Engelstalige Ubuntu-forum "Restore Panels In Ubuntu Back To Their Default Settings" vind ik geen aanrader, daar staat het nou net fout.

Van die website watchingthenet.com komen twee oplossingen, en jullie hadden een derde:
Oplossing 1, Onveilig: Wis de directory met alle instellingen van gnome-panel.
N.B. Deze oplossing is een afrader, één typfout en al de documenten, foto's, etc. van iemand zijn weg. Namelijk als iemand een spatie typt na de ~ of na de /
rm -rf ~/.gconf/apps/panel
pkill gnome-panel

Oplossing 2, Beste: Verplaats de directory met alle instellingen van gnome-panel.
Dit is wat jullie aanraden. Zo kunnen de instellingen van gnome-panel nog teruggeplaatst worden als de panelen herstellen toch niet het gewenste resultaat geeft.
mv ~/.gconf/apps/panel ~/oude-instellingen-gconf-apps-panel
pkill gnome-panel

Oplossing 3, Redelijk: In de GNOME configuratie database alle gnome-panel instellingen wissen.
Je kan niet meer terug naar hoe de panelen waren, maar het is wel een veilige oplossing.
gconftool --recursive-unset /apps/panel
pkill gnome-panel

Bij haar pc waren de panelen zo in de war dat pkill gnome-panel niet werkte. Een complete herstart van de computer komt uiteraard op hetzelfde neer als pkill gnome-panel, en dat werkte bij haar pc wel.

Oplossing om de panelen op haar pc te herstellen zoals ze waren voordat het misging
Omdat ik veel veranderd had aan haar twee panelen wilde ik ze weer terugzetten inclusief de fout waardoor het misging. En dan de fout eruit halen.

Oplossing: Directory met alle instellingen van gnome-panel terugplaatsen. Daarna kapotte instelling repareren.
mv ~/oude-instellingen-gconf-apps-panel ~/.gconf/apps/panel
gconftool --type boolean --set /apps/panel/toplevels/top_panel_screen0/auto_hide false
gconftool --type boolean --set /apps/panel/toplevels/bottom_panel_screen0/auto_hide false
Met de gconftool --set opdrachten verander ik twee instellingen direct in de GNOME configuratie database, in plaats van dat in de grafische omgeving te doen. Alsof ik in de grafische omgeving bij beide panelen Eigenschappen, Automatisch verbergen, vinkje weghalen, heb gedaan. Na een herstart werkte alles weer goed en waren de panelen precies zoals ze waren voordat alles misging, inclusief alle aanpassingen van mij. Ik was helemaal opgelucht :)

Uiteraard heeft deze oplossing alleen zin bij precies dit specifieke probleem van twee panelen onderaan het scherm + bovenste van de twee Automatisch verbergen aan. Als er een andere instelling alles in de war schopt zou je in de GNOME configuratie database moeten zoeken naar die instelling om het zo netjes te kunnen herstellen.

Een beetje meer over gconftool
* Je kan gconftool typen in plaats van gconftool-2. Op een Ubuntu-systeem is gconftool een link naar gconftool-2.
* Om uit te vinden welke key/value pairs ik moest aanpassen in de GNOME configuratie database heb ik gebruikgemaakt van commando's zoals dit:
gconftool --all-dirs /
gconftool --all-dirs /apps
gconftool --all-dirs /apps | sort
gconftool --all-dirs /apps/panel
gconftool --all-dirs /apps/panel/toplevels
gconftool --all-dirs /apps/panel/toplevels              
gconftool --all-entries --all-dirs /apps/panel/toplevels/top_panel_screen0
gconftool --all-entries --all-dirs /apps/panel/toplevels/bottom_panel_screen0
* Zie gconftool --help-client voor meer info over bovenstaande gconftool commando's.
* Wat bij gconftool --help-load staat lijkt ook interessant.
* Wat ik hierboven steeds consequent de GNOME configuratie database heb genoemd heet in werkelijkheid de ``GNOME configuration repository´´. Dit heeft helemaal niets met de software repository van Ubuntu te maken en het is dan ook een uiterst verwarrende naam. De GNOME configuratie database/repository lijkt volgens mij op het Windows register.

Over de directory .gnome2
@Cheap. Ik heb even gecheckt en de instellingen van de essentiële onderdelen van GNOME zoals metacity, nautilus en gnome-panel staan in .gconf en niet in .gnome2 . In .gnome2 staan wel een deel van de instellingen van Gedit en Eye of GNOME (eog) en nog een paar dingetjes.

Veel plezier met vrije en open source software,
Paulus/laudaka
« Laatst bewerkt op: 2012/03/15, 22:59:49 door laudaka »