Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Na installatie zwart scherm bij het opstarten  (gelezen 613 keer)

Offline Pr0t0n

  • Lid
  • Steunpunt: Nee
Na installatie zwart scherm bij het opstarten
« Gepost op: 2012/02/25, 02:31:38 »
Hey jongens,

Ik heb net de nieuwste server editie gedownload en geinstalleerd alles ging uitermate goed. Alleen na het installeren en bij de eerste keer opstarten vanaf de hdd komt hij bij GRUB aan, en volgt dan automatisch de bovenste optie en ik krijg zwart scherm sterker nog er komt totaal geen signaal meer door de VGA kabel heen me scherm knalt dan in de "slaapstand".
Ik kan dit oplossen door in GRUB de 2de optie te pakken waar hij gebruikmaakt van de (opstart)herstel modus, en daarna vanuit een nieuw menu de optie te pakken "doorgaan met booten vanaf de hard drive", jullie snappen dat dit voor een server zwaar irritant is. Ik heb vanuit dat herstel menu alle opties doorgelopen van pakketten nalopen op fouten tot het remounten van de files.
Ik heb de installatie 2 keer overgedaan nu en nog steeds hetzelfde probleem, waar kan dit aan liggen?

Groetjes

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Na installatie zwart scherm bij het opstarten
« Reactie #1 Gepost op: 2012/02/25, 02:55:57 »
Blijkbaar worden de gegevens van je videokaart/monitor niet goed uitgelezen, waardoor er een instelling gekozen wordt die je monitor niet aankan.

Dit kan je oplossen door op te starten in de herstelmodus.
Voer dit commando uit en voer je wachtwoord in (je ziet niets, ook geen sterretjes)
sudo nano /etc/default/grub

Zoek naar deze regel (of 1 die er erg veel op lijkt, ik werk nog met 10.04):
#GRUB_GFXMODE=640x480

Haal het hekje weg aan het begin, en stel een resolutie in die je monitor wel lust. 800x600 of 1024x768 zouden vrijwel zeker moeten werken. Afsluiten en opslaan via control-x.

Voer hierna dit commando uit:
sudo update-grub

Hierna zou het wel moeten werken.

Offline Pr0t0n

  • Lid
  • Steunpunt: Nee
Re: Na installatie zwart scherm bij het opstarten
« Reactie #2 Gepost op: 2012/02/25, 05:02:01 »
Hey,

Heel erg bedankt, het probleem ligt GELUKKIG aan me gpu, was even bang dat hij het helemaal niet meer deed. Je tip gaf me een gedeeltelijke oplossing, het ligt aan de videokaart alleen die lijn editen in grub zorgde niet dat ik me beeld terugkreeg, alleen kwam ik er op dit moment wel achter dat ik dmv putty me server wel kan benaderen dus in het geval van een restart hoef ik hem niet met toetsenbord en al weer aan te sluiten voor die werkt.

Weet je misschien een manier om mijn video kaart te herinstalleren? dat hij opnieuw de drivers ervan installeerd ofzo, want tijdens de installatie heeft hij het wel de hele tijd gedaan zonder problemen dus dan ga ik ervan uit dat hij de juiste drivers wel kent.

Groetjes