Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NVIDIA X driver, compiz en AWN werken niet, paars ubuntu scherm ==> zwart scherm  (gelezen 1639 keer)

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Computer hard uitgezet (aan/uit knop >3 sec indrukken).
AWN zag er raar uit, toen merkte ik dat compiz niet werkte (kubus etc).

Ik zie dat ik heb:

"You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

Dat heb ik gedaan, compiz werkt nog niet...Toen: compiz --replace

Kubus werkt, AWN ziet er normaal uit.

Hoop dat alles goed is, maar wat zou er gebeurt kunnen zijn???

UPDATE:  Opstarten gaat goed tot het paarse ubuntu scherm verschijnt, er verschijnt dan rechtsboven een logo van een dvi stekkertje in een zwart scherm en het scherm blijft daarna zwart....pffff

De LiveUSB met 10.o4.2 start wel op op deze computer....wat nu?


« Laatst bewerkt op: 2012/02/25, 22:33:03 door Al Bunty »
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10

Offline wermic

  • Lid
  • Steunpunt: Nee
10.04 had moeite met DVI
DVI bij NVIDIA-kaarten  in KUBUNTU
Als de juiste resolutie niet vastgehouden word :

Ga naar : NVIDIA X Server Settings
Klik op  : X Server Display Cofiguration
 
Selecteer de juiste resolutie
klik op Save to X Configuration File
Je ziet nu een venster met /etc/X11/xorg.config
Niet op save klikken maar op Show preview
Hier zie je de nieuwe xorg-config
alles selecteren  (met Ctrl-a) en kopieren

Open kdesudo kate, ga naar /etc/X11/xorg.config en maak een reservecopie met xorg.config.old o.i.d.

Wis alles uit de originele xorg.config en plak de inhoud van de Nvidia xorg.config.

PC opnieuw opstarten en hopen dat het goed is.

Bij mij werkt het. Anders de oude xorg.config terugzetten.

In UBUNTU gebruik  je gksudo = kdesudo en gedit = kate

« Laatst bewerkt op: 2012/02/25, 01:41:52 door wermic »

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Hoi, ik kwam er eerst helemaal niet meer in. Via de herstel lukt het nu, maar windows reageren hakerig, scherm lopen soms allerlei rare kleurbanden over?

Als ik NVIDIA X server start krijg ik: "You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

1)
Input: sudo nvidia-xconfig
Output: WARNING: Unable to locate/open X configuration file. New X configuration file written to '/etc/X11/xorg.conf'
Herstart: loopt tot het ubuntu scherm met de 5 rode punten en daarna wordt het weer zwart.

2)
Herstart met de herstelversie en dan kiezen voor "normale opstartprocedure hervatten" en ik kom weer op een zwart scherm uit.

3)
Herstart en dan kiezen voor "Veilige grafische omgeving"en dan kom ik er gewoon in. Daarbij draait NVIDIA X Server dus niet. /etc/X11/xorg.conf is hier helemaal leeg? Ik heb toen een oude xorg.conf-backup gebruikt van ergens vorig jaar. Daarmee start alles weer op ??? Nu ga ik NVIDIA X Server Settings draait nu wel.

4)
De Xorg.conf gesaved vanuit NVIDIA X Server Settings, is zelfde als de backup die ik heb gebruikt en die ook werkte. Beide werken. Alles lijkt weer goed, alleen Compiz werkt in ieder geval nog niet.

6)
Paar uur later: Op nieuw opgestart en het scherm is helemaal raar met kleurbanden?
Nieuwe start ==> weer zwart scherm? xorg.conf lijkt niet verandert.

8)
Start met veilige grafische modus werkt nog.
Weer de oude xorg.conf teruggehaald, en alles lijkt weer goed...
Dan: compiz --replace &, werkt ook.
Herstarten: alles lijkt ok...

« Laatst bewerkt op: 2012/02/25, 21:54:23 door Al Bunty »
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10

Offline wermic

  • Lid
  • Steunpunt: Nee
Bij mij kon nvidia x server settings de nieuwe config niet in etc/X11/xorg.conf saven, met de workaround werkte het wel.
Dus nvidia driver afgooien, herstarten in veilige grafische modus . bekijk nu de file ect/X11/xorg.config: moet iets instaan. Dan die truc van mij proberen. Succes.

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Zoals ik hierboven al schreef, met jouw oplossing lijkt alles weer te werken, bedankt!

Ben alleen steeds bang dat de grafische kaart kapot is...?
Al die rare kleurbanden.
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10

Offline wermic

  • Lid
  • Steunpunt: Nee
Sluit je monitor eens met een VGA-kabel aan. Dan zou het goed gaan ?

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Sluit je monitor eens met een VGA-kabel aan. Dan zou het goed gaan ?
Er zitten alleen 2 dvi aansluitingen op de kaart en geen video op moederbord.

Vannacht is de computer in de slaapstand gevallen en vanmorgen kwam die weeruit op een zwart scherm.

Ik heb de procedure weer herhaald: opstarten voor 1 sessie in veilige grafische mode, nieuwe xorg.conf (hoewel die onveranderd leek), dan  sudo nvidia-xconfig doen en weer normaal op te starten... ???

Nu vanavond heb ik het weer!?  >:(

Met de ubuntulive CD gestart, en bij de XP partitie staat een waarschuwing:
ntfs is inconsistent,
run chkdsk /f , reboot twice.
Gedaan en de waarschuwing in gparted bij deze partitie is weg.
« Laatst bewerkt op: 2012/02/27, 00:31:46 door Al Bunty »
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Opstarten gaat alleen nog in veilige grafische mode... :'(
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Sluit je monitor eens met een VGA-kabel aan. Dan zou het goed gaan ?
Ik heb geen VGA aansluiting op de computer.
Ik heb de schijf in een andere computer gezet met alleen moederbord graphics (dus geen NVIDIA kaart) en met VGA aansluiting.
Dan werkt het. Want dan heb je eigenlijk de standaard grafische omgeving.

Is er wat met de videokaart? Ik ga nu alles herinstalleren.
« Laatst bewerkt op: 2012/02/27, 22:48:35 door Al Bunty »
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10

Offline wermic

  • Lid
  • Steunpunt: Nee
Welke videokaart ?

Offline Al Bunty

  • Lid
  • Steunpunt: Nee
Videokaart is 8600GTS

Bij de XP partitie staat ook weer opnieuw de waarschuwing: ntfs is inconsistent, dus die ga ik ook opnieuw installeren.

Ik heb nu een nieuwe partitie met 10.04.4 geinstalleerd. De NVIDIA driver daarna meteen geinstalleerd.
Compiz was al geinstalleerd, cube aangezet etc., werkt allemaal. Herstart gaat goed, alles lijkt ok.

Ik heb niet zolang geleden een nieuwe voeding gehad en toen is de 8600GTS kaart getest tot 92 graden en dat gaf geen probleem. Ik had hiervoor een 8500GT en die lag bij het booten al dwars, dus die liet geen bootscherm zien.

Hier wordt trouwens hetzelfde probleem genoemd: http://forum.ubuntu-nl.org/hardware-en-drivers/nvidia-telkens-kwijt-na-update/new/#new
« Laatst bewerkt op: 2012/02/28, 19:49:27 door Al Bunty »
Intel P35, Q9450, 4GB RAM, GTX760, Dell 25" IPS, dual boot Ubuntu 16.04/Windows 10 === Intel G41, Q8400, 8GB RAM, Dell 24" IPS, Ubuntu 16.04 === HP Pavillion DM1 4000sd, 11.6", Windows 7 === Asus Vivobook R510CA, 15.6"touchscreen, Windows 10