Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ubuntu en Android ICS (4.0.3.)  (gelezen 1816 keer)

Offline weiland

  • Lid
  • Steunpunt: Ja
ubuntu en Android ICS (4.0.3.)
« Gepost op: 2012/02/24, 11:55:56 »
He mensen,

Al jaren gebruik ik naast ubuntu ( 11.10) samen met mijn android phone. Op dit moment mijn Samsung Galaxy S2. Mijn phone is geroot en draait normaal gesproken Oxygen Rom of Cyanogen Mod Rom. Geen enkel probleem om via usb te verbinden met ubuntu. Hij herkent alle mappen, mijn sd kaart... niks aan de hand. Muziek, fotos en bestanden kan ik feilloos overbrengen.
Maar met alle, ook inmiddels behoorlijk stabiele Android 4.0.3. roms krijg ik foutmeldingen bij usb verbindingen... Hebben anderen hier ook ervaring mee? In windows is het met de stabielere roms eigenlijk geen probleem meer. Maar ubuntu geeft alleen maar foutmeldingen dat ie niet kan aansluiten, en als het al wel lukt wordt de mappenstructuur niet herkend en geeft Ubuntu ze nummers inplaats van namen.
Tis geen ramp, die roms zijn nog experimenteel, maar hou wel van experimenteren met roms ..... in combi met ubuntu tot nu toe geen succes met Android 4.03. roms.
« Laatst bewerkt op: 2012/04/29, 10:30:33 door weiland »
www.thevintageknob.org, Het Online Audio-museum

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #1 Gepost op: 2012/02/24, 12:29:17 »
Voila, je probleem gevonden denk ik:
Citaat
Google has moved away from the USB mass storage protocol, which was used up till Android 2.3, to the MTP.
http://www.omgubuntu.co.uk/2011/12/how-to-connect-your-android-ice-cream-sandwich-phone-to-ubuntu-for-file-access/
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline weiland

  • Lid
  • Steunpunt: Ja
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #2 Gepost op: 2012/02/24, 12:43:57 »


aaaaah nou al lang blij dat het niet aan mij ligt... das wel  klote zeg.... bah... ziet er nog al ingewikkeld uit om het wel voor elkaar te krijgen, maar ga het straks rustig ff proberen...  BEDANKT VOOR DE TIP!

toch zonde, net nu ubuntu aangekondigd heeft een ubuntu versie uit te gaan brengen waarmee je je phone als computer kan gaan gebruiken...
www.thevintageknob.org, Het Online Audio-museum

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #3 Gepost op: 2012/02/24, 13:01:14 »
Ja dat zeker.
Meestal ligt het helaas ook aan de telefoon of software en niet aan Ubuntu zelf bij zulk soort gekkigheid, maar vandaag helaas een keer niet zo te zien :S

Ik vraag me verder af: wat is er zo fijn aan om ROMs te gebruiken?
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #4 Gepost op: 2012/02/24, 13:52:30 »
toch zonde, net nu ubuntu aangekondigd heeft een ubuntu versie uit te gaan brengen waarmee je je phone als computer kan gaan gebruiken...

Dat staat totaal los van Mass Storage en MTP.

Offline weiland

  • Lid
  • Steunpunt: Ja
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #5 Gepost op: 2012/02/24, 17:25:29 »
@ Vistaus: Ja ik snap dat dit er los van staat. Maar wel erg vervelend voor alle Android EN Ubuntu gebruikers straks als er steeds meer Android toestellen overgaan op Android 4.0.3. Juist van Android en Ubuntu zou je verwachten dat vanwege de gemeenschappelijkheid van de linux kernel compatibel zijn.

@Cheap

Ja wat is er leuk aan experimenteren met roms... Eigenlijk zijn dit gewoon de voorlopers van de Android versie die de komende maanden uitgerold gaan worden door de fabrikanten voor de meer high end phones. En er zijn veel gebruikers van de aangepaste roms die geen HTC Sense schil willen of een Samsung Touch Whiz schil over Android heen willen. En dat heb ik ook. Ik heb graag puur Android, zo min mogelijk rommel er om heen gebouwd. En ja dan wil je toch de nieuwste versie uitproberen en dat Ice Cream Sandwhich (Android 4.03.). Vooral lol en behoefte aan het nieuwste voor mijn phone. Net als ik ook altijd snel de nieuwste versie van Ubuntu wil hebben.
www.thevintageknob.org, Het Online Audio-museum

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #6 Gepost op: 2012/02/24, 17:33:37 »
Vooral lol en behoefte aan het nieuwste voor mijn phone. Net als ik ook altijd snel de nieuwste versie van Ubuntu wil hebben.
Dat beantwoord de vraag heel goed, dank je :)
Ik heb zelf ook de GS2, maar nog helemaal standaard. De TouchWiz skin vind ik niet echt denderend nee maar gelukkig stoort het ook weer niet, en HTC Sense (heeft mijn vriendin) wordt op een gegeven moment wel wat saaier. Verder vind ik de kale Android ook wel grappig om mee te spelen, heb alleen nog niet veel tijd in ICS gestoken, ga ik binnenkort nog een keer doen.
Voorlopig ben ik nog gelukkig met TouchWiz en ik wacht lekker nog tot maart of later op ICS ;) Schijnt ook een nieuwe TouchWiz skin te krijgen dus ben benieuwd. Kan altijd nog op een custom ROM overgaan =D
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #7 Gepost op: 2012/02/24, 17:41:05 »
@ Vistaus: Ja ik snap dat dit er los van staat. Maar wel erg vervelend voor alle Android EN Ubuntu gebruikers straks als er steeds meer Android toestellen overgaan op Android 4.0.3. Juist van Android en Ubuntu zou je verwachten dat vanwege de gemeenschappelijkheid van de linux kernel compatibel zijn.

Ik bedoel dat de verbinding van Ubuntu/Android die Canonical straks mee komt niet via MTP gaat, dus ook ICS kan worden gebruikt.

Offline weiland

  • Lid
  • Steunpunt: Ja
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #8 Gepost op: 2012/02/24, 18:11:35 »

AAAAH OK! Dus dat betekent dat het opgelost gaat worden? Dan is er binnenkort helemaal geen probleem meer mee dus.... Dat is heel goed nieuws! 
www.thevintageknob.org, Het Online Audio-museum

Offline weiland

  • Lid
  • Steunpunt: Ja
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #9 Gepost op: 2012/04/29, 10:33:14 »
He mensen, ik vroeg me af of er al android gebruikers waren die het gelukt is om in ubuntu 12.04 hun Android Ice Cream Sandwhich foon aan te sluiten met het MTP protocol.

Bij mij lijkt het in eerste instantie te werken maar krijg gelijk een knoert van een foutmelding....

Het weergeven van de inhoud van ‘store_00010001’ is mislukt: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Anderen al wel succesvol?
Overigens kan ik mijn Android Honeycomb tablet nu wel aansluiten, en wordt ook gezien, ook de mappenstructuur is zichtbaar maar het overzetten van bestanden werkt niet... geeft ook foutmeldingen. Honeycomb werkt ook met het MTP protocol.
« Laatst bewerkt op: 2012/04/29, 10:49:32 door weiland »
www.thevintageknob.org, Het Online Audio-museum

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #10 Gepost op: 2012/04/29, 10:52:20 »
Ik wist eigenlijk niet dat er een probleem zou zijn, ik heb ook een sgs2 maar nog niet gekoppeld aan ubuntu eigenlijk.

Eerst die telefoon eens resetten naar de standaard waarden. Ik heb wat last van vage problemen sinds de update naar android 4.0.3....

Offline weiland

  • Lid
  • Steunpunt: Ja
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #11 Gepost op: 2012/04/29, 12:03:30 »

Op Honeycomb en de officiele samsung rom van 4.03 lijkt het een en ander in eerste instantie goed te werken. Je krijgt een keurig keuzemenuutje, Er komt direct een goeie mappenstructuur in  beeld, maar klik je op een map, dan worden submappen  niet zichtbaar en bestanden heen en weer brengen gaat continu mis. Het enige wat lukt is bestanden op het 1e mappen niveau van het interne geheugen of de sd card te zetten of te deleten. De rest geeft alleen maar foutmeldingen. Overigens draait in het onder windows 7 ook nog verre van perfect.
www.thevintageknob.org, Het Online Audio-museum

Re: ubuntu en Android ICS (4.0.3.)
« Reactie #12 Gepost op: 2013/12/01, 13:35:40 »
Hallo,

Ik ben net nieuw hier op dit forum. Ik wou eigenlijk zelf een topic maken maar kan nergens vinden waar dat moet.. :P
Ik heb wel al jaren Ubuntu en ben er dus bekend mee. Ik had hiervoor een Samsung Galaxy Gio en die kon ik altijd gewoon aansluiten op mijn laptop bij Ubuntu. Hoefde ik niks voor te installeren. Ik kon gewoon map openen kiezen en daar waren mijn bestanden van mijn mobiel. Nu heb ik de Samsung galaxy s3 mini en nu kan ik m nog wel aansluiten maar geeft mijn laptop de bestanden ervan niet weer.

Iemand een oplossing?
bvd

Christien

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: ubuntu en Android ICS (4.0.3.)
« Reactie #13 Gepost op: 2013/12/01, 20:03:53 »
Hallo,

Ik ben net nieuw hier op dit forum. Ik wou eigenlijk zelf een topic maken maar kan nergens vinden waar dat moet.. :P
Ik heb wel al jaren Ubuntu en ben er dus bekend mee. Ik had hiervoor een Samsung Galaxy Gio en die kon ik altijd gewoon aansluiten op mijn laptop bij Ubuntu. Hoefde ik niks voor te installeren. Ik kon gewoon map openen kiezen en daar waren mijn bestanden van mijn mobiel. Nu heb ik de Samsung galaxy s3 mini en nu kan ik m nog wel aansluiten maar geeft mijn laptop de bestanden ervan niet weer.

Iemand een oplossing?
bvd

Christien

Als je Ubuntu 12.04 of 12.10 hebt, dan komt het omdat je dit moet doen: http://www.webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html