Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NVidia drivers versie probleem  (gelezen 4315 keer)

eL_Jee

  • Gast
NVidia drivers versie probleem
« Gepost op: 2007/02/12, 22:36:04 »
Ik ben op het moment bezig om de nvidia-drivers werkend te krijgen met mijn videokaart, aangezien ik met Beryl wil gaan werken. Hier stuit ik echter op een probleem.

Mijn videokaart (Geforce4 MX IGP) lijkt niet meer ondersteund te zijn door de nieuwste drivers 1.97.x, ik heb versie 1.96.x nodig.  In Synaptic is alleen de nieuwste versie beschikbaar. Deze heb ik nu geinstalleerd, maar zodra ik X opstart, met 'nvidia' als driver in xorg.conf krijg ik de foutmelding 'no screens found'.

Hoe kan ik een oudere versie van deze driver installeren? Ik heb ook al de .run van NVidia zelf geprobeerd, maar dan krijg ik problemen dat ik niet de juiste kernel-package (oid) heb.

Wie weet raad?

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #1 Gepost op: 2007/02/12, 23:15:37 »
Ter verduidelijking uit de Xorg.log:

(II) NVIDIA dlloader X Driver  1.0-9746  Fri Dec 15 09:56:41 PST 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 02:00:0
(WW) NVIDIA(0): The NVIDIA GeForce4 MX Integrated GPU GPU installed in this
(WW) NVIDIA(0):     system is supported through the NVIDIA 1.0-96xx Legacy
(WW) NVIDIA(0):     drivers. Please visit
(WW) NVIDIA(0):     http://www.nvidia.com/object/unix.html for more
(WW) NVIDIA(0):     information.  The 1.0-9746 NVIDIA driver will ignore this
(WW) NVIDIA(0):     GPU.  Continuing probe...
(EE) No devices detected.

Fatal server error:
no screens found

Piet

  • Gast
NVidia drivers versie probleem
« Reactie #2 Gepost op: 2007/02/13, 02:13:40 »
Citaat van: eL_Jee
Ter verduidelijking uit de Xorg.log:

(II) NVIDIA dlloader X Driver  1.0-9746  Fri Dec 15 09:56:41 PST 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 02:00:0
(WW) NVIDIA(0): The NVIDIA GeForce4 MX Integrated GPU GPU installed in this
(WW) NVIDIA(0):     system is supported through the NVIDIA 1.0-96xx Legacy
(WW) NVIDIA(0):     drivers. Please visit
(WW) NVIDIA(0):     http://www.nvidia.com/object/unix.html for more
(WW) NVIDIA(0):     information.  The 1.0-9746 NVIDIA driver will ignore this
(WW) NVIDIA(0):     GPU.  Continuing probe...
(EE) No devices detected.

Fatal server error:
no screens found
en heb je al gedaan wat 'ie zelf voorsteld?
Het is zo makkelijk soms he ;) :)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #3 Gepost op: 2007/02/13, 07:29:59 »
http://wiki.beryl-project.org/wiki/Install_Beryl_on_Ubuntu_Edgy_with_nVidia#Second_method_.28installing_official_package.29
Deze guide zou moeten werken.
Ik denk alleen dat je bij de eerste stap de andere driver van de nvidia site moet downloaden (de legacy driver)

Offline Gandyman

  • Lid
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #4 Gepost op: 2007/02/13, 11:53:15 »
Dat downloaden en zelf installeren van drivers gaat heel vaak fout.
Bijkomend probleem is de 1e beste update van je kernel en je kan weer overnieuw beginnen.

Open synaptic en zoek op NVIDIA.
Vind de legacy drivers en installeer die gewoon vanuit Synaptic.
Nu staan ze er goed in en kan je eerst eens proberen die drivers te activeren, door in je xorg.conf het woordje nv te veranderen naar nvidia.

Bij iedere HOW-TO altijd proberen de dingen die je moet installeren te doen via Synaptic, en niet handmatig.
Vind je ze niet in Synaptic terwijl je toch alle sources heb geactiveerd in de soureces.list dan pas beginnen aan handmatig downloaden en installeren.

SCCS

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #5 Gepost op: 2007/02/13, 12:53:12 »
Citaat van: eL_Jee
Ik ben op het moment bezig om de nvidia-drivers werkend te krijgen met mijn videokaart, aangezien ik met Beryl wil gaan werken. Hier stuit ik echter op een probleem.

Mijn videokaart (Geforce4 MX IGP) lijkt niet meer ondersteund te zijn door de nieuwste drivers 1.97.x, ik heb versie 1.96.x nodig.  In Synaptic is alleen de nieuwste versie beschikbaar. Deze heb ik nu geinstalleerd, maar zodra ik X opstart, met 'nvidia' als driver in xorg.conf krijg ik de foutmelding 'no screens found'.

Hoe kan ik een oudere versie van deze driver installeren? Ik heb ook al de .run van NVidia zelf geprobeerd, maar dan krijg ik problemen dat ik niet de juiste kernel-package (oid) heb.

Wie weet raad?
Ik geloof dat ik al wel weet wat er fout gegaan is...
want jou kaart wordt gewoon door de nvidia-driver in synaptic ondersteund.

Post je xorg.conf eens!

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #6 Gepost op: 2007/02/24, 22:13:03 »
Dank voor alle reacties!

Alle guides enzo had ik al doorgenomen, zonder succes. Uiteindelijk heb ik een tooltje gevonden, geschreven in Python die automatisch goede driver wist te downloaden en installeren. Ik kan helaas niet meer op de naam komen, maar het werkt echt perfect!

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #7 Gepost op: 2007/02/24, 22:15:03 »
Gevonden! Het programmaatje heet Envy.

Ik kan iedereen die problemen heeft met zijn/haar Nvidia-kaart aanraden.

Offline eendje

  • Lid
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #8 Gepost op: 2007/02/24, 22:17:11 »
Citaat van: eL_Jee
Dank voor alle reacties!

Alle guides enzo had ik al doorgenomen, zonder succes. Uiteindelijk heb ik een tooltje gevonden, geschreven in Python die automatisch goede driver wist te downloaden en installeren. Ik kan helaas niet meer op de naam komen, maar het werkt echt perfect!
Nou maar hopen dat bij een kernel update het goed gaat.... Daarom raden we je aan via Sybaptic te instaleren, dan gaat dat automatisch...
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #9 Gepost op: 2007/02/24, 22:30:41 »
jammer, in een paar stappen  hadden we een duurzame oplossing kunnen
vinden voor je drivers. en zoals eendje terecht opmerkt, ik ben bang dat het
bij een kernel(of security) update niet helemaal lekker gaat.
ik raad iedereen af dit soort scripts te gebruiken.

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #10 Gepost op: 2007/03/04, 00:00:13 »
Ik had alle verschillende drivers die in Synaptic beschikbaar zijn geprobeerd, helaas werkten deze allemaal niet. Tenminste... aangezien ik geen grafische omgeving had ben ik met aptitude in de weer geweest, maar dat is feitelijk hetzelfde toch?

Offline eendje

  • Lid
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #11 Gepost op: 2007/03/04, 11:47:15 »
Citaat van: eL_Jee
Ik had alle verschillende drivers die in Synaptic beschikbaar zijn geprobeerd, helaas werkten deze allemaal niet. Tenminste... aangezien ik geen grafische omgeving had ben ik met aptitude in de weer geweest, maar dat is feitelijk hetzelfde toch?
Aptitude gebruiken is prima, maar alleen de pakketten voor de grafische kaart installeren is niet voldoende. Je moet ook nog wat instellen. Je had beter de Howto kunnen volgen van de de pagina: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia . Het probleem met drivers van de grafische kaart is dat ze met maar exact 1 versie van de kernel werken. Daarom moeten de grafische pakketten ook geupdate worden als je een kernelupdate krijgt. De foutmelding is je eerste post over een niet juiste kernel package gaf dus al aan dat niet het juiste grafische pakket was geïnstalleerd.
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #12 Gepost op: 2007/03/04, 11:48:44 »
Ja, dat is wel hetzelfde, min of meer denk ik. Ik dacht dat aptitude via de terminal werkte, terwijl Synaptic via de GUI (Graphical User Interface) werkt.

Maar in elk geval, ik zit met hetzelfde probleem ... Ik krijg eveneens de melding dat ik de legacy drivers moet nemen (vind ik vreemd, want ik heb een Nvidia Geforce 4 TI 4200, en die wordt correct herkend door de computer), maar als ik die via synaptic probeer te installeren, en dan te activeren met het commando dat er bij zit in de beschrijving "sudo nvidia-glx-config enable", en dan herstart, krijg ik altijd precies dezelfde foutmelding terug.

Jullie spraken hier net over mogelijke oplossingen, dus als jullie willen kunnen we misschien met mijn xorg.conf en alles wat jullie nog nodig hebben naar een oplossing zoeken?
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #13 Gepost op: 2007/03/04, 13:40:57 »
Welke foutmelding krijg je precies terug?

Mijn ervaring met een GF4 is dat je dus nvidia-legacy drivers nodig hebt, versie 96xx. Die kun je alleen niet via Synaptic krijgen. Gezien bovenstaande reacties weet ik niet wat de meest veilige manier is.
Ben je ten einde raad kun je Envy proberen. Bij mij werkte het direct perfect, maar bij een kernel update heb je dus waarschijnlijk een probleem.
Mocht je een andere oplossing vinden houd ik me warm aanbevolen. :)
Nog een tip: in /var/log/Xorg.0.log staat de log van je xserver. Met cat /var/log/Xorg.0.log | grep "(WW)" (of grep "(EE)"), kun je foutmeldingen vinden.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #14 Gepost op: 2007/03/04, 14:41:19 »
nvidia legacy zit gewoon in Synaptic, hoor. Mits je een goede bronnenlijst hebt.

Offline BailHope

  • Lid
    • Techneut
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #15 Gepost op: 2007/03/04, 14:42:59 »
Ja, die zit er inderdaad in. Als ik die echter installeer krijg ik ook de melding van "no screens found".

Ik heb Envy al eens geprobeerd. Die installeert de gewone driver voor mij, en zorgt er dan voor dat ik diezelfde foutmelding krijg.
Nu zit ik niet aan het juiste systeem, dus ik kan geen xorg.conf of foutmeldingen aan jullie tonen dus dat is iets voor straks.
Ubuntu user #12046
Mijn blog voor techneuten: http://techneut.wordpress.com
Voor de professionele IT'er: http://it-potato.blogspot.com

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #16 Gepost op: 2007/03/04, 15:51:05 »
nvidia legacy zit zeker in synaptic, versie 97xx. Voor Geforce4 heb je versie 96xx nodig, en die kun je niet krijgen.

Jammer dat envy niet werkt, misschien dat we iets aan de foutmeldingen hebben en je xorg.conf

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #17 Gepost op: 2007/03/04, 16:06:44 »
Citaat van: eL_Jee
nvidia legacy zit zeker in synaptic, versie 97xx. Voor Geforce4 heb je versie 96xx nodig, en die kun je niet krijgen.

Jammer dat envy niet werkt, misschien dat we iets aan de foutmeldingen hebben en je xorg.conf
Ik heb een GeForce4 kaart zonder problemen draaiende...met beryl... ohw jah en de driver uit synaptic.

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #18 Gepost op: 2007/03/04, 16:26:53 »
Citaat van: CORVUS_CORAX
Citaat van: eL_Jee
nvidia legacy zit zeker in synaptic, versie 97xx. Voor Geforce4 heb je versie 96xx nodig, en die kun je niet krijgen.

Jammer dat envy niet werkt, misschien dat we iets aan de foutmeldingen hebben en je xorg.conf
Ik heb een GeForce4 kaart zonder problemen draaiende...met beryl... ohw jah en de driver uit synaptic.
Misschien dat er nog verschil tussen Geforce4 kaarten zit? Ik heb een GF4mx IGP (geintegreerd op moederbord)

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #19 Gepost op: 2007/03/04, 16:41:49 »
Citaat van: eL_Jee
Citaat van: CORVUS_CORAX
Citaat van: eL_Jee
nvidia legacy zit zeker in synaptic, versie 97xx. Voor Geforce4 heb je versie 96xx nodig, en die kun je niet krijgen.

Jammer dat envy niet werkt, misschien dat we iets aan de foutmeldingen hebben en je xorg.conf
Ik heb een GeForce4 kaart zonder problemen draaiende...met beryl... ohw jah en de driver uit synaptic.
Misschien dat er nog verschil tussen Geforce4 kaarten zit? Ik heb een GF4mx IGP (geintegreerd op moederbord)
Dat kan het verschil maken,
ik heb een AGP nVidia GeForce4 Ti4600.

Onboard geeft wel een enkele x een probleem bij wat voor merk dan ook, maar dat heeft niet met de driver of GeForce4 te maken.
Maar als het echt niet zou werken zal het waarschijnlijk er aan liggen dat het onboard is, oftewel een moederbord probleempje.

eL_Jee

  • Gast
NVidia drivers versie probleem
« Reactie #20 Gepost op: 2007/03/04, 17:03:53 »
Volgens mij is het geen moederbord probleem, de driver gaf namelijk specifiek aan (2e post), dat de 96xx-legacy driver nodig is.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #21 Gepost op: 2007/03/04, 17:10:31 »
Hier kan je de goede versie van de legacy nvidia drivers vandaan halen.
http://albertomilone.com/driver.html

Je moet de new legacy repo hebben.
Instructies staan er ook.

Als je die repo hebt toegevoegd, moet je de nvidia drivers even opnieuw installeren.

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #22 Gepost op: 2007/03/04, 17:22:29 »
Citaat van: eL_Jee
Volgens mij is het geen moederbord probleem, de driver gaf namelijk specifiek aan (2e post), dat de 96xx-legacy driver nodig is.
Dat zei ie ook bij bail hope, en die heeft een Ti4200, waarvan ik zeker weet dat die de legacy niet moet hebben.
Ook weet ik dat de Ti4200 en de Ti4600 bijna niks van elkaar verschillen, ze zijn van de zelfde serie en periode.

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
NVidia drivers versie probleem
« Reactie #23 Gepost op: 2007/03/04, 17:26:21 »
Overigens wordt in synaptic aangegeven dat de legacy voor TNT, TNT2, RIVA, GeForce en GeForce2 bestemd is.