Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Hapering in HD-film  (gelezen 2572 keer)

Offline kebabfish

  • Lid
  • Steunpunt: Ja
[opgelost] Hapering in HD-film
« Gepost op: 2012/02/09, 12:49:42 »
Ik zit al een tijdje met het probleem dat HD-video niet lekker afspeelt op mijn pc. Dit ging eerst gecombineerd met tearing, echter is dit probleem al een tijdje opgelost. Het probleem wat ik nu heb is dat de film soms wat lijkt te haperen, en dan vooral als er veel licht/donker in beeld is (een half besneeuwde berg bijvoorbeeld). De specificaties van de pc zijn als volgt:

CPU: AMD athlon II X4 640 (4x3.0 ghz)
GPU: Nvidia GTS450 1GB DDR5
Werkgeheugen: 4GB DDR3
OS: Ubuntu 11.10

Het volgende heb ik al geprobeerd:
Unity 2D gebruiken
XBMC/SMplayer met vdpau ondersteuning getest
Composite in xorg.conf uitzetten
In nvidia-settings Vsync aanzetten
In nvidia-setting de videokaart in hoogste stand zetten
In nvidia-settings alles op performance gezet
In sm-player het aantal threads voor decoding op 2 gezet (bij 4 liep hij wel eens vast)
Tevens uiteraard xv en vdpau in sm-player geprobeerd
Alleen inloggen bij xbmc, dit scheelde al aanzienlijk
Frequentie van de tv zelf veranderd, dit scheelde ook behoorlijk
Xfce ernaast geïnstalleerd, en hierin de film afgespeeld
De nieuwere driver voor nvidia geprobeerd (290 ipv 285)

En toch hou ik af en toe die hapering, wat erg irriteert. Games als oil rush draaien probleemloos, ook met de effecten op de hoogste stand. Dan moet een hd-film toch ook kunnen? Wat zou ik nog kunnen proberen om deze films netjes af te kunnen spelen?

bvd
« Laatst bewerkt op: 2012/05/06, 18:52:38 door kebabfish »

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Hapering in HD-film
« Reactie #1 Gepost op: 2012/02/09, 13:09:26 »
Heb je VLC al geprobeerd?

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: Hapering in HD-film
« Reactie #2 Gepost op: 2012/02/09, 13:23:18 »
Heb je VLC al geprobeerd?

Vergeten erbij te zetten, evenals het aanzetten van Vsync in compiz settings manager :P Is dus al geprobeerd, maar helaas deed vlc het nog slechter...

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Hapering in HD-film
« Reactie #3 Gepost op: 2012/02/10, 18:39:11 »
Vreemd, heb je het ook al met de stock-driver geprobeerd?
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: Hapering in HD-film
« Reactie #4 Gepost op: 2012/02/11, 00:12:33 »
Vreemd, heb je het ook al met de stock-driver geprobeerd?

Bedoel je de vorige nvidia-driver? Die zal ik binnenkort ook eens proberen.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Hapering in HD-film
« Reactie #5 Gepost op: 2012/02/11, 07:54:50 »
Ik zit al een tijdje met het probleem dat HD-video niet lekker afspeelt op mijn pc.
Vanaf een blu-ray disc? Speelt deze wel goed af, in een standalone blu-ray speler? Of als deze op de harddisk staat, speelt deze wel goed af in Windows? En presteert je harddisk nog wel goed met Schijfgereedschap > Alleen-lezen-Benchmark? Check verder nog deze Ubuntu Documentation Playing Blu-Ray and HD DVD Video.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Hapering in HD-film
« Reactie #6 Gepost op: 2012/02/11, 12:07:27 »
Vreemd, heb je het ook al met de stock-driver geprobeerd?
Bedoel je de vorige nvidia-driver? Die zal ik binnenkort ook eens proberen.
Nee, de open driver bedoel ik hiermee, dus de vrije driver als deze in je rijtje staat.
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Hapering in HD-film
« Reactie #7 Gepost op: 2012/02/11, 12:46:22 »
Met die kaart zou ik de nieuwste Nvidia driver gebruiken, dan heb je de beste ondersteuning.
Op dit moment is dat de 290-serie.
Betrouwbare updates kan je hier vinden: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

Verder heeft de Nvidia driver in Linux wat rare eigenschappen. Zo geeft hij de refresh rate niet goed weer, omdat dat intern door de driver gebruikt wordt voor identificatie van je schermen oid. Zo kom je dus uit op refresh rates van 53 of zo, totaal onlogisch.

Met een aantal workarounds kan je toch vloeiend en zonder tearing Ubuntu gebruiken.
Zet in de Nvidia Settings overal de "Sync to Vblank" aan.
Installeer de CompizConfig settings manager.
Zet in dit programma onder algemene opties in het tabblad display settings de verversingssnelheid op de waarde die je monitor ook gebruikt (meestal 60). En haal het vinkje weg bij "detecteer verversingssnelheid".

Met deze instellingen werkt het hier perfect, ik gebruik meestal SMplayer met de VDPAU uitvoer.

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: Hapering in HD-film
« Reactie #8 Gepost op: 2012/02/11, 16:40:27 »
Allereerst bedankt voor alle antwoorden:
@Cheap:
Met deze driver werken de games helaas niet, toch een belangrijk minpunt.

@Jolo:
ik speel de films momenteel vanaf de harde schijf af. Er zit een 2e in, daarmee zou ik kunnen kijken of de prestaties verschillen, al is die 2e een stuk trager (5400 rpm). Windows heb ik niet meer op staan.

@Johan van Dijk:
Die ppa heb ik al eens toegevoegd, maar dat hielp niet erg veel. Ik zal die andere tip eens proberen.

Edit: Met het aanpassen van de compiz-instellingen verbeterde de kwaliteit niet echt, maar in xbmc heb ik de refresh rate op 58 (hoger wilde niet) kunnen zetten. Hiermee zijn er minder haperingen, maar het is nog steeds niet helemaal weg. Maar ik kom al in de buurt :P
« Laatst bewerkt op: 2012/02/12, 12:54:16 door kebabfish »

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: Hapering in HD-film
« Reactie #9 Gepost op: 2012/03/17, 17:51:23 »
Laatst weer een middagje gezocht naar een oplossing, en ik moet het gaan zoeken in de frequentie instellingen. Als de tv op "game modus" (60 Hz) staat, schokt het beeld enorm tijdens films. Echter blijft het beeld af en toe schokken als de "game modus" uit staat. In nvidia-settings probeer ik de frequentie zo hoog mogelijk te zetten, echter komt het nooit overeen met de frequentie-instellingen in de settings van Xubuntu (ondertussen staat er Xubuntu 12.04 op). 60Hz in nvidia-settings is 58 Hz in Xubuntu-settings, of soms 174Hz (geen idee hoe die daar op komt). Xubuntu-settings zelf kan niet hoger dan 58Hz als ik die los instel, nvidia-settings gaat dan op "auto" staan. Resolutie verlagen en frequentie verhogen heeft helaas ook niet geholpen... Zou het kunnen zijn dat het signaal wordt verstoord door de kabel? Momenteel is de tv aangesloten via een DVI->HDMI kabel.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Hapering in HD-film
« Reactie #10 Gepost op: 2012/03/17, 20:59:13 »
Verder heeft de Nvidia driver in Linux wat rare eigenschappen. Zo geeft hij de refresh rate niet goed weer, omdat dat intern door de driver gebruikt wordt voor identificatie van je schermen oid. Zo kom je dus uit op refresh rates van 53 of zo, totaal onlogisch.
...
Overheen gelezen? :)

Mijn ervaring is dat de Nvidia-settings als enige de goede frequenties weergeeft. Alle andere programma's komen met onzinwaardes als 58 of 174. Er is geen enkele TV of monitor die die waardes kan weergeven en je computer stuurt ook echt geen signaal uit met die frequentie. Geeft een instelprogramma wel die rare frequenties aan, dan kan je daar niet op vertrouwen. De instellingen veranderen in xubuntu-settings heeft dus niet zoveel zin, aangezien die de verkeerde aantallen geeft.

Dit kan je "oplossen" door in de xorg.conf dynamic twinview oid uit te zetten, maar het gevolg is dan dat je maar 1 scherm tegelijk kan gebruiken. In jouw situatie dus niet geschikt.

Het probleem met films is dat er verschillen zijn in het aantal frames per seconde. 23,nogwat of 25 of 30 afhankelijk van NTSC, PAL of een bioscoop standaard. En er zijn er nog wel meer... De optimale snelheid van je monitor of TV kan dus per film verschillen. Denk aan 60, 72, 75 Hz enz.

Ik weet verder niet waar de instellingen in XBMC zitten, maar ik zou eerst eens opzoeken of je daar de autodetectie van de refresh rate uit kan zetten. Die pakt toch de verkeerde waarden en is daarom niet bruikbaar. Staat die uit, stel hem dan in op een vaste waarde, bijv. 60.
Doe hetzelfde in andere programma's, zoals videospelers en de instellingen van Compiz/Unity/whatever.

Aan de kabel zal het wel niet liggen, er zijn hele volksstammen die hun apparaten via converters aansluiten. Maar het kan geen kwaad om eens een andere te gebruiken. Ik verwacht dat het toch echt zit in de stomme instelling van Nvidia-settings.

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: Hapering in HD-film
« Reactie #11 Gepost op: 2012/03/17, 21:16:47 »
Haha, ik was er een middag mee bezig geweest, zonder moeite te nemen het topic nog eens goed door te spitten... Mijn fout :P Echter heb ik ook geprobeerd (of juist geprobeerd) de waardes in nvidia-settings in te stellen, zonder goed resultaat. Maar die dynamic twinview kan ik wel uitzetten, aangezien deze pc alleen op een tv zit aangesloten. Ik ga dat eens proberen :)

Zou ik hier nog iets aan moeten passen? Lijkt mij vrij normaal:

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "SAMSUNG"
    HorizSync       26.0 - 81.0
    VertRefresh     24.0 - 75.0
    Option         "DPMS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "1920x1080_60 +0+0; nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
« Laatst bewerkt op: 2012/03/17, 21:43:53 door kebabfish »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Hapering in HD-film
« Reactie #12 Gepost op: 2012/03/17, 22:01:46 »
Probeer eens een pc monitor, of je het dan ook nog hebt.

Heb je het met alle films of alleen bepaalde, dus misschien is het de film zelf.

Offline kebabfish

  • Lid
  • Steunpunt: Ja
Re: Hapering in HD-film
« Reactie #13 Gepost op: 2012/05/06, 18:52:23 »
Opgelost na de volgende handelingen (welke de doorslag gaf weet ik niet):
Nvidia 302.07 driver geïnstalleerd
In XBMC de optie aangezet dat de display eenzelfde refresh rate aan neemt als de film.

Haperingen komen nu bijna niet meer voor :)