Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Rewrite URL  (gelezen 892 keer)

Offline Prdele

  • Lid
  • Steunpunt: Nee
Rewrite URL
« Gepost op: 2012/01/21, 01:48:37 »
Ik heb via de admin panel bij mijn provider een subdomein aangemaakt (nas.domein.nl)
In de map "nas" heb ik een index.php pagina aangemaakt met de volgende inhoud:
<?php
header
("Location: http://nas-cg.domein.nl:8080");
exit;
?>
Als ik nu "nas.domein.nl" in tikt, dan wordt ik automatisch doorverwezen naar "http://nas-cg.domein.nl:8080/webUI/login.cgi"
Dan kan ik op mijn nas inloggen, dus het werkt allemaal wel, alleen vindt ik dat stukje ":8080/webUI/login.cgi" een doorn in het oog.
Nu wil ik dat met een mod_rewrite oplossen via een .htaccess, althans, ik denk dat dat zo moet.
Maar nu ben ik al een aantal uurtjes verschillende pagina's aan het uitspitten, maar ik kom er niet mee uit.
Veel wat ik vindt is PHP technisch omschreven, en aardig abracadabra voor mijn.
Ik heb totaal geen verstand van scripten en of PHP.

Mijn brutale vraag is of dat hier iemand mij mee kan helpen?

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Rewrite URL
« Reactie #1 Gepost op: 2012/01/21, 23:34:57 »
Hele brutale vraag, maar daar is dit forum dan ook voor... Om elkaar te helpen.

Kun je iets beter je situatie beschrijven?
Mijn aanname is de volgende:

Je draait een website met domeinnaam bij externe provider.
Je hebt thuis een server of nas staan.

Heb je op deze thuis server ook apache2 draaien?

Als dit zo is dan is de oplossing redelijk simpel. Het is mij ook gelukt.
Via de dns records van je externe provider maak je een verwijzing voor je sub domein naar het statische ip adres van je server.

Via de terminal ga je naar de volgende map in je server.

/etc/apache2/sites-enabled

Daar maak je een een nieuwe file aan met de naam van je site. Bijvoorbeeld domain.com Het maakt volgens mij niet uit hoe die precies heet.

Daar vul je de volgende code in:

<VirtualHost *:8080>
     ServerAdmin xxx@domain.com
     ServerName nas.domain.com
     ServerAlias nas.domain.com
     DocumentRoot /path/naar/je/nas   (bv /var/www/nas)
</VirtualHost>

Daarna moet je apache2 een restart geven

sudo /etc/init.d/apache2 restart

Als de output ok is, dan is dat goed gegaan.
Denk er wel aan dat jij je eigen oplossing even aanpast, zodat die niet actief is.
Laat maar weten of het lukt.
« Laatst bewerkt op: 2012/01/21, 23:48:31 door tap »

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Rewrite URL
« Reactie #2 Gepost op: 2012/01/22, 00:33:40 »
Je kunt het inderdaad op twee manieren doen:
1. zorgen dat als je het adres intypt je dus meteen op de juiste server zit. (Dat kan, als je subdomein en je nas 1 en hetzelfde adres hebben)
2. ProxyPass gebruiken.

1. staat hier al boven uitgelegd, gewoon server alias gebruiken.
2. ProxyPass is het onder water doorsluisen van de content zonder dat je dit ziet in je browserbalk.

Zet hiervoor in de virtualhost van je subdomein:

ProxyPass               /      http://<ander-adres>/
ProxyPassReverse     /      http://<ander-adres>/

Wel even de proxy module actief maken natuurlijk.

Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Rewrite URL
« Reactie #3 Gepost op: 2012/01/22, 00:39:54 »
Als dit zo is dan is de oplossing redelijk simpel. Het is mij ook gelukt.
Via de dns records van je externe provider maak je een verwijzing voor je sub domein naar het statische ip adres van je server.

Via de terminal ga je naar de volgende map in je server.

/etc/apache2/sites-enabled

Daar maak je een een nieuwe file aan met de naam van je site. Bijvoorbeeld domain.com Het maakt volgens mij niet uit hoe die precies heet.
Maakt inderdaad niet uit, maar zorg wel dat de naam duidelijk is voor jezelf
MAAR: Nooit in sites-enable files aanmaken!!
Altijd in /etc/apache2/sites-available/
Vervolgens met a2ensite <naam van bestand> de site aanzetten.
Proxy module zet je dus ook aan met a2enmod proxy

Citaat
Daar vul je de volgende code in:

<VirtualHost *:8080>
     ServerAdmin xxx@domain.com
     ServerName nas.domain.com
     ServerAlias nas.domain.com
     DocumentRoot /path/naar/je/nas   (bv /var/www/nas)
</VirtualHost>

Daarna moet je apache2 een restart geven

sudo /etc/init.d/apache2 restart

Als de output ok is, dan is dat goed gegaan.
Denk er wel aan dat jij je eigen oplossing even aanpast, zodat die niet actief is.
Laat maar weten of het lukt.
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Rewrite URL
« Reactie #4 Gepost op: 2012/01/22, 01:07:14 »
Ik wil ook graag bijleren  ^-^

Waarom niet in sites-enabled en wel in sites-available?
Toen ik het net bij mijzelf controleerde zag ik inderdaad dat ik ook een soft link heb in sites-enabled en dat de file zelf staat in sites-available

Maar ik wil nog steeds graag leren.
« Laatst bewerkt op: 2012/01/22, 01:10:44 door tap »

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Rewrite URL
« Reactie #5 Gepost op: 2012/01/22, 14:55:08 »
De sites-enable is precies wat de naam zegt, de sites die aangezet zijn (met het a2ensite commando)
Hier horen dus alleen maar symlink naar de sites-available map te staan.
Hierdoor kun je makkelijk meerdere site configs maken zonder dat deze allemaal meteen actief zijn.
Zo houd je de administratie mooi en gaat apache geen onverwachte dingen doen.
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline tap

  • Lid
  • Steunpunt: Nee
Re: Rewrite URL
« Reactie #6 Gepost op: 2012/01/22, 18:30:17 »
Bedankt voor de uitleg!