Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid DMX 6fire 24/96 Ubuntu 11.10  (gelezen 1334 keer)

Offline plek

  • Lid
  • Steunpunt: Nee
Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Gepost op: 2012/01/03, 15:36:55 »
Onlangs heb ik Ubuntu 11.10 geïnstalleerd (schoon, singleboot). Mijn geluidskaart DMX 6fire 24/96 doet het niet. Onder Ubuntu 10.04 (had ik hiervoor) was dat eerst ook zo, maar met hulp van dit forum vond ik een oplossing (http://forum.ubuntu-nl.org/hardware-en-drivers/geen-geluid-met-live-cd-ubuntu-10-04/msg614823/#msg614823). Die heb ik ook nu weer geprobeerd, zij het met enkele kleine aanpassingen ivm 11.10 (cursief aangegeven). Het gaat om de volgende stappen:

1. Tik in de terminal in gksudo gedit, druk op enter en vul je wachtwoord in.
Kopieer de volgende regels (de tekst tussen ---) en plak deze in de teksteditor:

---
SUBSYSTEM!="sound", GOTO="ice1712_end"
ACTION!="change", GOTO="ice1712_end"
KERNEL!="card*", GOTO="ice1712_end"

SUBSYSTEMS=="pci", ATTRS{vendor}=="0x1412", ATTRS{device}=="0x1712", ATTRS{subsystem_vendor}=="0x1412", ATTRS{subsystem_device}=="0x1138", ENV{PULSE_PROFILE_SET}="via-ice1712.conf"

LABEL="ice1712_end"
---

Kies Bestand>Opslaan als, noem het bestand ice1712-pulseaudio-workaround.rules en sla het op in de map /etc/udev/rules.d/

2. Tik in de terminal in gksudo gedit, druk op enter en vul je wachtwoord in.
Kopieer de inhoud van de link http://launchpadlibrarian.net/34620379/via-ice1712.conf en plak deze in de teksteditor. (de tekst zelf is nogal lang, vandaar de link)

Kies Bestand>Opslaan als, noem het bestand via-ice1712.conf en sla het op in de map /usr/share/pulseaudio/alsa-mixer/profile-sets/

3. Tik in de terminal in gksudo gedit /lib/udev/rules.d/90-pulseaudio.rules, druk op enter en vul je wachtwoord in.
In het bestand zijn acht aansluitende regels die beginnen met SUBSYSTEMS. Voeg daar als negende regel de volgende aan toe:

SUBSYSTEMS=="pci", ATTRS{vendor}=="0x1412", ATTRS{device}=="0x1712", ATTRS{subsystem_vendor}=="0x153b", ATTRS{subsystem_device}=="0x1138", ENV{PULSE_PROFILE_SET}="via-ice1712.conf"

Kies Bestand>Opslaan.

4. Voer in de terminal de opdracht (de tekst tussen"") "pulseaudio --kill && pulseaudio --start" uit.

5. Herstart de computer, en  :D.

Toch heb ik nu geen werkende geluidskaart. Weet iemand misschien een oplossing?

Alvast dank voor het meedenken. Groet, Peter

Offline plek

  • Lid
  • Steunpunt: Nee
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #1 Gepost op: 2012/01/07, 14:15:49 »
Zijn er nog geluidsexperts onder jullie??? ;)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #2 Gepost op: 2012/01/07, 21:27:59 »
Geluidexpert is misschien wat te veel van het goede, een helpende hand kan ik wel bieden. :)
Open een terminal en type daar lspci -vv en geef een ENTER,ik neem aan dat het een pci geluidskaart is, kan je de uitkomst hier plaatsen?
In der Beschränkung zeigt sich der Meister.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #3 Gepost op: 2012/01/13, 20:56:11 »
Gijsbert, dank voor je reactie! Het commando geeft het volgende resultaat:

00:00.0 Host bridge: Intel Corporation 82845 845 [Brookdale] Chipset Host Bridge (rev 11)
Subsystem: EPoX Computer Co., Ltd. Device 4002
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
Latency: 0
Region 0: Memory at d0000000 (32-bit, prefetchable) [size=128M]
Capabilities: <access denied>
Kernel driver in use: agpgart-intel

00:01.0 PCI bridge: Intel Corporation 82845 845 [Brookdale] Chipset AGP Bridge (rev 11) (prog-if 00 [Normal decode])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64
Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
Memory behind bridge: e8000000-e9ffffff
Prefetchable memory behind bridge: d8000000-e7ffffff
Secondary status: 66MHz+ FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
BridgeCtl: Parity- SERR+ NoISA+ VGA+ MAbort- >Reset- FastB2B-
PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
Kernel modules: shpchp

00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01) (prog-if 00 [UHCI])
Subsystem: EPoX Computer Co., Ltd. Device 4002
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin A routed to IRQ 10
Region 4: I/O ports at b800 [size=32]
Kernel driver in use: uhci_hcd

00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01) (prog-if 00 [UHCI])
Subsystem: EPoX Computer Co., Ltd. Device 4002
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin B routed to IRQ 10
Region 4: I/O ports at b000 [size=32]
Kernel driver in use: uhci_hcd

00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01) (prog-if 00 [UHCI])
Subsystem: EPoX Computer Co., Ltd. Device 4002
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin C routed to IRQ 11
Region 4: I/O ports at b400 [size=32]
Kernel driver in use: uhci_hcd

00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01) (prog-if 20 [EHCI])
Subsystem: EPoX Computer Co., Ltd. Device 4002
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin D routed to IRQ 9
Region 0: Memory at ec000000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81) (prog-if 00 [Normal decode])
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR+ INTx-
Latency: 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
I/O behind bridge: 00009000-0000afff
Memory behind bridge: ea000000-ebffffff
Prefetchable memory behind bridge: 20000000-200fffff
Secondary status: 66MHz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- <SERR- <PERR-
BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-
PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
Kernel modules: shpchp

00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Kernel modules: iTCO_wdt, intel-rng

00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01) (prog-if 8a [Master SecP PriP])
Subsystem: EPoX Computer Co., Ltd. Device 4002
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0
Interrupt: pin A routed to IRQ 11
Region 0: I/O ports at 01f0 [size=8]
Region 1: I/O ports at 03f4 [size=1]
Region 2: I/O ports at 0170 [size=8]
Region 3: I/O ports at 0374 [size=1]
Region 4: I/O ports at f000 [size=16]
Region 5: Memory at 20100000 (32-bit, non-prefetchable) [size=1K]
Kernel driver in use: ata_piix

00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
Subsystem: EPoX Computer Co., Ltd. Device 4002
Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin B routed to IRQ 5
Region 4: I/O ports at 0500 [size=32]
Kernel modules: i2c-i801

01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4400] (rev a3) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 8073
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248 (1250ns min, 250ns max)
Interrupt: pin A routed to IRQ 10
Region 0: Memory at e8000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at d8000000 (32-bit, prefetchable) [size=128M]
Region 2: Memory at e0000000 (32-bit, prefetchable) [size=512K]
[virtual] Expansion ROM at e0080000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nvidia_96, nouveau, nvidiafb, rivafb

02:02.0 Ethernet controller: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 (rev 11)
Subsystem: SiteCom Europe BV Device 0020
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (63750ns min, 63750ns max), Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 11
Region 0: I/O ports at 9000 [size=256]
Region 1: Memory at eb000000 (32-bit, non-prefetchable) [size=1K]
[virtual] Expansion ROM at 20000000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: tulip
Kernel modules: tulip

02:03.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
Subsystem: TERRATEC Electronic GmbH DMX 6fire 24/96
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64
Interrupt: pin A routed to IRQ 5
Region 0: I/O ports at 9400 [size=32]
Region 1: I/O ports at 9800 [size=16]
Region 2: I/O ports at 9c00 [size=16]
Region 3: I/O ports at a000 [size=64]
Capabilities: <access denied>
Kernel driver in use: ICE1712
Kernel modules: snd-ice1712

Tot wat voor inzicht leidt dit allemaal?

Edit: code tags
« Laatst bewerkt op: 2012/01/13, 22:53:43 door Johan van Dijk »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #4 Gepost op: 2012/01/14, 00:15:45 »
Dit lijd tot het inzicht of je kaart herkent wordt, dat wordt de kaart inderdaad, zoals blijkt uit lspci -vv:
02:03.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)
Subsystem: TERRATEC Electronic GmbH DMX 6fire 24/96
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64
Interrupt: pin A routed to IRQ 5
Region 0: I/O ports at 9400 [size=32]
Region 1: I/O ports at 9800 [size=16]
Region 2: I/O ports at 9c00 [size=16]
Region 3: I/O ports at a000 [size=64]
Capabilities: <access denied>
Kernel driver in use: ICE1712
Kernel modules: snd-ice1712
In de laatste twee regels is te zien dat de kernel driver en de kernel module zijn geladen.
Als je wilt, kan je dan nog wat commando's typen in de terminal? Het beste is om de commando's te kopiëren en te plakken:

aplay -l
cat /proc/asound/card0/codec#* | grep Codec
lspci | grep -i audio
En kan je de uitkomst hier plaatsen van elk commando?

Had je al het pakket alsa-tools-gui geïnstalleerd?
GUI based ALSA utilities for specific hardware

A collection of GUI based ALSA utilities for specific sound hardware:

 echomixer - control tool for Echoaudio soundcards
 envy24control - control tool for Envy24 (ice1712) based soundcards       <-------------- Deze dus.
 hdspconf - GUI program to control the Hammerfall HDSP Alsa Settings.
 hdspmixer - tool to control the advanced routing features of the
             RME Hammerfall DSP.
 rmedigicontrol - control tool for RME Digi32 and RME Digi96 soundcards

Ik weet niet of dit laatste eventueel jou helpt, je kan het pakket altijd weer verwijderen.
In der Beschränkung zeigt sich der Meister.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #5 Gepost op: 2012/01/15, 17:32:13 »
Gijsbert, de commando's geven het volgende resultaat.

aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: DMX6Fire [TerraTec DMX6Fire], apparaat 0: ICE1712 multi [ICE1712 multi]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

cat /proc/asound/card0/codec#* | grep Codec
cat: /proc/asound/card0/codec#*: Bestand of map bestaat niet

lspci | grep -i audio
02:03.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI Multi-Channel I/O Controller (rev 02)

Pakket alsa-tools-gui was niet geïnstalleerd. Dat heb ik alsnog gedaan, maar dat gaf geen geluid (zonder herstart van de pc).

Het geluidsprobleem deed zich ook na installatie van 10.04 voor. Met hulp van het forum heb ik de Pulse-workaround doorgevoerd die ik aan het begin van dit topic heb beschreven. Toen de geluidskaart het na installatie van 11.10 ook niet deed, heb ik die workaround eerst uitgeprobeerd als oplossing. De bestanden die je met de oplossing wijzigt, zijn onder 10.04 en 11.10 namelijk hetzelfde. Wat ik niet begrijp is warom de workaround het nu niet doet.

Ik lees graag je reactie. Gr, Peter

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #6 Gepost op: 2012/01/15, 20:04:35 »
Heb je ook nog een onboard kaart op het moederbord? Deze nl VIA Technologies Inc., kan je die in de BIOS uitzetten?
In der Beschränkung zeigt sich der Meister.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #7 Gepost op: 2012/01/16, 20:42:19 »
Op het moederbord (EPoX 4BEA, S-478, i845E) zit inderdaad een geluidskaart. In een ander topic had ik gelezen dat het handig kan zijn die uit te zetten. Ik heb in de BIOS gezocht, en daar staat AC97-audio op disabled. Verder heb ik in de BIOS niets kunnen ontdekken wat met geluid te maken heeft (maar ik ben geen BIOS-deskundige).

Heb je overigens een idee waarom de workaround het nu niet doet, terwijl naar mijn idee de bestanden waarmee dat gebeurt hetzelfde zijn als onder 10.04 waar die workaround het wèl deed? Wat wie weet ligt daarin misschien de/een oplossing.

Gr, Peter
« Laatst bewerkt op: 2012/01/16, 20:51:27 door plek »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #8 Gepost op: 2012/01/16, 20:56:15 »
Daar kan het dan niet aan liggen. Mocht het een troost zijn: Heel veel mensen hebben er last van bij de upgrade naar 11.10.
Ik kwam een oplossing tegen, alleen jij kan die uitproberen. Maak in ieder geval een reserve map aan.
http://ubuntuforums.org/showpost.php?p=11410244&postcount=22 De punt voor .gconf betekent dat hety een verborgen map is. Als je met Nautilus je eigen map opent en tegelijkertijd CTRL+H ingedrukt houdt krijg je alle verborgen mappen en bestanden te zien, nog een keer CTRL+H indrukken en ze zijn weer verborgen. Ben benieuwd of dit voor jou de oplossing is.
In der Beschränkung zeigt sich der Meister.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #9 Gepost op: 2012/01/21, 15:07:15 »
Ik heb op icoon Persoonlijke map geklikt, en nadat de inhoud was weergegeven op Ctrl+H gedrukt. Daardoor werd ook de map .gconf zichtbaar, maar de map .gconf/system/pulse heb ik niet kunnen ontdekken.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #10 Gepost op: 2012/01/21, 19:16:03 »
Dan zit daar het probleem niet, het was de juist de bedoeling om de map pulse daar te verwijderen.
Ik ga verder zoeken. :)
In der Beschränkung zeigt sich der Meister.

Offline plek

  • Lid
  • Steunpunt: Nee
Re: Geen geluid DMX 6fire 24/96 Ubuntu 11.10
« Reactie #11 Gepost op: 2012/01/23, 21:51:17 »
Dank Gijsbert. Ik wacht in spanning af :D