Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ALSA-sound driver instaleren en configureren  (gelezen 2940 keer)

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
ALSA-sound driver instaleren en configureren
« Gepost op: 2011/12/21, 23:55:54 »
Ik heb enorme problemen met mijn geluid, dus daarom kreeg ik van velen aangeraden om over te stappen op ALSA i.p.v. Pulse-audio.
Zo gezegd, zo gedaan, maar bij het installeren loop ik al vast.
in de INSTALL file staat:
8) Run 'modprobe snd-xxxx' where xxxx is the name of your card.Nou heb ik ten eerste geen flauw idee hoe ik ik op die 'xxxx' moet komen,
(Ik heb wel wat geprobeerd, maar 'rev02' is alleen waar die chipset familie op zit, niet de audio)
Ik heb ooit, ergens iets gelezen hoe je dat doet maar het is niet bepaald blijven zitten :D
Verder, gaat het er mij vervolgens vooral om: Hoe laat je Wine (1.3) er mee werken?
Volgens sommigen moet ik dan naar de 'wine config file' gaan, maar de map /.../.wine/config/ bestaat al niet..., dus zit de file daar ook niet in...

Verdere info:
ALSA map staat in: $HOME/Documenten/alsa-driver-1.0.24/
Ik gebruik Ubuntu 11.10
Chipset/Geluidskaart: Intel 82801I (ICH9 Fam.)

Iedereen heel erg bedankt!
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #1 Gepost op: 2011/12/22, 02:47:53 »
Volgens mij haal je wat dingen door elkaar.
ALSA is standaard al geïnstalleerd en is de standaard "driver" voor je geluid.
Pulseaudio zorgt bij desktopsystemen dat het de enige gebruiker is van de ALSA drivers, zodat het geluid kan mixen etc. voordat het bij ALSA terecht komt.
Programma's die geluid af willen spelen sturen hun geluid naar Pulseaudio, die doet er wat leuks mee en stuurt het door naar ALSA. ALSA stuurt het uiteindelijk naar je geluidskaart.

Pulseaudio uit dat systeem halen en dus je programma's alles direct naar ALSA laten sturen kan wel, maar is niet aan te raden bij normaal gebruik.

Het handigste is om eerst wat informatie te verzamelen. Welke hardware zit er in je systeem, welke versie van Ubuntu draai je, wordt je hardware goed gedetecteerd, enz.
Geef ook aan of je totaal geen geluid hebt of dat het alleen bij sommige toepassingen niet werkt, enz.
Plaats de antwoorden op bovenstaande vragen in je post.

Vervolgens (in dezelfde post, of een nieuwe) de resultaten van de volgende commando's:
sudo lspci
lsmod |grep snd
aplay-l

Het zijn allemaal losse commando's, plaats de resultaten tussen [code]...[/code] tags zodat alles leesbaar blijft op het forum.

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #2 Gepost op: 2011/12/22, 09:16:27 »
'sudo lspci': 00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
(Alleen de audio kaart, er zat verder óók alle info bij over m'n host brigde, maar die is, dacht ik, nu niet van belang)

'lsmod | grep snd': Niks

'aplay -l': aplay: device_list:240: geen geluidskaarten gevonden...

Subsysteem: Dell OptiPlex 755 (Niet met orginele Processor, RAM en Videokaart)
OS: Dual Boot: WinVista / Ubuntu 11.10

Ik heb zelf niet heel vaak problemen met m'n audio kaart, alleen sinds 11.10 is ie een beetje aan het glitchen soms...
Alles werkt gewoon, behalve een paar programma's waaronder het Ubuntu opstart deuntje en Wine (die werkt qua geluid al niet sinds 11.04)
Het zou fijn zijn als deze programma's ook werkten...
En waarom is het niet slim om Pulse audio uit te schakelen?

Uit deze command komt:
$ lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Subsystem: Dell Optiplex 755
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at febdc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])
« Laatst bewerkt op: 2011/12/22, 17:15:19 door brickmasterj »
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #3 Gepost op: 2011/12/22, 09:22:05 »
****, nu heb ik ineens TOTAAL geen geluid meer...  :-[
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #4 Gepost op: 2011/12/22, 17:05:26 »
Weet iemand hoe ik m'n geluid weer terug krijg? Onder het kopje Hardware in Geluids instellingen staat nu niks meer, i.p.v. Webcam en Intern Geluid...
HELP!!!
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #5 Gepost op: 2011/12/22, 22:12:01 »
Je zou alvast deze hyperlink kunnen checken http://sites.google.com/site/computertip/geengeluid
Post verder de output van lsmod | grep snd [Enter]
 
Heb je verder nog wel geluid, als je de PC opstart vanaf de Ubuntu 11.10 CD als Live CD?
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #6 Gepost op: 2011/12/23, 12:18:27 »
Je zou alvast deze hyperlink kunnen checken http://sites.google.com/site/computertip/geengeluid
Post verder de output van lsmod | grep snd [Enter]
 
Heb je verder nog wel geluid, als je de PC opstart vanaf de Ubuntu 11.10 CD als Live CD?

Sorry hoor, maar nadat ik die command had gedaan, had ik geen geluid meer...
Ik heb het nu gerepareerd, door HEEL Pulse-Audio en ALSA opnieuw te installeren, maar nu ga ik niet nog een keer die command doen...
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #7 Gepost op: 2011/12/23, 18:29:04 »
Dat is onmogelijk.
Het enige wat die commando's doen is kijken welke drivers er in gebruik zijn, en filteren zodat je alleen de drivers voor geluid in beeld krijgt.

Was je niet tegelijkertijd ook andere dingen aan het proberen waardoor het geluid uitviel?

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #8 Gepost op: 2011/12/23, 18:46:26 »
Dat is onmogelijk.
Het enige wat die commando's doen is kijken welke drivers er in gebruik zijn, en filteren zodat je alleen de drivers voor geluid in beeld krijgt.

Was je niet tegelijkertijd ook andere dingen aan het proberen waardoor het geluid uitviel?
Dan weet ik het ook niet meer, maar na die specefieke command deed heel m'n audio systeem het niet meer, maar nu komt er uit 'aplay -l' wel ineens:
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: AD198x Analog [AD198x Analog]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0
kaart 0: Intel [HDA Intel], apparaat 1: AD198x Digital [AD198x Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
Dat kwam er na de 'lsmod | grep snd' niet...
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #9 Gepost op: 2011/12/23, 19:19:48 »
Wat heb je in de tussentijd allemaal aan je systeem aangepast?
Gisteren gaf hetzelfde commando nog helemaal niks als resultaat en nu wel... zo wordt het niet makkelijker om uit te zoeken waar het probleem zit, laat staan hoe het opgelost kan worden.

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #10 Gepost op: 2011/12/23, 20:54:08 »
Wat heb je in de tussentijd allemaal aan je systeem aangepast?
Gisteren gaf hetzelfde commando nog helemaal niks als resultaat en nu wel... zo wordt het niet makkelijker om uit te zoeken waar het probleem zit, laat staan hoe het opgelost kan worden.
Niks, dat was het rare... Anyway, Sorry voor alle ophef, na nog een paar na-zoekingen, heb ik de command toch nog maar eens geprobeerd, en nu flipte m'n systeem hem niet, maar gaf de uitkomst waar jullie allemaal op zaten te wachten:
~$ lsmod | grep snd
snd_hda_codec_analog    75090  1
snd_usb_audio         100880  1
snd_usbmidi_lib        24558  1 snd_usb_audio
snd_hda_intel          24262  3
snd_hda_codec          91754  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep              13276  2 snd_usb_audio,snd_hda_codec
snd_pcm                80435  4 snd_usb_audio,snd_hda_intel,snd_hda_codec
snd_seq_midi           13132  0
snd_rawmidi            25241  2 snd_usbmidi_lib,snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
snd_timer              28932  2 snd_pcm,snd_seq
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    55902  18 snd_hda_codec_analog,snd_usb_audio,snd_usbmidi_lib,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              12600  1 snd
snd_page_alloc         14115  2 snd_hda_intel,snd_pcm

~$ aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: AD198x Analog [AD198x Analog]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0
kaart 0: Intel [HDA Intel], apparaat 1: AD198x Digital [AD198x Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
Dus, srry, maar nu weer back to the point,
Ik was sowieso al van plan om een los intern PCI (of PCIe x1) los geluids kaartje te kopen, misschien kan pulse daar beter mee omgaan...
Ik zat te denken (voor iets goedkoops) aan:
Sweex Sound Card 5.1 PCI SC012 (Intern) of CiT SC-1723 5.1 PCI Sound Card
(Allebei tussen de 5 en 15 Euro's)
Of zijn er betere alternatieven? Of zal een nieuwe geluidskaart sowieso geen verschil kunnen brengen in m'n probleem?

Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #11 Gepost op: 2011/12/23, 21:09:16 »
Tegenwoordig is een goedkope PCI geluidskaart niet beter, dan onboard geluid. Je zou eventueel deze Sweex 5.1 PCI Sound Card kunnen proberen. Alleen moet je er niet al te veel van verwachten. 
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #12 Gepost op: 2011/12/23, 21:17:24 »
Blijkbaar worden de juiste drivers voor je geluidskaart wel gevonden en geladen, dus waarschijnlijk zit er in de instellingen iets niet helemaal lekker.
Heb je al bij je geluidsvoorkeuren gekeken of er niet toevallig gekozen is voor digitaal geluid? Zo ja, zet die dan even om.

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #13 Gepost op: 2011/12/23, 21:38:11 »
Blijkbaar worden de juiste drivers voor je geluidskaart wel gevonden en geladen, dus waarschijnlijk zit er in de instellingen iets niet helemaal lekker.
Heb je al bij je geluidsvoorkeuren gekeken of er niet toevallig gekozen is voor digitaal geluid? Zo ja, zet die dan even om.
Geluidsvoorkeuren? Bedoel je 'pavucontrol' ofzo?
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline brickmasterj

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #14 Gepost op: 2011/12/23, 21:42:02 »
Tegenwoordig is een goedkope PCI geluidskaart niet beter, dan onboard geluid. Je zou eventueel deze Sweex 5.1 PCI Sound Card kunnen proberen. Alleen moet je er niet al te veel van verwachten.  
Daar gaat het me ook zo zeer niet om, maar meer: éérst maar eens probleem-loos geluid eruit krijgen...
En dat geld vooral voor Wine, gamen zonder geluid is als Ubuntu zonder sudo...
Maar als een losse PCI geluids kaart nog niks uitmaakt, ben ik ook niet van plan om hem te kopen.
Workstation:
Dell Precision 690 Workstation
Dual Xeon X5365 Quad (8-Cores @3.0GHz)
64GB DDR2 R.A.M.
Sapphire Radeon HD 6570 (2GB GDDR3)

PC:
Dell OptiPlex 755
Intel Core 2 Duo E8400 (2-Cores @3,00Ghz)
4GB DDR2 R.A.M.
ATi Radeon HD 2400 XT (258MB GDDR2)

IGN: brickmasterj (of brickmaster-j)

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: ALSA-sound driver instaleren en configureren
« Reactie #15 Gepost op: 2011/12/23, 22:31:16 »
Ik doel vooral op de geluidskwaliteit. Eventueel zou je een Sound Blaster Live 5.1 kunnen proberen, lees ik hier http://superuser.com/questions/199536/why-does-most-on-board-sound-worse-than-dedicated-sound-cards Die ervaring daarin deel ik overigens niet, wat onboard geluid betreft dan. Een PCI geluidskaart zou je alleen moeten proberen, wanneer je zelf vind dat onboard sound niet voldoet.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro