Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (helaas nog niet opgelost)Gtkpod udate in 10.04  (gelezen 1772 keer)

Offline Arend8810

  • Lid
  • Steunpunt: Nee
(helaas nog niet opgelost)Gtkpod udate in 10.04
« Gepost op: 2011/12/19, 21:16:55 »
Ik wil graag gtkpod 0.99.14 die ik via het softwarecentrum heb geinstalleerd updaten naar de nieuwe versie 2.0.2. Ik heb een ipod nano 6e generatie, en de oude gtkpod versie werkt hier nog niet mee.. Ik heb de nieuwe versie gedowload, maar krijg hem niet geinstalleerd. De installatie-data die in de INSTALL map staan heb ik doorlopen, maar ik krijg hem niet aan de praat. Iemand een tip?
« Laatst bewerkt op: 2012/01/03, 21:33:23 door Arend8810 »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Gtkpod udate in 10.04
« Reactie #1 Gepost op: 2011/12/19, 22:20:21 »
Heb je het laatste deel gelezen, speciaal voor Ubuntu en Debian, welke afhankelijkheden je moet installeren voordat je gtkpod installeerd.
De regel met # ervoor geeft aan wat je moet doen, gevolgd door de terminal commando's
Quick guide for Ubuntu/Debian

The following steps were necessary to install libgpod and gtkpod on a fairly virgin Ubuntu Hardy (LTS 8.04) installation.

# required packages
sudo apt-get install autoconf flex gettext libglib2.0-dev libgtk2.0-dev libglade2-dev libid3tag0-dev libxml-parser-perl pkg-config automake gcc git-core gtk-doc-tools

# recommended packages
sudo apt-get install libcurl4-dev libflac-dev libgnomevfs2-dev libhal-dev libvorbis-dev libmp4v2-dev libwebkit-dev

# checkout libgpod and gtkpod
git clone git://gtkpod.git.sourceforge.net/gitroot/gtkpod/libgpod
git clone git://gtkpod.git.sourceforge.net/gitroot/gtkpod/gtkpod

# compile libgpod
cd libgpod/
./autogen.sh
make
sudo make install

# compile gtkpod
cd ../gtkpod/
cd libgpod/
./autogen.sh
make
sudo make install
sudo ldconfig

#start gtkpod
gtkpod &
In der Beschränkung zeigt sich der Meister.

Offline Arend8810

  • Lid
  • Steunpunt: Nee
Re: Gtkpod udate in 10.04
« Reactie #2 Gepost op: 2011/12/20, 19:23:58 »
Ik heb idd uitgevoerd wat er stond, maar geen gtkpod te bekennen, tenminste geen nieuwe versie, of moet je na het installeren van al die extra's nog iets doen. Is het aan te raden om via softwarecentrum de oude versie al te installeren, of is het beter om dit niet te doen.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Gtkpod udate in 10.04
« Reactie #3 Gepost op: 2011/12/20, 20:07:45 »
Je kan beter eerst de oude versie verwijderen. :)
In der Beschränkung zeigt sich der Meister.

Offline Arend8810

  • Lid
  • Steunpunt: Nee
Re: Gtkpod udate in 10.04
« Reactie #4 Gepost op: 2011/12/21, 21:33:56 »
Ik heb alles geprobeerd wat er in de betreffende installatiemappen staat maar gtkpod zie ik niet verschijnen. Nu, gdverdmme, 't is natuurlijk wel klte dat je moet gaan zitten rommelen om een ipod aan de praat te krijgen. Vroeger had ik wel een boontje voor Apple producten, maar nu begint hun alomtegenwoordgheid en pieterige verplichtingen als itunes behoorlijk te irriteren, itunes werkt tot nu toe perfect voor ipod, maar 't is wel lullig dat dit enkel via windows of os draait. Nu, ik ga nog wat experimenteren, en zal wel een oplossing vinden.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Gtkpod udate in 10.04
« Reactie #5 Gepost op: 2011/12/22, 00:22:30 »
Snelste manier open een terminal (onder Hulpmiddelen) en type gtkpod en geef een ENTER, gebeurt er niets of je krijgt de mededeling dat gtkpod niet geïnstalleerd is, dan is er wat fout gegaan bij het compileren.
Ga eens naar Locaties > En klik op bestanden zoeken>Selecteer het Bestandsysteem en zoek op gtkpod. Als het goed is worden een hoop bestanden gevonden. Kijk nu of er een map usr/bin is waar gtkpod inzit. Maak een starter aan met dit pad.
Mocht iets niet duidelijk zijn, kan ik de installatie stap voor stap doornemen.
In der Beschränkung zeigt sich der Meister.

Offline Arend8810

  • Lid
  • Steunpunt: Nee
Re: Gtkpod udate in 10.04
« Reactie #6 Gepost op: 2011/12/22, 19:49:45 »
Het bestand zit idd in usr/bin, maar als ik dit open, opent gtkpod 0.99.14, degene die ook in de synaptic staat; als ik daarop 0.99.14 via synaptic verwijder, verdwijnt ook het gtkpod bestand in usr/bin.  Ik heb hierop nog eens de procedure doorlopen die bij de download zit en die jij ook aangeeft, maar het resultaat blijft hetzelfde. Is er zowieso een standaard om een programma welke is gedownload buiten synaptic, te installeren?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Gtkpod udate in 10.04
« Reactie #7 Gepost op: 2011/12/22, 23:27:34 »
Synaptic is met het hele systeem verweven, vandaar dat je eerst de oude versie geheel moet verwijderen. Buiten Synaptic kan je best allerlei bestanden installeren, bijv een tar of dergelijke. Het enige probleem kan zijn dat er niet in de mappen wordt geïnstalleerd waar Synaptic niet installeert. Bijv. de map /opt, daar heb ik diverse programma's staan. Je moet alleen zelf een starter aanmaken naar dat programma. Soms kan je een deb downloaden en installeren met de pakketmanager, alleen kan het zijn dat er niet kan worden voldaan aan afhankelijkheden(bibliotheken).
Ik ben even bezig geweest met de tar en met de deb. De installatie lukt niet door de afhankelijkheden. Of je kan nu upgraden naar Ubuntu 11.10 of als je tot mei geduld hebt, upgraden naar de 12.04 LTS, dit kan direct vanuit 10.04

Nog even de foutmeldingen van de tar:
Today :         do dec 22 22:43:22 CET 2011
  System :         Ubuntu 10.10 (maverick)
  Kernel :         GNU/Linux 2.6.35-28-generic (x86_64)


───[gijs@gijs-desktop]──[22:43]──> /home/gijs
k2.0-dev libglade2-dev libid3tag0-dev libxml-parser-perl pkg-config automake gcc git-core gtk-doc-tools
[sudo] password for gijs:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
autoconf is reeds de nieuwste versie.
automake is reeds de nieuwste versie.
automake is ingesteld voor handmatige installatie.
gcc is reeds de nieuwste versie.
gettext is reeds de nieuwste versie.
gettext is ingesteld voor handmatige installatie.
libxml-parser-perl is reeds de nieuwste versie.
pkg-config is reeds de nieuwste versie.
git-core is reeds de nieuwste versie.
libglib2.0-dev is reeds de nieuwste versie.
libglib2.0-dev is ingesteld voor handmatige installatie.
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 libglade2-dev : Vereisten: libxml2-dev maar het zal niet geïnstalleerd worden
 libgtk2.0-dev : Vereisten: libpango1.0-dev (>= 1.20) maar het zal niet geïnstalleerd worden
                 Vereisten: libcairo2-dev (>= 1.6.4-6.1) maar het zal niet geïnstalleerd worden
E: Niet-werkende pakketten:

───[gijs@gijs-desktop]──[22:44]──> /home/gijs
libhal-dev libvorbis-dev libmp4v2-dev libwebkit-devbgnomevfs2-dev  
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
Let op, 'libcurl4-gnutls-dev' wordt geselecteerd, in plaats van 'libcurl4-dev'
libvorbis-dev is reeds de nieuwste versie.
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 libgnomevfs2-dev : Vereisten: libgconf2-dev (>= 2.8.0-1) maar het zal niet geïnstalleerd worden
                    Vereisten: libxml2-dev maar het zal niet geïnstalleerd worden
                    Vereisten: libavahi-glib-dev (>= 0.6) maar het zal niet geïnstalleerd worden of
                               hurd maar het is niet installeerbaar
 libwebkit-dev : Vereisten: libwebkit-1.0-2 (= 1.2.4-1ubuntu1) maar 1.2.5-0ubuntu0.10.10.1 zal geïnstalleerd worden
                 Vereisten: libgtk2.0-dev maar het zal niet geïnstalleerd worden
                 Vereisten: libsoup2.4-dev (>= 2.27.91) maar het zal niet geïnstalleerd worden
E: Niet-werkende pakketten:

Edit: 10.04 is gtk 2 while gtkpod 2.1.0 is gtk3. The last gtk2 version is 2.0.1 so you should try that version. The latest ubuntu is gtk3.
van http://blog.gmane.org/gmane.comp.ipod.gtkpod.user/month=20111201
Van deze link http://ubuntuforums.org/showthread.php?t=1765258 naar https://launchpad.net/~phantomjinx/+archive/gtkpod-2.0.1-beta

Vergeet niet, om eerst de oude versie te verwijderen.

En zo ziet het er uit:



Klik op het plaatje voor een groter beeld.

« Laatst bewerkt op: 2011/12/22, 23:51:17 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline Arend8810

  • Lid
  • Steunpunt: Nee
Re: Gtkpod udate in 10.04
« Reactie #8 Gepost op: 2011/12/23, 22:12:27 »
Ik heb de oude versie proberen 'volledig' te verwijderen via synaptic, maar de na het downloaden en uitvoeren  van 2.0.1 werd na 'sudo apt-get install gtkpod' toch weer versie 0.99.14 geinstalleerd. 11.10 heb ik effe uitgeprobeerd maar die liep zeer traag op mijn computer (acer aspire T135 met amd en 250 mb geheugen) met haperingen en freezes. Ik zal de ipod dan maar voorlopig bedienen via Vista en Itunes. Toch in ieder geval bedankt voor je tips en tijd, sorry dat ze tot nu toe nog niet geholpen hebben. De links die je hebt doorgegeven had ik al eens bezocht maar hebben ook geen resultaat gehad. Wel jammer, hierin vindt ik Ubuntu toch een nadeel hebben; het feit dat het niet altijd 'plug and play' is, alhoewel dit in het geval van een Ipod meer aan Apple ligt dan aan Ubuntu, voor de rest heb ik tot nu toe weinig problemen ondervonden met diverse hardware. Waarschijnlijk ontbeer ik misschien wat fingerspitzengefuhl met Linux en zijn toverspreuken  :|

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Gtkpod udate in 10.04
« Reactie #9 Gepost op: 2011/12/23, 23:44:21 »
Verwijder eerst weer de oudere versie, hierna sluit je Synaptic en/of het Ubuntu software centrum.Nu onderstaande uitvoeren.
Je moet de laatste link volgen: Deze dus https://launchpad.net/~phantomjinx/+archive/gtkpod-2.0.1-beta Hiermee voeg je een bron toe, PPA,.
Klik op Read about installing Open een terminal.
Het eerste commando is sudo add-apt-repository ppa:ppa:phantomjinx/gtkpod-2.0.1-beta en geef een ENTER, nu moet je het wachtwoord intypen, hier zie je niets van, gewoon blind typen, en geef een ENTER.
Voor de verdere stappen kan je gewoon de commando's van de plaatjes of tekst volgen.
In der Beschränkung zeigt sich der Meister.

Offline Arend8810

  • Lid
  • Steunpunt: Nee
Re: Gtkpod udate in 10.04
« Reactie #10 Gepost op: 2012/01/03, 21:31:38 »
Sorry, ben effe afwezig geweest.

Ik heb nog een heel tijd zitten klooien met Gtkpod, Banshee, Amarok en Rythmbox, instellingen allerlei in+ en her-installaties van 10.04, en 10.10 en ik heb van ellende heel ubuntu uiteindelijk ervanaf gezwierd en helaas vista  :'( moeten installeren om fatsoenlijk met m'n ipod te kunnen werken. Ik was het effe heel erg moe om te moeten gaan zitten experimenteren om een wereldwijd gebruikt item als een ipod te kunnen gebruiken. Heel erg jammer, en ik weet niet wat er nu iriterender is; Een heerlijk OS als Ubuntu die helaas m'n ipod weigert of een klXXte 'os' als vista. Nu, voorlopig ga ik het hierbij houden. Mocht het me op één of andere manier toch nog lukken dan laat ik het je zeker weten.
Groetjes.