Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geen geluid  (gelezen 2201 keer)

Offline oetspiek

  • Lid
  • Steunpunt: Nee
geen geluid
« Gepost op: 2011/12/03, 00:58:25 »
Heb net de laatste versie van ubuntu 11.10 op mijn medion md 96218 geinstalleerd en heb geen geluid.
Geluidkaart/chip is een ati ixp sb4x0 high definition, de laatste alsa versie geprobeert maar werkt daar ook niet mee.
Kan modem in bios niet uitschakelen en diverse schuifjes geprobeert maar het lukt niet.
Wie heeft het wel werkend op een medion of heeft er een script voor, baal als een stekker.

Jan

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #1 Gepost op: 2011/12/03, 13:29:25 »
Is er een speciale reden om te gaan voor de nieuwste Ubuntu 11.10? Want je md 9621 is zo te zien, niet al te nieuw meer. Daarop had je net zo goed Ubuntu 10.04 LTS op kunnen installeren. Je had de laatste alsa versie geprobeerd. Bedoel je zo iets als in deze thread ALSA Upgrade Script. Je zou alle informatieve ouputs uit bericht #603 kunnen uitvoeren. Behalve die sudo commando.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #2 Gepost op: 2011/12/04, 11:58:17 »
Deze laptop is vrij gekomen omdat wij een andere hebben gekocht, voorheen had ik een HP een nog oudere versie.
Dus dacht zo windows eraf en de nieuwste ubuntu erop, maar nu loop ik tegen het geluid issue.
Begrijp ik het goed dat ubuntu 10.04 LTS wel goed zal gaan werken qua geluid.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #3 Gepost op: 2011/12/04, 12:47:48 »
Dat kan ik niet met zekerheid zeggen. Het downloaden van een Ubuntu 10.04.3 image en er een CD-R(W) van branden. Zodat je laptop daarmee kan opstarten als Live CD, is de enige manier om daar achter te komen.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #4 Gepost op: 2011/12/04, 17:43:07 »
heb net 10.10 erop gezet en geluid doet het niet.

@Je zou alle informatieve ouputs uit bericht #603 kunnen uitvoeren. Behalve die sudo commando

werkte ook niet.

Men zegt dat je de modem moet uitschakelen in bios, heb ik naar gekeken maar mogelijkheid is er niet.
vraag:

Kan dit via terminal en wie heeft wel eens een bios update gedaan van medion MD 96218?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #5 Gepost op: 2011/12/04, 18:07:51 »
Die commando's zijn dan niet bedoelt om het probleem op te lossen. Die cat /proc/asound/version toont de geïnstalleerde ALSA versie. Die  aplay -l toont hoe je playback hardware-apparaten worden herkend. Ook alsamixer geeft info over je geluidskaart. De bedoeling daarvan is, dat je die info hier post. Post ook nog de output van lsmod | grep snd die toont welke modules voor je geluidskaart zijn geladen.

Als je er via commando lsmod er achter kan komen welke module er geladen wordt voor je modem, dan zou je die module in de /etc/modprobe/blacklist.conf kunnen plaatsen. Je zou de output kunnen posten van commando lspci
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #6 Gepost op: 2011/12/04, 18:32:02 »
@ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.

@aplay -l
kaart 0: SB [HDA ATI SB], apparaat 0: STAC92xx Analog [STAC92xx Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

@alsamixer
Card: HDA ATI SB                                     F1:  Help               │
│ Chip: SigmaTel STAC9200                              F2:  System information │
│ View: F3: Playback  F4: Capture  F5:[All]            F6:  Select sound card  │
│ Item: Capture [dB gain: 22,50, 22,50]                Esc: Exit               │
│                                                                              │
│                       ┌──┐     ┌──┐     ┌──┐     ┌──┐                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       │▒▒│     │▒▒│     │▒▒│     │  │                        │
│                       ├──┤     └──┘     └──┘     └──┘                        │
│                       │OO│                                                   │
│                       └──┘             L    R                                │
│                                       CAPTURE                                │
│                     100<>100 100<>100 100<>100   0<>0                        │
│                      Master    PCM   <Capture >  Mux     
@lsmod | grep snd

**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: SB [HDA ATI SB], apparaat 0: STAC92xx Analog [STAC92xx Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
jan@medion:~$ alsamixer
jan@medion:~$ alsamixer
jan@medion:~$ lsmod | grep snd
snd_hda_codec_idt      54887  1
snd_hda_intel          22107  2
snd_hda_codec          87552  2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep               5040  1 snd_hda_codec
snd_pcm                71475  2 snd_hda_intel,snd_hda_codec
snd_seq_midi            4588  0
snd_rawmidi            17783  1 snd_seq_midi
snd_seq_midi_event      6047  1 snd_seq_midi
snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
snd_timer              19067  2 snd_pcm,snd_seq
snd_seq_device          5744  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    49006  13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore                880  1 snd
snd_page_alloc          7120  2 snd_hda_intel,snd_pcm

Module                  Size  Used by
binfmt_misc             6599  1
sha256_generic         11267  2
aes_i586                7280  174
aes_generic            26875  1 aes_i586
parport_pc             26058  0
joydev                  8735  0
ppdev                   5556  0
dm_crypt               11385  1
snd_hda_codec_idt      54887  1
arc4                    1165  2
snd_hda_intel          22107  2
snd_hda_codec          87552  2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep               5040  1 snd_hda_codec
snd_pcm                71475  2 snd_hda_intel,snd_hda_codec
snd_seq_midi            4588  0
snd_rawmidi            17783  1 snd_seq_midi
snd_seq_midi_event      6047  1 snd_seq_midi
snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
snd_timer              19067  2 snd_pcm,snd_seq
snd_seq_device          5744  3 snd_seq_midi,snd_rawmidi,snd_seq
rtl8180                27401  0
mac80211              231541  1 rtl8180
eeprom_93cx6            1345  1 rtl8180
snd                    49006  13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
psmouse                59033  0
cfg80211              144470  2 rtl8180,mac80211
serio_raw               4022  0
soundcore                880  1 snd
shpchp                 29886  0
i2c_piix4               8635  0
snd_page_alloc          7120  2 snd_hda_intel,snd_pcm
lp                      7342  0
parport                31492  3 parport_pc,ppdev,lp
radeon                825934  3
ttm                    56633  1 radeon
usbhid                 36882  0
drm_kms_helper         30200  1 radeon
video                  18712  0
hid                    67742  1 usbhid
drm                   168054  5 radeon,ttm,drm_kms_helper
output                  1883  1 video
sky2                   45127  0
ati_agp                 5202  0
pata_atiixp             3288  3
agpgart                32011  3 ttm,drm,ati_agp
i2c_algo_bit            5168  1 radeon


jan@medion:~$ lspci
00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller (rev 80)
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 83)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: ATI Technologies Inc IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8038 PCI-E Fast Ethernet Controller (rev 14)
08:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)

Bedoel je dit?


Offline jolo

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #7 Gepost op: 2011/12/04, 20:34:47 »

Inderdaad. Je outputs lijken me in orde. Alleen zou ik meer regelaars verwacht hebben met alsamixer. Of is hier het kopiëren/plakken mislukt?

Op welke wijze zijn de PC speakers aangesloten, op de onboard geluidskaart? Op het Engelstalige Ubuntu forum zie ik bijvoorbeeld deze thread No sound through hdmi (radeon hd 4200) on ubuntu 11.10. Ik vond nog wel een bug report. Alleen ging dat over Geen geluid na stanby. https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/801079

Ik heb overigens geen modem kunnen vinden, in de outputs. Maar ook niet bij de Technische specificaties http://www.vergelijk.nl/notebook/medion/md_96218/specs.rhtml
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #8 Gepost op: 2011/12/04, 21:40:44 »
@Je outputs lijken me in orde. Alleen zou ik meer regelaars verwacht hebben met alsamixer. Of is hier het kopiëren/plakken mislukt?

Nee klopt wel, zal even op engelse forum kijken.

Jan


Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #9 Gepost op: 2011/12/04, 22:22:09 »
Het is wel jammer, wordt gedwongen om weer naar windows te gaan ???

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #10 Gepost op: 2011/12/05, 00:50:38 »
Heb je bij Geluidsinstellingen onder het tabblad Uitvoer iets veranderd aan "Connector", indien aanwezig? Dat kan wel eens helpen.

Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #11 Gepost op: 2011/12/05, 20:07:35 »
@Heb je bij Geluidsinstellingen onder het tabblad Uitvoer iets veranderd aan "Connector", indien aanwezig? Dat kan wel eens helpen.

Bij connector staat analoge output, kan ik niet veranderen.

Iets op een Engelse forum gelezen over de video driver die je moet updaten.
Het is een Ati radeon express 200M, zou dit van invloed kunnen zijn op de drivers van geluid?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #12 Gepost op: 2011/12/05, 21:02:43 »
En als je checkt bij Geluidsinstellingen, tabblad Uitvoer. Uit welke apparaten voor geluidweergave kun je kiezen? En Geluidsinstellingen, tabblad Hardware, Speakers testen. En daar je speakers test. Staat daar wel het juiste apparaat bij Profiel?

In welke Engelstalige thread had je gelezen over het updaten van de video driver? Welke video drivers had je dan geïnstalleerd? Gebruikelijk is, typen in Dash: stuur. Zodat je kunt klikken op Extra stuurprogramma's. Waar je dan FGLRX van ATI/AMD selecteert. Tenminste, als deze nog niet in gebruik is. Deze heeft bij mijn weten geen invloed op het geluid.   
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #13 Gepost op: 2011/12/05, 21:13:20 »
Intern geluid analoog stereo, als geluidsweergave. Maar ik kan niet kiezen ofzo
Bij hardware staat analoog stereo output, -input, - duplex kan uit deze 3 kiezen maar werken niet.

Offline oetspiek

  • Lid
  • Steunpunt: Nee
Re: geen geluid
« Reactie #14 Gepost op: 2011/12/05, 22:29:56 »
Heb het gevonden!!!!

http://www.serenux.com/2009/02/howto-get-sigmatel-stac-9200-chipset-audio-working-in-ubuntu-intrepid/

Mouhcine says:
August 9, 2009 at 10:02

I’ve also the STAC9200 on a Medion MD96282

with these steps it should work:

1) sudo gedit /etc/modprobe.d/alsa-base.conf

2) add the line: options snd-hda-intel model=gateway-m4

3) restart

4) enjoy the sound!

Blij Blij  =D