Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: libGL.so.1 word niet gevonden.  (gelezen 2179 keer)

Offline glaasje

  • Lid
  • Steunpunt: Nee
libGL.so.1 word niet gevonden.
« Gepost op: 2011/11/27, 14:15:49 »
Hallo allemaal! :)

Ik heb een probleempje.

Sinds ik Ubuntu 11.10 (clean) op mijn laptopje heb geïnstalleerd heb ik last van de fout:
error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
Toen ik keek of ik die wel had, kreeg ik dit:

locate libGL.so.1
/home/ivo/.apps/desura-x86_64/desura/common/red-eclipse/libs/libGL.so.1
/opt/voxatron/libGL.so.1
/usr/lib/i386-linux-gnu/mesa/libGL.so.1
/usr/lib/i386-linux-gnu/mesa/libGL.so.1.2
/usr/lib/nvidia-current/libGL.so.1
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1
/usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.2
/usr/lib32/mesa/libGL.so.1
/usr/lib32/mesa/libGL.so.1.2
/usr/lib32/nvidia-current/libGL.so.1

Ik heb 2 grafische kaarten (Optimus dus Intel en Nividia ;) ) en ik heb dus Bumblee geinstalleerd. ;)

Ik gebruik ook (voor nieuwere drivers ;) ) de ppa: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

Kan iemand mij helpen? :P
sine errores, nos discere nihil.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #1 Gepost op: 2011/11/27, 17:17:56 »

Offline glaasje

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #2 Gepost op: 2011/11/27, 17:36:14 »
Nope, geen resultaat... :(

Ik heb ondertussen bij Synaptic gekeken.
Als ik daar libGL.so.1 invoer in ze zoekbalk krijg ik als resultaat dat het pakket libgl1-mesa-swx11 niet is geïnstalleerd.

Als ik dit wil installeren dan wilt hij me allerlei pakketten verwijderen (waaronder bumblebee).
(Dit wil ik natuurlijk niet :P)

wat nu nog? :P
sine errores, nos discere nihil.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #3 Gepost op: 2011/11/27, 17:36:48 »
Je moet nvidia-glx-185 installeren.

Offline glaasje

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #4 Gepost op: 2011/11/27, 17:56:25 »
Helaas,

Geen resultaat :(

Ik krijg nog steeds:
ivo@ivo-W150HNM-W170HN:~$ '/home/ivo/Bureaublad/voxatron/vox-run'
./vox: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

moet ik dat ene pakket nu verwijderen? ;)
sine errores, nos discere nihil.

Offline glaasje

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #5 Gepost op: 2011/11/28, 18:07:59 »
*bump*
sine errores, nos discere nihil.

Offline rja

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #6 Gepost op: 2011/11/28, 19:06:51 »
Staan er geen libGL.so.1 op schijf ?

Doe eens in een terminal locate -i libGL.so.1


Offline niekn

  • Lid
    • omega-xis
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #7 Gepost op: 2011/11/28, 19:27:54 »
bumblebee beperkt je tot het uitvoeren van 64-bit spul op de nvidia-kaart.
ironhide heeft dat niet, maar ironhide heeft met sommige spellen last van gliches.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #8 Gepost op: 2011/11/28, 20:33:25 »
sudo apt-get install libgl1-mesa-glx:i386 libc6:i386

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #9 Gepost op: 2011/11/28, 20:35:30 »
sudo apt-get install libgl1-mesa-glx:i386 libc6:i386

Ja, dat kan ie inderdaad nog proberen.

Offline glaasje

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #10 Gepost op: 2011/11/28, 22:48:57 »
Helaas...

Dit heeft ook geen effect... :(

Dit keer heb ik een 64bit spel geprobeerd die hetzelfde probleem gaf maar ik heb nog steeds geen resultaat... :(
ivo@ivo-W150HNM-W170HN:~$ "/home/ivo/.apps/aquaria/aquaria"
Message: SDL_GL_LoadLibrary Error: Failed loading libGL.so.1

Ik heb dit ook me optirun geprobeerd.
Maar helaas geen resultaat. ;)
ivo@ivo-W150HNM-W170HN:~$ "/home/ivo/.apps/aquaria/aquaria"
Message: SDL_GL_LoadLibrary Error: Failed loading libGL.so.1
ivo@ivo-W150HNM-W170HN:~$ optirun "/home/ivo/.apps/aquaria/aquaria"
ERROR: ld.so: object 'libdlfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'librrfaker.so' from LD_PRELOAD cannot be preloaded: ignored.
X Error of failed request:  GLXUnsupportedPrivateRequest
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  16 (X_GLXVendorPrivate)
  Serial number of failed request:  25
  Current serial number in output stream:  26
sine errores, nos discere nihil.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #11 Gepost op: 2011/11/28, 22:55:54 »
Probeer eens:

sudo apt-get install libsdl1.2-dev

Als het daarna nog niet werkt, dan is er een ander probleem, namelijk dit: https://github.com/MrMEEE/bumblebee/issues/624
Oftewel: je moet een nieuwere versie van BumbleBee hebben dan die je nu hebt.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #12 Gepost op: 2011/11/28, 23:04:48 »
Mag het allemaal niet baten, doe dan een:

"/home/ivo/.apps/aquaria/aquaria"

Offline glaasje

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #13 Gepost op: 2011/11/29, 18:13:50 »
Nee helaas :(

ivo@ivo-W150HNM-W170HN:~$ "/home/ivo/.apps/aquaria/aquaria"
Message: SDL_GL_LoadLibrary Error: Failed loading libGL.so.1
sine errores, nos discere nihil.

Offline rja

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #14 Gepost op: 2011/11/29, 20:35:15 »
Ik heb die library in m´n configuratie van ld.so.conf staan, zelfs een GL.conf

Wat is de output van : cat /etc/ld.so.conf.d/*

Offline glaasje

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #15 Gepost op: 2011/11/29, 20:57:11 »
hier is de output! :D :
# Legacy biarch compatibility support
/lib32
/usr/lib32
# Multiarch support
/lib/i386-linux-gnu
/usr/lib/i386-linux-gnu
/lib/i686-linux-gnu
/usr/lib/i686-linux-gnu
# libc default configuration
/usr/local/lib
/usr/lib/nvidia-settings
# Multiarch support
/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/mesa
sine errores, nos discere nihil.

Offline rja

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #16 Gepost op: 2011/11/30, 17:42:56 »
Typisch.

In je library path staat /usr/lib/x86_64-linux-gnu/mesa/ daarin staat een libGL.so.1, misschien niet de goede versie, gebruik je 64 bit ?

Jammer dat Ubuntu geen LD_LIBRARY_PATH meer kent, anders hadden die nu kunnen gebruiken.

Ik zou handmatig een van de andere libGL.so.1 symbolische linken of kopieren naar bijvoorbeeld /usr/lib


Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #17 Gepost op: 2011/12/01, 04:39:46 »
Jammer dat Ubuntu geen LD_LIBRARY_PATH meer kent, anders hadden die nu kunnen gebruiken.
Is dat zo? In 10.04 in ieder geval nog wel, want dat heb/had ik nodig om Blocks That Matter te kunnen starten.
Is het in een latere versie niet meer mogelijk?
In het bovengenoemde geval zette ik dit in een script:
LD_LIBRARY_PATH=$(dirname $0) java -jar BTM.jar -Xmx1024M - bla bla enzovoort

Offline rja

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #18 Gepost op: 2011/12/01, 05:53:35 »
Jammer dat Ubuntu geen LD_LIBRARY_PATH meer kent, anders hadden die nu kunnen gebruiken.
Is dat zo? In 10.04 in ieder geval nog wel, want dat heb/had ik nodig om Blocks That Matter te kunnen starten.
Is het in een latere versie niet meer mogelijk?
In het bovengenoemde geval zette ik dit in een script:
LD_LIBRARY_PATH=$(dirname $0) java -jar BTM.jar -Xmx1024M - bla bla enzovoort

Ik zocht een howto over LD_LIBRARY_PATH voor deze thread .

Kwam ik dit tegen.

https://help.ubuntu.com/community/EnvironmentVariables

Nog een keer gelezen, werkt schijnbaar wel in een shell
Maar niet globaal



« Laatst bewerkt op: 2011/12/01, 05:55:18 door rja »

Offline glaasje

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #19 Gepost op: 2011/12/17, 13:13:11 »
Ik heb vandaag eindelijk weer eens tijd gevonden om dit probleem op te lossen. (druk...druk...druk)
en wat blijkt... de oplossing is eigenlijk erg simpel! :D

Na even zoeken kwam ik op deze pagina:
http://askubuntu.com/questions/79359/hib-games-aquaria-penumbra-cannot-find-libgl-so-1-even-though-it-exists

Helemaal onderaan stond et volgende:
LD_LIBRARY_PATH="/usr/lib" ./penumbra.bin (it is one command!!)
Toen heb ik dat op een paar spellen uitgeprobeerd en toen werkte ze ineens. :D

Een paar andere spellen hadden een beetje 'speciale' behandeling nodig...
Bij die moest ik een verwijzing plaatsen naar LibGL.so.1
En nu doen die het ook! :D

Een paar andere moesten 'nog' specialer aangepakt worden en die moest ik met een scriptje te lijf gaan :P

#!/bin/bash

cd /home/ivo/.apps/NightSkyHD_Linux/NightSkyHD_Linux
echo 'Starting NightskyHD...'
'/home/ivo/.apps/NightSkyHD_Linux/NightSkyHD_Linux/NightSkyHD'
echo 'Started!!! =3'

En nu doen al mijn spelletjes het! :3

Alleen Aquaria heeft last van heel rare lijnen :P
http://dl.dropbox.com/u/11362056/Schermafdruk%20op%202011-12-16%2020%3A55%3A25.png

En bij Shank zie ik alleen maar zwart O_O
(sorry geen screenshot)
sine errores, nos discere nihil.

Offline Lekensteyn

  • Lid
  • Steunpunt: Nee
Re: libGL.so.1 word niet gevonden.
« Reactie #20 Gepost op: 2011/12/17, 17:53:10 »
Als je 32-bit programmas met bumblebee wilt werken moet je virtualgl-libs:i386 installeren:
sudo apt-get install virtualgl-libs:i386
Het zou niet nodig moeten zijn om LD_LIBRARY_PATH=/usr/lib in te stellen, al helemaal niet als libGL.so niet in /usr/lib staat. Probeer eens andere compressie methoden voor virtualgl, bijv jpeg:
optirun -c jpeg ./penumbraOm dit permanent te maken, bewerk /etc/bumblebee/bumblebee.conf