Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Updates niet te installeren  (gelezen 4863 keer)

V-ernie-R

  • Gast
Updates niet te installeren
« Gepost op: 2007/02/08, 14:25:01 »
In de update manager staan een aantal "belangrijke veiligheidsupdates" die ik niet kan installeren. Het zijn de pakketten linux-headers-386, linux-headers-generic, linux-image-generic en linux-restricted-modules-generic. Ook een 'sudo apt-get dist-upgrade' wil deze pakketten niet installeren. Wat raden jullie mij aan? De updates niet installeren, of ze toch installeren? De vraag is dan: hoe?

breukkie

  • Gast
Updates niet te installeren
« Reactie #1 Gepost op: 2007/02/08, 14:32:47 »
sudo apt-get update lijkt mij de keuze inplaats van sudo aptpget dist-upgrade  ..
Ik heb dit ook wel eens gehad dat hij via de gui de updates niet pakte en wel via de terminal met sudo apt-get update ..

breukkie

  • Gast
Updates niet te installeren
« Reactie #2 Gepost op: 2007/02/08, 14:34:05 »
ik bedoel sudo apt-get dist-upgrade

V-ernie-R

  • Gast
Updates niet te installeren
« Reactie #3 Gepost op: 2007/02/08, 14:37:34 »
ik heb geprobeert:
apt-get update (om vernieuwde pakketlijst binnen te halen)
apt-get upgrade
De volgende pakketten zijn achtergehouden:
  linux-headers-386 linux-headers-generic linux-image-generic linux-restricted-modules-generic
0 pakketten opgewaardeerd, 0 nieuwe pakketten geïnstalleerd, 0 verwijderen en 4 niet opgewaardeerd.
Vaak installeert dist-upgrade deze achtergehouden pakketten wel maar nu dus niet:
apt-get dist-upgrade
De volgende pakketten zijn achtergehouden:
  linux-headers-386 linux-headers-generic linux-image-generic linux-restricted-modules-generic
0 pakketten opgewaardeerd, 0 nieuwe pakketten geïnstalleerd, 0 verwijderen en 4 niet opgewaardeerd.

Offline Riny Feller

  • Lid
    • De wereld van Riny Feller
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #4 Gepost op: 2007/02/08, 16:20:03 »
Hier heb ik hetzelfde probleem... achter gehouden pakketten.

Ook als je de update-manager gebruikt, zie je ze wel, maar kunnen ze niet aangevinkt worden. Heel vreemd.

Ik draai trouwens Edgy...

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #5 Gepost op: 2007/02/08, 16:34:27 »
Citaat van: riny
Hier heb ik hetzelfde probleem... achter gehouden pakketten.

Ook als je de update-manager gebruikt, zie je ze wel, maar kunnen ze niet aangevinkt worden. Heel vreemd.

Ik draai trouwens Edgy...
zijn alle "oude" pakketten wel aanwezig op jullie compu?
bijv. zijn de restricted modules wel eerder geinstalleerd? kun je in
synaptic pakketbeheer nazien. :) tis maar een wilde gedachte.....

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #6 Gepost op: 2007/02/08, 16:35:50 »
Citaat van: leoquant
Citaat van: riny
Hier heb ik hetzelfde probleem... achter gehouden pakketten.

Ook als je de update-manager gebruikt, zie je ze wel, maar kunnen ze niet aangevinkt worden. Heel vreemd.

Ik draai trouwens Edgy...
zijn alle "oude" pakketten wel aanwezig op jullie compu?
bijv. zijn de restricted modules wel eerder geinstalleerd? kun je in
synaptic pakketbeheer nazien. :) tis maar een wilde gedachte.....
en hoogst onwaarschijnlijk...

Offline Riny Feller

  • Lid
    • De wereld van Riny Feller
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #7 Gepost op: 2007/02/08, 16:41:02 »
Ja hoor,...

en het gaat hier bij mij om:
1. linux-headers-generic
Generic Linux kernel headers

2. linux-image-generic
Generic Linux kernel image

beiden gaat het om versie 2.6.17.10 die vervangen moet worden door 2.6.17.11

Deze twee heb je toch ook nodig om Efty te draaien, of zie ik dat verkeerd?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #8 Gepost op: 2007/02/08, 16:44:25 »
Citaat van: riny
Ja hoor,...

en het gaat hier bij mij om:
1. linux-headers-generic
Generic Linux kernel headers

2. linux-image-generic
Generic Linux kernel image

beiden gaat het om versie 2.6.17.10 die vervangen moet worden door 2.6.17.11

Deze twee heb je toch ook nodig om Efty te draaien, of zie ik dat verkeerd?
die heb je nodig! het ging mij meer om de restricted modules.
en de stap tussen de verschillende kernels moet "kloppen".
de kernel is de basis van je systeem.:)
2.6.17.10  vervangen voor  2.6.17.11 is ook volstrekt logisch.

V-ernie-R

  • Gast
Updates niet te installeren
« Reactie #9 Gepost op: 2007/02/08, 16:46:15 »
Citaat van: leoquant
Citaat van: riny
Hier heb ik hetzelfde probleem... achter gehouden pakketten.

Ook als je de update-manager gebruikt, zie je ze wel, maar kunnen ze niet aangevinkt worden. Heel vreemd.

Ik draai trouwens Edgy...
zijn alle "oude" pakketten wel aanwezig op jullie compu?
bijv. zijn de restricted modules wel eerder geinstalleerd? kun je in
synaptic pakketbeheer nazien. :) tis maar een wilde gedachte.....
pakket | huidige versie | niewste versie
linux-headers-386 | 2.6.17.10 | 2.6.17.11
linux-headers-generic | 2.6.17.10 | 2.6.17.11

die andere 2 heb ik ook vast wel. Check ik zo nog wel ff.

Ik denk dat ik wel weer wat verder gekomen ben, als ik in synaptic wil bijwerken krijg ik de volgende foutmelding:
linux-headers-386:
 Vereisten: linux-headers-2.6.17-11-386  but it is not installable

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #10 Gepost op: 2007/02/08, 16:50:20 »
Citaat van: V-ernie-R
Citaat van: leoquant
Citaat van: riny
Hier heb ik hetzelfde probleem... achter gehouden pakketten.

Ook als je de update-manager gebruikt, zie je ze wel, maar kunnen ze niet aangevinkt worden. Heel vreemd.

Ik draai trouwens Edgy...
zijn alle "oude" pakketten wel aanwezig op jullie compu?
bijv. zijn de restricted modules wel eerder geinstalleerd? kun je in
synaptic pakketbeheer nazien. :) tis maar een wilde gedachte.....
pakket | huidige versie | niewste versie
linux-headers-386 | 2.6.17.10 | 2.6.17.11
linux-headers-generic | 2.6.17.10 | 2.6.17.11

die andere 2 heb ik ook vast wel. Check ik zo nog wel ff.

Ik denk dat ik wel weer wat verder gekomen ben, als ik in synaptic wil bijwerken krijg ik de volgende foutmelding:
linux-headers-386:
 Vereisten: linux-headers-2.6.17-11-386  but it is not installable
hou ons op de hoogte he, dit moet goed komen. :)
het is wel een veiligheidsupdate. dus belangrijk.

V-ernie-R

  • Gast
Updates niet te installeren
« Reactie #11 Gepost op: 2007/02/08, 16:52:15 »
Zo te zien zijn linux-image-2.6.17-11-386, linux-image-2.6.17-11-generic, linux-headers-2.6.17-11-386 en linux-headers-2.6.17-11-generic niet aanwezig in de repos

edit:
Die van de oudere kernel 2.6.17.10 staan er wel allemaal in

En ja, dit moet natuurlijk goedkomen, dat komt t vast ook wel ;)

Offline Riny Feller

  • Lid
    • De wereld van Riny Feller
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #12 Gepost op: 2007/02/08, 16:52:23 »
Eens kijken of de deb bestanden los van de Ubuntu site af te halen zijn... dacht het wel ergens.

Kijken of ik ze dan los installeren kan...

Maar gaat dan de volgende update wel goed.. of zit ik dan in het vervolg vast aan de handmatige routine die ik net beschreef?

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #13 Gepost op: 2007/02/08, 16:54:59 »
Citaat van: riny
Eens kijken of de deb bestanden los van de Ubuntu site af te halen zijn... dacht het wel ergens.

Kijken of ik ze dan los installeren kan...

Maar gaat dan de volgende update wel goed.. of zit ik dan in het vervolg vast aan de handmatige routine die ik net beschreef?
ik zou er zeker nog even mee wachten. misschien weet iemand anders een oplossing. het beste is gewoon updaten. :)

Offline Riny Feller

  • Lid
    • De wereld van Riny Feller
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #14 Gepost op: 2007/02/08, 16:56:46 »
Dan wacht ik wel een daggie of wat... bedankt in elk geval voor de snelle antwoorden :D leoquant

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #15 Gepost op: 2007/02/08, 17:03:15 »
Citaat van: riny
Dan wacht ik wel een daggie of wat... bedankt in elk geval voor de snelle antwoorden :D leoquant
toch wel al sudo apt-get update
                  sudo apt-get upgrade geprobeerd he?
(sorry als ik er overheen gelezen heb....)
zoals breukki voorstelde.

V-ernie-R

  • Gast
Updates niet te installeren
« Reactie #16 Gepost op: 2007/02/08, 17:03:40 »
Jah ik wacht ook ff af, maar nu eerst ff snowboarden in Snowworld. Ik hou jullie op de hoogte.

Offline Erik Meulman

  • Lid
    • http://www.de-meulies.nl
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #17 Gepost op: 2007/02/08, 17:27:34 »
The following packages have been kept back:
  linux-headers-generic linux-image-generic linux-restricted-modules-generic
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

Dit krijg je te zien als je sudo apt-get upgrade
Er zal wel iets met die bestanden aan de hand zijn.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #18 Gepost op: 2007/02/08, 17:34:14 »
@postman
zelfde probleem dus.....(?)

Pensacola

  • Gast
Updates niet te installeren
« Reactie #19 Gepost op: 2007/02/08, 17:37:44 »
Ik gebruik Kubuntu en als ik deze packages wil updaten komt er BREAK bij te staan in plaats van update dus er is iets mis met de updates...

Offline Erik Meulman

  • Lid
    • http://www.de-meulies.nl
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #20 Gepost op: 2007/02/08, 17:48:44 »
Citaat van: leoquant
@postman
zelfde probleem dus.....(?)
Inderdaad. Gebruik overigens 6.10

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #21 Gepost op: 2007/02/08, 18:26:10 »
Op ubuntuforums.org wordt er ook aandacht aan besteed.
Blijkbaar is er weer een probleem(pje) mbt de updates.

Voorlopig dus niet updaten, even wachten tot het opgelost is.


Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #23 Gepost op: 2007/02/08, 19:15:36 »
Citaat van: Johanvd
hier dus:
http://ubuntuforums.org/showthread.php?t=356408
yep.

Offline vliegje20

  • Lid
  • Steunpunt: Nee
Updates niet te installeren
« Reactie #24 Gepost op: 2007/02/08, 19:28:49 »
Ik heb inmiddels ook deze problemen

patrick@ubuntu:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-image-386 linux-restricted-modules-386
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Ik heb het maar even zo gedaan ;)